Содержание

 Содержание | Далее

Введение

О системе

Отличительные особенности

Основные функции

Архитектура

Установка системы

Установка сервера

Установка клиентского приложения

Активация системы

Начальная настройка, первый звонок

Клиентское приложение

Офис

Сотрудники

Клиенты

Мои звонки

Переадресация

Статистика АТС

Кабинет

Call-центр

Мое рабочее место

Операторы

Проекты

Таблицы абонентов

Сценарии

Общее

Редактор сценариев

Общие принципы обработчика сценариев

Переменные

Аргументы

Выражения

Функции

Правило включения типов

Проверка и сохранение сценариев

Общие компоненты сценариев

Сценарии IVR

Компоненты сценариев IVR

Сценарии диалога

Стоп-форма

Компоненты сценариев диалога

Редактор диалоговых форм

Компоненты редактора форм

Инспектор объектов

Редактор web-форм

Компоненты редактора web-форм

Инспектор объектов

Служебные сценарии

Компоненты служебных сценариев

Задачи

Голосовые задачи

Текстовые задачи

Ресурсы

Индикаторы

Статистика

Контрольные события

Отчеты

Администрирование

Пользователи

Карта сети

Редактор карты сети

Свойства компонентов

Проверка и сохранение карты

Права

Линии

Внутренние номера

Общие нанстройки

Системные настройки

Параметры АТС

Временные параметры АТС

Параметры автодозвона

Параметры очереди

Параметры менеджера задач

Call-центр

Мобильная статистика

E-mail серверы

SMS-сервис

Клиентское приложение

Управление записями разговоров

Управление сервером

Сборка лог-журналов

Информация

Запись разговоров

Служебные задачи

Настройки оборудования

Сценарии

Мониторинг

Мобильная статистика

Телефон

Звонки и сервис автодозвона

Офисный факс

Гарнитуры

Конференц-связь

Серверное приложение (служба)

Дополнительно

Принципы работы логики

Менеджер очередей

Сервис автодозвона

Менеджер голосовых задач

Возможные проблемы и способы их устранения

Перечень файлов, необходимых для озвучивания числовых значений

Структура пространственной БД

Порты, используемые системой

Параметры файлов конфигурации

Форматы звуковых файлов

Подключение внешних БД

Обеспечение бесперебойности работы

Резервное копирование баз данных

Порядок обновления программы в ручном режиме

История обновлений. Новые возможности


Введение

 Содержание | Назад | Далее

В этом разделе:

— О системе

— Отличительные особенности

— Основные функции

— Архитектура


О системе

 Содержание | Назад | Далее

Система «Oktell» — многофункциональное программно-аппаратное решение для организации операторских центров приема и обработки вызовов (call-центров), интеллектуальных офисных АТС с функциями call-центра, автоматических голосовых информаторов, справочных служб и развлекательных сервисов. Положенный в основу решения анализ типовых задач, возникающих в организациях, активно взаимодействующих с абонентами, позволил автоматизировать многие операторские функции и предложить клиентам новые, ранее недоступные сервисы. Мы надеемся, что заложенный в программе функционал, простой клиентский интерфейс, удобство настройки и администрирования, связь с корпоративными базами данных и веб-сервисами сделают Oktell эффективным маркетинговым инструментом в Вашей компании, позволят довести до совершенства многие бизнес-процессы и удовлетворить потребности ваших клиентов.


Отличительные особенности

 Содержание | Назад | Далее

Oktell имеет ряд конкурентных преимуществ перед системами, решающими аналогичные задачи. Одним из преимуществ является поддержка технологии IP через встроенный программный шлюз. Это позволяет создать единую телефонно-компьютерную инфраструктуру без прокладки дополнительных телефонных линий, а также объединять территориально распределенные офисы компании в единый внутренний номерной план и создавать удаленные рабочие места, подключенные к системе через сеть Internet. Встроенный программный IP шлюз позволил также отказаться от дополнительных аналоговых портов на платах CTI и аппаратных средств, производящих преобразование аналогового сигнала в VoIP, что неизбежно привело к значительному снижению стоимости решения. Система Oktell дает возможность одновременно использовать различные виды аппаратных средств. Среди поддерживаемых устройств: платы CTI «Synway», «Ольха-9», «Ольха-14», «Dialogic», несколько видов USB телефонов, аналоговые телефонные, jack и usb гарнитуры, аналоговые телефонные аппараты и факсы, внешние SIP каналы, IP-телефоны стандарта SIP.

В «Oktell» широко использованы графические редакторы, позволяющие производить настройку системы даже неподготовленным пользователям. Редактор сценариев автоматической обработки вызова позволяет покомпонентно создавать необходимые схемы маршрутизации звонка и взаимодействия с системой, редактор диалогов Oktell помогает легко настраивать задачи на запрос и доведение информации до клиента, закладывая алгоритмы общения с абонентом. Служебные сценарии позволяют производить различные действия не связанные с ресурсами системы, такие как рассылка и прием SMS, обработка контента звонка, проведение запланированных действий. Уникальным является графический редактор настройки АТС, где администратор может выстраивать из стандартных компонентов модель телефонно-компьютерной инфраструктуры организации.

Удобный механизм связи с корпоративными приложениями, базами данных, web-сервисами, CRM системами позволяют создавать интегрированные программные решения и обеспечивать автоматизацию многих функций, таких как предоставление оператору информации о клиенте при поступлении вызова или ведение истории звонков по каждому клиенту, анкетирование.


Основные функции

Интерактивное голосовое меню

Oktell обеспечивает речевое взаимодействие с абонентом по заранее определенному сценарию. Абонент имеет возможность перемещаться по голосовому меню с помощью тоновых сигналов. При этом система будет воспроизводить в телефонную линию записанные речевые сообщения, определять маршрут прохождения вызова, производить переключения на операторов, воспроизводить персонифицированную информацию.

Идентификация абонента

Oktell производит определение абонента по АОН или набранному в голосовом меню персональному коду для последующего определения маршрута вызова и предоставления оператору информации об абоненте из корпоративных баз данных.

Маршрутизация вызова

Oktell определяет оптимальный маршрут прохождения вызова на основании данных о состоянии оператора (свободен / занят / нет на месте), АОН абонента, информации по абоненту из корпоративных баз данных, набранных тоновых команд в голосовом меню, даты и времени суток.

Очередь ожидания

Oktell удерживает вызов, поступившего к оператору, разговаривающему по телефону и имеющему статус «занят». При этом абонент не получает сигнал «занято» и может оставаться на линии, дожидаясь ответа.

Окна информации

Oktell направляет операторам системные уведомления о заказе встречных звонков, постановке звонка в очередь, получении сообщений голосовой почты. Окно информации может содержать необходимые сведения об абоненте из корпоративной базы данных, в том числе наименование организации, контактном лице, состоянии счета, состоянии заказа, дате последнего обращения и др.

Статистика соединений

Oktell ведет учет всех внешних и внутренних соединений, попыток набора номера, смены состояний оператора. На основании статистических данных строятся необходимые графики и диаграммы, позволяющее оценить распределение нагрузки на операторов, достаточность количества телефонных линий, динамику поступления телефонных вызовов в течение суток и др.

Сценарии диалога с абонентами

Oktell позволяет создать алгоритм, определяющий разговор оператора с абонентом. Во время разговора на экране монитора отображаются карточки, из которых оператор получает справочную информацию, вносит полученную информацию, выбирает путь дальнейшего развития диалога. Накопленные статистические данные могут быть использованы для построения графиков и диаграмм, которые будут наглядно показывать распределение ответов абонентов.

Исходящее оповещение

Oktell позволяет осуществлять массовый телефонный обзвон с передачей информации абонентам в автоматическом режиме, с помощью оператора или группы операторов. Прогрессивный и предиктивный способы осуществления звонков минимизируют время ожидания оператором соединения с абонентом.

Контрольные события

Oktell ведет непрерывный мониторинг телефонных линий, фиксирует недопустимые действия оператора и выдает соответствующие уведомления о возникновении контрольного события.

Запись разговоров

Oktell обеспечивает запись разговоров операторов и абонентов. Поиск нужного разговора может осуществляться по дате, времени, оператору, набранному номеру абонента, АОН, и другим параметрам. Каждый пользователь имеет доступ к своим разговорам, подобно журналу звонков мобильного телефона.

SMS

Oktell позволяет проводить массовое оповещение при помощи SMS-сообщений, а также осуществлять прием и обработку сообщений в автоматическом режиме или операторами.

E-mail

Oktell в автоматическом или полуавтоматическом режиме отправляет клиентам почтовые сообщения с вложениями и персонифицированной информацией в теле письма.

ICQ

Oktell производит рассылку ICQ сообщений в сценариях любых типов указанным контактам, а также следит за поступлениями новых сообщений и производит различные служебные действия.

Факсы

Oktell в автоматическом или ручном режиме занимается приемом или отправкой факсимильных сообщений.

Переадресация

Oktell производит переадресацию звонков по индивидуально настроенным правилам. Важные звонки в нерабочее время переадресуются на мобильный телефон, менее важные обрабатываются в голосом меню или переводятся на других пользователей.

Подключение удаленных пользователей

Oktell объединяет в единый номерной план сотрудников, работающих дома, на выезде, в удаленном офисе. Организует канал связи и полнофункциональный доступ к ресурсам для филиалов.

Отчеты

Oktell непрерывно ведет учет результатов всех звонков, производимых в ходе массового оповещения или приема. Произвольным образом настраиваемые отчеты дают доступ к любым срезам статистических данных, позволяя выстраивать наиболее эффективную модель работы с абонентами.


Архитектура

Серверы

Сервер представляет собой одну или несколько физических единиц (компьютеров), с установленными платами телефонно-компьютерной интеграции (CTI), и приложениями:

· сервером баз данных Microsoft SQL Server,
· сервером логики Oktell,
· сервером управления аппаратурой и программным IP шлюзом (VoIP) Oktell.

При проведении стандартной установки сервер подключается к внешней и внутренней телефонной сети, локальной сети, сети Интернет и обеспечивает интеллектуальное управление входящими, исходящими, внутренними вызовами.

Подробнее о приложении сервера в разделе «Серверное приложение (служба)».

Клиентские места

Клиентские места операторов определяют характер решаемых ими задач в составе комплекса, а также доступный функционал. В зависимости от решаемых задач к серверу могут быть подключены следующие типы клиентских мест:

· Аналоговый телефонный аппарат, подключенный к серверу телефонии по аналоговой телефонной линии (тип 1). При отсутствии компьютерного интерфейса работа такого типа рабочего места полностью определяется логикой сервера и предоставленными администратором настройками.

· Компьютерный интерфейс, подключенный по локальной сети + аналоговый телефонный аппарат, подключенный по аналоговой телефонной сети (тип 2). Интегрированное рабочее место, позволяющее получать на экран монитора сообщения о поступающих вызовах, информацию о работе системы, управлять процессами приема и совершения вызова через периферийные устройства (клавиатура, мышь).

· Компьютерный интерфейс, подключенный по локальной сети + USB телефонный аппарат или аудиогарнитура (тип 3). Такой тип рабочего места аналогичен по функционалу с рабочим местом типа 2, но в отличие от него не требует подключения аналоговых телефонных линий и может быть организован удаленно.

· SIP телефон, подключенный к общей локальной сети и настроенный на регистрацию к серверу телефонии или на прямой доступ по адресу (тип 4). При отсутствии компьютерного интерфейса работа такого типа рабочего места полностью определяется логикой сервера и предоставленными администратором настройками.

· Компьютерный интерфейс, подключенный по локальной сети + SIP телефон, подключенный к общей локальной сети и настроенный на регистрацию к серверу телефонии или на прямой доступ по адресу (тип 5). Интегрированное рабочее место, позволяющее получать на экран монитора сообщения о поступающих вызовах, информацию о работе системы, управлять процессами приема и совершения вызова через периферийные устройства (клавиатура, мышь).

Клиентский интерфейс гибко настраивается. В зависимости от прав пользователя на доступ к определенным модулям, на возможность контроля других пользователей системы и прочего может приобрести вид от управляющего аппаратурой модуля без возможности доступа к каким бы то ни было модулям системы до полнофункционального рабочего места администратора.

Подробнее о приложении клиента в разделе «Клиентское приложение».


Установка системы

Установка включает в себя настройку аппаратных систем, а также установку и настройку используемых программных средств на все компьютеры, определенные в плане разворачивания комплекса.

Установка производится с помощью программы-инсталлятора с установочного диска. Дальнейшие обновления программы могут производиться с помощью установочного диска и в ручном режиме (см. раздел «Дополнительно. Порядок обновления программы в ручном режиме»).

В этом разделе:

— Установка сервера

— Установка клиентского приложения

— Активация

— Найстройка, начальное администрирование


Установка сервера

1. Установите CD диск с дистрибутивом в привод считывающего устройства и дождитесь автозапуска инсталлятора. В случае если автозапуска не произошло, самостоятельно запустите файл setup.exe.

2. В инсталляторе комплекса выберите тип установки – «Полная» (Клиент и сервер). При таком варианте на компьютер устанавливаются драйверы плат, драйверы ключа защиты, сервисы, осуществляющие необходимую для работы системы деятельность, сервер БД MS SQL Server (MSDE edition).

3. В процессе установки будет запрошен тип используемых в составе комплекса плат CTI и IP-каналов. Выберите необходимый тип и нажмите «Далее». Назначение используемых типов определяется настройками в файле конфигурации сервера, который автоматически формируется при установке комплекса в соответствии с выбором администратора. При необходимости модифицировать настройки уже установленного комплекса откорректируйте соответствующие параметры или добавьте/удалите необходимые. Порядковый номер сервера ХХ должен быть уникальным двузначным числом.

Сервер плат «Synway»:

<add key="START_SERVER_XX" value="Synway Server;oktell.HALSynwaySrv.dll;ShCti;" />

Сервер плат «Ольха 9»:

<add key="START_SERVER_XX" value="Alder9 Server;oktell.HALAlder9Srv.dll;Alder9;_Loaders\" />

Сервер плат «Ольха 14»:

<add key="START_SERVER_XX" value="Alder14 Server;oktell.HALAlder9Srv.dll;Alder14;_Loaders\" />

Сервер SIP:

<add key="START_SERVER_XX" value="SIP Server;oktell.HALSipSrv.dll;SIP" />

4. Oktell работает на базе Microsoft Framework 1.1. Если на компьютере пакет не будет обнаружен инсталлятором, автоматически начнется установка версии 1.1.4322. Во избежание возможных проблем настоятельно рекомендуется отключить имеющиеся антивирусы, а также завершить или прервать прочие процессы установок ПО. Если установка производится на компьютер с операционной системой Windows XP, после установки комплекса рекомендуется накатить Service Pack 1 для Microsoft Framework 1.1 (файл «ndpsp_xp.exe» в корне инсталлятор).

5. В случае установки на сервер, на котором уже установлен Microsoft SQL Server, будет предложено ввести логин и пароль администратора на доступ к системе сервера для создания базы данных комплекса Oktell, а также для создания логина обращения к ней. В противном случае MS SQL будет установлен, администраторский логин «sa», пароль «123».

6. После завершения установки необходимо выключить компьютер, вставить и закрепить платы СTI в свободных слотах, согласно инструкции к платам. При использовании двух и более плат CTI с возможностью межплатной коммутации – их необходимо объединить шлейфом по шине CT-Bus, действуя согласно инструкции (при необходимости выставляя указанным в инструкции способом перемычки).

7. После установки плат включите компьютер и запустите сервер. Если сервер Oktell установлен как служба, то он стартует автоматически при включении компьютера.

8. При первом запуске будет произведена стандартная процедура автоматического поиска драйверов для новых устройств и их регистрация. Перезагрузите сервер после окончания этого процесса.

Одновременно с сервером будет установлено и клиентское приложение. Убедитесь, что сервер запущен, и запустите клиентское приложение. В случае успеха в окне авторизации в левом нижнем углу вы увидите надпись «Связь с сервером установлена». При невозможности запуска приложения, а также при отсутствии подобной надписи обратитесь к разделу «Возможные проблемы и способы их устранения».

9. Введите в окне авторизации логин «Администратор», пароль оставьте пустым. После входа с учетной записью администратора появится доступ к разделу администрирования клиентского приложения.

Подробнее в разделе «Клиентское приложение. Администрирование».


Установка клиентского приложения

В ряде случаев до установки и настройки клиентских рабочих мест лучше создать карту сети в соответствующем модуле раздела Администрирования клиентского приложения. Это можно сделать с помощью учетной записи системного администратора. Обратитесь к разделу «Начальная настройка, первый звонок».

При необходимости надо соединить компьютер с USB телефоном, если это описано в плане установки. В инсталляторе выбрать «Минимальная установка» и ввести адрес или имя сервера, к которому будет производиться по плану подключение этого клиента. Будут созданы файлы конфигурации в соответствии с этими настройками.

Установка клиентского приложения проходит в порядке, аналогичном установке сервера. В разделе «Тип установки» выберите пункт «Минимальная». При этом будет произведена только установка клиентского приложения.

Если учетная запись пользователя ОС, работающего в Oktell, обладает ограничениями, необходимо разрешить ему полный доступ к каталогу, в который устанавливается клиентское приложение. В противном случае не будет возможности корректного автоматического обновления программы. Разрешение на доступ осуществляется из под учетной записи администратора на вкладке «Безопасность» в окне свойств настраиваемого каталога. Если вкладка «Безопасность» отсутствует, необходимо отключить использование простого общего доступа к папкам (Панель управления > Свойства папки > вкладка Вид > Использовать простой общий доступ). Для решения проблемы существуют также другие варианты. Можно осуществлять установку программы в каталоги с полным доступом. По умолчанию таким является только каталог учетной записи пользователя в Documents and Settings. Либо осуществлять установку программы из под учетной записи пользователя, работающего в Oktell. В этом случае ограниченный пользователь на правах владельца получит полный доступ к каталогу. Однако последние способы неприменимы в случае, если на компьютере работают несколько различных пользователей с ограниченными правами.

Oktell работает на базе Microsoft Framework 1.1. Если на компьютере пакет не будет обнаружен инсталлятором, автоматически начнется установка версии 1.1.4322. Во избежание возможных проблем настоятельно рекомендуется отключить имеющиеся антивирусы, а также завершить или прервать прочие процессы установок ПО. Если установка производится на компьютер с операционной системой Windows XP, после установки необходимо накатить SP1 на Framework 1.1 (файл «ndpsp_xp.exe» в корне установочного диска).

Подключите устройство, если настраиваемое рабочее место оснащается VoIP каналом.

Если карта сети уже создана, то после установки можно запустить клиентское приложение и попытаться подключиться к серверу под любой существующей учетной записью или записью системного администратора. При входе под учетной записью пользователя системы с компьютера, определенного в карте как рабочее место типа 3 (компьютер + USB-телефон), в случае успеха на экране появится уведомление об успешной регистрации линии подключенного к компьютеру USB-телефона, а на телефоне (при наличии на нем дисплея) появится соответствующее изображение.

При возникновении проблем обратитесь к разделу «Возможные проблемы и способы их устранения».


Начальная настройка, первый звонок

Данный раздел поможет без обращения к подробному изучению инструкции быстро настроить систему и осуществить первый звонок.

Запустите клиентское приложение на любом компьютере, где оно установлено, и в окне авторизации введите данные учетной записи системного администратора (логин «Администратор», пароль пустой).

После того как внизу появится надпись «Связь с сервером установлена», в окне авторизации станет доступна кнопка «ОК». Нажмите ее для входа в систему.

При возникновении проблем на этапе подключения и запуска обратитесь к разделу «Возможные проблемы и способы их устранения».

Процесс начальной настройки и ввода в эксплуатацию включает в себя:

· Создание учетных записей пользователей;
· Создание карты офиса;
· Задание детальных прав пользователям;
· Создание внутренних номеров;
· Настройка аппаратного модуля;
· Создание главного сценария IVR, принимающего все входящие звонки.

Все прочие установки и настройки не относятся к базовым и могут быть изменены позднее. В процессе эксплуатации доступ к настройкам осуществляется пользователями, наделенными соответствующими правами. Подробнее о модулях и правах доступа в разделе «Клиентское приложение».

За ответами на любые вопросы, возникающими в ходе проведения начальной настройки, обращайтесь в соответствующие разделы настоящего руководства.

Пользователи

(раздел «Клиентское приложение. Администрирование. Пользователи»)

Щелкните в главном меню (в левой части окна) на заголовке «Администрирование» на голубом фоне для отображения списка его модулей. Найдите заголовок «Пользователи» и щелкните на нем для загрузки модуля.

Нажмите кнопку «Добавить» для входа в режим создания/редактирования учетной записи пользователя.

Заполните поля на вкладке «Карточка»:

· Имя;
· Отдел (выберите из списка, или введите с клавиатуры в случае отсутствия);
· Логин;
· Пароль.

Раздел прав контроля можете опустить и вернуться к заполнению в дальнейшем с помощью модуля «Права».

Перейдите на вкладку «Права» и выберите роль для настраиваемого пользователя. Вы также можете выставить индивидуальные права для пользователя. Задайте для полученного уникального набора прав название, если желаете сохранить его в виде роли для дальнейшего использования. Среди выставляемых в этом разделе прав настройки доступа к модулям системы.

Перейдите на вкладку «Номера». Здесь осуществляется быстрое назначение внутренних номеров. Нажмите кнопку «Создать» и заполните поля «Внутренний номер» и «Описание».

В таблице правил для номера щелкните мышью в сетке справа от имени создаваемого пользователя и протащите линию до конца для образования подобной картины:

Нажмите кнопку «Сохранить» внизу для сохранения информации о создаваемом пользователе.

Карта сети

(раздел «Клиентское приложение. Администрирование. Карта сети»)

В главном меню (в левой части) найдите заголовок «Карта сети» и щелчком на нем откройте соответствующий модуль.

Главное окно модуля состоит из поля карты и окна инструментов.

Создание сервера.

Подведите курсор мыши к окну и пользуясь всплывающими подсказками найдите и щелкните на пиктограмме «Сервер». Щелкните в свободном месте поля карты. Появившееся изображение являет собой проекцию сервера телефонии. Перейдите на вкладку «Свойства» и заполните поля

· Название (используется для отображения в карте);
· Описание;
· Адрес (имя компьютера или IP адрес, по которому сервер обнаруживает себя). Должен быть уникальным в пределах сети;
· В поле «Сервер состояний» поставьте галочку.

Подробное описание полей смотрите в разделе «Администрирование. Карта сети. Свойства компонентов».

Нажмите кнопку «Опросить сервер» в левом нижнем углу для обнаружения доступных каналов плат CTI. Соответствующие каналы (внешние и внутренние) появятся в двух таблицах.

Нажмите кнопку «ОК» для сохранения изменений.

Создание IP-шлюзов, IP-аккаунтов и IP-линий.

Щелкните на компоненте «IP-шлюз» в окне инструментов для выделения шлюза текущим инструментом. Подведите курсор мыши к свободному месту карты и однократно щелкните. У появившегося объекта «IP-шлюз» на вкладке свойств заполните поля, необходимые для подключения к внешнему устройству или sip-серверу в интернет. Подробное описание полей смотрите в разделе «Администрирование. Карта сети. Свойства компонентов». Нажмите кнопку «ОК» для сохранения изменений.

Создание компьютеров.

Щелкните на компоненте «Компьютер» в окне инструментов для выделения компьютера текущим инструментом. Подведите курсор мыши к свободному месту карты и однократно щелкните. У появившегося объекта «Компьютер» также имеются свойства, которые необходимо заполнить. Перейдите на вкладку «Свойства» и заполните соответствующие поля подобным образом..

Объединение объектов локальной сетью.

Соедините компьютер LAN-связью с сервером. Для этого щелкните на инструменте «Связь», подведите курсор мыши к компьютеру и щелкните на нем. Появившуюся линию дотяните до сервера и щелкните. Изображение сервера обрамлением подскажет момент, когда можно щелкнуть мышью для установления связи.

Аналогичным образом соедините IP-шлюз с сервером. После установления LAN-связи шлюза с сервером на вкладке свойств сервера среди списка линий можно будет увидеть созданные динамически SIP-линии, соответствующие заполненным в свойствах шлюза аккаунтам (потокам).

Создание телефонов.

Создайте необходимые телефонные аппараты аналогичными действиями. Свойства телефонов назначаются автоматически по умолчанию. Можно оставить все по умолчанию и не переназначать их. На аналоговые и SIP телефоны могут быть назначены пользователи по умолчанию. В случае, если подобный телефон работает без управления клиентским приложением, к нему применяются настройки выбранного таким образом пользователя. В частности, информация о звонках будет попадать в статистику под его именем.

Связи.

Выбрав инструмент «Соединение» свяжите аналоговые аппараты с сервером FXS каналом, sip-телефоны с сервером LAN каналом, USB-телефоны с соответствующими компьютерами, которые будут осуществлять их аппаратную поддержку, а также необходимые аналоговые и sip-телефоны с компьютерами для образования комбинированных рабочих мест. Тип канала формируется автоматически при определении типов соединяемых устройств.

Комбинации «Компьютер + Usb» телефон представляют собой рабочие места типа 3.

Отдельно стоящие аналоговые и sip аппараты представляют собой рабочие места типа 1.

Для создания комбинированного рабочего места типа 2 (компьютер + аналоговый или sip телефон) соедините соответствующие объекты логическим соединением (проводится при его отсутствии, в случае если телефон уже связан основным соединением).

После создания всех рабочих мест (или части, необходимой для первоначальной настройки) вы можете растащить объекты, создать визуальные зоны, сделав карту удобной для восприятия в дальнейшем.

Перейдите на вкладку «Сохранение» и нажмите кнопку «Проверить» внизу. Будут выявлены все ошибки и вынесены предупреждения. При отсутствии ошибок карту можно сохранить нажатием соответствующей кнопки.

Все компьютеры, определенные в карте, получат доступ к системе.

Права

(раздел «Клиентское приложение. Администрирование. Права»)

На вкладке «Внешние линии» для созданных пользователей проставьте права и последовательности выдачи внешних линий. Для этого в левом списке пользователей выделите строчку с пользователем, а в правом списке отметьте галочками те внешние линии, которые ему разрешено использовать для осуществления исходящих звонков в режиме персонального выхода в город. Пользуясь стрелками в правой части списка линий можно формировать последовательность выделения линий в случае недоступности некоторых из них.

Внутренние номера

(раздел «Клиентское приложение. Администрирование. Внутренние номера»)

В списке номеров уже присутствуют номера, назначенные для пользователей при их создании в модуле «Пользователи».

Создайте служебный номер для выхода в город. Нажмите кнопку «Добавить» для входа в режим создания/редактирования номера.

· В поле «Внутренний номер» введите «9».
· В поле «Тип» выберите «Специальный».
· В списке «Действие» выберите пункт «Выход в город».

Нажмите «Сохранить».

Закройте клиентское приложение.

Перезапустите сервер.

· Если это оконное приложение, нажмите крест в правом верхнем углу окна и дождитесь выхода.
· Если это служба, в окне служб операционной системы остановите службу «oktellServer», дождитесь завершения остановки и заново запустите ее.

Запустите клиентское приложение и зайдите под учетной записью пользователя, наделенного правами администратора или создателя сценариев.

Настройки оборудования

(раздел «Клиенсткое приложение. Администрирование. Параметры аппаратуры»)

В представленном дереве отображены все элементы аппаратной системы сервера: Серверы, устройства, платы, каналы, элементы каналов. При выделении любого из них в правой части окна приложения отображается соответствующие ему настройки. Все настройки имеют значения по умолчанию и не требуют изменения в большинстве случаев. Основное, что необходимо сделать – для каждой из плат CTI выставить индекс группы в соответствии с объединением их шинами CT-BUS. Каналы плат, находящихся в одной группе, будут коммутироваться аппаратно через шину CT-BUS. Каналы плат в разных группах (и группе 0) будут соединены через шлюз VoIP Oktell.

Сценарии

(раздел «Клиентское приложение. Администрирование. Сценарии»)

Нажмите кнопку «Создать» внизу; в появившемся окне выберите пункт «IVR» и введите название «Сценарий приема звонка»

Подобно созданию карты к уже существующим в поле сценария компонентам «Старт» и «Поднять трубку» перенесите в поле сценария из формы инструментов объекты «Переключение», «Воспроизведение», «Стоп» и «Обрыв связи» как показано на рисунке.

Поочередно дважды щелкните на каждом из объектов для отображения окна инспектора объектов для отображения свойств. Рассмотрим задание свойств объекту «Переключение 1»

В поле «Номер» введите внутренний номер пользователя системы, под учетной записью которого была осуществлена авторизация в программе (внутренний номер был назначен ему при создании).

В поле «Назначение» оставьте пункт «Внутрь».

Задействуйте очередь ожидания, выставив в поле «Очередь ожидания» значение «Да».

Задайте свойства перехода как приведено на изображении выбрав соответствующие значения в списке. При успешном переключении компонент «Стоп 1» прервет выполнение сценария без разрыва связи, при любом другом ответе обработчик сценария проиграет звуковой файл согласно настройкам компонента «Воспроизведение1».

Подобным образом задайте свойство перехода объекту «Поднять трубку 1», предварительно выделив его в поле сценария.

До завершения создания сценария осталось задать свойства компоненту «Воспроизведение 1». Выделите его; в инспекторе объектов заполните свойство «Переход», выбрав в списке значений объект «Обрыв связи 1». Щелкните мышью в правой части столбца значений в строке поля «Файл» инспектора объектов (там где изображена кнопка с тремя точками), чтобы отобразить окно указания файла для воспроизведения компонентом.

В открывшемся окне «Выбор файла» нажмите кнопку «Обзор» и выберите небольшой звуковой файл в формате PCM, G711 или G610. При отсутствии таких файлов – выберите любой из файлов в каталоге «Windows\Media», как это сделано на изображении. Нажмите кнопку «ОК» для сохранения свойства.

Сценарий готов. Перейдите на вкладку «Сохранение» для осуществления автоматической проверки и сохранения сценария.

Нажмите кнопку «Проверить» в левом нижнем углу модуля и дождитесь проверки. В случае, если Вы четко следовали инструкциям, вы должны увидеть результат, который приведен на изображении. В случае появления красных строк изучите информационное наполнение ошибок и исправьте их.

Поочередно нажмите кнопки «Сохранить» и «На сервер» для осуществления соответствующих перемещений сценария внутри системы Oktell.

Нажмите кнопку «Закрыть» для перехода к списку сценариев.

В списке сценариев появился созданный сценарий «Сценарий приема звонка». Для того, чтобы он автоматически активировался при поступлении входящих звонков, выделите его и нажмите кнопку «Главный» в левом нижнем углу.

Первый звонок

Убедитесь, что телефон, объединенный с Вашим компьютером в одно интегрированное рабочее место, подключен к системе. Для этого снимите трубку и убедитесь в наличии гудка – тона АТС. Положите трубку и позвоните на внешний номер организации, линия которого подключена к серверу телефонии. При успешной настройке Ваш телефон зазвонит, а в абонентском телефоне пойдут длинные вызывные гудки.

Вы можете также снять трубку и набрать «9» и внешний номер для осуществления вызова городского номера. Или просто наберите внутренний номер любого из сотрудников, подсоединенных к системе.


Клиентское приложение

Рабочее место пользователя системы в развернутом виде представляет собой окно, в левой части которого находится главное меню, состоящие из разделов:

— Офис

— Call-центр

— Администрирование

— Телефон

Каждый из разделов главного меню может быть развернут щелчком на его заголовке. Разделы объединяют в себе логически связанные модули. Каждый модуль представляет собой набор визуальных интерфейсов, предоставляющих доступ к определенным видам работ.

После щелчка на интересующем модуле в правой части разворачивается соответствующий ему интерфейс.

В строке состояния пользователь может видеть и изменять свой статус (подробнее в разделе «Офис. Сотрудники»). Также в строке состояния находится пиктограмма в виде конверта, по нажатию на которую происходит переход к ящику с голосовой почтой, и sms-сообщениями. В случае поступления новых сообщений пиктограмма начинает характерно мигать.

В правой части строки состояния ссылка «Показать очередь ожидания» разворачивает панель отображения текущего состояния очереди (всех очередей, к которым имеет отношение пользователь: личные, групповые номера, задачи, в которых участвует пользователь или его линия). Последовательность формируется на основе приоритетов звонков и времени ожидания. Звонки по задачам группируются.

В трее (панели с иконками, находящейся в правом нижнем углу экрана рядом с изображением текущего времени) находится пиктограмма приложения (цветной квадрат). Цвет квадрата дублирует статус пользователя из панели состояния и помогает ориентироваться, когда приложение свернуто. Пользуясь пунктами контекстного меню, пользователь может изменить свой статус, свернуть/развернуть главное окно, а также закрыть программу.

В этом разделе:

— Офис

— Call-центр

— Администрирование

— Телефон


Офис

Раздел предоставляет сервис пользователям системы внутри АТС и операторам без прав управления call-центром и формирования индивидуальных отчетов.

Пользователям становятся доступны записи собственных разговоров, быстрые переключения на других пользователей системы, сервис голосовой почты, индивидуальная переадресация, а также прочие индивидуальные режимы.

При необходимости среди пунктов меню допускается размещение дополнительного модуля со встроенным браузером. Это может использоваться для ссылки на корпоративный веб-сервис или на любую другую веб-страницу с передачей в нее идентификаторов пользователя в качестве параметров входа. Дополнительная информация в разделе «Администрирование. Общие настройки. Клиентское приложение».

В этом разделе:

— Сотрудники

— Клиенты

— Мои звонки

— Переадресация

— Статистика АТС

— Кабинет


 Сотрудники

Сотрудники

 Содержание | Назад | Далее

е

Модуль «Сотрудники» позволяет в реальном времени видеть состояние пользователей системы в различных режимах.

Пользователи характеризуются номерами, назначенными на них. Среди номеров, видимых в списках сотрудников могут быть быстрые номера, групповые и одиночные стандартные номера, при создании которых был выставлен флаг «Отображать на панели сотрудников». Одиночный номер характеризуется состоянием, в котором пребывает объект, на который назначен номер (пользователь системы или внутренняя линия)

Перечень возможных состояний:

· Не зарегистрирован. Состояние определяет пользователей с незапущенной программой, или линии неподключенных серверов и компьютеров
· Отключен. Пользователь может определить себе состояние, явно выбрав его в списке доступных для перехода состояний. Также в это состояние попадают пользователи и линии, не снявшие трубки при поступлении звонка, в случае, если администратором установлен соответствующий режим работы.
· Перерыв. Пользователь (оператор) может самостоятельно определить это состояние, явно выбрав его в списке доступных для перехода и заполнив поле ввода причины перерыва. Информация отображается в статистике работы оператора.
· Занят. Состояние определяет пользователей, ведущих разговор, а также занятых в задаче (заполнением данных, или ожиданием коммутации)
· Готов. Состояние определяет пользователя подключенного к системе и не являющегося занятым.
· Без телефона. Состояние определяет пользователя, подключенного к системе, но не имеющего телефона, или телефонная линия которого находится длительное время в неопределенном состоянии, отображаемом в мониторинге со знаком вопроса.

Среди состояний есть дополнительное состояние «Переадресация». Устанавливая себе это состояние, пользователь указывает системе на активацию определенного вида правил переадресации. При поступлении звонка на номер пользователя активируется подходящее по параметрам правило и звонок перенаправляется на указанный в нем номер (подробнее «Офис. Переадресация»).

Несколько доступных вкладок определяют режим просмотра списка сотрудников:

· Организация. Список отображаемых сотрудников включает в себя всех пользователей системы.
· Мой список. Список отображаемых сотрудников может корректироваться и включать/исключать некоторых пользователей.
· Отделы. Все пользователи системы группируются по отделам, назначенным администратором системы. Отображается группа сотрудников, состоящих в выбранном отделе.

В каждом из режимов существуют несколько видов-представлений таблиц:

· Иконки.
· Свободный стиль. В отличие от вида «иконки» пользователю доступны любые перемещения, а не только смена порядка следования.
· Список.
· Таблица.

Выделив один из номеров в списке, можно воспользоваться контекстным меню, или дублирующей кнопкой снизу и произвести одно из действий:

· Позвонить. Осуществляется звонок на указанного в списке абонента. При этом, если звонящий пользователь находится в состоянии «Готов», автоматически будет задействован сервис автодозвона. Пользователь будет переведен в режим ожидания (состояние «занят») и как только соединение установится, у пользователя зазвенит телефон, а с противоположной стороны зазвучит мелодия ожидания соединения с оператором. Если пользователь находится в состояние «поднять трубку», будет осуществлен набор номера без использования сервиса автодозвона. В любой момент пользователь может снять трубку, прервав сервис автодозвона, и взяв управление на себя. При необходимости прервать полностью осуществляющийся звонок, необходимо снять и положить трубку на телефонном аппарате.
· Переключить. В случае разговора по телефону кнопка «переключить» аналогична нажатию FLASH и набору необходимого номера.

Подписи (имена сотрудников и названия номеров) берутся из описаний соответствующих внутренних номеров (раздел «Администрирование. Внутренние номера»).

При участии пользователя в конференции в контекстном меню доступна команда приглашения номера в текущую конференцию. Команда недоступна простым участникам, если управляющим пользователем конференции выставлен запрет на приглашения.

В контекстном меню раздел «Сообщения» дает доступ к режиму переписки между пользователями системы подобно ICQ. Открыв окно сообщений нужного абонента, наберите текст и отправьте его. Пользователь получит его сразу же как только окажется на своем рабочем месте. История переписки хранится в БД (а не на локальном компьютере) и доступна обоим пользователям, участвующим в диалоге. В окне можно открыть одновременно несколько закладок (не более одной для каждого пользователя). Пользуясь кнопкой «Позвонить» можно осуществить звонок текущему пользователю. Для удобства при открытии окна всегда открывается история из 4 последних сообщений. При поступлении сообщений на адрес пользователя, если его приложение не запущено, он получит все сообщения сразу после запуска.

С помощью отдельной вкладки можно осуществить массовую рассылку сообщений. Для открытия этой вкладки необходимо выделить групповой номер или несколько номеров и выбрать пункт «Отправить сообщение» в контекстном меню.

Если пользователь обладает правом просмотра экранов (скриншотов) своих подчиненных, то в контекстном меню ему будет доступна команда «Посмотреть экран». Если выделенный номер содержит информацию о пользователях, то в окне просмотра будет отображен экран первого указанного в номере пользователя (если он авторизован и достаточно прав на его контроль). Подробнее в разделе «Администрирование.Мониторинг подключений».


Мои контакты

Модуль предоставляет доступ к таблицам с информацией о клиентах. На основании этих таблиц при поступлении звонков с номеров, указанных в свойствах записей клиентов, производятся специфические действия. В сценариях IVR можно определить состоит ли указанный клиент в той или иной группе и в зависимости от этого произвести различные действия. Например, часто используются группы «VIP» и «Черный список». Очевидны и действия, производимые в случае обнаружения клиента в одной из этих групп.

В момент создания записи для клиента пользователь может указать будет ли этот контакт общим или персональным. Общие контакты доступны всем пользователям системы, персональные доступны только создавшим их пользователям. В любой момент редактирования свойств можно поменять свойство принадлежности клиента.

Для пользователей можно задавать произвольное число контактов произвольных типов. Создание новых типов контактов производится в момент редактирования контакта. Среди контактов необходимо задать телефоны клиента для идентификации при поступлении звонка, а также для дозвона до клиента.

В момент редактирования свойств клиента его можно поместить в одну или в несколько групп. Группы создаются на отдельной вкладке.

Пользуясь контекстным меню или нажатием кнопки «Позвонить» внизу можно задействовать сервис автодозвона для набора номера, выделенного в списке клиента.


Мои звонки

 Содержание | Назад | Далее

Модуль предоставляет доступ к таблицам коммутаций по личным звонкам. В списке по выбранному фильтру появляются все разговоры с участием пользователя. Исключаются только коммутации с голосовым меню. Все записанные разговоры отображаются с пиктограммой записи в правом столбце. Любой записанный разговор можно прослушать во встроенном проигрывателе, дважды щелкнув на соответствующей ему строке в таблице.

В контекстном меню доступны выгрузка звуковых файлов и экспорт данных в текстовый файл, файл Microsoft Excel, html-документ. В зависимости от выбранного пункта меню производится выгрузка всех разговоров, отображенных по результатам поиска в таблице, либо только разговоров, соответствующим выделенным строчкам в таблице.

Модуль позволяет осуществить вызов абонента, который был собеседником выделенного в таблице разговора (коммутации). Перед началом дозвона система производит запрос подтверждения с отображением определенного номера. Осуществление вызова возможно только в случае, если номер абонента был определен. Дозвон производится средствами сервиса автодозвона.


Переадресация

Раздел, позволяющий пользователям формировать правила переадресаций. Единовременно может существовать множество правил. Все правила переадресации имеют порядок – последовательность их обработки. В каждый момент времени часть правил может быть активна, а часть неактивна. Неактивные правила могут быть включенными и выключенными принудительно пользователем.

При поступлении звонка выявляется активное правило, подходящее по параметрам к данному звонку и осуществляется непосредственно переадресация. Если правило не найдено – осуществляется звонок пользователю в обычном режиме на рабочее место.

Правила переадресаций доступны только пользователю, создающему их. Они автоматически назначаются на создателя.

Свойства правила переадресации:

Название

Отображается в списке

Описание

Описание позволяет не запутаться в названиях после создания достаточного количества правил.

График

Таблица активности правила. С помощью графика можно ограничить активность правила переадресации, чтобы каждый раз не менять активность правила вручную (например, с 6 вечера и до 9 утра)

На номер

Номер, на который осуществляется дозвон и последующая коммутация при необходимости переадресации звонка по данному правилу.

Может быть указан внешний (городской) номер, внутренний номер любого пользователя системы, внутренний быстрый номер, а также внутренний номер, запускающий сценарий IVR.

ВНИМАНИЕ! Если в выбранном для переадресации правиле номер не задан, производится прямой звонок на абонента. Эта возможность позволяет исключать некоторых абонентов из общего перечня правил переадресации.

Состояние
· Активно в статусе переадресации
· Активно всегда
· Выключено

Любое правило можно принудительно отключить, чтобы звонки в любом случае не использовали его.

Состояние «активно в статусе переадресации» определяет дополнительный фильтр активности правила. Правило начинает быть активным только при выставлении соответствующего состояния пользователем в панели состояния приложения или системном трее. Состояние пользователя «Переадресация» сохраняется при выходе из системы.

Абоненты, клиенты, дополнительные номера

Список абонентов, для которых активировать данное правило. Такими абонентами могут являться пользователи системы, отделы, клиенты, клиентские группы, а также дополнительные номера, с которых может поступить вызов извне.

При установке галочки «Все вызовы» выбор абонентов блокируется, и правило становится активным для любого поступающего звонка.

Каскадная переадресация

Определяют, будут ли по этому правилу проходить звонки, поступившие пользователю в качестве переадресованных.

В случае переадресации на внешний номер система осуществляет переключение самостоятельно (выделяя внешние линии в порядке, обратном их кодам) или по служебному IVR-сценарию, по умолчанию «(Служебный) Переадресация на внешние номера» или названного в соответствии с настройками в модуле «Администрирование. Общие настройки. Системные. Параметры АТС». В сценарий в переменную компонента «Старт» передается номер для осуществления переадресации. Далее администратор может в зависимости от всех доступных ему параметров и функций осуществить выделение необходимой линии и настроить общий или индивидуальный регламент переключения.


Статистика АТС

Модуль «Статистика АТС» позволяет просматривать информацию о состоявшихся разговорах и прослушивать их записи.

Модуль доступен пользователям, наделенным соответствующим правом просмотра. Вся информация модуля фильтруется в соответствии с правами контроля пользователя, таким образом, подчиненные пользователи не видят состоявшихся разговоров их руководителей, и, соответственно, не могут прослушивать их записи. С помощью расширения прав отдельных пользователей, их можно наделить правом видеть записи с участием отдельных телефонных линий. При этом пользователь наделяется правом просмотра, если он обладает соответствующим правом хотя бы на один из элементов, участвовавших в разговоре.

Для уточнения и поиска доступен фильтр звонков, в котором можно задать параметры, в соответствии с которыми необходимо сузить перечень состоявшихся разговоров. Для подстановки в поле периода дат и времени используется компонент «Календарь», позволяющий двумя щелчками мыши выбрать соответствующий интервал дат. Используя графические режимы отображения можно применить дополнительные фильтры двойным щелчком на интересующем блоке данных и отобразить коммутации в журнале звонков.

ВНИМАНИЕ! В системе различаются понятия «Звонок» и «Коммутация». В таблице журнала представляются данные о коммутациях с возможностью прослушивания состоявшегося разговора. Несколько коммутаций могут быть объединены одним звонком. Это можно представить на примере входящего звонка от абонента, переключения его на оператора 1 и последующего переключения на оператора 2. В контексте рассмотрения звонков все коммутации представляют один элемент, в контексте же изучения коммутаций (или разговоров) это три или четыре отдельных элемента. Имейте это в виду при переходе из режима диаграмм и шкалы времени в журнал по выбранному дополнительному фильтру. При выделении в списке коммутации автоматически подсвечиваются смежные с ней коммутации (принадлежащие одному звонку).

В модуле доступны три режима работы со статистикой, определяющиеся соответствующими вкладками. При переходе между вкладками параметры фильтра сохраняются.

Журнал звонков

Режим предоставляет все разговоры в виде списка, который можно отсортировать по любому столбцу щелчком на его заголовке. Чтобы убрать сортировку по полю, нажмите и удерживайте кнопку «Ctrl» на клавиатуре и одновременно щелкните мышью по заголовку столбца. Для применения множественной сортировки отфильтруйте поочередно необходимые столбцы с нажатой кнопкой «Shift» на клавиатуре.

o Столбец «Запись» указывает на возможность прослушать разговор. Дважды щелкните на соответствующей записи, чтобы открыть встроенный проигрыватель звукозаписи и начать прослушивание.
o Пользователь, наделенный правом удаления записей, может с помощью контекстного меню стирать из БД информацию о записанном разговоре, если таковой имеется.
o Для выгрузки данных статистики используйте соответствующие пункты контекстного меню режима «Журнал звонков». Для выгрузки звуковых файлов укажите папку на компьютере пользователя, в которую необходимо произвести выгрузку. Будут скопированы файлы всех записанных разговоров, относящихся к текущему примененному фильтру. Каждый разговор записываются в 2 файла – одному на каждого абонента, но при включенной функции микширования записи объединяются, что позволяет экономить дисковое пространство. Имена файлов состоят из номеров линий, дате и времени. Необходимо учитывать, что выгрузка значительного количества на компьютер пользователя может на время занять значительные ресурсы сети и произвести дополнительную нагрузку на сервер.
o Выгрузка табличного вида статистических данных в файл Microsoft Excel, документ HTML или текстовый файл. Укажите файл, в который хотите произвести копирование данных. Выгрузка таблицы не требует ресурсов сервера.

ВНИМАНИЕ! При запросе больших объемов данных необходимо учитывать, что это создает дополнительную нагрузку на процессорное время сервера и сетевой трафик. В некоторых случаях это может отразиться на качестве разговоров, осуществляющихся через VoIP шлюз сервера.

Диаграммы

Режим позволяет строить графики, гистограммы и диаграммы соответствующих распределений интересующих величин, основанных на звонках, которые отобраны по текущему фильтру. Двойным щелчком на соответствующем узле графика, столбце гистограммы или секторе диаграммы осуществляется автоматический переход на вкладку «Журнал» с дополнительным фильтром по выбранному значению. Так, например, щелкнув на диаграмме «Общее число звонков по операторам» на секторе «Бочкарев Евгений», в журнал попадут только звонки с участием этого пользователя.

Шкала времени

Режим сеточного отображения данных по фильтру. В столбцах — даты, в строках — часы. На каждом пересечении находится соответствующее значение. Двойным щелчком на соответствующей ячейке шкалы осуществляется автоматический переход на вкладку «Журнал» с дополнительным фильтром по выбранному значению. Так, например, щелкнув на ячейке, соответствующей времени 12:00 – 13:00 и дате 25.12.2006 в таблицу попадут только те звонки, начало которых принадлежит указанному выше промежутку времени и дате.


Кабинет

Модуль служит для работы с личными данными.

Каждая вкладка предоставляет отдельный вид документов для просмотра в любое время

Голосовая почта

Почтовый ящик голосовых сообщений есть у каждого пользователя. Голосовая почта попадает в почтовый ящик из сценария обработки голосового меню (IVR). К голосовому сообщению прикрепляется идентификационная информация (CallerId, входящий номер).

После поступления сообщения на ящик, доступный пользователю, в панели состояния в нижней части главного окна начинает мигать пиктограмма конверта. Двойным щелчком на ней можно сразу перейти на вкладку «Голосовая почта» модуля «Кабинет».

Соответствующий компонент сценария определяет перечень голосовых ящиков для рассылки сообщений. Среди ящиков доступны групповые и индивидуальные. Отличие группового ящика от индивидуального заключается в том, что он доступен сразу нескольким пользователям. При этом все пользователи группы будут видеть кто первым получил сообщение и прослушал его.

В таблице черным цветом выделяются новые сообщения, серым – сообщения, уже прослушанные обладателем почтового ящика. Поставив внизу галочку «только новые», вы переведете таблицу в режим отображения новых записей и скрытия уже прослушанных. Таблица записей позволяет сортировать ее по любому из полей.

В контекстном меню доступен экспорт данных в текстовый файл, html-документ или файл Microsoft Excel. Также в контекстном меню доступна возможность осуществления вызова внешних абонентов средствами сервиса автодозвона.

Внизу доступны кнопки «Прослушать» (дублирует двойное нажатие на записи), открывающая проигрыватель для воспроизведения сообщения, и «Удалить».

Заказы на встречные звонки

Клиенту, позвонившему в компанию в то время, когда нужный сотрудник отсутствует на рабочем месте, может быть предложено сделать заказ на встречный звонок. Уведомление о заказанном встречном звонке поступит на рабочее место сотрудника или на его мобильный телефон. Заказ формируется в сценарии IVR, к заказу прикрепляется номер звонившего абонента, а также номер, на который необходимо осуществить звонок (если был заполнен).

Ящик для хранения подобных заказов есть у каждого пользователя. У отделов также имеются групповые ящики. Содержимое доступных пользователю ящиков можно просмотреть на вкладке «Встречные звонки» модуля «Кабинет»

Помимо общей информации об оставившем заказ абоненте в поле заказа имеются графы для отметки состояния. Поле «Выполнено» и поле «Комментарий». Комментарий изначально заполнен в сценарии IVR, но может быть изменен или дополнен информацией пользователями, работающими с ящиком заказов, содержащим конкретный заказ.

Отметка о выполнении ставится пользователем, когда заказ успешно выполнен.После этого заказ можно удалить нажатием соответствующей кнопки внизу.

В контекстном меню доступен экспорт данных в текстовый файл, html-документ или файл Microsoft Excel. Также в контекстном меню доступна возможность осуществления вызова абонента по заказанному номеру средствами сервиса автодозвона.

Системные уведомления

Все сообщения системы, которые отображались во всплывающих окнах, складируются в отдельный ящик и доступны для просмотра много позднее. На вкладке «Уведомления» модуля «Кабинет» вы можете воспользоваться фильтром для более детального поиска. В частности, можно отобрать только конкретные типы поступивших уведомлений, а также период дат. Таблица с уведомлениями предоставляет возможность сортировки. Двойной щелчок в строке сообщения раскрывает полный текст.

Папка с уведомлениями автоматически не чистится, поэтому самостоятельно периодически удаляйте старые и не имеющие предполагаемой ценности уведомления по прошествии времени актуальности. Для этого используйте кнопку «Удалить» внизу.


Call-центр

Раздел доступен пользователям, имеющим соответствующие права. Call-центр Oktell – это отдельный режим работы сотрудников. Вход и выход осуществляется с помощью пункта меню «Войти в Call-центр» / «Выйти из Call-центра».

После входа сотруднику открывается доступ к разрешенным модулям, а также сотрудник становится активным оператором call-центра. Оператор в отличие от сотрудника имеет дополнительные задачи, связанные с массовым приемом и/или осуществлением звонков. Тем не менее, он остается доступен для других пользователей АТС по назначенным на него номерам и сервисам.

ВНИМАНИЕ! Вне зависимости от того, какие модули разрешены пользователю на просмотр в разделе «Call-центр», система будет рассматривать находящегося в call-центре пользователя в качестве оператора (доступным на выполнение задач), только если в его личной карточке администратором выставлен флаг «Является оператором» (модуль «Администрирование. Пользователи»).

В любой момент оператор, находящийся в call-центре может перевести себя в состояние перерыва (в меню системного трея или в строке состояния главного окна клиентского приложения). В дополнительном окне необходимо указать причину перерыва, которая в совокупности с другими параметрами попадет в базу данных и будет доступна для анализа супервизором. Помимо регламентных перерывов, причину и цель которых оператор определяет самостоятельно, доступен также список предустановленных администратором перерывов. Настройка их производится в модуле «Администрирование. Общие настройки. Call-центр». Если оператор выставляет состояние перерыва в момент звонка, то система после его завершения автоматически выставляет статус перерыва. В этом состоянии входящие звонки на оператора не проходят, однако он может совершать исходящие звонки. Для выхода из состояния перерыва необходимо выставить статус готовности или покинуть call-центр.

При входе в режим call-центра пользователь расходует лицензию. Одновременно работать в call-центре может только лицензированное ключом защиты количество пользователей.

При выходе из приложения пользователь остается в call-центре, если он предварительно не осуществил выход из него. Это может быть использовано для работы так называемых «пользователей по умолчанию» (задаются в карте офиса), в случае, если для работы в качестве оператора им не требуется компьютеризированного рабочего места. При повторном входе под своей учетной записью такой пользователь сразу получит доступ к модулям раздела «Call-центр».

ВНИМАНИЕ! Если при входе очередного пользователя в call-центр исчерпыватся количество лицензированных мест, система попытается в автоматическом режиме вывести из call-центра отключенных пользователей.

В разделе производится управление проектами (кампаниями). Весь процесс работы над кампанией состоит из нескольких основных этапов, для успешной реализации которых необходимо четкое представление менеджера о решаемых задачах. Работу можно подразделить на перечисленные ниже этапы.

Предварительный этап:

· Определение задач, решаемых проектом, и методик, применяемых при решении.
· Определение абонентов (компаний или физических лиц), работа с которыми будет производиться.
· Определение группы операторов, супервизоров, занятых в проекте.
· Определение сроков актуальности проекта.
· Определение стратегии оптимизации ресурсов.
· Определение форм отчетности и выходной статистики.

Этап подготовки данных:

· Формирование звуковых файлов голосового меню, мелодий ожидания.
· Формирование списков абонентов, а также необходимой для осуществления взаимодействия с ними информации.
· Формирование веб-страниц при использовании соответствующего функционала.

Этап создания:

· Создание проекта.
· Создание таблиц абонентов (для исходящих задач) или правил их построения (например, для входящих задач или для исходящих задач с повторными проходами, где заранее неизвестно, каков будет итоговый список).
· Создание сценариев обработки звонков, оперирующих с данными, представленными в таблицах проекта или в произвольных таблицах БД.
· Создание и настройка сценариев диалога, форм для взаимодействия оператора с абонентом и с БД.
· Создание при необходимости главного сценария проекта, производящего вход в голосовую задачу.
· Создание задач, детальная настройка их свойств для полного соответствия ожидаемым.
· Корректировка существующих или создание индивидуальных отчетов реального времени для оптимального управления ресурсами во время реализации проекта.
· Настройка форм отчетности для отображения итоговых результатов.

Этап реализации:

· Обучение операторов правилам работы в проекте.
· Активация задач.
· Формирование ветки главного сценария, осуществляющей вход в проект или вход непосредственно в задачи (для входящих голосовых задач).
· Слежение за нормальным ходом процесса работы с абонентами: корректировка задач, оптимизация распределения ресурсов на основе стандартных индикаторов загрузки, а также индивидуальных индикаторов проекта, дополнительная работа с операторами.
· Корректировка сценариев на основе получаемой статистики для более точного соответствия заложенных алгоритмов с реальной обстановкой.

Этап формирования результатов:

· Оценка эффективности проведенной кампании.
· Построение отчетных форм.
· Экспорт данных и записанных разговоров.

Правильный подход к формированию проекта и полноценное использование функционала комплекса Oktell дают возможность провести наиболее точно соответствующую ожиданиям кампанию и получить наилучший из возможных результат.

Сбор статистической информации по работе и результатам call-центра, а также слежение за показателями в реальном времени дают возможность в полном объеме видеть итоги на этапе их формирования, а также выявлять тонкие места в работе операторов и управлять ресурсами как в проекте, так и в call-центре в целом.

В этом разделе:

— Мое рабочее место

— Операторы

— Проекты

— Таблицы абонентов

— Сценарии

— Задачи

— Ресурсы

— Индикаторы

— Статистика

— Контрольные события

— Отчеты


Мое рабочее место

Модуль доступен всем пользователям, участвующим в работе call-центра организации. Для доступа необходимо лишь право доступа к разделу Call-центр. В текущем модуле в нескольких вкладках представлена текущая информация для оператора.

На вкладке «Информация» производится отображение текущих показателей дня, информация о текущем абоненте, о текущем состоянии очереди (совместно личной и очереди всех задач, в которых участвует оператор), а также список активных задач, назначенных на оператора.

Кнопка вызова супервизора осуществляет рассылку уведомлений всем супервизорам задач, в которых участвует оператор. Супервизор по своему усмотрению может вступить в переписку или посетить рабочее место оператора.

Среди показателей присутствуют основные (определяемые системой) и пользовательские (задаваемые администратором БД). Пользовательские показатели выводятся в продолжении списка показателей исходя из данных, возвращаемых хранимой процедурой собственной БД Oktell «A_CallCenter_Info_GetOperatorIndexes_Custom» в виде таблицы (или строки), в первом столбце которой строковый заголовок, а в одном из других столбцов непустое значение показателя. Отображаются только корректно подготовленные показатели.

На вкладке «Статусы» осуществляется доступ к собственной статистике смены состояний.

На вкладке «Рабочий график» представлен недельный график оператора, осуществляется расчет времени до окончания дня, до начала перерыва, а также отображаются другие временные показатели текущего дня.


Операторы

Модуль доступен супервизорам и пользователям, имеющим соответствующее право. Для пользования модулем необходимо зарегистрироваться в call-центре системы. Позволяет настраивать графики работы операторов, видеть их состояния в реальном времени, а также назначенные на них задачи и минимальную статистику авторизаций в call-центре. Пользователь становится оператором в разделе «Администрирование.Пользователи». Флаг «оператор» и право доступа к разделу «Call-центр» в совокупности дают возможность пользователю участвовать в работе call-центра.

В режиме просмотра списка операторов помимо просмотра состояний доступны функции обмена сообщениями внутри системы, а также просмотра текущего содержания экрана оператора. При обладании супервизора соответствующими правами доступа эти команды размещаются в контекстном меню списка операторов. Подробнее о возможности просмотра экранов в разделе «Администрирование.Мониторинг подключений».

В модуле происходит настройка индивидуального недельного графика работы оператора, в соответствии с которым производится учет рабочего времени, а также автоматическое назначение и исключение оператора в активных задачах.

Для настройки индивидуального графика используется блок управления в виде таблицы. В левом верхнем углу выбирается режим выделения: основное рабочее время или график перерывов. Выделением некоторой зоны в таблице блока управления с нажатой кнопкой мыши производится назначение соответствующих интервалов времени в текущем выбранном режиме. В любой момент нажатие правой кнопки мыши над зоной таблицы детализирует текущий отмеченный час по минутам. Кнопка Shift на клавиатуре инвертирует выделение, кнопка Ctrl - снимает.

На вкладке «Информация» доступны сведения по оператору, аналогичные информационному блоку модуля «Мое рабочее место». Сводные отчеты по операторам строятся в модуле «Статистика».


Проекты

Модуль доступен администраторам БД и пользователям, имеющим соответствующее право. Для пользования модулем необходимо зарегистрироваться в call-центре системы. Служит для создания и удаления проектов (кампаний) с очисткой оперативной БД Oktell.

Проект состоит из совокупности задач, сценариев, таблиц, объединенных одной целью, или являющихся следствиями друг друга (например две задачи: «Проработка базы клиентов младшими операторами на предмет интереса к новому продукту» и «Проработка старшими операторами тех клиентов, кто дал негативный ответ на предмет выяснения причин»).

В списке проектов перечислены все существующие проекты системы с указанием принадлежащих им объектов.

Создание и модификация проекта происходит в режиме свойств на соответствующих вкладках. Основная вкладка позволяет задать имя, описание проекта и выбрать режим доступа к нему. Проект может быть общедоступным (доступен всем пользователям, имеющим права доступа к соответствующим модулям системы для просмотра и/или изменения информации), либо разрешен только указанным в свойствах проекта пользователям.

На вкладке «Дополнительно» производится выбор совокупности используемых в задачах проекта пользовательских статусов звонков (результатов). В модуле «Администрирование. Общие настройки» производится заполнение таблицы общих пользовательских состояний, доступных всем проектам. Однако при настройке проекта можно выбрать режим и уникальную совокупность отображаемых в стоп-форме пользовательских статусов. В зависимости от выбранного режима в стоп-форме задач проекта могут отображаться только проектные статусы, только общие статусы, или совместно проектные и общие статусы. Указанием кода проектного состояния, аналогичного общему, произойдет его подмена. Состояния с пустыми именами не отображаются и таким образом не используются. Этим можно воспользоваться для блокировки некоторых общих состояний внутри проекта.

Экспорт и импорт проектов производится соответствующими кнопками в нижней части модуля. В экспортируемый архив включается информация непосредственно о проекте, а также все принадлежащие ему элементы: таблицы абонентов, сценарии и задачи. Локальные таблицы абонентов экспортируются вместе с данными.

ВНИМАНИЕ! После импорта проекта в другую систему необходимо в ручном режиме поправить все свойства элементов (сценариев и задач), касающиеся пользователей и линий. В противном случае идентификаторы не будут совпадать и поведение менеджера задач будет аналогичным случаю, если соответствующие свойства не заполнены.


Таблицы абонентов

Модуль доступен администраторам БД и пользователям, имеющим соответствующее право. Для пользования модулем необходимо зарегистрироваться в call-центре системы.

Выполнение задач на исходящее оповещение или рассылку SMS-сообщений невозможно без указания списков абонентов. Таблица абонентов предоставляет задаче доступ к соответствующей информации. В ней содержится код абонента, перечень номеров его телефонов, а также дополнительная информация для отображения оператору. Помимо предопределенной информации в таблице абонентов могут содержаться поля для ввода информации после запроса ее у абонента в ходе обработки звонка.

Таблица абонентов не лишена смысла и для входящей задачи. В этом случае каждый входящий звонок может либо создавать новую запись в таблице для ввода сопутствующей или запрошенной у абонента информации, либо искать по определившемуся номеру запись соответствующего абонента в таблице и предоставлять данные для модификации или вовсе отклонять звонок от абонента, не содержащегося в списке. Вид производимых действий зависит от реализуемого сценария и настроек каждой конкретной задачи.

Раздел дает возможность создавать и настраивать соответствующие таблицы.

В приведенном двойном списке выделите слева интересующий проект. Справа отобразятся все существующие в нем таблицы абонентов. Выделив необходимую, Вы можете редактировать и удалить ее, а также можете создать новую таблицу в выбранном проекте.

По характеру создания и доступа к информации они делятся на «локальные» и «внешние».

Локальная таблица

Создается внутри оперативной базы данных Oktell автоматически. Пользователю необходимо указать столбцы, заполнить таблицу данными. Информация внутри созданной таблицы доступна для редактирования и просмотра лишь через описываемый модуль, хотя и не закрыта для пользования непосредственно через БД. В связи с этим локальная таблица больше подходит для ограниченных списков, использующихся в небольших задачах, не имеющих продолжения и не требующих полномасштабного анализа статистики. В локальную таблицу возможна вставка табличных данных из буфера, а также импорт из файлов MS Excel.

По умолчанию для локальной таблицы при сохранении в БД автоматически генерируется уникальное название. Однако пользователь имеет возможность задать явное имя таблице для последующего обращения к ней из модуля статистических отчетов, диалговых форм или внешних приложений.

Все столбцы по умолчанию имеют строковый тип (nvarchar) с авторазмерностью (до 2000). Пользователь может по своему усмотрению задать любой другой тип данных для столбца. При смене типа данных столбца осуществляется попытка автоматического преобразования данных к новому типу. Однако следует помнить, что при обнаружении некорректных данных, преобразование которых невозможно, весь столбец с данными очищается (удаляется, а вместо него создается новый).

В локальной таблице всегда существует столбец Id, являющийся идентификатором абонента. Поэтому каждая строка в отличие от внешних таблиц представляет собой информацию по отдельному абоненту.

Создание локальной таблицы может производиться на базе уже существующей таблицы в БД. В этом случае она будет подключена и автоматически сформируется информация о столбцах, доступная к редактированию (название, тип данных, назначение, описание). Однако невозможно в режиме редактирования локальной таблицы подключиться к существующей таблице БД. Система в этом случае выдает отказ, так как в таблицу с новым именем будет преобразована имеющаяся и подключенная в данный момент таблица БД.

После создания таблицы при редактировании появляется возможность задания фильтрующего запроса на выборку данных из таблицы для осуществления звонков по задачам.

Смена имени таблицы БД внутри локального списка при редактировании производится с сохранением данных, но с удалением текущей таблицы. При удалении локального списка осуществляется запрос к пользователю на предмет необходимости удаления физической таблицы БД (как вариант таблица может быть оставлена в БД).

Внешняя таблица

Пользователю предоставляется возможность подключить в качестве таблицы абонентов набор данных из собственной таблицы или запрос в БД, возвращающий произвольный набор данных. Одно другого не исключает. «Таблица» здесь не всегда понимается в буквальном смысле.

· Таблица БД. Используется для сохранения данных, полученных от абонента в ходе реализации сценариев по задаче, а также при выборе режима вставки новых записей по поступающим звонкам во входящей задаче. Помимо этого таблица используется для получения информации, если отдельно не указан запрос на выборку данных.

· Запрос в БД. Если указан запрос, то выборка данных по абонентам для исходящей задачи будет формироваться на его основе, также как и загрузка данных по абонентам в сценарии и диалоговые формы. Запрос может быть сколь угодно сложным с разумным ограничением на время исполнения. В качестве примера использования можно привести задачу формирования данных по абоненту из нескольких таблиц, где раздельно хранятся телефоны и прочая информация, а также, если в ходе реализации задачи необходимо производить работу не со всеми абонентами в таблице, а по какому то заранее известному условию, например, где долг более 1000 рублей. Если в дополнение к запросу не указана базовая таблица с идентификаторами абонентов, то сохранение вводимых данных невозможно. Следует отметить, что запрос с течением времени может возвращать разные данные. При работе с исходящей задачей в моменты синхронизации перечень абонентов будет корректироваться в соответствии с возвращаемой выборкой.
ВНИМАНИЕ! Введенный текст используется для формирования более сложного запроса на получение данных. Поэтому в теле допускается использовать только одну команду SELECT (ORDER-группа допускается только вместе с использованием TOP).

Работа сервера логики не зависит от типа представления таблицы («внешняя» или «локальная»).

После выбора типа таблицы и указания способа получения данных производится переход на вкладку проверки и назначения типов столбцов.

Для локальной таблицы, как было отмечено выше, здесь доступно изменение таблицы. Выделите соответствующую запись, и щелкните в поле, которое хотите отредактировать. Появится курсор ввода текста, позволяющий изменять данные. Каждая строка представляет собой отдельного абонента, его идентификатор назначается автоматически и не виден пользователю. Чтобы создать новую запись вставьте курсор ввода в последнюю строку (пустую) и введите данные. При редактировании последнего столбца последней записи появится новая пустая строка. Пользователь может создавать/удалять столбцы, изменять данные в ячейках вручную, а также импортировать табличные данные из файлов Microsoft Excel и из буфера обмена, столбцы при этом автоматически создаются по необходимости. Из локальной таблицы возможен экспорт данных в файлы Excel. Соответствующая команда находится в контекстном меню.

ВНИМАНИЕ! Все создаваемые для локальной таблицы поля имеют строковый тип. Длина поля для хранения данных рассчитывается как максимальное значение длины среди всех сохраняемых данных в столбце, но не менее 50 символов. Это необходимо иметь в виду при формировании пустых локальных таблиц (для вставки данных) для использования с внешними задачами. Если прогнозируются объемные данные, то рекомендуется первой и единственной строчкой вставлять «бессмысленные» данные с целью формирования полей с соответствующим ограничением на длину.

Для внешней таблицы выполняется указанный запрос, или производится выборка из указанной таблицы при его отсутствии. Возвращаются первые 10 записей.

В обоих случаях (локальный и внешний тип таблиц) имеющимся в списке столбцам необходимо назначить типы. Среди обязательных типов:

· Поле идентификатора абонента. Числовое значение, уникально определяющее запись абонента. В таблице могут существовать несколько записей с одним идентификатором. При синхронизации поля всех таких записей считаются принадлежащими одному абоненту. Номера телефонов из разных записей объединяются. Прочая информация при загрузке берется из первой строки, при записи заносится во все строки. Поле идентификатора может быть только одно для таблицы абонентов.

· Поле номера телефона. В таблице может быть один или несколько столбцов типа «Номер». В каждой ячейке может лежать номер телефона или несколько номеров телефонов, разделенных запятыми, пробелами или прочими символами, отличными от +()-Ww и цифр. Полей номеров телефонов может быть неограниченное число. В случае, если соответствующие поля не заполнены данными, они игнорируются менеджером задач.

· Информационное поле. Значение полей с непустыми значениями подставляются в диалоговую форму оператора, а также в форму уведомления оператора о его резервировании на выполнение исходящей голосовой задачи в момент осуществления дозвона по номеру абонента (действует для типов задач «С резервированием оператора» и «С уведомлением оператора»). Информационных полей может быть неограниченное число. Все незаполненные данными значения игнорируются менеджером задач.

· Наименование. Значение поля наименование является аналогичным обычному информационному полю, однако наименование может быть только одно. Значение поля является первым и основным текстовым полем в списке, на которое оператор в первую очередь обращает внимание. Выводится в список информационных полей в том случае, если задано описание для поля.

· Прочие поля. Другие поля, а также перечисленные выше могут быть использованы для отображения данных в форме, для ввода данных из формы, для маршрутизации сценария, для озвучивания в IVR, а также для других необходимых действий. Доступ к ним осуществляется в сценариях посредством переменных типа «Поле таблицы» или непосредственными запросами на основании текущего идентификатора абонента.

Сохраненный список становится доступным для прикрепления к задачам внутри текущего проекта.

Любые поля таблицы абонентов доступны в сценариях всех типов, выполняемых по задачам, в которых таблица абонентов используется. Абсолютно любые поля доступны в сценариях для чтения с использованием переменных типа «Поле таблицы», имя которых совпадает с именем соответствующих полей. Однако аналогичным образом для записи доступны только поля, которые находятся в прикрепленной таблице в случае внешнего списка и все поля из локального списка. То есть, если в качестве источника для исходящей задачи используется внешняя таблица абонентов с типом «Запрос в БД», то запись не будет производиться в поля, не принадлежащие к прикрепленной таблице. И запись не будет производиться вообще, если прикрепленная таблица вовсе не указана.

ВНИМАНИЕ! При вставке в реальную таблицу БД в строковое поле с определенным ограничением на длину данных большей длины, вставка не осуществляется. Происходит генерация исключения с выводом информации в лог-журнал исключительных ситуаций. Если требуется избежать этого и вместо генерации исключения обрезать переходящие за рамки ограничения данные, в запросах необходимо явно приводить SQL-типы. Это можно сделать, например, так (здесь @a – внутренняя переменная):

Select cast ( @a as nvarchar ( 50 ) )

ВНИМАНИЕ! При вставке новых столбцов, а равно и при использовании внешних таблиц используйте в качестве имен латинские буквы и цифры. Несмотря на возможность использовать и другие символы, делать этого не рекомендуется во избежание ошибок, которые обычно длительно устраняются, и часто в этом случае не обходится без помощи технической поддержки. Чтобы представить оператору адекватные названия на родном языке, необходимо задать свойство «Описание» столбцам таблицы абонентов.

ВНИМАНИЕ! В задачах по умолчанию используется буфер синхронизации, позволяющий реализовывать различные варианты обхода таблицы абонентов. Однако в этом случае работа с большим количеством записей требует от сервера существенных ресурсов. Например, на сервере c процессором Intel Core2Duo 6300 и ОЗУ 1GB синхронизация с таблицей из 10000 абонентов происходит 0.5 секунды, 50000 абонентов - 2.2 секунды, 100000 абонентов - 7 секунд. Значительно возрастает объем используемой памяти. Синхронизационный буфер при формировании задач рекомендуется оставлять для таблиц с числом записей менее 50 тысяч. При настройке работы нескольких задач одновременно обращайте внимание на объем используемой памяти во избежание зависания системы. При необходимости прикрепления значительно больших таблиц используйте при настройке задач режим работы с таблицей через кэш внутри БД.

ВНИМАНИЕ! При организации массовых исходящих кампаний с большим числом операторов рекомендуется выносить БД на отдельную рабочую станцию или сервер, организовать распределение БД по нескольким жестким дискам. В обязательном порядке необходимо проверить наличие индекса по полю идентификатора основной прикрепленной таблицы. В случае отсутствия его необходимо создать.


Сценарии

Сценарий — это подпрограмма, автоматизирующая некоторую задачу, которую без него пользователь делал бы вручную, используя интерфейс клиентского приложения или иные подручные средства. Каждый сценарий представляет собой последовательность отдельных процедур и операций, выполняемых в контексте одного потока исполнения. Сценарии системы Oktell создаются пользователями, наделенными соответствующими правами. Создание и модификация доступны в ходе работы системы в графической оболочке клиентского приложения. Хранятся и исполняются сценарии на сервере интерпретатором соответствующего типа.

Модуль сценариев call-центра аналогичен модулю сценариев АТС раздела «Администрирование» с разницей в привязке к проектам, а также некоторых административных функциях, выполняемых общими сценариями системы. Хранение всех сценариев происходит на диске в каталоге проектов в виде папок, содержащих xml файл и прикрепленные к нему дополнительные файлы данных.

В системе существует 3 типа сценариев:

· Сценарии IVR (голосовое меню обработки звонка).
· Диалоговые сценарии (помощь оператору при обработке звонка в call-центре).
· Служебные сценарии (различные действия без привязки к линиям и операторам).

В разделе приведены общие принципы, объекты по работе всех типов сценариев. Ниже будут подробно изложены отличия каждого типа сценариев.

Модуль доступен администраторам БД, супервизорам и другим пользователям, имеющим соответствующее право. Для пользования модулем необходимо зарегистрироваться в call-центре системы.

В левой части списка находится перечень проектов. После выделения необходимого проекта в правой части отображаются принадлежащие ему сценарии. Созданные в рамках проекта сценарии (или импортированные в проект) становятся доступны для выбора в задачах соответствующего проекта. Задачи могут использовать и общие сценарии («Администрирование. Сценарии»), однако ссылку на них необходимо создавать вручную впечатывая его наименование.

В этом разделе:

— Общее

— Редактор сценариев

— Общие принципы обработчика сценариев

— Переменные

— Аргументы

— Выражения

— Функции

— Правило включения типов

— Проверка и сохранение сценариев.

— Общие компоненты сценариев

— Сценарии IVR

— Сценарии диалога

— Служебные сценарии


Общее

Любой сценарий состоит из набора отдельных компонентов. Компонентом сценария называется полностью законченный блок, осуществляющий конкретный характер действий. Каждый компонент обладает фиксированным рядом свойств, определяющих детали его работы. В сценарии каждый компонент может присутствовать несколько раз. Конкретное представление компонента в сценарии называется объектом сценария. Различные объекты могут иметь разные значения свойств. Все объекты соединяются логическими связями. Каждый объект после своей реализации передает управление одному из других объектов сценария по заложенным создателем условиям.

Сценарий может ветвиться и иметь циклы. Различные реализации одного и того же сценария могут отличаться друг от друга в зависимости от внешних факторов. Каждый компонент (соответственно и объект сценария) имеет некоторое количество возможных исходов своего действия, в результате чего может передать управление любому другому объекту текущего сценария (свойство перехода). Сценарий с ветвящейся логикой в момент реализации имеет фиксированную последовательность выполненных объектов.

Все типы сценариев обладают схожими наборами компонентов (сравнения, присвоения, общение с БД, пауза и прочие), однако каждый тип сценария имеет и свой уникальный набор компонентов, отражающих его суть.

Среди большого числа факторов, влияющих на поведение сценария, в учет могут быть взяты: время, дата, идентификаторы звонка, линий, пользователей, абонентов, внешняя информация из различных БД, xml и web-сервисов, вводимый абонентом с клавиатуры телефона сигнал DTMF, вычисляемые значения различных переменных внутри сценария, информация из форм ввода и пр.

При выполнении задачи, указанный сценарий берется из папки ее проекта. Если же сценарий в ней не найден, производится попытка найти сценарий среди общих сценариев системы. Точно также работает переключение сценариев. Вне зависимости от того, где находится текущий выполняемый сценарий, если он производит переключение на другой сценарий, поиск производится сначала в папке проекта текущей задачи, и в случае отсутствия в общей папке сценариев. Это может быть полезно при использовании одного сценария в нескольких разных проектах.

Оператор всегда может переключить абонента на сценарий IVR. Для этого ему необходимо нажать FLASH и набрать номер, за которым закреплен соответствующий сценарий. Переключение производится на текущий выполняемый сценарий (а не на сценарий, который был запущен после набора номера) с повторной передачей в него входного параметра.

Открыв модуль «Сценарии» в таблице слева выделите необходимый проект, справа отобразятся все сценарии, прикрепленные к нему. Вы можете создавать новые сценарии, а также редактировать и удалять существующие.

Сценарии хранятся и исполняются на серверах, редактирование же и создание их проходит на рабочих местах сотрудников. После внесения изменений в сценарий, его можно сохранить локально (сценарий будет доступен для дальнейшего редактирования только на данном рабочем месте), а можно отправить на сервер, при этом сценарий становится доступен как другим пользователям, так и системе. Любой другой пользователь, открывая сценарий с сервера, автоматически закачивает его себе на компьютер, и редактирование происходит на локальном компьютере.

В таблице со списком сценариев цвета иконки определяет место хранения сценария: только на сервере, только локально или на обеих машинах.

Сценарии доступны для импорта и экспорта. Соответствующие команды находятся в контекстном меню списка сценариев.


Редактор сценариев

Для перехода в режим редактирования дважды щелкните на названии сценария в таблице или нажмите кнопку «Создать» внизу.

Любой сценарий состоит из объектов, имеющих свойства. Каждый объект решает определенную задачу. Свойства объекта определяют детали действия объекта. Создание сценария происходит в графической оболочке системы Oktell, дающей возможность взглянуть на сценарий как на блок-схему.

Редактор сценариев состоит из 3 основных элементов управления:

· Среда визуального представления;
· Окно с перечнем доступных компонентов;
· Инспектор объектов.

Среда визуального представления сценария – это поле, в котором пользователь располагает объекты сценария и связывает их между собой стрелками перехода. В дальнейшем «поле сценария».

Окно с компонентами (открывается и закрывается нажатием F10 на клавиатуре). В этом окне перечислены все варианты доступных в данной категории сценариев компоненты. Выделите любой компонент (пользуйтесь всплывающими подсказками) и щелкните в любое пустое место поля сценария. Соответствующий выбранному компоненту объект с назначенными по умолчанию свойствами появится в поле.

Визуально объекты разделены на 4 группы:

· Общие объекты работы с данными;
· Индивидуальные объекты типа сценария;
· Общие объекты действий;
· Компоненты по работе с контакт-сервисом (SMS, e-mail, ICQ, факс).

В нижнем разделе находится выпадающий список вариантов отображения стрелок перехода в поле сценария. Они могут быть прямыми и строго горизонтально-вертикальными ломаными. Тип отображения влияет только на способ визуального восприятия.

Для смены типа нажмите кнопку «Перестроить».

Если объектов не выделено, будут перестроены все стрелки сценария.

Если выделен один объект, будут перестроены все исходящие из него стрелки.

Если выделены два или более объектов, будут перестроены только внутренние соединяющие их стрелки.

Инспектор объектов – окно для назначения свойств отдельных объектов (открывается и закрывается нажатием F11 на клавиатуре, открыть можно также двойным щелчком на любом объекте).

Инспектор постоянно отображает свойства и значения выделенных объектов сценария. В левом столбце находится название свойства, в правом столбце - текущее значение. Способ изменения значения свойства может принадлежать к одному из типов:

· Текстовое поле. Значение изменяется непосредственно в таблице инспектора.
· Выпадающий список значений. Для назначения доступны только перечисленные в выпадающем списке значения.
· Текстовое поле с кнопкой вызова формы настроек. Изменение значения происходит в индивидуальном формате в открывающейся форме. Для ее вызова необходимо щелкнуть в ячейке со значением по кнопке, находящейся в правой части и отображающейся после получения ячейкой фокуса ввода.

Некоторые свойства у компонентов индивидуальны (например, имя) и при групповом выделении объектов не отображаются в инспекторе. В то же время некоторые другие свойства у различных объектов могут быть одинаковы. При выделении группы объектов, каждый из которых содержит подобное свойство, они отображаются в окне инспектора и доступны для изменения. Изменение свойства происходит одновременно для всех выделенных объектов.

В поле сценария вы можете, пользуясь графической средой и мышкой, изменять положения объектов и, в большинстве случаев, задавать связи (назначать свойства перехода).

Для выделения объекта щелкните по нему левой кнопкой мыши. Щелчок с одновременным нажатием кнопки Shift на клавиатуре инвертирует текущее выделение.

Для выделения группы объектов растяните прямоугольную рамку от одной точки к другой (подобно векторным графическим редакторам). Щелчками по объектам с одновременно нажатой кнопкой Shift вы можете добавить/исключить соответствующие объекты из выделения.

Для перемещения выделенных объектов по полю нажмите и удерживайте левую кнопку мыши на выделении и тащите в необходимую область. При подведении к краям поля оно автоматически перематывается в сторону движения. После отпускания левой кнопки мыши все объекты переместятся, при этом все их связи сохранятся.

Для копирования существующего объекта или группы объектов сценария можно использовать буфер обмена. В контекстном меню выберите «Вырезать» или «Копировать» (или нажмите соответственно Ctrl+Х и Ctrl+C на клавиатуре) для проведения соответствующего действия с выделенными объектами. В необходимом месте любого сценария выберите пункт «Вставить» контекстного меню (или нажмите Ctrl+V) на клавиатуре. Все объекты, находящиеся в буфере, появятся в указанной области. Все свойства новых объектов будут идентичны свойствам объектов, находящихся в буфере обмена. Все свойства внутренних переходов также будут идентичны соответствующим свойствам объектов в буфере. Свойства перехода (стрелки), ведущие из объекта, находящегося в выделении, в объект, не находящийся в выделении (и наоборот) будут сброшены. При вставке объектов из одного сценария в другой будут полностью скопированы все переменные исходного сценария. У существующих переменных с идентичными именами будут изменены идентификаторы. Объекты, не подходящие по типу сценария вставлены не будут. Например, невозможно скопировать объект «Воспроизведение» из сценария IVR в диалоговый сценарий.

Также вы можете скопировать элементы, путем перехода в режим копирования в момент перетаскивания. Для этого одновременно с перетаскиванием (и нажатой левой кнопкой мыши) щелкните правой кнопкой мыши, курсор при этом приобретет соответствующий вид. Второй щелчок правой кнопки мыши отменяет режим копирования и возвращает режим перетаскивания.

Большие сценарии имеют достаточно много объектов. Для удобного расположения – выделяйте логические зоны сценария. Площадь поля сценария условно не ограничена. Вы можете перемещать и вставлять объекты в любые места. Используйте полосы прокрутки или движение мышью около краев видимой части поля в момент перетаскивания/копирования для осуществления прокрутки поля.

Логические зоны можно снабжать комментариями, отображаемыми непосредственно на поле. Для этого в панели инструментов необходимо выделить элемент с символом «T» и растянуть на поле зону с текстом. По аналогии с заданием свойств объектам сценария, комментарию в инспекторе объектов могут быть заданы текст и цвета.

Также в вашем распоряжении помощник обзора сценария. Подведите курсор в правый нижний угол поля сценария к пиктограмме с изображением ладони. Нажмите и удерживайте левую кнопку мыши для отображения формы обзора сценария. На ней сценарий представлен полностью и в уменьшенном виде. Используйте ее для быстрого перемещения, а также для визуальной оценки зон сценария.

Для быстрого задания свойств перехода или их очистки используйте кнопки мыши и клавишу Ctrl клавиатуры. Нажмите и удерживайте клавишу Ctrl, после чего нажмите кнопку мыши на объекте и тяните появившуюся стрелку к необходимому объекту (для задания) или в пустое место поля (для очистки). При появлении соответствующей рамки на объекте-назначении отпустите кнопку мыши, зафиксировав значение свойства перехода. Вы можете задавать свойство перехода одновременно для группы выделенных объектов. Левая кнопка мыши используется для назначения прямых свойств перехода (большинство), правая кнопка мыши используется для назначения побочных свойств перехода (таких как, например, свойства «Переход в прочих случаях» и «Переход, если неудача»). Для удобства работы с компонентами, имеющими большое число стрелок перехода, существует возможность тянуть стрелки с нажатыми цифровыми клавишами на клавиатуре подобно нажатию Ctrl в вышеописанном случае. Соответственно порядковому индексу свойства перехода в компоненте 1 – для задания первого свойства, 2 – для задания второго, и т.д. Стрелки, определяющие дополнительные свойства перехода, а также переходы, сопоставленные некоторым пользовательским значениям, имеют подписи-подсказки. В редакторе сценариев стрелки перехода не являются объектами, поэтому рисуются автоматически.

Для более детального задания свойств используйте инспектор объектов.

Все компоненты сценариев будут достаточно подробно описаны в блоках «Компоненты сценариев». Также там будут рассмотрены их свойства, возможные значения и значения по умолчанию, вариации в работе компонентов в зависимости от значений свойств, а также формы для задания и просмотра значений свойств.


Общие принципы обработчика сценариев

Обработчик сценария в зависимости от типа сценария может быть запущен разными способами.

· IVR

o поступление входящего звонка;
o начало обработки звонка по задаче автоматического оповещения;
o звонок на внутренний номер, за которым назначен сценарий IVR;
o передача управления из одного сценария в другой;
o входящий звонок на задачу автоматической обработки;
o переключение оператором абонента на номер, за которым назначен сценарий IVR;
o переадресация на внешние номера с детальным указанием направлений;
o гибкая маршрутизация (Вход в АТС) при снятии трубки на любом внутреннем телефоне и переключениях;
o обработка вызовов, поступающих в момент ожидания завершения всех коммутаций при перезапуске сервера.

· Диалоговый

o начало обработки звонка по задаче приема звонков оператором;
o начало обработки звонка по задаче исходящего оповещения оператором;
o запрос оператору на дозвон в задаче с резервированием и запросом;

· Служебный

o по таймеру, по расписанию;
o после разрыва связи с внешней линией с передачей в сценарий собранного контента;
o в ходе отработки контрольных событий;
o вложенный запуск из других служебных сценариев;
o асинхронный параллельный запуск из любых сценариев с передачей кода сессии и значений всех переменных;
o исходящие текстовые задачи (также ICQ, e-mail и служебные действия);
o активация контрольного события;
o асинхронный запуск служебного сценария из других сценариев;
o набор номеров в менеджерах задач и автодозвона;
o преобразования строк.

В ходе обработки сценария сервер поочередно выполняет соответствующие команды или преобразования, которые определяются объектами. Все обработанные объекты выстраивается в одну последовательность. Очередной объект определяется результатами выполнения предшествующего ему объекта. Выполняемый в текущий момент времени объект – активный объект.

При реализации сценариев по задачам call-центра, у сценария появляется доступ к информации о текущей выполняемой задаче, а также доступ на чтение и/или запись к строке текущего абонента в прикрепленной к задаче таблице абонентов.

Ход обработки можно проследить на примере. Производится звонок по задаче на исходящее оповещение. К задаче прикреплена таблица с информацией об абонентах. Звонок был произведен на одного из них. В диалоговые формы заносится информация из полей таблицы, соответствующих этому абоненту, маршрутизация звонка происходит на основе имеющейся в БД информации, а также на основе введенной абонентом или оператором информации. Вся введенная информация попадает в ту же таблицу в другие поля, или перезаписывает имеющиеся. При автоматической обработке абоненту могут быть озвучены значения полей из таблицы. Вся полученная информация помимо прикрепленной таблицы может быть загружена во внешнюю БД в ходе реализации сценариев IVR или диалога с указанием параметров задачи, по которой производился звонок. Точно также сценарий диалога может всю имеющуюся информацию выгрузить наружу и запустить любое внешнее приложение, включая PHP и ASP.NET скрипты.


Переменные

Переменная сценария – это величина, хранящая свое значение на всем протяжении выполнения сценария. У некоторых объектов существует доступ к чтению значения переменной и к его изменению.

Переменные в сценариях принадлежат к одному из типов:

· Число (целое или десятичное);
· Строка;
· Дата/время;
· Поле таблицы;
· Служебные (только для присвоение значений).

Все переменные сценария определяются на этапе его создания. При назначении свойств, имеющих своим значением переменную, пользователь может редактировать список переменных, а также выбирать и подставлять в значение свойства ссылку на конкретную переменную.

В именах переменных не допускаются символы '[', ']', '\'. Запрещены также дублирующие имена.

Переменные используются в сценарии для переноса значения из одних объектов в другие. Например, заполнение переменной может происходить в БД (соответственно компонент «Запрос в БД»), а использование при воспроизведении этого значения абоненту (компонент «Воспроизведение числа») или при определении необходимой ветки сценария (компонент «Сравнение») путем выбора следующего обрабатываемого объекта на основании значения этой переменной.

Для работы с переменными (создание, удаление, подстановка) служит соответствующая вкладка окна «Аргумент». При подстановке переменной в качестве значения свойства объекта ее значение вычисляется или назначается (в зависимости от типа свойства) в сценарии в момент работы объекта-владельца.

Переменные типа «Поле таблицы» используются в сценарии наравне с другими переменными, но имеют совершенно иную структуру. Каждый запрос на получение данных из такой переменной обращается к таблице абонентов, прикрепленной к текущей выполняемой задаче. По имени такой переменной ищется столбец в соответствующей таблице и производится запрос данных из ячейки на пересечении найденного столбца со строкой, содержащей информацию о текущем абоненте. При записи производится аналогичное действие. Если не найден столбец с указанным именем, либо строка с кодом текущего абонента, действие по записи не производится, а при чтении возвращается пустая строка. Подобный усложненный характер работы обусловлен тем, что сценарий создается независимо от задачи и таблицы абонентов и не имеет информации о них до начала выполнения на сервере. В дальнейшем в руководстве переменные типа «Поле таблицы» не будут рассматриваться обособленно, работа с ними полностью аналогична переменным других типов.

В списке доступных переменных переменные типа «Поле таблицы» отображаются зеленым цветом.

ВНИМАНИЕ! Использовать переменные типа «Поле» в сценарии рекомендуется в режиме «1 чтение, 1 запись». Если необходимо использовать значение переменной типа «Поле таблицы» в сравнении или других промежуточных объектах, с точки зрения скорости работы лучше после считывания из базы сохранять ее значение во временной переменной (число, строка, дата/время) и использовать на протяжении сценария именно временную переменную.

ВНИМАНИЕ! Связь переменных типа «Поле» осуществляется как с локальными таблицами абонентов, так и с внешними. Однако, если внешняя таблица абонентов формируется только лишь на базе запроса в БД, связь не будет осуществлена. Поиск полей производится только среди столбцов указанной базовой таблицы БД вне зависимости от того, используется ли параллельно с этим запрос в БД. Подробнее в разделе «Таблицы абонентов».

В каждом типе сценариев существует перечень служебных переменных. Они доступны только в компоненте «Присвоение значения переменной» в качестве приемщика значения. Такие переменные связывают логику выполняющейся задачи с исходом выполнения сценария. Принимая в расчет соответствующие значения в случае их корректности, сервисы-владельцы сценариев будут действовать соответствующим образом. По умолчанию значения переменных выставлены в «-1», что указывает обслуживающим сервисам на отсутствие необходимости учета.

В списке доступных переменных служебные переменные отображаются серым цветом.

Переменные размещаются в хранилище обработчика сценариев и существуют в рамках его жизни. Каждый экземпляр обработчика (даже если они реализуют один и тот же сценарий) имеет свой экземпляр каждой переменной. Запуск вложенных сценариев осуществляется в том же самом обработчике, поэтому переменные с одинаковыми именами имеют одно и то же размещение, и, соответственно, их значения перетекают из сценария в сценарий при запуске и при возврате управления.

При запуске асинхронных служебных сценариев значения переменных с совпадающими именами и типами копируются в хранилище значений переменных запускаемого обработчика, дальше переменные существуют независимо в каждом обработчике.

При создании переменной можно установить для ее размещения глобальное хранилище сессии. В этом случае разные на низком уровне обработчики будут связаны между собой через идентификатор сессии, совпадающий с кодом цепочки коммутаций. Например, если создать глобальные переменные с одинаковым именем в нескольких сценариях IVR, в диалоговом и служебном сценарии, то при входящем звонке можно организовать следующую схему: в главном сценарии IVR переменной устанавливается значение. Далее звонок переходит в задачу, в ходе обработки которой запускается сценарий диалога. Обращаясь к глобальной переменной он получит установленное ранее в сценарии IVR значение. При переключении оператором абонента на второй сценарий IVR, там может быть доступно модифицированное в сценарии диалога значение. Служебный сценарий (запущенный асинхронно или как обработчик контента) также будет иметь доступ к значению, установленному ранее в других сценариях. Все это происходит, потому что глобальная переменная хранится на сервере состояний и все сценарии обращаются к одной области памяти, поскольку все связаны с обработкой звонка в сессии - цепочке коммутаций, инициированной входящим звонком абонента.

Любой служебный сценарий перенимает номер сессии от запускающего объекта - другого сценария, задачи, линии. Служебные сценарии, стартующие вне канальных сессий (цепочек) генерируют уникальный код. При организации набора номера в служебном сценарии (компонент «Дозвон») в качестве кода цепочки активированного канала устанавливается код сессии служебного сценария, но не более 1 раза и только в случае, если код сессии сценария не был передан извне. В остальных случаях код цепочки будет генерироваться. Так происходит во избежание дублирования кодов цепочек в разных по смыслу звонках.


Аргументы

Компоненты сценариев оперируют аргументами. Аргументом сценария называется некий объект, значение которого может быть вычислено в любой момент в ходе выполнения сценария по запросу активного компонента.

В качестве аргумента могут выступать:

· Фиксированное значение (константа);
· Переменная (в частности поле прикрепленной таблицы в строке соответствующей звонку);
· Выражение (арифметические и строковые операции с переменными, константами и функциями от них).
· Одна из встроенных функций, заложенных в обработчик сценариев соответствующего типа;
· SQL запрос в БД (только в диалоговых и web-формах)

Значение аргумента может принадлежать к одному из типов:

· Число (целое или десятичное);
· Строка;
· Дата/время.

Аргументы задаются с помощью специального окна, предоставляющего доступ к определенным вкладкам в зависимости от разрешенных в конкретной ситуации типов и сущностей. Окно появляется при задании свойства типа «Аргумент» любому из объектов сценария.

В окне выбора аргумента доступны несколько вкладок, каждая из которых дает доступ к соответствующему ей типу аргумента. Константа, Переменная, Выражение, Функция, Запрос SQL. В зависимости от места применения некоторые вкладки могут быть недоступны.

Внутренние переменные сценария могут создаваться, редактироваться и удаляться на вкладке «Переменные» окна выбора аргумента. Для редактирования доступно имя переменной, а тип переменной редактированию не подлежит в целях избежания некорректных ситуаций.

Вычисление значения аргумента производится на этапе выполнения сценария на сервере при передаче управления объекту сценария, свойство которого определяет данный аргумент. Результат вычисления подставляется в качестве значения соответствующего свойства объекта.


Выражения

Выражение — это заданная создателем сценария последовательность арифметических или строковых действий, оперирующая с константами и переменными и функциями от них. Выражение используется для подстановки в качестве аргумента в значение объектов сценария. Значением выражения могут являться строка и число. Для явного указания строки заключайте текст в кавычки. В противном случае, сначала будут вычислены все арифметические комбинации, доступные для расчета. В приведенных примерах 7 и 8 результат будет разный, то есть началом результирующей строки примера 7 будет являться символ «5», а примера 8 – символы «23».

Примеры числовых выражений:

· [переменная_число_1] + 1
· 2 ^ [переменная_число_2] * ( Log10 ( [переменная_число_3] ) + 2 )
· Sin ( Len ( [переменная_строка_1] ) )

Примеры строковых выражений:

· [переменная_строка_1] + [переменная_строка_2]
· Кусок текста + [ переменная_строка_1]
· "Кусок текста" + [переменная_строка_1]
· 2 + 3 + [переменная_строка_1]
· "2" + "3" + [переменная_строка_1]
· SubStr ( [переменная_строка], 1, Length ( [переменная_строка] ) - 1 )

Для задания выражения служит соответствующая вкладка окна «Аргумент». Выражения вычисляются в сценариях и результат вычисления подставляется в качестве аргумента текущего выполняемого объекта (свойства объекта) сценария.

Операции и подстановочные функции, доступные для использования в составе выражений:

Операция | Параметры | Тип возвращ. значения | Описание
+ | s1 + s2 x1 + x2 s + x x + s | строка число строка строка | Если один из операндов функции является строкой, то возвращаемым значением будет строка, склеенная из двух частей. Если все операнды являются числами, результатом будет число.
- | x1 - x2 | число | Вычитает из числа X1 число X2.
* | x1 * x2 | число | Перемножает числа X1 и X2.
/ | x1 / x2 | число | Делит число X1 на число X2.
^ | x1 ^ x2 | число | Возводит число X1 в степень X2.
( ) |  |  | Выставление приоритета любой арифметической операции.
% | x1 % x2 | число | Возвращает действительный остаток от деления.
& | x1 & x2 s1 & s2 x & s s & x | число строка строка строка | Соединяет числа или строки (в строковом представлении). Примеры: 2.16 & 3 => 2.163; "2" & 5 => "25"; 2 & -3 => "2-3"

Функции для работы со строковыми и числовыми значениями, доступные для использования в составе выражений:

Функция

Параметры

Тип возвращ. значения

Описание

Abs (x)

x - число

Число

Абсолютная величина числа X.

Cos (x)

x - число

Число

Косинус угла, определяемого параметром X в радианах.

Ceil (x)

x - число

Число

Округляет число до целого в большую сторону.

Char (x)

x - число

Строка

Возвращает ANSI-символ, соответствующий коду X (0 - 255).

Eval (s)

s - строка

Число, строка

Осуществляет расчет вложенного выражения, содержащегося в строке-параметре. Таким образом, давая возможность динамически задавать выражения вне сценария.

Примеры: Eval ( "1 + 3" ) => 4; Eval ( "Привет" ) => ошибка; Eval ( " 'Привет' ") => "Привет"; Eval ( [cтр.переменная_1] ) => результат выполнения выражения, заданного в переменной; Eval ( " [стр.переменная_1] " ) => возвращает содержимое переменной.

Exp (x)

x - число

Число

Экспонента числа X.

Floor (x)

x - число

Число

Округляет число до целого в меньшую сторону.

IndexOf (s1, s2)

s1 - строка,

s2 - строка

Число

Ищет подстроку S2 в строке S1 и возвращает номер позиции. Отсчет ведется с 0 символа. В случае, если подстрока не найдена, возвращается -1.

Length (s)

s - строка

Число

Длина строки S в символах.

Lg (x),

Log10 (x)

x - число

Число

Десятичный логарифм числа X.

Ln (x)

x - число

Число

Натуральный логарифм числа X.

Log (x, y)

x - число

y - число

Число

Логарифм числа Y по основанию X.

Если в функцию передается один параметр - возвращается его натуральный логарифм.

Max (x, y)

x - число

y - число

Число

Максимум из двух чисел X и Y.

Min (x, y)

x - число

y - число

Число

Минимум из двух чисел X и Y.

Num (s)

s - строка

Число

Принудительное преобразование строки к числу. Если строка не является корректным числом, возвращает 0.

Numval (s)

s - строка

Число

Принудительное преобразование строки к числу. Если строка не является корректным числом, возвращает число, преобразованное из максимального количества начальных символов строки-параметра, соответствующих корректному представлению.

Random (x)

x - число

Число

Случайное целое число из отрезка [0, x-1].

Remove (s, idx, len)

s - строка,

idx - число,

len - число

Строка

Возвращает строку, полученную удалением из строки S символов в количестве LEN, начиная с позиции IDX. Отсчет ведется с 0 символа.

Replace (s, s1, s2)

s - строка,

s1 - строка,

s2 - строка

Строка

Возвращает строку, образованную замещением в строке S всех встречающихся подстрок S1 на подстроки S2.

Round (x)

x - число

Число

Ближайшее целое значение числа X.

Sin (x)

x - число

Число

Синус угла, определяемого параметром X в радианах.

Sqr (x)

x - число

Число

Квадрат числа X.

Sqrt (x)

x - число

Число

Квадратный корень числа X.

Str (x)

x - число

Строка

Принудительное преобразование числа к строке.

Substr (s, idx, len)

s - строка,

idx - число,

len - число

Строка

Возвращает вырезанную из строки S подстроку длиной LEN, начиная с позиции IDX. Отсчет ведется с 0 символа.

Tan (x)

x - число

Число

Тангенс угла, определяемого параметром X в радианах.

Trim (s)

s - строка

Строка

Возвращает строку, в которой исключены начальные и конечные пробельные символы.

TrimEnd (s)

s - строка

Строка

Возвращает строку, в которой исключены конечные пробельные символы.

TrimStart (s)

s - строка

Строка

Возвращает строку, в которой исключены начальные пробельные символы.

Функции для работы со значениями Дата/время, доступные для использования в составе выражений.

В качестве параметра функций, ожидающих значения Дата/время, может быть передано значение типа Дата/время, либо строковое в установленном формате. Стандартным форматом представления даты в строке является формат «dd.MM.yyyy HH:mm:ss», либо любой другой, установленный в системе или упомянутый в конфигурационном файле серверного приложения.

Функция | Параметры | Тип возвращ. значения | Описание
Date (d) | d - дата/время или строка | Дата/время | Возвращает дату, сформированную на основе параметра (начало дня - время дня нулевое).
DateTime ( Y[, M[, D[, H[, m[, s[, ms]]]]]] ) | Y, M, D, H, m, s, ms - числа | Дата/время | Возвращает дату/время, сформированную на основе переданных параметров, которые могут быть не указаны. Соответственно: год, месяц, день, час, минута, секунда, миллисекунда.
DateTime (s) | s - строка | Дата/время | Принудительное преобразование строки к формату Дата/время.
DayOfWeek (d) | d - дата/время или строка | Число | День недели, которому соответствует дата-параметр (1-7).
DayOfYear (d) | d - дата/время или строка | Число | Порядковый номер дня в году.
Hour (d) | d - дата/время или строка | Число | Час.
Millisecond (d) | d - дата/время или строка | Число | Миллисекунда.
Minute (d) | d - дата/время или строка | Число | Минута.
Month (d) | d - дата/время или строка | Число | Месяц.
Second (d) | d - дата/время или строка | Число | Секунда.
Year (d) | d - дата/время или строка | Число | Год.

Специальные символы, доступные для использования в составе выражений:

Спецсимвол | Параметры | Тип возвращ. значения | Описание
EndLine (), EndLine | нет | Строка | Возвращает символ конца строки.
Tab (), Tab | нет | Строка | Возвращает символ табуляции.
Quot (), Quot | нет | Строка | Возвращает символ одинарной кавычки.
DblQuot (), DblQuot | нет | Строка | Возвращает символ двойной кавычки.

Константы, доступные для использования в составе выражений:

Константа | Тип возвращ. значения | Описание
Pi | Число | Число «Пи». 3,1415926...
Fi | Число | Число «Фи». 1,6180339...
E | Число | Число «E». 2,74182818...

В качестве типов параметров (число и строка) указаны ожидаемые типы, в которые будет производится преобразование. Однако параметрами могут являться переменные другого типа, если они удовлетворяют правилу включения типов.

Безпараметровые функции можно указывать в выражении как с пустыми круглыми скобками в конце, так и без них.


Функции

Встроенная функция сценария осуществляет доступ к некоторым данным в момент выполнения сценария обработчиком.

Среди функций можно выделить несколько типов по направлению их действия:

· Оперирующие конкретным звонком и обслуживающей линией;
· Временные;
· Общие серверные (определяющие некоторые состояния системы);
· Специальные функции конкретного типа сценария.

Для задания функции сценария служит соответствующая вкладка окна «Аргумент». Значение функции вычисляется в момент обработки сценария и подставляется в качестве аргумента текущего выполняемого объекта (свойства объекта) сценария.

Список встроенных функций сценариев:

Функция

Тип возвращ. значения

Типы сценариев

(IVR, Д, С)

Описание

Код сессии сценария

Строка

Все

Текущий уникальный код сессии сценария (строковое представление GUID), в соответствии с которым осуществляется доступ к хранилищу глобальных переменных, формируются цепочки коммутаций при дозвоне.

Текущая дата

Дата/время

Все

Текущая дата.

Текущий год

Число

Все

Текущий год.

Текущий месяц

Число

Все

Текущий месяц.

Текущий день

Число

Все

Текущий день.

Текущий день недели

Число

Все

Текущий день недели (1-7).

Текущее время

Строка

Все

Текущее время.

Текущий час

Число

Все

Текущий час.

Текущая минута

Число

Все

Текущая минута.

Текущая секунда

Число

Все

Текущая секунда.

Номер абонента (CallerId)

Строка

IVR, Д

Для внешних линий - определитель номера абонента (если не определен – строка «Номер не определен»).

Для внутренних линий (только в IVR) - номер пользователя, который обслуживается в сценарии. В качестве номера возвращается строка, начинающаяся с символа «U» и соответствующая прямому сервисному внутреннему номеру, назначенному на пользователя. Такие номера недоступны для набора непосредственно с телефона из-за спец.символов и используются только для служебных целей. Этот номер может быть подставлен в качестве аргумента в компоненты сценария, имеющие свойство «Внутренний номер получателя» (Уведомление, Голосовая почта и др.).

Набранный (внешний) номер (CalledId)

Строка

IVR, Д

Номер, по которому дозвонился абонент (актуально для потоков Е1). Если номер не определился – подставляется значение из свойства внешней линии.

Для внутренних линий (только в IVR) - номер, по которому был осуществлен вход в текущий сценарий из АТС. При звонке с IP-телефона: если номер дозвона в АТС в начальных символах содержит внутренний номер для входа в сценарий, то в сценарии функция вернет всю последовательность. Например: номер сценария 25, на IP телефоне набрали 2511 CALL => функция вернет 2511.

XML-INFO абонента

Строка

IVR, Д

Строка, сформированная внешним приложением, и переданная вместе со звонком из собственного интеграционного модуля SipClient (подробнее в руководстве по интеграции, раздел «Звонок разработчику»). Может быть подвергнута разбору в сценарии и использована для проведения произвольной маршрутизации вызова. Вызов поступает на каналы шлюзов с типом регистрации «Вхощящие из COM-клиента».

Guid-идентификатор пользователя

Строка

IVR

Строка, содержащая идентификатор пользователя, который обслуживается в сценарии.

Имя пользователя

Строка

IVR

Используется для внутренних линий всех типов, которые связаны с пользователем. Для остальных возвращает пустую строку.

Имя обслуживаемого в сценарии пользователя.

Номер пользователя внутри АТС

Строка

IVR

Используется для внутренних линий всех типов. Для внешних возвращает пустую строку.

Определяет внутренний стандартный номер, по которому можно дозвониться до обслуживаемой линии (и/или пользователя) - далее обслуживаемые объекты.

Если во внутреннем номерном плане содержатся несколько номеров со ссылками на обслуживаемые объекты, то будет выбран негрупповой - тот, в списке ссылок которого присутствует единственный объект - обслуживаемый (линия или пользователь). Если негрупповой номер отсутствует, то преимущественно будет выбран тот групповой, в котором объект является основным (стартующим в правиле вызова первым и единственным среди первых). Если такие номера тоже отсутствуют, то выбран будет тот, у которого объект является одним из основных (стартующим первым, но не единственным среди первых). В конце концов будет выбран любой групповой номер, где присутствует объект.

Тип линии

Строка

IVR, Д

Число, определяющее типа линии

· 1 - Внешняя аналоговая;
· 2 - Внутренняя аналоговая;
· 3 - VoIP канал;
· 4 - Внешняя GSM;
· 5 - IP;
· 6 - Канал потока Е1.

Номер линии

Строка

Все

Строка, определяющая номер линии по идентификации АТС Oktell (1001, 1549 и т.п.). Можно посмотреть в модуле «Администрирование. Линии».

В служебном сценарии функция возвращает непустое значение только в некоторых режимах, например при использовании сценария в качестве преобразователя callerid на входящих вызовах.

Код направления

Строка

IVR

Строка, определяющая код первого найденного активного направления, в котором присутствует обслуживаемая IVR-сценарием линия.

Время в текущем сценарии

Число

Все

Время в секундах, прошедшее после запуска непосредственно текущего сценария.

Время в обработчике сценариев

Число

Все

Время в секундах, прошедшее после запуска текущей сессии сценариев.

Тип соединения

Число

IVR, Д

1 – Звонок с внутренней линии на внешнюю (Только диалоговый)

2 – Звонок с внутренней линии в IVR

4 – Звонок с внешней линии в IVR

5 – Звонок с внешней линии на внутреннюю (Только диалоговый)

7 – Звонок из IVR на внешнюю линию (из задачи)

8 – Звонок из IVR на внутреннюю линию (из задачи)

Количество свободных внешних линий

Число

IVR, Д

Число свободных внешних линий, находящихся в активном состоянии.

Количество абонентов на набранном номере

Число

IVR, Д

Число абонентов, дозвонившихся на тот же номер, что и текущий абонент. Используется для обрубания вызовов по конкретным номерам при превышении лимита допустимого количества подключений.

Количество зарегистрированных операторов

Число

Все

Число операторов, находящихся в call-центре онлайн (в свободном и занятом режимах, исключая перерывы).

Количество свободных операторов

Число

Все

Число операторов, находящихся в call-центре в свободном состоянии, готовых обработать вызов незамедлительно.

Случайное число

Число

Все

Случайное число от 0 до 999999 (равномерное распределение).

Id оператора

Строка

Д

Идентификатор текущего оператора в виде

«00000000-0000-0000-0000-000000000000».

Необходимо помнить, что в ходе обработки сценария диалога операторы могут переключаться.

Имя оператора

Строка

Д

Имя текущего оператора.

Внутренний номер оператора (Uguid)

Строка

Д

Номер оператора, обслуживающего текущий звонок. Кодовое представление номера. Необходим для компонентов «Уведомление», «Определение статуса», и других, в которых требуется указание номера.

Хост оператора

Строка

Д

Имя компьютера оператора, обслуживающего текущий звонок.

Id задачи

Строка

Все

Идентификатор текущей задачи, в ходе обработки которой был запущен сценарий.

Код задачи

Строка

Все

Код текущей задачи, в ходе обработки которой был запущен сценарий.

Название задачи

Строка

Все

Название текущей задачи, в ходе обработки которой был запущен сценарий.

Параметр задачи

Число

Все

Параметр запуска сценария, переданный из задачи, куда попал в свое время в момент ее создания из компонента «Задание на звонок».

Код абонента в списке

Число

Все

Идентификатор абонента в прикрепленной таблице абонентов.

Id коммутации

Строка

IVR, Д

Уникальный идентификатор коммутации.

Id цепочки коммутаций

Строка

IVR, Д

Уникальный идентификатор звонка (сессии) внутри АТС Oktell.

Id sip-сессии

Строка

IVR

По умолчанию уникальный идентификатор sip-сессии из поля «Call-ID».

КС: идентификатор

Строка

С

При запуске служебного сценария для обработки контрольного события Guid-идентификатор контрольного события в строковом представлении.

КС: название

Строка

С

При запуске служебного сценария для обработки контрольного события название контрольного события.

КС: идентификатор задачи

Строка

С

При запуске служебного сценария для обработки контрольного события Guid-идентификатор задачи, в которой событие обнаружено, в строковом представлении.

КС: идентификатор оператора

Строка

С

При запуске служебного сценария для обработки контрольного события Guid-идентификатор оператора, совершившего контрольное событие, в строковом представлении

КС: показатель

Число

С

При запуске служебного сценария для обработки контрольного события числовой показатель соответствующего события.

КС: описание

Строка

С

При запуске служебного сценария для обработки контрольного события дополнительное текстовое поле с информацией о деталях события.

Инициатор дозвона. Тип

Строка

С

Определяет инициатора запуска служебного сценария в некоторых режимах.

«КС» - сценарий запущен как обработчик контрольного события.

«Задача» - сценарий запущен как набор номера в задаче.

«АДЗ» - сценарий запущен как набор номера в автодозвоне.

В других случаях возвращается пустая строка.

Инициатор дозвона. Идентификатор (задача/пользователь)

Строка

С

Для вышеприведенных типов запуска служебного сценария возвращает Guid-идентификатор в строковом представлении соответственно контрольного события, задачи, пользователя, запустившего автодозвон. В других случаях возвращается пустая строка.

Инициатор дозвона. Имя (задача/пользователь)

Строка

С

Для вышеприведенных типов запуска служебного сценария возвращает название соответственно контрольного события, задачи, пользователя, запустившего автодозвон. В других случаях возвращается пустая строка.

Инициатор дозвона. Внутренний номер (пользователь)

Строка

С

Для режима запуска служебного сценария в качестве набора номера в режиме автодозвона возвращает внутренний номер пользователя, инициировавшего автодозвон. В других случаях возвращается пустая строка.


Правило включения типов

При задании значений переменным, сравнении, а также прочих операциях, где участвуют два аргумента, возможно допущение логической ошибки – сравнение данных разных типов (например, строки и числа). Сервер логики Oktell помогает решить подобные задачи и исключить подобные некорректности использованием правила включения типов.

Правило: если на выходе при подстановке значения переменной требуется строка, то ее значение переводится в строку без потерь. Если требуется число или дата/время, то обработчик сценария пытается преобразовать значение переменной к нужному типу, и в случае невозможности корректного приведения типов в качестве результата будет взято значение по умолчанию (для типа «число» – это 0, для типа «строка» – это пустая строка, для типа «дата/время» – это текущая дата/время).

В качестве примеров:

· Целое число 1 корректно переходит в строку «1»;
· строка «1» менее корректно переходит в число 1, поскольку в строке могут содержаться нечисловые символы;
· десятичное число 1,5 корректно переходит в строку «1.5»;
· Строка «1.5», а также «1,5» переходит в десятичное число менее корректно;
· Дата/время корректно преобразуется в строку, определяемую текущими настройками операционной системы (в стандартной русской раскладке «25.12.1981 12:30:00»);
· Перевод из строки в тип «дата/время» наименее корректен в силу больших различий в представлениях дат;
· Перевод из числа в дату и наоборот – некорректен;
· Перевод из строки, содержащей «лишние символы» в число – некорректен;
· Перевод из строки, содержащей текст, не соответствующий представлению дат/времени в строках в операционной системе сервера, в дату – некорректен.

Использование разных типов в одной операции может привести к нежелаемым последствиям для создателя сценария. Имейте это в виду при редактировании сценариев, и, по возможности, не допускайте подобного назначения свойств (за исключением случаев, когда это крайне необходимо и продиктовано форматом хранения данных в БД, а также необходимостью преобразования в число символов, набираемых абонентом с клавиатуры телефона).


Проверка и сохранение сценариев.

После создания сценария его можно проверить на корректность на странице «Сохранение». Эта процедура необязательна, но рекомендуема для исключения очевидных «ляпов». В режиме редактирования сценария перейдите на вкладку «Сохранение». Нажмите кнопку «Проверить» внизу и дождитесь окончания.

После проверки в заполненном списке будет приведена статистика по сценарию, а также все замечания и ошибки, которые рекомендуется проанализировать создателю сценария.

Все ошибки и замечания можно классифицировать на 2 типа:

· Общие замечания и ошибки, относящиеся к сценарию в целом (например, отсутствие стартового элемента) необходимо тщательно проанализировать. Общие замечания выводятся перед началом проверки свойств объектов, и вы их увидите в самом начале списка.
· Ошибки и замечания по значениям свойств объектов.

Двойным щелчком мыши на замечаниях и ошибках, которые относятся к отдельным объектам, вы задействуете процедуру автоматического выделения и центрирования соответствующего объекта и осуществите переход на вкладку редактора сценария. Используя инспектор объектов (F11), поправьте ошибку или замечание и вернитесь вновь на вкладку «Сохранение». Такими же двойными щелчками проанализируйте свойства всех объектов, после чего вновь нажмите кнопку «Проверить».

ВНИМАНИЕ! В сценарии могут оставаться некоторые замечания и ошибки, при этом сервер выполнит сценарий корректно с точки зрения логики комплекса Oktell. Но возможно, что при этом некоторые компоненты будут вести себя неожиданно для создателя.

Пример: Ошибками будут помечены все свойства типа «Переход» объектов, для которых не заданы значения, что, впрочем, не приведет к невозможности сохранить сценарий (как локально, так и на сервер). Однако учитывайте, что если обработчик сценария в момент получения объекта обнаружит пустое свойство перехода – он автоматически прервет выполнение сценария (а для сценария IVR — повесит трубку на обрабатываемой линии).

После внесения необходимых изменений сценарий подлежит сохранению. Сохранение производится на той же вкладке «Сохранение». Вы можете задать/изменить имя для созданного или редактируемого сценария. Сохранение сценария проводится локально. Таким образом, можно длительное время редактировать сценарий, который работает в реальном времени на сервере и находится совершенно в иной реализации. Чтобы сохранить сценарий на сервер – нажмите кнопку «На сервер» внизу. При этом будет проведена попытка сохранить сценарий на сервере. В случае неудачи (отсутствие доступа к одному из файлов, если он существует и используется) будет выдано окно с уведомлением. Немного подождите, и попробуйте снова.

Сценарий может быть сохранен в режиме отладки. В этом случае будут отображаться все уведомления, для которых установлено свойство отладки. В нормальном режиме работы они пропускаются. Режим отладки может применяться для создания масштабных сценариев и вывода временных значений. Отключение режима отладки для сценария позволяет не удалять уведомления, заполоняющие экран и полезные только в случае работ по модификации сценария (должен быть установлен соответствующий параметр компонента уведомление). Активация режима происходит соответствующим флажком в разделе информации о сценарии.

Все находящиеся на сервере сценарии доступны для работы, корректирования всеми пользователями, имеющими на то право.


 Общие компоненты сценариев

Общие компоненты сценариев

 Содержание | Назад | Далее

В данном блоке в справочном порядке будут приведены все компоненты, являющиеся общими для всех типов сценариев, а также краткое описание действий и перечни свойств.

Старт

Компонент существует в любом сценарии – с него начинается действие, если трубка обрабатываемой линии положена. Старт на вход принимает параметр, который может сохранить в некоторой внутренней переменной сценария для дальнейшего использования.

Свойства:

Параметр запуска | Переменная, в которую необходимо сохранить значение, переданное из другого сценария, запустившего этот.
Переход | Компонент, на который передается управление.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Стоп

Осуществляет завершение сценария без разрыва связи. Служит для остановки выполнения сценария после появления соответствующих условий. Классические примеры успешное переключение в сценарии IVR или корректное завершение работы в сценарии диалога.

Свойства:

Возврат управления | Да/нет. По умолчанию «Да». Флаг определяет необходимо ли в текущей точке передать управление стеку (да) или прекратить выполнение всей последовательности сценариев (нет). Актуален только в сценариях, вызванных через компонент «Запуск вложенного сценария» с установленным флагом «Возврат управления» и в проектных сценариях IVR, вызванных через компонент «Вход в проект».
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Пауза

Осуществляет задержку сценария перед выполнением следующего компонента. В случае указания длительности 0 – компонент пропускается. В некоторых случаях при работе с большими сценариями удобно использовать компонент «Пауза» в качестве пустышки, для удобства и быстроты смены свойств. Например, по веткам выхода из компонента «Меню», где каждое свойство перехода задается внутри специального окна путем выбора одного объекта из списка всех объектов сценария.

Свойства:

Время задержки | Время в миллисекундах, которое необходимо простоять на компоненте в паузе.
Переход | Компонент, на который передается управление.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Присвоение значения

Задает значение указанной переменной. В качестве присваемого значения выступает аргумент. Используется механизм преобразования типов, если типы значения аргумента и переменной не совпадают.

Свойства:

Режим

Одиночный / Множественный

Множественный режим позволяет в одном компоненте производить сразу несколько операций присвоения.

Переменная

Локальная переменная, в которую нужно записать указанное значение.

Доступно только в режиме одиночной операции.

Значение

Аргумент (значение, переменная, функция, выражение), значение которого необходимо задать для указанной переменной.

Доступно только в режиме одиночной операции.

Операции

Список операций (пар элементов {Переменная, Аргумент}), которые будут выполнены в порядке перечисления в окне задания значений нескольких операций присвоения.

Если в одной из операций в аргументе используется переменная, указанная в качестве приемщика значения в более ранней операции по списку, то при расчете значения аргумента будет использовано новое ее значение.

Таким образом компонент с множественным присвоением является компактным аналогом последовательности одиночных присвоений.

Переход

Компонент, на который передается управление.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Сравнение

Сравнивает значения двух аргументов. Компонент осуществляет ветвление сценария. В случае соответствия выбранной логической операции и значений аргументов переход осуществляется по ветке «Правда», в противном случае – по ветке «Ложь».

Свойства:

Аргумент 1

Аргумент (значение, переменная, функция, выражение), значение которого необходимо сравнить.

Аргумент 2

Аргумент (значение, переменная, функция, выражение), значение которого необходимо сравнить.

Тип сравнения

Один из вариантов логической операции

· = (равно)
· > (больше)
· => (больше или равно)
· < (меньше)
· <= (меньше или равно)
· != (не равно)

Переход, правда

Компонент, на который передается управление, если выбранная логическая операция вернула истину.

Переход, ложь

Компонент, на который передается управление, если выбранная логическая операция вернула ложь.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Меню

Сравнивает аргумент со списком значений. Компонент может иметь неограниченное число веток перехода. Переход осуществляется по ветке значения, с которым совпало значение аргумента. Если совпадений не найдено, переход осуществляется по ветке «Прочее».

Свойства:

Аргумент | Аргумент (значение, переменная, функция, выражение), значение которого необходимо сравнить.
Значения (варианты) | Окно ввода значений, позволяющее задать возможные значения и связывающее с каждым указанным значением элемент перехода. Соответственно переход осуществляется по ветке первого найденного совпадающего значения.
Переход, прочее | Компонент, на который передается управление, если среди значений не найдено того, которое соответствует значению аргумента.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Удаление файла

Производит удаление файлов. Чаще используется в случае, если данные от пользователя записаны некорректно, время вышло, и данные не имеют смысла.

Свойства:

Имя файла | Аргумент, значение которого определяет имя файла для удаления.
Переход | Компонент, на который передается управление после успешного завершения ввода.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Голосовая почта

Осуществляет перемещение данных об указанном звуковом файле (чаще после записи в этом же сценарии) в голосовой ящик указанных пользователей. Подробнее о сервисе голосовой почты в разделе «Офис. Кабинет. Голосовая почта».

Заполняя свойство «Голосовой ящик» в окне адресата, можно явно указать существующих в системе пользователей, а также существующие отделы и внутренние номера. Также можно использовать свойство «Внутренний номер получателя», значением которого является вычисляемый аргумент. Это удобно, когда заранее неизвестно получателя, и данные о нем формируются в момент исполнения сценария. При этом сообщение попадет ко всем пользователям, которые составляют указанный внутренний номер. У пользователей, которым поступает голосовая почта, в их модулях появляются данные об абоненте, и возможность прослушать файл. Сообщение отправится всем выбранным по одному из двух параметров – указателей адресатов.

Свойства:

Имя файла | Аргумент, значение которого определяет абсолютный путь к файлу, который необходимо поместить в голосовой ящик. При использовании после объекта «Запись файла», в котором имя файла генерируется, необходимо в соответствующем свойстве выбирать возврат полного пути в переменную, сохраняющую имя записанного файла.
Внутренний номер получателя | Аргумент, определяющий внутренний номер, обладателям которого будет послано голосовое сообщение.
Голосовой ящик | Окно ввода адресата: списка получателей, среди которых могут быть пользователи системы, отделы и конкретные внутренние номера. Каждый пользователь, участвующей явно через отдел, или через номер получит соответствующее голосовое сообщение.
Переход | Компонент, на который передается управление после успешного завершения ввода.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Уведомление

Уведомление – всплывающее окно, позволяющее донести до пользователя информацию о происходящем в сценарии действии. В качестве адресатов могут быть выбран список из пользователей, отделов и конкретных номеров. Также в качестве адреса может выступать номер, определяемый значением аргумента.

Уведомление получат все пользователи, которые указаны персонально, либо состоят в выбранных группах или внутренних номерах. В режиме «Офис. Кабинет. Уведомления» пользователь всегда сможет просмотреть пришедшие к нему уведомления и осуществить поиск.

Свойства:

Отладочный режим

Да / нет. По умолчанию «нет». При сохранении сценария может быть установлен общий режим отладки (на странице свойств сценария). Отладочные уведомления будут отображаться только в режиме отладки сценария. Остальные будут отображаться в любом случае.

Внутренний номер получателя

Аргумент, определяющий внутренний номер, обладателям которого будет послано текстовой сообщение из сценария.

Адресат

Окно ввода адресата: списка получателей, среди которых могут быть пользователи системы, отделы и конкретные внутренние номера. Каждый пользователь, участвующий явно, через отдел, или через номер получит соответствующее уведомление.

Сохранять в БД

Да/нет. По умолчанию «да». При установке свойства сообщение будет сохранено в БД и будет доступно в модуле «Офис. Кабинет. Уведомления». Если пользователь отсутствует, то сообщение будет доставлено сразу после его авторизации в системе.

Текст

Аргумент, определяющий текст уведомления.

Поддерживается минимальный набор тегов HTML для форматирования. Чтобы отобразить текст в виде HTML-документа необходимо его заключить в теги <html>..</html>

Ниже за пределами таблицы свойств приведен перечень поддерживаемых HTML-тегов.

Цвет фона

Определяет цвет фона всплывающего окошка.

Скрывать автоматически

Да/нет. По умолчанию «да». При отключении уведомление будет скрыто только после щелчка пользователя на нем. Поступающие уведомления помещаются в очередь, из которой отображаются в видимых областях экрана в порядке поступления. Очередь сообщений может быть очищена из системного меню в трее.

При отправке уведомления отключенному пользователю с сохранением в БД, отображаемые после авторизации последние несколько пропущенных уведомлений будут в любом случае автоматически скрываться.

Асинхронный режим

Да/нет. Способ рассылки уведомлений. При выборе асинхронного режима компонент не ожидает доставки уведомлений пользователям и сразу передает управление следующему объекту сценария. Имеет смысл при рассылке уведомления множеству пользователей из сценариев IVR обработки входящих вызовов во избежание незапланированных пауз. Однако при завершении сценария асинхронные рассылки всех уведомлений, не успевшие завершиться, будут прерваны.

Переход

Компонент, на который передается управление после успешного завершения ввода.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Поддерживаемые HTML-теги:

· <html>..</html> - определяет, что блок текста должен быть отображен как HTML-документ
· <span>..</span> - текстовый блок, атрибуты: style - стиль
· <a>..</a> - гиперссылка, атрибуты: href - ссылка, title - заголовок, style - стиль
· <b>..</b> - полужирный, атрибуты: style - стиль
· <u>..</u> - подчеркнутый, атрибуты: style - стиль
· <i>..</i> - курсив, атрибуты: style - стиль
· <s>..</s> - перечеркнутый, атрибуты: style - стиль
· <br> - переход на следующую строчку, атрибуты: style - стиль
· <center>..</center> - выравнение по центру, атрибуты: style - стиль
· <p>..</p> - параграф, атрибуты: style - стиль

Атрибутами стиля могут быть

1) font-weight - толщина символов

Значения:

· bold - полужирный
· normal - обычный

(Не поддерживается: bolder | lighter | 100 | 200 | 300 | 400 | 500 | 600 | 700 | 800 | 900)

2) text-decoration - декорация текста

Значения:

· line-through - перечеркнутый
· underline - подчеркнутый
· none - отсутствует

(Не поддерживается: blink | overline )

3) font-style - стиль шрифта

Значения:

· normal - обычный
· italic - курсив

(Не поддерживается: oblique)

4) text-align - выравнение текста (только для <p>)

Значения:

· left - по левому краю
· right - по правому краю
· center - по центру
· justify - по ширине

5) color - цвет текста

Значения:

· red - красный
· green - зеленый
· blue - синий
· black - черный
· white - белый
· yellow - желтый
· gray - серый
· #XXXXXX - шестнадцатеричный код цвета где (X - шестнадцатеричное число 0..F )

Другие атрибуты игнорируются

Примеры:

1) <html>Данное устройство <b style='color:red;'>не обнаружено</b></html>

2) <html>У Вас новая <a style='font-style:bold;color:#127A81;' href='http://mail.ru' title='Нажмите, чтобы открыть'>почта</a></html>

Задание на звонок

Компонент инициирует задачу однократного выполнения в указанное время на указанный номер. Задача запускает указанный в соответствующем свойстве компонента сценарий IVR. Для формируемой задачи в компоненте указываются инициирующие значения, а также параметр задачи, который будет доступен через функцию «Параметр задачи» в сценарии IVR.

Свойства:

Номер | Аргумент, определяющий номер, по которому производить дозвон.
Назначение | Номер может быть городским (внешним) и АТС-ным (внутренним).
Выполнить сразу | Да/Нет. Сразу выполнять задачу или дожидаться указанного времени.
Дата/время | Дата и время, когда производить выполнение задачи. Поле доступно только при выборе значения «Нет» в свойстве «Выполнить сразу».
Сценарий | Текстовое поле с возможностью выбора из списка имеющихся сценариев. Определяет имя сценария, который необходимо запустить после дозвона.
Параметр запуска | Числовой аргумент, передающий свое значение в задачу, а через нее на старт запускаемого сценария и в функцию «Параметр задачи». Может быть использован для идентификации через сопоставление по таблице в БД, или для передачи множества параметров. Доступен в сценарии автоматической задачи через встроенную функцию «Параметр задачи».
Количество сигналов «Занято» | Сколько дозвонов с ответом «Занято» считать успешным выполнением задачи.
Количество сигналов «Не отвечает» | Сколько дозвонов с ответом «Не отвечает» считать успешным выполнением задачи.
Время фиксации в секундах | Сколько секунд необходимо выполнять сценарий после дозвона, чтобы считать успешным выполнение задачи.
Время ожидания ответа | Сколько секунд ожидать ответа от линии для получения сигнала «Не отвечает».
Пауза после сигнала «Занято» | Сколько секунд делать перерыв в выполнении задачи, если от линии получен сигнал «Занято».
Пауза после сигнала «Не отвечает» | Сколько секунд делать перерыв в выполнении задачи, если от линии получен сигнал «Не отвечает».
Переход | Компонент, на который передается управление.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Запрос SQL в БД

Позволяет производить действия в БД, а также передавать параметры (на вход и на выход). В качестве параметров выступают переменные сценария. Обращение к БД происходит по одной из выбранных технологий: ADO, OLE, ODBC. Для запросов во внешние БД необходимо заполнить строку подключения с помощью помощника – построителя. В случае ошибки переход осуществляется по ветке «Ошибка», и в переменную «Код ошибки» возвращается соответствующий код исключения БД.

Свойства:

SQL запрос

Окно ввода запроса в формате SQL. В нем вы можете проверить запрос, а также исполнить в базе в момент создания. Параметры запроса в виде переменных SQL обозначаются маркером «@» в начале имени («:» в начале имени для OLE, Oracle, или «?» для входных параметров ODBC). Встроенный парсер разберет параметры и предложит сопоставить им переменные сценария. Входные параметры запроса получат значение из соответствующих переменных сценария перед выполнением запроса, выходные параметры занесут свои значения в переменные сценария после выполнения запроса. Также, если в возвращаемой выборке название какого-либо поля совпадает с названием внутренней переменной сценария, в нее будет занесено соответствующее значение из выборки.

На вкладке «Подключение» вы можете выбрать один из вариантов подключения к БД. Это используется в большей части для получения индивидуальных нестандартных настроек, а также при подключении к внешним БД. В случае использования общего формата ADO, OLE или ODBC (а также подключения по отдельно выделенным каналам к БД Oracle) необходимо заполнить строку подключения. В строке и определяются индивидуальные настройки. Например, таймаут ожидания ответа, или драйвер для подключения к различным СУБД при использовании технологии ODBC. В окне помощника формирования строки подключения вы можете увидеть все доступные для использования параметры и их описания.

В случае необходимости плотного взаимодействия с внешней СУБД, обилия хранимых процедур, запросов и их параметров рекомендуется настроить прилинкованный сервер СУБД в MS SQL Server и работать с внешней СУБД по правилам, определяемым TSQL. Подробнее о процедуре подключения линкованных серверов можно узнать в разделе «Подключение внешних БД»

Формат самих запросов SQL вне рамок данного описания.

Код ошибки

Переменная, в которую сохранится код возврата.

Переход

Компонент, на который передается управление после успешной транзакции.

Переход, ошибка

Компонент, на который передается управление при появлении исключительной ситуации. В переменную свойства «Код ошибки» попадает код полученного исключения из сервера БД.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Запрос к WEB-сервису, XML-запрос

Позволяет выполнять запросы к web-сервисам в форматах get и post. На вход может передавать указанным образом заполненную структуру XML документа. Прием данных и их обработку осуществляет также согласно прикрепленной к компоненту структуре XML документа. В случае ошибки переход осуществляется по ветке «Ошибка», и в переменную «Код ошибки» возвращается соответствующий код исключения. Для детального разбора ответа может быть использован совместно с компонентом «Парсер»: сохранив ответ в строковой переменной, его дальнейший анализ производится совокупностью других компонентов сценария.

Компонент поддерживает работу в сессиях, сохраняя и используя COOKIE, а также HTTPS и подтверждение сертификатов.

Свойства:

Подключение

Форма, определяющая адрес сервера, а также способ подключения к нему и параметры авторизации. При необходимости устанавливаются адрес и пароль подключения к Proxy-серверу.

Тип контента

Строка contenttype, подставляемая в отсылаемый запрос.

Например

· application/x-www-form-urlencoded
· text/xml
· text/html
· text/plain

Допускается указание других строк.

Метод

POST / GET

Запрос

Форма, определяющая структуру запроса и подстановку в качестве параметров аргументов (переменных) сценария.

Кодировка запроса

Определяет в какой кодировке передается тело POST-запроса. В списке возможных вариантов:

· UTF-16
· UTF-8
· UTF-7
· Текущая кодовая страница Windows
· Windows-1251
· Указанная кодовая страница Windows

Кодовая страница Windows для запроса

Доступно только при выборе кодировки запроса «Указанная кодовая страница Windows».

Числовой аргумент, определяющий кодовую страницу Windows для формирования запроса.

Режим работы

Определяет режим работы компонента. Один из четырех вариантов:

· Ожидание результата. Компонент завершает свою работу только после получения ответа от сервера, ошибки сокета или принудительного завершения работы сценария (по обрыву связи). Во всех случаях кроме последнего производится анализ результата и сохранение значений в соответствии с настройками компонента.
· Асинхронный запуск. Запускает асинхронную процедуру запроса к серверу и мгновенно возвращает управление. Ответ сервера не сохраняется и не анализируется. Запрос продолжает выполняться даже после завершения работы сценария.
· Обрыв по таймауту. Ожидает ответа сервера не дольше установленного времени, после чего обрывает запрос и возвращает управление. Если ответ сервера получен в промежутке до таймаута, то производится анализ результата и сохранение значений в соответствии с настройками компонента. В случае принудительного завершения работы сценария (по обрыву связи) выполнение запроса обрывается.
· Выход по таймауту. Ожидает ответа сервера не дольше установленного времени, после чего возвращает управление, оставляя запрос работать асинхронно. Если ответ сервера получен в промежутке до таймаута, то производится анализ результата и сохранение значений в соответствии с настройками компонента. В противном случае ответ сервера не сохраняется (так как сценарий может быть уже завершен). В случае принудительного завершения работы сценария (по обрыву связи) запрос продолжает выполняться.

Таймаут, секунды

Определяет таймаут, после которого компонент завершит свою работу в соответствии с выбранным режимом работы. Доступно только для режимов обрыва и выхода по таймауту.

Тип ответа

XML / TEXT. Определяет, в каком режиме производить сохранение полученного ответа - парсить XML или сохранять в строковую переменную для дальнейшего анализа. Недоступно для асинхронного режима.

Ответ(XML)

Форма, определяющая структуру стандартного ответа сервера и характер распределения выходных значений по переменным сценария. Поддерживает только строгое соответствие дерева XML. Недоступно для асинхронного режима.

Ответ(строка)

Переменная, в которую сохранится текст ответа. Недоступно для асинхронного режима.

Кодировка ответа

Определяет в какой кодировке форматировать тело ответа. В списке возможных вариантов:

· UTF-16
· UTF-8
· UTF-7
· Текущая кодовая страница Windows
· Windows-1251
· Указанная кодовая страница Windows
· Авто (заголовок)
· Авто (метатэги, заголовок)

Кодовая страница Windows для ответа

Доступно только при выборе кодировки ответа «Указанная кодовая страница Windows».

Числовой аргумент, определяющий кодовую страницу Windows для разбора ответа.

Код ошибки

Переменная, в которую сохранится код возврата сценария.

Переход

Компонент, на который передается управление после успешной транзакции.

Переход, таймаут

Компонент, на который передается управление в случае, если выход осуществляется по таймауту.

Переход, ошибка

Компонент, на который передается управление, если web-сервис не доступен или вернул ошибку.

Имя

Название компонента для отображения в визуальной среде и выбора.

Парсер текста

Осуществляет разбор любых текстовых структур. Может использоваться метод регулярных выражений или встроенный анализатор гипертекста OQuery. Согласно строке поиска формирует ответ, либо вырезает запрошенный раздел или их совокупность, либо определяет количество элементов в указанном разделе структуры. Сложные структуры могут быть разобраны последовательностью элементов «Парсер». Каждый из которых выделяет из документа некоторую структуру и возвращает ее на вход следующего элемента.

В общем случае производится разбор HTML, XML структур различного формата. На уровне сценария могут быть организованы циклы и условия. Чаще применяется для разбора ответов веб-сервисов компонентом «Web-запрос».

Документ

Аргумент, содержащий текстовую структуру, подлежащую разбору.

Алгоритм

Метод разбора:

· Регулярные выражения.
· Язык OQuery.

Поисковый запрос

Строка запроса для соответствующего алгоритма. Язык регулярных выражений совпадает со стандартом .NET. Синтаксис языка OQuery описан ниже.

Функция

Тип запроса (возвращаемого значения)

В зависимости от выбранного алгоритма допускает выбор одного из возможных вариантов. Для регулярных выражений доступны:

· Содержимое.
· Количество найденных.

Для OQuery доступны:

· Документ. Возвращает текст структуры с обрамляющими тэгами.
· Содержимое. Возвращает текст структуры без обрамляющих тэгов.
· Количество найденных. Возвращает число - количество найденных структур, расположенных согласно поисковому запросу на одном уровне.
· Значение атрибута.
· Имя атрибута.
· Количество атрибутов.

Номер элемента

Аргумент, определяющий порядковый номер структуры на случай, если поисковый запрос нашел несколько результатов одного уровня вложенности.

Атрибут

Аргумент, определяющий параметры интересующего атрибута. Доступен только для алгоритма OQuery и функций, связанных с атрибутами.

Функция "Значение атрибута" ждет в качестве значения аргумента имя или порядковый номер атрибута.

Функция "Имя атрибута" ждет в качестве значения аргумента порядковый номер атрибута.

Результат в переменную

Переменная, в которую будет сохранен результат применения поискового запроса к документу (число или часть текста вырезанного или сформированного).

Переход

Компонент, на который передается управление в случае корректного выполнения поискового запроса.

Переход, неудача

Компонент, на который передается управление в случае неудачи при разборе.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Синтаксис OQuery:

Запрос - это набор команд.

Запрос пишется в одну строчку и выполняется в порядке перечисления (слева направо)

Уровни:

* | Все элементы
> | Все дочерние элементы
^ | Корневые элементы (содержатся на нулевом уровне искомой структуры)
пробел | Все элементы кроме корневых

Простые команды:

название тега документа | Теги, английские буквы и цифры (начинаются на букву). Пример: ^TITLE - найдет тег TITLE в корне
#значение | Возвращает теги, у которых атрибут id равен указанному значению. Пример: FORM#32 - найдет все теги FORM, у которых атрибут id равен 32 ( <FORM class=a id=32> )
[название=значение] | Возвращает теги, в теле которых присутствует атрибут с соответствующим названием и значением. Пример: TABLE[width=90%]
.значение | Возвращает теги, у которых атрибут class равен указанному значению. Пример: INPUT.b.c - найдет теги, у которых атрибут class содержит b и c ( <INPUT class="a b c" /> )

Примечание: Результат не зависит от порядка перечисления команд. Например TABLE#big.sample = TABLE.sample#big - найдет теги, у которых атрибут id = big и атрибут class содержит sample.

Операции сравнения:

= | Знак полного совпадения значения аттрибута. Пример: TABLE[width=90%]
^= | Начинается со значения. Пример: IMG[src^="http://bulmas.ru/images"]
$= | Заканчивается значением. Пример: IMG[src$=".gif"]
*= | Значение содержится где-то в центре. Пример: IMG[src*="erotic"]

Суффиксы:

:first | Возвращает первый элемент коллекции. Пример: TD:first
:last | Возвращает последний элемент коллекции. Пример: UL:last
:parent | Возвращает родительские теги элементов коллекции. Пример: TABLE>TD>A:parent:parent

Простые функции - команды с параметрами:

:gt(позиция) | Возвращает элементы начиная с текущей позиции. Пример: TD:gt(10)
:lt(позиция) | Возвращает элементы до текущей позиции включительно. Пример: TD:lt(15)
:eq(позиция) | Возвращает элемент соответсвующей позиции, если число отрицательное, то с конца. Пример: TD:eq(-3) третий тег с конца.
:eq(начало,конец) | Возвращает набор элементов от начальной до конечной позиции, если числа отрицательные, то с конца. Пример: TD:eq (10,24) - Аналог TD:eq(10):lt(15) Пример: TD:eq(-1,-3) - возвращает последние 3 элемента eq, equal, range - синонимы

Сложные функции - команды, которым в качестве параметра можно передавать набор команд:

:has(OQuery-запрос) | Возвращает теги, содержащие другие теги, которые удовлетворяют указанному OQuery-запросу. Пример: TABLE:has(^TD>A) - аналог TABLE>TD>A:parent:parent
:not(OQuery-запрос) | Возвращает теги не удовлетворяющие указанному OQuery-запросу. Пример: A:not([href=http://bulmas.ru]) - найдет все теги A, которые не ссылаются на http://bulmas.ru. Или: A:eq(1,10):not(:eq(2)) - Все теги A по порядку от 1 до 10, кроме второго.

Пример: Результат следующих запросов разный

A:has(:not(IMG)) - все теги A, которые содержат не IMG

A:not(:has(IMG)) - все теги A, которые не содержат IMG

Операции и знаки:

запрос1 , запрос2 | Запятая (логическое "или"), для перечисления запросов. Примеры: *A>IMG,>TABLE - вернет все IMG, содержащиеся в A, и TABLE содержащиеся в корне. INPUT([value="Петр"],[value="Виктор"]) - все INPUT со значениями "Петр" или "Виктор".
запрос1 + запрос2 | Плюс, найдет теги удовлетворяющие запросу1, за которым идут теги удовлетворяющие запросу2.
запрос1 - запрос2 | Минус, найдет теги удовлетворяющие запросу1 перед которым идут теги, удовлетворяющие запросу2.

Примечание: Операции могут объединять и более двух запросов например A + IMG + #num - вернет все теги A, за которыми идут теги IMG, за которым в свою очередь идут теги с id="num".

Скобки:

()

Скобки, для объединения команд одинакового приоритета.

Пример: (FONT,A)(:has(IMG),:has(SPAN)) - теги FONT и A содержащие IMG или SPAN,

Аналог (FONT:has(IMG), FONT:has(SPAN), A:has(IMG), A:has(SPAN))

Наборы команд:

^FONT | все теги FONT корневого (нулевого) уровня.
>FONT | все теги FONT первого уровня.
*FONT | все теги FONT.
*>FONT | все теги FONT кроме корня.
*>>FONT или >*>FONT | все теги FONT начиная со второго уровня.
A>>B | все теги B находящиеся на втором уровне у A.

Рекомендации:

Время выполнения запроса в основном зависит от размера исходного текста и количетсва тегов в нем, и значительно меньше от длины самого запроса.

Если данные нужно получать в цикле, постарайтесь, сначала сократить размер исходного текста.

Например, если хотим вернуть прогноз погоды в Казани с содержимого сайта "http://weather.yandex.ru/?city=27595" (Около 50кб) за последние

10 дней, можно воспользоваться запросами

tr.data.day>td>b:eq(1)

tr.data.day>td>b:eq(2)

tr.data.day>td>b:eq(3)

и т. д.

Каждый запрос выполняется примерно ~50мс.

Итого: ~500мс

Но можно поступить следующим образом: Организуется цепочка из нескольких компонентов «Парсер», первый из которых забирает все нужные теги <B> запросом tr.data.day>td>b (~50мс) в переменную сценария. Далее в цикле сценария следующими компонентами забираются соответствующие значения

:eq(1)

:eq(2)

:eq(3)

и т. д.

Каждый запрос выполняется примерно ~0.2мс. Итого время выполнения ~50мс. Получается тот же результат, но в 10 раз быстрее.

Заказ на встречный звонок

Сохраняет информацию о заказанном звонке в БД, и отображает в клиентском приложении Oktell у пользователей-адресатов, определяющихся указанным внутренним номером. Подробнее о сервисе заказов встречных звонков в разделе «Офис. Кабинет. Встречные звонки».

Свойства:

Внутренний номер получателя | Аргумент, определяющий номер адресата для заказанного звонка.
Заказ на номер | Аргумент, определяющий номер, на который заказан встречный звонок. Может быть введен пользователем с клавиатуры, определен как «CallerId», или подставлен из базы по коду.
Заказ на время | Ориентировочное время, на которое заказан встречный звонок (сохранится в базе и будет отображено в описании заказа). Не заполнять, если время не указывается.
Комментарий | Комментарий к компоненту (сохранится в базе и будет отображен в описании заказа).
Переход | Компонент, на который передается управление.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Статус объекта

Позволяет получить доступ к состояниям различных объектов (на чтение и запись). Например до начала переключения определить статус объекта (пользователя, задачи, номера), чтобы без попытки переключения и, соответственно, без включения сигнала ожидания, озвучить соответствующий текст меню.

Свойства:

Действие

Доступные действия:

· Определить. Формирует работу компонента для записи в назначенную переменную выбранного состояния указанного объекта.
· Установить. Изменяет выбранное состояние указанного объекта на результат вычисления назначенного аргумента.
· Создать. Создает объект выбранного типа, возвращая его идентификатор.

Тип объекта

Один из вариантов: Задача, Пользователь, Номер, Линия. Тип объекта, с которым производится работа: статус которого подлежит определению, изменению, или который необходимо создать/удалить.

В зависимости от выбранного действия перечень типов может меняться.

Задача (код), Пользователь, Номер, Линия

Доступны только для действий определить/установить.

В зависимости от выбранного типа поле принимает тот или иной вид:

· Задача. Одна из списка задач системы (или проекта, если сценарий принадлежит проекту). Возможно задание через строковый аргумент «Код задачи» в виде GUID значения «xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx». Будет использован только в случае, если задача не указана явно в списке имеющихся в системе задач.
· Пользователь. Один из списка пользователей системы.
· Номер. Аргумент, определяющий внутренний номер (стандартный).
· Линия. Аргумент, определяющий номер или Guid-идентификатор линии.

Функция / действие

Доступно только для действий определить/установить.

В зависимости от выбранного действия и типа объекта поле содержит список доступных состояний.

Определение состояния.

Доступные функции для задач:

· Количество абонентов в очереди;
· Наибольшее время ожидания среди абонентов очереди (при сохранении в переменную типа дата/время подставляется значение переменной начиная с 01.01.0000; в переменную строка - значение ЧЧ:мм:cc, ЧЧ при превышении 24 продолжает увеличиваться; в числовую переменную попадает действительное значение количества минут);
· Количество активных операторов задачи;
· Активность задачи;
· Проверка доступности входа (работает в сценариях IVR).

Доступные функции для пользователей:

· Количество абонентов в очереди;
· Наибольшее время ожидания среди абонентов очереди;
· Статус (0 - не авторизован, 1 - готов, 2 - перерыв, 3 - отключен (нет на месте), 5 - занят, 6 - зарезервирован, 7 - без телефона);
· Свободен.

Доступные функции для номеров:

· Количество абонентов в очереди;
· Наибольшее время ожидания среди абонентов очереди;
· Есть свободные.

Доступные функции для линий:

· Состояние;
· Время активности.

Установка состояния.

Доступные функции для задач:

· Активность (1 - активна, 0 - неактивна).

Доступные функции для линий:

· Разорвать (выполняется безусловно).

Значение в переменную

Доступно только для действия «Определить».

Переменная, в которую заносится результат вычисления функции.

Значение

Доступно только для действия «Установить».

Аргумент, значение которого вычисляется для установки состояния.

Идентификатор в переменную

Доступно только для действия «Создать».

Переменная, в которую заносится идентификатор вновь созданного объекта.

Переход

Компонент, на который передается управление.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Определить группу клиента

Осуществляет проверку на принадлежность контакта (определившегося номера телефона, почтового адреса и любого другого переданного аргумента) указанной группе клиентов. Позволяет разделить обработку в сценарии звонков VIP клиентов, клиентов из черного списка, личных контактов и пр.

Свойства:

Контакт | Аргумент, содержащий произвольную контактную информацию.
Группа | Аргумент, содержащий имя группы клиентов.
Переход, принадлежит | Компонент, на который передается управление, если соответствующий контакту клиент найден, указанная группа существует, и клиент принадлежит группе.
Переход, не принадлежит | Компонент, на который передается управление, если не найден соответствующий контакту клиент, не существует группа, или клиент не принадлежит группе.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Счетчик

Увеличивает значение выбранного счетчика на 1. Подробнее о счетчиках, их создании и анализе в модуле общего меню «Call-центр. Отчеты. Счетчики».

Свойства:

Счетчик | Список счетчиков, существующих в системе и доступных для увеличения.
Переход | Компонент, на который передается управление в случае успешной коммутации.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Запуск процесса

Запускает на сервере внешний процесс или открывает приложение с указанным документом. В сценариях IVR используется чаще для запуска системных программ, а также учетных, сервисных, обслуживающих программ организации-клиента Oktell.

ВНИМАНИЕ! При работе сервера Oktell в режиме службы запуск процесса производится от имени того пользователя, который указан в настройках службы. По умолчанию это системная учетная запись «NETWORK SERVICE». Запускаемые таким образом процессы выполняются в фоновом режиме и не отображаются на экране пользователя.

Свойства:

Имя файла | Аргумент, определяющий имя файла, который необходимо запустить .
Относительный путь | Да/нет. Определяет, какой путь будет подставляться впереди к имени файла. Относительный – от папки запуска серверного приложения Oktell.
Параметры | Строковый аргумент, определяющий параметры запуска, если необходимо.
Переход, успех | Компонент, на который передается управление, если приложение успешно стартовало.
Переход, неудача | Компонент, на который передается управление, если файл не найден, отсутствует доступ, или по другой причине не удалось запустить приложение.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Запуск сценария

В случае организации автоматических сервисов размеры сценария могут быть достаточно велики, и компонент «Запуск сценария» предоставляет возможность разбить крупный сценарий на несколько логических блоков. Таким образом, один сценарий передает управление в начало другого сценария. При этом можно задать некоторое значение на запуск, которое примет компонент «Старт» вложенного сценария и сохранит в свою локальную переменную. Помимо этого, все переменные одного типа, которые названы одинаково в запускающем и запускаемом сценариях, перенесут свои значения из одного в другой без изменений. Такой способ запуска называется вложенным.

ВНИМАНИЕ! Обработка сценария начинается с компонента Старт и ведется последовательно согласно значениям свойств перехода, если трубка положена (в основном это входящие звонки с внешних линий). В случае, когда трубка уже поднята, после компонента "Старт" производится безусловный переход к компоненту "Поднять трубку", если такой имеется в сценарии. При этом обработчик пропускает все компоненты, которые находятся между ними. Запуск вложенных сценариев следует этим же правилам.

Также с помощью компонента можно запускать в параллельный процесс любой служебный сценарий, не работающий с зависимыми от основного сценария ресурсами (линией, оператором). При запуске асинхронного служебного сценария начальные значения его переменных, совпадающих по типам и именам с переменными основного сценария, будут установлены в соответствии с их значениями.

Свойства:

Тип запуска

Вложенный / Асинхронный служебный. Определяет тип и формат запуска дочернего сценария. Запуск вложенного сценария прекращает выполнение (возможно на время, до возврата управления) текущего сценария и активизирует обработку выбранного сценария того же типа. Асинхронный запуск служебного сценария запускает в параллельном процессе выполнение выбранного служебного сценария и продолжает выполнение текущего.

Сценарий

Текстовое поле с возможностью выбора из списка имеющихся сценариев. Определяет имя сценария, который необходимо запустить.

Параметр запуска

Аргумент, передающий свое значение на старт запускаемого сценария.

Возврат управления

Да/нет. По умолчанию «Нет». Определяет способ вызова вложенного сценария.

При установке значения «Нет» выполнение текущего сценария прекращается и запускается вложенный сценарий (с сохранением значений всех переменных). Такой способ наиболее часто применим на практике.

При установке значения «Да» вложенный сценарий вызывается как функция и после его завершения происходит возврат в точку вызова. Все переменные исходного сценария доступны во вложенном и наоборот, таким образом после возврата они будут иметь соответствующие измененные значения. На процедуру возврата также влияет флаг «Возврат управления» компонента «Стоп», - используется во вложенном сценарии после успешного переключения с необходимостью безусловно прервать обработчик сценариев.

ВНИМАНИЕ! Обработчик сценариев поддерживает условно неограниченную вложенность и имеет стек с ограничением в 100 сценариев во избежание зацикливания.

ВНИМАНИЕ! Вызов внутри одной цепочки исполнения может происходить одновременно как с возвратом, так и без возврата.

Переход

Компонент, на который передается управление после возврата в случае запуска вложенного сценария, а также непосредственно после запуска служебного сценария.

Поле используется (и обязательно для заполнения) только в случае асинхронного запуска служебного сценария, а также в случае вложенного, если флаг «Возврат управления» установлен.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Регистрация

Компонент используется совместно со шлюзом с динамической регистрацией потоков (подробнее в разделе «Карта сети. Компоненты. Шлюз»). Служит для проведения динамической регистрации под указанным аккаунтом перед осуществлением звонка по каналу потока такого шлюза. Параметры аккаунта - логин и пароль - могут быть взяты из БД, вычислены, указаны явно в сценарии. Для проведения регистрации достаточно указать в свойствах компонента шлюз, и свободный поток автоматически будет зарегистрирован и зарезервирован под совершение вызова именно в этом экземпляре сценария. Потоки и линии шлюзов с динамической регистрацией недоступны для выбора ни в задачах, ни в настройках прав пользователей, ни в списках линий при наборе номера компонентами сценариев. Осуществить дозвон через них можно только путем явного указания кода зарегистрированного потока в соответствующий аргумент компонентов «Дозвон» служебного сценария и «Переключение на внешние» сценария IVR.

ВНИМАНИЕ! В случае успешной коммутации поток будет разрегистрирован автоматически по завершению разговора и переводу одной из линий потока в состояние готовности. Однако, если коммутации не произведено, то разрегистрация производится автоматически по истечению времени неактивности (3 минуты), либо путем использования этого же компонента с действием «Отмена регистрации».

Свойства:

Действие | Выбор режима работы. Регистрация / отмена регистрации. В случае установки режима регистрации осуществляет прямое действие по регистрации аккаунта на сервере и активации (перевода в состояние готовности) одного из потоков указанного шлюза с динамической регистрацией потоков. В режиме отмены регистрации освобождает аккаунт и переводит указанный поток в отключенное состояние.
Шлюз | Доступно только для действия «Регистрация». В списке выбирается один из существующих в карте сети шлюзов с динамической регистрацией потоков.
Аккаунт | Доступно только для действия «Регистрация». Аргумент, представляющий собой логин для регистрации потока.
Пароль | Доступно только для действия «Регистрация». Аргумент, представляющий собой пароль для регистрации потока.
Время ожидания | Доступно только для действия «Регистрация». Максимальное время ожидания регистрации, по истечению которого будет прервана регистрация и произведен выход по ветке «Таймаут».
Автоматическая отмена регистрации | Доступно только для действия «Регистрация». Позволяет установить такой режим работы, при котором при любой последующей попытке дозвона по одной из линий зарегистрированного потока даже в случае неудачи (занято, недоступно и т.д.) будет производиться мгновенная отмена регистрации.
Код потока в переменную | Доступно только для действия «Регистрация». В случае успешного проведения операции по регистрации в указанную переменную будет размещен Guid-идентификатор зарегистрированного потока. Эта переменная впоследствии может быть использована для осуществления вызова в компонентах «Переключение на внешние» и/или «Дозвон» или отмены регистрации.
Код ошибки в переменную | Доступно только для действия «Регистрация». В переменную попадает код ошибки в случае возникновения проблем при регистрации. Большинство кодов совпадают с типами ответов HTTP-сервера (например, 404 - not found).
Код потока | Доступно только для действия «Отмена регистрации». Аргумент, представляющий собой Guid-идентификатор потока в строковом представлении. Может быть указан явно, или получен в переменную в одном из предыдущих компонентов «Регистрация».
Переход | Компонент, на который передается управление после возврата в случае успешного проведения операции.
Переход, потоков не найдено | Доступно только для действия «Регистрация». Компонент, на который передается управление, если у выбранного шлюза нет свободных потоков.
Переход, таймаут | Доступно только для действия «Регистрация». Компонент, на который передается управление в случае, если за установленный интервал времени не получен ответ от внешнего сервера/шлюза.
Переход, ошибка | Компонент, на который передается управление в случае возникновения ошибок.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Отправка SMS-сообщения

Осуществляет отправку SMS-сообщения по указанному номеру с назначенным текстом. Может быть настроен на ожидание доставки.

Свойства:

Номер | Аргумент, определяющий номер адресата.
Текст | Аргумент, определяющий текст SMS-сообщения.
Подставляемый номер | Номер, от которого осуществляется доставка.
Push Id | Код отправленного сообщения (для дальнейшего запроса отчета о доставке).
Ожидание доставки | Да/Нет. Требуется ли ожидать отчета о доставке.
Таймаут ожидания | Время, которое компонент будет ожидать отчета о доставке. Поле доступно только при выборе значения «Да» в свойстве «Ожидание доставки».
Переход, доставлено | Компонент, на который передается управление после успешной отправки сообщения. В случае установки значения «Да» в свойстве "Ожидание доставки", если сообщение успешно доставлено до таймаута ожидания.
Переход, не доставлено | Компонент, на который передается управление, если сообщение отправлено, но не было доставлено за установленное время ожидания (в случае если ожидание было назначено). Поле доступно только при выборе значения «Да» в свойстве «Ожидание доставки».
Переход, ошибка | Компонент, на который передается управление, если сервис недоступен или вернул ошибку.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Получение статуса отправленного SMS-сообщения

Производит запрос к SMS-сервису на получение отчета о доставке конкретного SMS-сообщения по коду отправки (Push Id).

Свойства:

Push Id | Код отправленного сообщения.
Переход, доставлено | Компонент, на который передается управление, если sms уже доставлено.
Переход, не доставлено | Компонент, на который передается управление, если sms еще не доставлено.
Переход, ошибка | Компонент, на который передается управление, если сервис недоступен или вернул ошибку.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Получение входящего SMS-сообщения

Производит запрос к SMS-сервису на получение первого в очереди входящих сообщений. В случае успеха наполняет переменные сценария соответствующими сообщению значениями.

Свойства:

Номер отправителя | Переменная, куда запишется номер отправителя.
Текст | Переменная, куда запишется текст сообщения.
Номер адресата | Переменная, куда запишется номер, на который сообщение было отправлено.
Переход, получено | Компонент, на который передается управление, если сообщение на сервере имеется и получено успешно.
Переход, сообщений нет | Компонент, на который передается управление, если входящих сообщений на сервере нет.
Переход, ошибка | Компонент, на который передается управление, если сервис недоступен или вернул ошибку.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Баланс счета на SMS-сервере

Запускает на сервере внешний процесс или открывает приложение с указанным документом. В сценариях IVR используется чаще для запуска системных программ, а также учетных, сервисных, обслуживающих программ организации-клиента Oktell.

Свойства:

Количество | Переменная, куда вернется количество оставшихся оплаченных SMS-сообщений.
Переход | Компонент, на который передается управление, если запрос отработан.
Переход, ошибка | Компонент, на который передается управление, если сервис недоступен или вернул ошибку.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Отправка сообщения электронной почты

Осуществляет отправку email-сообщения на указанный ящик электронной почты.

Свойства:

Способ отправки

Форма, определяющая способ отправки email-сообщения.

Кому

Аргумент, определяющий получателей email сообщения. Если письмо предназначается нескольким адресатам, то адреса должны быть перечислены через «;».

От кого

Аргумент, определяющий отправителя email сообщения. Ряд почтовых серверов требует явного указания поля "Отправитель" (e-mail адрес отправителя). В этом случае свойство должно быть вычислено к моменту, когда компонент получит управление.

Тема

Аргумент, определяющий тему email сообщения.

Формат тела письма

Текст/HTML. Определяет формат, в котором будет сформировано тело для отправки.

Содержание письма

Аргумент, определяющий текстовую часть e-mail сообщения.

Кодировка

Определяет кодировку отправляемого письма. При необходимости осуществляется преобразование тела.

· UTF-8
· UTF-7
· Windows-1251
· KOI8-R
· Текущая кодовая страница Windows
· Указанная кодовая страница Windows

Кодовая страница Windows

Доступно только при выборе кодировки «Указанная кодовая страница Windows».

Числовой аргумент, определяющий кодовую страницу Windows для формирования тела письма.

Вложение 1

Аргумент, значение которого определяет абсолютный путь к файлу, который необходимо прикрепить к сообщению email.

Вложение 2

По аналогии со свойством «Вложение 1».

Вложение 3

По аналогии со свойством «Вложение 1».

Вложение 4

По аналогии со свойством «Вложение 1».

Вложение 5

По аналогии со свойством «Вложение 1».

Уведомлять об ошибках

Форма выбора пользователей-получателей уведомлений об ошибках, возникающих в момент выполнения отправки. Необходимо в отладочных целях в первые дни работы новых проектов.

Переход

Компонент, на который передается управление, если сообщение успешно отправлено.

Переход, неудача

Компонент, на который передается управление, если при отправке SMTP сервер вернул ошибку.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Форма «Способ отправки»:

Форма определяет способ отправки email сообщения. В зависимости от типа сценария email можно отправить через:

· SMTP сервер
· Встроенный почтовый клиент (доступен только для сценариев диалога)

Если для отправки выбран выбран «SMTP сервер», письмо будет отправлено немедленно на указанный SMTP сервер.

Для настройки доступны свойства:

Тип SMTP сервера

Свойство, определяющее источник настроек для SMTP сервера

· Операторский - используются настройки SMTP сервера по умолчанию в случае настроенного SMTP сервера на компьютере, где установлен клиент. Например - MS IIS SMTP Server.
· Общий (из настроек комплекса) - используются общие настройки комплекса
· Отдельный - настройки SMTP сервера определяются нижеследуюшими свойствами.

Адрес

Адрес SMTP сервера

Порт

Порт SMTP сервера. Значение не должно содержать более 4 цифр ( максимум: 9999 )

Требуется авторизация

Установлено, если SMTP сервер требует авторизацию

Требуется SSL авторизация

Установлено, если SMTP сервер требует SSL авторизацию

Логин

Учетная запись на почтовом сервере

Пароль

Пароль учетной записи на почтовом сервере

Если для отправки выбран «Встроенный почтовый клиент», письмо будет открыто на компьютере оператора в почтовом редакторе по умолчанию. Открыть письмо может любой почтовый редактор, поддерживающий MAPI интерфейс.

Прием входящего сообщения электронной почты

Осуществляет прием email-сообщения с указанного ящика электронной почты.

Свойства:

Способ получения

Форма, определяющая способ получения email-сообщения.

MessageId

Переменная, в которую будут сохранен идентификатор email сообщения.

Кому

Переменная, в которую будут сохранены получатели email сообщения.

От кого

Переменная, в которую будут сохранены отправители email сообщения.

Тема

Переменная, в которую будут сохранена тема email сообщения.

Текст письма

Переменная, в которую будут сохранен текст email сообщения.

Текст письма часть2

Переменная, в которую будут сохранен текст из второй части email сообщения. Используется для сообщений multipart.

Текст письма часть3

Переменная, в которую будут сохранен текст из третьей части email сообщения. Используется для сообщений multipart.

IMAP каталог

Аргумент, значение которого определяет IMAP каталог, из которого будет получено сообщение. По умолчанию используется стандартный каталог входящей почты Inbox.

Поле доступно только при работе с IMAP-сервером (свойство «Способ получения»).

IMAP запрос

Аргумент, значение которого определяет IMAP запрос. Запрос определяет критерии выбора сообщения из каталога, заданного свойством IMAP каталог. По умолчанию используется запрос, возвращающий все письма (значение "ALL"). Более подробно о синтаксисе IMAP запросов можно узнать из документации RFC 2060.

Поле доступно только при работе с IMAP-сервером (свойство «Способ получения»).

Принимать только заголовки

Да/Нет. Требуется ли получать только заголовки письма (в этом случае тело сообщения и прикрепленные файлы скачиваться с почтового сервера не будут)

Удалять с сервера

Да/Нет. Требуется ли удалить письмо с почтового сервера после получения.

Сохранять вложения

Определяет режим сохранения вложений.

· Нет. Вложения сохранены не будут.
· В указанную папку. В этом случае все вложенные файлы будут сохранены в папку, путь к которой установлен свойством "Папка для вложений".
· Во временную папку. В этом случае название каталога будет сгенерировано внутри папки, установленной в общих настройках, и сохранено в переменную, указанную в свойстве "Путь к папке с вложениями".

Путь к папке для вложений

Доступно только при выбранном режиме сохранения вложений.

В зависимости от выбранного режима представляет собой либо аргумент, устанавливающий абсолютный или относительный путь к папке, куда и будут сохранены вложения с исходными именами, либо переменную, в которую будет сохранен путь к папке с вложениями, имя которой было сгенерировано компонентом.

Уведомлять об ошибках

Форма выбора пользователей-получателей уведомлений об ошибках, возникающих в момент выполнения отправки. Необходимо в отладочных целях в первые дни работы новых проектов.

Переход, получено

Компонент, на который передается управление, если сообщение успешно получено.

Переход, не получено

Компонент, на который передается управление, если сообщение не получено, но при этом ошибок не возникло. Такая ситуация может возникнуть, если:

· на POP3 сервере нет сообщений
· на IMAP4 сервере нет сообщений в заданном каталоге
· на IMAP4 сервере нет сообщений в заданном каталоге удовлетворяющих заданным критериям

Переход, неудача

Компонент, на который передается управление, если при получении сообщения POP3 ( IMAP4 ) сервер вернул ошибку.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Форма «Способ получения»:

Форма определяет способ получения email сообщения. Сообщение можно получить через:

· POP сервер (по протоколу POP3)
· IMAP сервер (по протоколу IMAP4)

Для настройки доступны свойства:

Тип почтового сервера

Свойство, определяющее источник настроек для сервера входящей почты

· Общий (из настроек комплекса) - используются общие настройки комплекса
· Отдельный - настройки SMTP сервера определяются нижеследуюшими свойствами.

Адрес

Адрес сервера.

Порт

Порт сервера. (стандартный порт POP сервера - 110, IMAP сервера - 143).

Требуется авторизация

Установлено, если сервер требует авторизацию.

Требуется SSL авторизация

Установлено, если сервер требует SSL авторизацию.

Логин

Учетная запись на почтовом сервере.

Пароль

Пароль учетной записи на почтовом сервере.

Отправка ICQ сообщения

Осуществляет отправку сообщения ICQ. Указываются сервер ICQ, UIN адресата, UIN отправителя, способ подключения к серверу ICQ.

Работа с аккаунтом происходит через пул подключений. Любые обращения к аккаунту (отправки/приема из разных сценариев), влекущие подключение к серверу ICQ, помещают созданное подключение в специальный пул, где оно поддерживается некоторое время (устанавливается в разделе «Общие настройки. ICQ-сервис»). Каждое последующее обращение к аккаунту работает с подключением из пула и продляет время его существования. В случае таймаута аккаунт отключается. Также аккаунт отключается при получении ошибки сервера или выгрузке серверного приложения. Такой механизм работы гарантирует работу комплекса от ошибки сервера ICQ «Превышен лимит подключений». Для каждого аккаунта в пуле держится отдельное подключение.

Свойства:

Настройки прокси

Форма, определяющая настройки подключения к прокси-серверу.

Настройки учетной записи

Форма, определяющая настройки учетной записи ICQ, которая будет использоваться в качестве отправителя сообщения ICQ.

UIN

Аргумент, определяющий номера ICQ получателей ICQ сообщения. Если сообщение предназначается нескольким адресатам, то адреса должны быть перечислены через «,».

Таймаут ожидания соединения

Аргумент, определяющий временной интервал ( в миллисекундах ), в течение которого система ожидает соединения с ICQ сервером. При отправке сообщения выполнение сценария будет приостановленно до тех пор пока:

· Будет установлено успешное соединение с ICQ сервером
· Истечет таймаут ожидания соединения

Таймаут отправки соединения

Аргумент, определяющий временную задержку ( в миллисекундах ) перед отправкой сообщения.

Текст сообщения

Аргумент, определяющий текст сообщения.

Уведомлять об ошибках

Форма выбора пользователей-получателей уведомлений об ошибках, возникающих в момент выполнения отправки. Необходимо в отладочных целях в первые дни работы новых проектов.

Переход

Компонент, на который передается управление, если сообщение успешно отправлено.

Переход, неудача

Компонент, на который передается управление, если при отправке сервер вернул ошибку.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Форма «Настройки подключения»:

Форма определяет настройки подключения к ICQ серверу. Имеется возможность подключения напрямую и через прокси-сервер. Поддерживаются следующие типы прокси-серверов:

· SOCKS5
· HTTPS

Для настройки доступны свойства:

Тип прокси сервера

Свойство, определяющее источник настроек для сервера ICQ

· Без прокси-сервера - используется прокси-сервер по умолчанию на клиентской машине. В случае его отсутствия, подключение выполняется напрямую к ICQ серверу.
· Общий (из настроек комплекса) - используются общие настройки комплекса
· Отдельный - настройки прокси-сервера определяются нижеследуюшими свойствами.

Тип протокола

Свойство, определяющее тип протокола прокси-сервера:

· SOCKS5 - протокол SOCKS5
· HTTPS - протокол HTTPS

Адрес

Адрес сервера.

Порт

Порт сервера. (стандартный порт SOCKS5 сервера - 1080, HTTPS сервера - 8080).

Требуется авторизация

Установлено, если сервер требует авторизацию.

Логин

Учетная запись на прокси сервере.

Пароль

Пароль учетной записи на прокси сервере.

Форма «Настройки учетной записи»:

Форма определяет учетную запись ICQ, которая будет использоваться в качестве отправителя сообщения ICQ.

Для настройки доступны свойства:

Тип учетной записи

Свойство, определяющее источник настроек учетной записи

· Общий (из настроек комплекса) - используются общие настройки комплекса
· Отдельный - настройки учетной записи определяются нижеследуюшими свойствами.

UIN

Номер ICQ

Пароль UIN

Пароль ICQ

Получение ICQ сообщения

Осуществляет прием сообщения ICQ. Указываются сервер ICQ, UIN отправителя, UIN получателя, способ подключения к серверу ICQ.

Работа компонента происходит через пул подключений к серверу ICQ аналогично компоненту «Отправка ICQ-сообщения».

Свойства:

Настройки прокси

Форма, определяющая настройки подключения к прокси-серверу.

Настройки учетной записи

Форма, определяющая настройки учетной записи ICQ, которая будет использоваться в качестве получателя сообщения ICQ.

UIN

Переменная, в которую будет сохранен UIN отправителя ICQ сообщения.

Таймаут ожидания соединения

Аргумент, определяющий временной интервал ( в миллисекундах ), в течение которого система ожидает соединения с ICQ сервером. При получении сообщения выполнение сценария будет приостановленно до тех пор пока:

· Будет установлено успешное соединение с ICQ сервером
· Истечет таймаут ожидания соединения

Таймаут получения сообщения

Аргумент, определяющий временную задержку ( в миллисекундах ) перед получением сообщения. Если на учетную запись ICQ, указанную в свойстве «Настройки учетной записи» раньше приходили сообщения таймаут игнорируется, а в переменные «UIN», «Текст сообщения» будет подставлены значения, сохраненные в пуле сервера состояний системы.

Текст сообщения

Переменная, в которую будет сохранен текст полученного сообщения.

Уведомлять об ошибках

Форма выбора пользователей-получателей уведомлений об ошибках, возникающих в момент выполнения получения. Необходимо в отладочных целях в первые дни работы новых проектов.

Переход

Компонент, на который передается управление, если сообщение успешно получено.

Переход, сообщений нет

Компонент, на который передается управление, если новых сообщений не обнаружено.

Переход, неудача

Компонент, на который передается управление, если при получении сервер вернул ошибку.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Другие компоненты сценариев:

— Компоненты сценариев IVR

— Компоненты сценариев диалога

— Компоненты служебных сценариев


Сценарии IVR

Сценарии голосовой обработки (IVR) используются системой для автоматической обработки звонков. В каждый сценарий закладывается некая логика действия, в соответствии с которой происходит обработка вызова. Сценарии голосовых меню отличается от других сценариев возможностью управления линией, которой он назначается при поступлении звонка. Управление линией включает в себя возможность закончить соединение, коммутацию, проигрывание и запись файлов из линии, анализ полученных DTMF сигналов.

Обработчик сценария IVR характеризуется конкретным звонком, а соответственно и конкретной линией связи. Одновременно в системе может работать несколько обработчиков IVR, каждый из которых обслуживает отдельную линию системы.

Сценарии IVR используются в нескольких режимах:

· Поступление входящего звонка - главный сценарий;
· Начало обработки звонка по задаче автоматического исходящего оповещения;
· Входящий звонок на задачу автоматической обработки;
· Звонок на внутренний номер, за которым назначен сценарий IVR;
· Передача управления из одного сценария в другой;
· Переключение оператором абонента на номер, за которым назначен сценарий IVR;
· Переадресация на внешние номера с детальным указанием направлений;
· Гибкая маршрутизация (Вход в АТС) при снятии трубки на любом внутреннем телефоне и переключениях.
· Обработка вызовов, поступающих в момент ожидания завершения всех коммутаций при перезапуске сервера - для блокирования новых коммутаций.

Обработчик сценария IVR начинает выполнение сценария с объекта «Старт», если трубка на обслуживаемой линии не поднята (только для внешних линий), и выполняется последовательно. Если трубка на момент начала сценария поднята, после обработки объекта «Старт» производится безусловный переход к объекту «Поднять трубку», после которого уже производится последовательная обработка согласно значению свойств перехода. В каждом создаваемом сценарии изначально присутствуют два этих элемента, соединенные связью, но создатель может вставить между ними ряд определяющих конкретный сценарий объектов, или вовсе удалить один из них. Они создаются по умолчанию как напоминание о принципе работы обработчика сценариев IVR.

При передаче управления из одного сценария в другой может быть передан параметр. Также сохраняют свое значение все переменные, существующие под одним именем в обоих сценариях. Если оператором производится переключение абонента на сценарий IVR путем набора внутреннего номера, оператор изначально сам попадает в обработку сценарием. Переключение же производится на текущий выполняемый сценарий (не на тот, что был запущен изначально после набора номера), и в него повторно передается тот же параметр. Это дает возможность оператору перед переключением производить некоторые действия в сценарии за абонента.

Сценарии IVR хранящиеся в общей папке доступны для назначения на них номеров.

Чтобы задействовать прием входящих внешних вызовов и назначить на управление входящими вызовами некоторый сценарий – перейдите в раздел «Администрирование. Сценарии», выберите его в списке и назначьте главным. Убедитесь, что он сохранен на сервере, в противном случае доступ к нему будет блокирован, и все входящие вызовы останутся без ответа.

Главным может быть только один сценарий IVR. Однако из него могут получать управление любые другие сценарии IVR с помощью компонента «Запуск вложенного сценария».

Мы рекомендуем делить сценарии IVR согласно выполняемым задачам. Серверу Oktell и обработчику сценариев решительно безразлично, насколько объемны и структурированы сценарии. Но для понимания логики работы задач, для возможности быстрого редактирования, а также для использования готовых и законченных блоков с одним входом – используйте вложенные сценарии. Рекомендуемый максимальный объем сценария (с точки зрения удобства и понимания): 100 объектов.

Служебные переменные:

· Статус звонка. Используется в голосовых задачах, выполняющихся в автоматическом режиме с использованием сценариев IVR. Принудительно устанавливает состояние звонка (0– неудача, 1– успех). При отсутствии заполнения или при его сбросе (любое отличное от 0, 1 значение) производится принятие стандартного решения согласно установленному в задаче времени коммутации.
· Приоритет очереди. Используется при переключениях с использованием очереди. По умолчанию значение устанавливается из поля «Приоритет по умолчанию» в разделе «Общие настройки. Менеджер очередей». Изменение значения будет непосредственным образом влиять на позицию в очереди АТС при совершении звонка. Размещение будет произведено после всех элементов очереди, имеющих тот же самый приоритет. В качестве приоритета может быть выставлено любое целое числовое значение. Чем меньше значение, тем выше приоритет и, соответственно, размещение ближе к началу очереди. Это может быть использовано для VIP-клиентов, руководителей организации и пр. Текущий установленный приоритет сбрасывается в значение по умолчанию каждый раз после завершения звонка (трубка положена).

В этом разделе:

— Компоненты сценариев IVR


 Компоненты сценариев IVR

Компоненты сценариев IVR

 Содержание | Назад | Далее

В данном разделе в справочном порядке приведены лишь узкоспециализированные компоненты, доступные только сценариям IVR. Наличие таких компонентов обусловлено тем, что в отличие от других типов сценариев, IVR управляет одной конкретной линией и имеет доступ к аппаратным ресурсам. Среди появляющихся в этой связи возможностей: Проигрывание звуков, запись звуков, прием нажатых клавиш, возможность снять/положить трубку, переключение звонка на указанный номер и пр. Остальные компоненты являются общими для всех типов сценариев и описаны выше в разделе «Общие компоненты сценариев».

Поднять трубку

Компонент дает команду АТС снять трубку на обрабатываемой линии. Имеет смысл для внешних линий, на которые поступает звонок. Между компонентами «Старт» и «Поднять трубку» можно вставить другие компоненты, позволяющие отклонить звонок, не снимая трубки, в зависимости от некоторых условий.

Свойства:

Переход | Компонент, на который передается управление.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Положить трубку

Осуществляет разрыв связи на обслуживаемой линии и производит завершение сценария. Компонент нельзя использовать после проведения успешного переключения (коммутации).

Свойства:

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Воспроизведение звукового файла

Осуществляется проигрывание указанного звукового файла в линию абонента.

Файл можно указать явно и по имени. В случае явного указания файл копируется и присоединяется к сценарию. В случае указания файла по имени – в соответствующей форме определяется принцип построения полного пути, состоящего из каталога и имени, определяющихся отдельно друг от друга.

Проигрывание можно прервать одной из набора указанных последовательностей прерывания, при необходимости сохранив ее в буфер-переменную. Для длинного файла можно указать время, после которого прервать звучание, вне зависимости от того, завершился файл или нет. Таким образом завершение действия компонента осуществляется как только происходит одно из событий:

· файл закончился;
· сработал таймер установленного времени звучания;
· набрана последовательность или символ прерывания.

У компонента в контекстном меню доступна команда «Воспроизвести». При использовании прикрепленного файла он будет открыт во встроенном проигрывателе.

Свойства:

Файл

Окно ввода выбора проигрывающегося файла.

Файл может быть прикреплен к сценарию (выбран в момент редактирования и скопирован к сценарию), а также найден по сформированному пути в момент обработки сценария. Путь строится из составных частей: каталог и имя файла.

Каталог, в котором лежит файл может быть задан

· локальной категорией (в папке сценария);
· глобальной категорией (в папке, где хранятся все сценарии);
· абсолютным путем (C:\AAA\BBB);
· пустота – в этом случае считается, что значение имени файла уже содержит весь путь.

Имя файла берется из значения указанной переменной сценария.

Режим

Определяет режим проигрывания файла:

· Файл полностью
· Предпрослушивание
· Файл + дополнительное время

Время предпрослушивания

Доступно только в режиме предпрослушивания.

Числовой аргумент, опредляющий время в секундах, по истечении которого проигрывание прервется и управление перейдет к следующему компоненту.

ВНИМАНИЕ! В зависимости от значения (при наличии) ключа «EnableGuaranteePlayTimeout» в файле конфигурации сервера обработчик сценария может ждать или пропускать ожидание сигнала об окончании воспроизведения.

Дополнительное время

Доступно только в режиме «файл + дополнительное время».

Числовой аргумент, определяющий дополнительную задержку после воспроизведения, в ходе которой воспроизводится тишина и производится аналогичное ожидание набора символов.

Символы прерывания

Символы прерывания или их последовательности, разделенные запятыми или пробелами. При вводе с клавиатуры абонента указанной последовательности проигрывание прекращается, и управление переходит к следующему компоненту.

Буфер

Переменная, в которую сохранится последовательность, прервавшая воспроизведение.

Очистить буфер

Флаг, определяющий, будет ли последовательность дописана в конец к уже существующим в буфере данным, либо очистит их и запишется с начала.

Переход

Компонент, на который передается управление после завершения воспроизведения.

Переход, неудача

Компонент, на который передается управление в случае, если по какой либо причине произошел сбой и файл не начал воспроизводиться. Например незаданное имя, отсутствие файла или доступа к нему, неверный формат и т.п.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Проигрывание числа

Осуществляется проигрывание числа, определяемого аргументом (переменной, функцией, выражением, значением). Для проигрывания существуют несколько видов голосов, которые можно пополнять своими записями. Проигрывание производится по указанному формату (время, телефонный номер и т.д.), либо по указанной схеме (посимвольно, целиком).

Свойства:

Число

Аргумент (значение, переменная, функция, значение), строковое представление которого в числовом формате нужно проговорить текстом.

Голос

Выбор голоса для воспроизведения. Каждый голос представляет собой папку с набором файлов, озвучивающих достаточно большой набор числительных и используемых дополнительных слов. Папки хранятся в каталоге со сценариями. В комплект входят 3 голоса.

Перечень всех используемых файлов приведен в конце руководства в разделе «Перечень файлов, необходимых для озвучивания числовых значений».

Формат

Формат проигрываемого значения:

· Телефонный номер
· Дата
· Время
· Дата/время
· День недели
· Деньги в рублях
· Деньги в USD
· Деньги в Евро
· Количество
· «ПО ФОРМАТУ» — определяет расширенную настройку типа воспроизводимого числа

Тип проигрывания

Используется, если формат задан «По формату»

· Посимвольно (один ноль два три семь…)
· По 2 символа (двадцать два сорок четыре…)
· По 3 символа (триста пять двести тридцать четыре…)
· Целиком (Двести тридцать четыре триллиона пятьсот двадцать…)
· Буквы и числа посимвольно (один а б в X Y Z тире слэш.. )
· Слова и фразы (пожалуйста_введите_свой_код занято...). Ожидаются через любой пустой разделитель. В папке осуществляется поиск соответствующих файлов и их последовательное воспроизведение.

Поле доступно только при выборе значения «По формату» в свойстве «Формат».

Род

Используется, если формат задан «По формату».

· Мужской (один)
· Женский (одна)
· Средний (одно)

Поле доступно только при выборе одного из значений «По формату», «Количество» в свойстве «Формат».

Понижение тона

Осуществляет понижение тона в конце. Для этого в качестве последнего файла подставляется аналогичный с символом "_" в конце, озвученный как окончание речи. При его отсутствии берется обычный файл.

Переход

Компонент, на который передается управление после завершения воспроизведения.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Ввод числа

Ввод числа сопровождается тишиной в трубке. Принимает от пользователя число, набираемое с клавиатуры телефона, и сохраняет в буфер-переменную. Ввод прекращается, когда происходит одно из событий: сработал таймер назначенного времени ввода, набралось указанное количество символов, набрана последовательность или символ прерывания. При этом, в случае срабатывания таймера переход осуществляется по ветке «Время», имитируя неудавшийся ввод. В других случаях ввод считается успешным.

Свойства:

Символы прерывания | Символы прерывания или их последовательности, разделенные запятыми или пробелами. При вводе с клавиатуры абонента указанной последовательности проигрывание прекращается, и управление переходит к следующему компоненту.
Буфер | Переменная, в которую сохранится введенное значение. Последовательность прерывания сохранена не будет.
Очистить буфер | Флаг, определяющий, будет ли введенное значение дописано в конец к уже существующим в буфере данным, либо очистит их и запишется с начала.
Максимальное время | Аргумент, определяющий число - время ожидания ввода в секундах. По истечению времени введенное значение не сохраняется, и переход осуществляется по ветке «если время вышло». Если задан 0 – время не ограничивается.
Количество символов | Аргумент, определяющий количество символов, ввода которых будет ждать компонент. По приему указанного количества – сразу осуществляется переход. Если задан 0 – число не ограничено. Компонент ожидает ввода указанного количества символов безотносительно предварительного содержимого буфера (даже если он не очищается).
Переход | Компонент, на который передается управление после успешного завершения ввода.
Переход, время | Компонент, на который передается управление, если отведенное время истечет.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Воспроизведение звукового файла с преднабором

Объединение проигрывания файла и ввода. Компонент используется, если необходимо ввести данные, описав пользователю, что конкретно ему предстоит ввести. При этом пользователю предоставляется возможность не дослушивать звуковой файл до конца, и начать набирать в любом удобном ему месте. После набора первого символа звуковой файл прекращает звучать и запускается таймер времени ввода. Далее компонент действует также как Ввод числа.

У компонента в контекстном меню доступна команда «Воспроизвести». При использовании прикрепленного файла он будет открыт во встроенном проигрывателе.

Свойства:

Файл

Окно ввода выбора проигрывающегося файла.

Файл может быть прикреплен к сценарию (выбран в момент редактирования и скопирован к сценарию), а также найден по сформированному пути в момент обработки сценария. Путь строится из составных частей: каталог и имя файла.

Каталог, в котором лежит файл может быть задан

· локальной категорией (в папке сценария);
· глобальной категорией (в папке, где хранятся все сценарии);
· абсолютным путем (C:\AAA\BBB);
· пустота – в этом случае считается, что значение имени файла уже содержит весь путь.

Имя файла берется из значения указанной переменной сценария.

Символы прерывания

Символы прерывания или их последовательности, разделенные запятыми или пробелами. При вводе с клавиатуры абонента указанной последовательности проигрывание прекращается, и управление переходит к следующему компоненту.

Буфер

Переменная, в которую сохранится введенное значение. Последовательность прерывания сохранена не будет.

Очистить буфер

Флаг, определяющий, будет ли введенное значение дописано в конец к уже существующим в буфере данным, либо очистит их предварительно.

Максимальное время

Аргумент, определяющий число, которое толкуется как время ожидания ввода в секундах. По истечению времени введенное значение не сохраняется, и переход осуществляется по ветке «если время вышло». Если задан 0 – время не ограничивается.

Время засекается по набору первого символа, либо по завершению воспроизведения файла.

Количество символов

Аргумент, определяющий число, которое толкуется как количество символов будет ждать компонент. По приему указанного количества – сразу осуществляется переход. Если задан 0 – число не ограничено.

Переход

Компонент, на который передается управление после успешного завершения ввода.

Переход, время

Компонент, на который передается управление, если отведенное время истечет.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Запись звукового файла

Компонент позволяет записывать звуковые данные с микрофона абонента. Указывается составное путь к файлу (отдельно каталог и имя), в который нужно сохранить данные. Имя файла можно генерировать случайно, после чего сохранять в буфер-переменную для дальнейшего использования или сохранения в БД. Остановка записи производится при срабатывании одного из событий: набрана одна из заданных в компоненте последовательностей прерывания или установленное время записи вышло (переход осуществляется по ветке «Время вышло»).

Свойства:

Файл

Окно ввода выбора пути к файлу для записи.

Файл задается при помощи правила построения пути. Путь формируется из двух частей: каталог и имя файла.

Каталог, в котором лежит файл

· локальная категория (в папке сценария);
· глобальная категория (в папке, где хранятся все сценарии);
· абсолютный путь (C:\AAA\BBB);
· не задан (в этом случае считается, что значение имени файла уже содержит весь путь).

Имя файла

· задается и фиксировано;
· генерируется, и значение сгенерированное сохраняется в переменную;
· из значения указанной переменной сценария.

Имя файла в переменную

Сохраняется имя файла, в который записали (используется, если имя генерируется).

Возвращать полный путь

Да/нет. Устанавливает формат возвращаемого имени файла. Только имя и расширение или полный путь к файлу с указанием диска.

Символы прерывания

Символы прерывания или их последовательности, разделенные запятыми или пробелами. При вводе с клавиатуры абонента указанной последовательности запись прекращается, и управление переходит к следующему компоненту, определенному веткой «Переход».

Буфер

Переменная, в которую сохранится последовательность прерывания.

Очистить буфер

Флаг, определяющий, будет ли введенная последовательность дописана в конец к уже существующим в буфере данным, либо очистит их предварительно.

Максимальное время

Аргумент, определяющий число, которое толкуется как время ожидания ввода в секундах. По истечению времени введенное значение не сохраняется, и переход осуществляется по ветке «если время вышло». Если задан 0 – время не ограничивается.

Время засекается по набору первого символа, либо по завершению воспроизведения файла.

Начинать новую папку

Определяет, вставлять ли между указанным именем файла и указанной папкой еще папку, и как часто их начинать. Возможные варианты:

· Никогда
· Каждый час
· Каждый день
· Каждую неделю
· Каждый месяц
· Каждые 3 месяца
· Каждый год

Переход

Компонент, на который передается управление после успешного завершения ввода.

Переход, время

Компонент, на который передается управление, если отведенное время истечет.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Переключение на номер

Переключение на номер позволяет коммутировать обслуживаемую линию с другой линией, на противоположном конце которой находится абонент с указанным номером. Переключение можно осуществлять как во внешнюю среду (город), так и во внутреннюю (внутри Oktell).

В случае успеха коммутации переход осуществляется по ветке «Переход» и ожидается появление компонента «Стоп», который прервет выполение сценария без разрыва коммутации и без возврата управления в родительские сценарии. Если номер занят – по ветке «Занято», если не отвечает – по ветке «Не отвечает».

В ходе набора городского номера производится резервирование свободной и доступной по правам внешней линии, набор в нее номера и ожидание ответа в течение установленного интервала времени (по умолчанию 40 секунд). В ходе ожидания воспроизводится стандартная мелодия. При обработке сценария по внешней линии, или по внутренней линии, которая не связана с пользователем, выделение внешних линий производится в обратном порядке с самой последней.

Для переключения на город (или на внешнюю АТС) существует также компонент «Переключение на внешний номер с указанием последовательности выделения внешних линий», в котором явно устанавливается перечень и последовательность выделения внешних линий, а также существует возможность выбора воспроизводимой мелодии ожидания.

Переключение внутри АТС может осуществляться на все типы внутренних номеров.

Стандартный номер. Производится попытка соединения абонента с одним из операторов или одной из внутренних линий, назначенных в номере. В случае, если все операторы/линии номера заняты возможно использование очереди ожидания.

Быстрый номер. Переключение осуществляется внутрь АТС, однако физически производится набор номера во внешнюю линию. В зависимости от типа быстрого номера (АТС/Город) производится выбор соответствующей внешней линии. Если свободных внешних линий не найдено, производится возврат управления по ветке «Занято». При успешном резервировании линии возврат происходит после получения ответа городской (или внешней) АТС по соответствующей ветке.

Запуск IVR. Производится безвозвратный запуск назначенного в номере сценария. Текущий сценарий прекращает свое исполнение и дальнейший переход по веткам компонента не осуществляется.

Служебный номер. Среди внутренних служебных номеров, на которые возможно переключение из компонента, доступны «Выход в город», «Выход в АТС» и «Перехват». В первых двух случаях при наборе номера осуществляется резервирование соответствующей служебному номеру внешней линии (или коммутация с ней в зависимости от установки способа набора в модуле «Общие настройки. АТС»). Если операция успешно выполнена, управление в сценарий возвращается по ветке «Переход», и ожидается завершение сценария компонентом «Стоп». Дальше абонент попадает в условия как если бы он на внутренней линии после снятия трубки набрал соответствующий служебный номер.Это дает возможность пользоваться соответствующими служебными номерами пользователям и абонентам, находящимся на внешних линиях системы. «Перехват» работает стандартным способом и в основном необходим только в случае использования режима входа в АТС через установленный сценарий IVR (здесь).

В случаяе отсутствия в системе указанного номера или несоответствия его типа одному из описанных выше происходит возврат управления по ветке «Не отвечает».

Свойства:

Назначение

Номер может быть городским (внешним) и внутренним АТС.

Режим «Авто» позволяет установить автоматическое распознавание номера и в случае его наличия во внутреннем номерном плане производить переключение внутрь системы, в противном случае набирать номер в город.

Назначение «Возврат к оператору» может быть использовано в call-центре для принудительного разрыва коммутации абонента, отбоя второго участника и возврата звонка на зарезервированного в этот момент оператора, который в задаче ожидает обратного соединения. Подробнее в разделе «Голосовые задачи. Дополнительно. Поведение при переключении на IVR. Оставлять оператора ожидающим соединения». Также режим может использоваться для разрыва только что начавшейся коммутации по некоторому событию (истечению времени, набора команды DTMF, появления в БД некоторых данных и т.п.) и перевести его на дальнейшую полноценную обработку в сценарии IVR.

Номер

Аргумент, определяющий номер, по которому производить дозвон.

Очередь ожидания

Активировать ли очередь ожидания для внутреннего переключения, в случае, если номер занят.

Поле доступно только при выборе значения «Внутри АТС» в свойстве «Назначение».

Время ожидания

Определяет, сколько секунд необходимо ожидать соединения перед отбоем. На очередь ожидания параметр не влияет.

Параметр команды

Свойство для служебных сценариев. Не используется в обычном режиме. Служит для передачи пароля пользователя и автоматической подстановки его в статистику в качестве инициатора звонка.

Поле доступно только при выборе значения «В город» в свойстве «Назначение».

Запись разговора

Параметр, определяющий необходимость записи. По умолчанию выбран вариант «Согласно настройкам», при котором используется стандартная процедура поиска правил записи для звонка. Также доступны варианты «Записывать» и «Не записывать», производящие соответствующие безусловные действия.

Переход

Компонент, на который передается управление в случае успешной коммутации

Переход, занято

Компонент, на который передается управление, если номер занят (для внутренних, если очередь ожидания не активирована).

Переход, не отвечает

Компонент, на который передается управление, если время ожидания истекло.

Переход, отсутствует

Компонент, на который передается управление, если номер не обнаружен, нет ни одного активного абонента, отсутствует внешняя линия при попытке набора быстрого номера.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Переключение на внешний номер с указанием последовательности выделения линий

Переключение на номер позволяет коммутировать обслуживаемую линию с другой (внешней) линией, на противоположном конце которой находится абонент с указанным внешним (городским/АТС) номером.

В ходе набора номера производится поиск свободной внешней линии в соответствии с установленным списком, резервирование, набор номера и ожидание ответа в течение установленного интервала времени (по умолчанию 40 секунд). В ходе ожидания воспроизводится выбранная мелодия. В зависимости от установленных свойств поведение компонента может меняться кардинальным образом.

Свойства:

Номер

Аргумент, определяющий номер, по которому производить дозвон.

В качестве номера может быть принята команда (строка, содержащая DTMF символы и командные спец. символы w, q, z, {, }). Подробнее о командах в разделе «Администрирование. Направления».

ВНИМАНИЕ! Если номер пустой или не указан, то вместо набора номеров производится выход на одну из назначенных внешних линий, аналогичный служебному номеру «Выход в город» или «Выход в АТС». Выборка линий производится в установленной компонентом последовательности. Исключение составляет случай, когда значение свойства «Коммутировать сразу» - нет.

CallerId

Подставляемый для звонка номер. При отсутствии или некорректном значении будет взят номер по умолчанию для канала.

Тип команды

Определяет способ преобразования номера в команду, отсылаемую на набор. По умолчанию без преобразования.

· Без преобразования. Отправляет номер как есть в зарезервированную линию.
· Использовать команду направления. Если зарезервированная линия взята из направления, и в нем настроено преобразование номера, то перед отправкой на набор номер будет преобразован в строку-команду по указанной в направлении схеме. Подробно здесь.

В некоторых случаях преобразование номера в команду может быть произведено предварительно в самом сценарии, или вовсе команда как итог может быть указана в таблице абонентов (номер в чистом виде - частный случай команды). В этом случае дополнительно преобразовывать команду не следует, и стоит оставить режим "без преобразования". Конечный режим реализации зависит от задач и целей.

Линии, направления

Осуществляет выбор линий и направлений для осуществления звонка.

На вкладке «Список объектов» предоставляется возможность указать явно последовательность существующих в системе линий и направлений для осуществления звонка. Можно отключить использование некоторых элементов, а для выбранных установить последовательность поиска свободной линии.

Поиск свободной будет осуществляться в соответствии с установленной последовательностью. По каждому направлению анализируются все линии, входящие в его состав. Если линия присутствует в нескольких направлениях, то при обнаружении ее свободной и установленном в компоненте режиме преобразования номера в соответствии с командой направления, будет применена команда того направления, которое в перечислении находится выше по приоритету.

На вкладке «Аргумент» возможно динамическое указание линии через ее Guid-идентификатор в строковом представлении. Также здесь может быть указан идентификатор направления, потока или шлюза. В этом случае будут последовательно перебираться все линии указанного объекта до обнаружения свободной и готовой к совершению вызова. Режим введен для использования совместно со шлюзами с динамической регистрацией потоков и компонентом сценариев «Регистрация потока».

Фильтровать по правам

Да/нет. При задействовании режима в случае, если осуществляется обработка канала пользователя системы, может быть осуществлена дополнительная фильтрация перечисленных в компоненте линий в соответствии с настройками прав выхода на внешние линии для пользователя. По умолчанию «Нет» - не фильтровать.

Время ожидания

Аргумент определяет, сколько секунд необходимо ожидать соединения перед отбоем.

Коммутировать сразу

Да/нет. По умолчанию «нет». Определяет поведение компонента. В случае, если флаг выставлен, то после нахождения доступной внешней линии и начала набора в нее номера сразу производится ее коммутация с каналом, обслуживаемым в сценарии. Возврат осуществляется по стандартной ветке «Переход». Если происходит сбой при ожидании или при коммутации, то возврат происходит по ветке «Не отвечает». При отсутствии доступной линии - возврат по ветке «Занято».

ВНИМАНИЕ! В случае, если одновременно с установкой значения «да» этому свойству в компоненте назначен пустой номер, то поведение CTI каналов (FXO, E1) меняется. После снятия трубки на внешнем канале производится его коммутация с обслуживаемым каналом. Необходимо крайне аккуратно пользоваться этим режимом в случае работы с потоками Е1, так как в общем случае без дополнительных устройств-преобразователей протокол не поддерживает посимвольного набора номера через звуковой интерфейс, и, следовательно, такая комбинация параметров повлечет невозможность дальнейшего набора номера и коммутации с абонентом. Также описанный режим небходимо осмотрительно использовать при назначении в компоненте последовательности линий из разных потоков, и тем более линий разного типа (E1, FXO, IP).

Мелодия ожидания

Окно выбора мелодии ожидания, аналогичное выбору файла компонента «Воспроизведение». Мелодия будет воспроизводиться вплоть до окончания работы компонента. Может быть выбрана непосредственно и прикреплена к сценарию, а также быть взята по сформированному пути на сервере.

Параметр команды

Свойство для служебных сценариев. Не используется в обычном режиме. Служит для передачи пароля пользователя и автоматической подстановки его в статистику в качестве инициатора звонка.

Запись разговора

Параметр, определяющий необходимость записи. По умолчанию выбран вариант «Согласно настройкам», при котором используется стандартная процедура поиска правил записи для звонка. Также доступны варианты «Записывать» и «Не записывать», производящие соответствующие безусловные действия.

Переход

Компонент, на который передается управление в случае успешной коммутации.

В случае, если установлен режим коммутирования сразу, успешной коммутацией считается момент соединения двух каналов (от абонента на внешней линии не получено никаких сигналов, в дальнейшем возможно получение КПВ, отбоя или ответа абонента).

Переход, занято

Компонент, на который передается управление, если номер занят (для внутренних, если очередь ожидания не активирована).

Свойство доступно только если не установлен режим коммутирования сразу.

Переход, не отвечает

Компонент, на который передается управление, если время ожидания истекло.

Свойство доступно только если не установлен режим коммутирования сразу.

Переход, линия не найдена

Компонент, на который передается управление, если не обнаружена доступная для совершения вызова внешняя линия из списка.

Переход, ошибка

Компонент, на который передается управление, если в ходе проверки пароля, набора номера, ожидания событий или коммутации двух каналов возникла какая-либо ошибка.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Вход в задачу

Вход в задачу инициирует существующую в системе и указанную в сценарии задачу и осуществляет переключение на оператора . Оператор выбирается менеджером задач из списка свободных и назначенных на задачу операторов по заложенному в нее алгоритму. В случае если операторы все заняты, может быть задействована очередь ожидания, для этого установите свойство компонента «Очередь». В зависимости от текущего состояния задачи выход производится по одному из свойств перехода. Переключение также может осуществляться на входящую задачу автоматической обработки звонка. В этом случае производится переключение сценария с формированием записи в статистической БД. Вход в задачу может быть осуществлен как из основного сценария IVR, так и из принадлежащего проекту. В последнем случае в списке доступных задач отображаются только задачи текущего проекта.

Свойства:

Задача

Одна из списка входящих голосовых задач системы Oktell или текущего проекта.

Тип идентификации

Идентификацией является определение строки в таблице абонентов, прикрепленной к запускаемой задаче. Режим идентификации задействуется только если в запускаемой входящей голосовой задаче установлено свойство «Модифицировать записи». Противоположным режимом является создание новых записей при каждом звонке вне зависимости от того, найден или не найден абонент в таблице. Также возможно, совместно установив свойства «Модифицировать записи» в задаче и «Возврат, если абонент не найден» в текущем компоненте, задействовать режим входа в задачу только при успешном обнаружении абонента в таблице.

Среди способов идентификации выделяются два:

· По АОН среди полей таблицы, обозначенных типом «Телефон»;
· По значению в указанном поле таблице (используются свойства «Идентификатор абонента» и «Поле идентификации» текущего компонента.

В некоторых случаях, когда одного поля недостаточно, и нужна более серьезная проверка условий идентификации, можно использовать «Запрос в БД» с произвольной проверкой условий и возвратом уникального значения строки в таблице с последующим входом в задачу и идентификацией по основному полю «Id», обозначенного в таблице абонентов как «Идентификатор».

Идентификатор абонента

Аргумент, значение которого берется для идентификации абонента. Ожидается, что значение уникально определяет абонента. Используется совместно со свойством «Поле идентификации».

Поле доступно только при выборе значения «По столбцу» в свойстве «Тип идентификации».

Поле идентификации

Строковый аргумент, содержащий название столбца (поля) в прикрепленной таблице абонентов, по которому будет осуществлен поиск на совпадение значений таблицы и передаваемого идентификатора абонента. В качестве поля для идентификации может быть взят любой существующий столбец в таблице абонентов.

Поле доступно только при выборе значения «По столбцу» в свойстве «Тип идентификации».

Возврат, если абонент не найден

Да/Нет. Определяет способ запуска задачи с идентификацией абонентов. Имеет смысл только при входе в задачу с установленным свойством «Модифицировать записи прикрепленной таблицы».

При установке значения «Да» в случае неудачного поиска абонента в таблице осуществляет возврат по ветке «Переход, абонент не найден».

При установке значения «Нет» осуществляется стандартная процедура добавления новой записи в таблицу с установкой поля идентификаторов, по которому осуществлялся поиск.

Очередь ожидания

Активировать ли очередь ожидания в случае, если номер занят.

Переход

Компонент, на который передается управление в случае успешной коммутации с оператором. В случае успешного запуска сценария задачи автоматической обработки выполнение текущего сценария прекращается на этом компоненте.

Переход, превышено число подключений

Компонент, на который передается управление, если данным звонком превышено установленное в задаче максимальное число подключений (одновременных звонков во входящей задаче). Максимальное число задается в свойствах голосовой задачи на вкладке «Ресурсы».

Переход, задача не найдена

Компонент, на который передается управление, если задача не задана или указанная не найдена среди существующих в системе.

Переход, абонент не найден

Компонент, на который передается управление, если абонент не идентифицирован в прикрепленной таблице. Это может произойти в случае, если установлено свойство «Возврат, если абонент не найден» текущего компонента, а также в запускаемой задаче установлено свойство «Модифицировать записи прикрепленной таблицы».

Поле доступно только при выборе значения «Да» в свойстве «Возврат, если абонент не найден».

Переход, вне расписания

Компонент, на который передается управление, если вход осуществляется во время, не установленное недельным графиком активности задачи.

Переход, вне периода активности

Компонент, на который передается управление, если вход осуществляется во время, находящееся за границами активации или деактивации задачи.

Переход, параметры не подходят

Компонент, на который передается управление, если задача неактивна, задача не является входящей или звонок осуществляется с линии, не поддерживающей обработку в задаче (внутренние линии или линии, подключенные к АТС).

Переход, превышено время в очереди

Компонент, на который передается управление, если абонент попал в очередь задачи и находился в ожидании более установленного времени (свойства задачи на вкладке «Дополнительно»).

Переход, занято

Компонент, на который передается управление, если все операторы заняты, и не включена очередь ожидания.

Переход, не отвечает

Компонент, на который передается управление, если не найдено ни одного оператора, либо время ожидания ответа последнего оператора истекло.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Вход в проект

Администратор комплекса, не владея информацией о задачах, может настроить переадресацию потока звонков на проект. Компонентом «Вход в проект» производится поиск и запуск главного сценария IVR указанного в свойстве проекта. Тот в свою очередь может иметь любую структуру: запускать задачи, ветвиться, запускать вложенные сценарии и пр.

Непосредственно перед запуском осуществляется упаковка текущего сценария в стэк. Таким образом, обработка звонка продолжится по общему принципу, заложенному администратором, если главный сценарий проекта вернет управление (с помощью компонента «Стоп» с установленным свойством «Возврат управления»). В случае успеха, или отсутствия необходимости возврата управления в основной сценарий, в сценарии проекта должен присутствовать компонент «Стоп» с неустановленным свойством «Возврат управления» (в случае успешного переключения) или «Положить трубку».

Свойства:

Проект | Один из списка существующих проектов системы Oktell.
Переход | Компонент, на который передается управление в случае возврата управления из главного сценария запускаемого проекта (с помощью компонента «Стоп» с установленным свойством «Возврат управления»).
Переход, проект не найдена | Компонент, на который передается управление, если проект не указан или не найден среди существующих в системе.
Переход, параметры не подходят | Компонент, на который передается управление, если в проекте не задан главный сценарий или не найден файл главного сценария.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Управление контентом

Осуществляет чтение или изменение пользовательского поля выбранного контента. В ходе работы с каналом системой производится сбор и формирование контента. Это XML документ, который существует в памяти сервера и постоянно пополняется происходящими действиями в ходе обработки вызова. Контент линии существует только у внешних линий, формируется при поступлении или совершении звонка по каналу, и сбрасывается при завершении этого звонка. Может быть передан в служебный сценарий, запускаемый по окончании обработки вызова по внешнему каналу. Также существует контент цепочки коммутаций, который формируется пока существует обозначенная цепочка. При присоединении или отбое каналов из цепочки ее контент существует, наполняется и может быть обработан внешним образом.

Свойства:

Объект | Линия (канал) / цепочка коммутаций. Источник обрабатываемого контента (контент в системе двух видов - для канала и для цепочки коммутаций)
Элемент | Заголовок/коммутация. Пользовательское поле может быть взято в заголовке всего контента или в поле конкретной коммутации.
Действие | Получить/установить. Определяет действие, которое производится с пользовательским полем
Переменная/Аргумент | В зависимости от действия назначается либо аргумент (значение которого будет установлено в определенное пользовательское поле контента) или переменная, в которую будет размещено значение определенного пользовательского поля контента.
Переход | Компонент, на который передается управление после завершения работы.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Вход в конференцию

Производит подключение канала к конференции. Подробно о конференц-связи и управлении в разделе «Клиентское приложение. Телефон. Конференц-связь».

Компонент предоставляет возможность доступа к конференциям для активных каналов, для реализации автоматического сбора конференций, а также для подключения к конференции при отсутствии клиентского интерфейса по инициативе пользователя системы.

Свойства:

Номер конференции

Числовой аргумент, определяющий номер виртуальной комнаты, в которой проходит конференция. В каждый момент времени уникальным образом идентифицирует активную конференцию. Номера могут повторяться в истории, однако в каждый момент времени не существует двух активных конференций с одним номером.

В случае обнаружения активной конференции с указанным номером производится подключение к ней (с проверкой прав). В противном случае в зависимости от установленных свойств производится ее создание, либо выход из компонента.

Создать, если отсутствует

Да/нет. Определяет поведение компонента в случае, если конференции с указанным номером комнаты не существует на текущий момент. «Да» - производит создание конференции и подключается к ней, «Нет» - отклоняет вход и производит выход по ветке «Отсутствует».

Название конференции

Название конференции для отображения в клиентском интерфейсе и в статистических модулях. Применяется, если конференция не существует и компонентом производится ее создание.

Запись

Определяет будет ли производиться запись конференции. Применяется, если конференция не существует и компонентом производится ее создание. В случае наличия такой записи доступ к ее прослушиванию будет открыт для всех участников конференции, если иного не будет установлено создателем через клиентский интерфейс, пока конференция активна.

Таймаут ожидания разрешения

Время, в течение которого компонент будет ожидать ответа управляющего в случае, если конференция имеет режим входа с подтверждением.

Переход

Компонент, на который передается управление после успешного входа в конференцию.

Переход, отсутствует

Компонент, на который передается управление в случае, если конференция не существует и заблокирован режим создания (свойством «Создать, если отсутствует» или не установленной привилегией пользователя на создание).

Переход, нет доступа

Компонент, на который передается управление в случае, если конференция существует, и доступ к конференции заблокирован (закрытая конференция или управляющий отклонил запрос на вход).

Переход, таймаут ожидания разрешения

Компонент, на который передается управление в случае, если при входе в конференцию требуется разрешение управляющего, реакции которого не последовало в течение установленного свойством «Таймаут» времени.

Переход, неудача

Компонент, на который передается управление после завершения работы в случае, если произошло исключение, сбой или любой другой непредвиденный результат, приведший к отклонению входа.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Отправка факсимильного сообщения

Компонент открывает факс сеанс на линии и в случае успеха отправляет документы, определенные в параметрах. Для корректной работы необходимо наличие в текущей плате возможности работы с факсимильными сообщениями, наличие свободных портов для факс-сеансов.

Для плат семейства Ольха-9 необходим ключ, лицензирующий работу с факсами.

Для плат Synway необходимо наличие мезонина для работы с факсами.

Каждое из семейств плат требует свои уникальные параметры для работы: ширина страницы в пикселях, режим многостраничности, высота страницы, способ формирования имен. Настройку компонента рекомендуется производить под конкретную плату.

Компонент отправки предоставляет возможность автоматического преобразования изображения в необходимый формат. Однако в зависимости от используемых параметров (тип преобразования, размер исходного документа и т.д.) это может занять некоторое время. Поэтому настоятельно рекомендуется во избежание пауз готовить файлы в нужном формате.

Свойства:

Документ 1

Файл изображения для отправки. Окно выбора изображения. Допускаются статические файлы, хранящиеся вместе со сценариями, а также динамически прикрепляемые файлы, имя которых формируется в компоненте на этапе исполнения.

Документ 2

Аналогичено свойству Документ 1.

Документ 3

Аналогичено свойству Документ 1.

Тип преобразования к битовому изображению

Один из вариантов преобразования отправляемых изображений к битовому, поддерживаемому формату факсимильной передачи.

Среди способов преобразования допускаются:

· Без изменений. Файл будет передан в исходном виде. В случае если он не подходит, будет возвращена ошибка;
· По фиксированной границе яркости. В соответствии с коэффициентом;
· По границе яркости от крайних точек;
· По проценту заполнения листа;
· Случайный офсет.

Коэффициент границы контрастности

Аргумент, представляющий собой действительное число от 0 до 1, являющееся параметром для функции преобразования к битовому изображению. Например при выборе пункта "По фиксированной границе яркости" определяет уровень яркости, ниже которого производится преобразование к черному цвету, остальные к белому.

Приведение ширины

Для отправки факса в битовом изображении требуется строго фиксированная ширина.

Среди способов преобразования допускаются:

· Без изменений. Файл будет передан в исходном виде с исходной шириной. В случае, если он не подходит, будет возвращена ошибка.
· Достраивать без изменения размера. Если изображение меньше требуемой ширины, его ширина будет увеличена за счет белых полос по краям.
· Приводить по X. Ширина будет изменена до требуемой, высота останется без изменений.
· Приводить по XY пропорционально. Ширина будет изменена до требуемой, высота будет изменена аналогично изменению ширины для сохранения пропорций.
· Растягивать по X. Если изображение меньше требуемой ширины, ширина будет увеличена до необходимой, высота останется без изменений.
· Растягивать по XY пропорционально. Если изображение меньше требуемой ширины, ширина будет увеличена до необходимой, высота будет изменена аналогично для сохранения пропорций.
· Сужать по X. Если изображение больше требуемой ширины, ширина будет уменьшена до необходимой, высота останется без изменений.
· Сужать по XY пропорционально. Если изображение больше требуемой ширины, ширина будет уменьшена до необходимой, высота будет уменьшена аналогично для сохранения пропорций.

Таймаут, с

Числовой аргумент, определяющий время в секундах до принудительного разрыва сеанса. Если не задан или равен нулю, ограничение снимается.

Код ошибки в переменную

Переменная, в которую будет записан числовой код ошибки.

Коды возвращаемых ошибок:

0 - Ошибок нет.

1 - Канал не поддерживает факс сеанс.

3 - Таймаут.

4 - Исключение при вызове аппаратной функции.

5 - Неверные параметры.

65281 - Системная ошибка.

65282 - Ошибка драйвера.

65283 - Ошибка ввода-вывода устройства.

65284 - Ошибка памяти.

65285 - Факс сессия уже открыта.

65288 - Ошибка файла.

65289 - Страницы не обнаружены.

65290 - Превышение количества строк.

65292 - Несоответствие версии драйвера.

65295 - Некорректная версия.

Переход, успех

Компонент, на который передается управление после успешно проведенной операции.

Переход, неудача

Компонент, на который передается управление, если отправка завершилась неудачей.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Прием факсимильного сообщения

Компонент открывает факс сеанс на линии и в случае успеха принимает факсимильные сообщения и сохраняет в определенное в параметрах место. Для корректной работы необходимо наличие в текущей плате возможности работы с факсимильными сообщениями, наличие свободных портов для факс-сеансов.

Для плат семейства Ольха-9 необходим ключ, лицензирующий работу с факсами.

Для плат Synway необходимо наличие мезонина для работы с факсами.

Каждое из семейств плат требует свои уникальные параметры для работы: ширина страницы в пикселях, режим многостраничности, высота страницы, способ формирования имен. Настройку компонента рекомендуется производить под конкретную плату.

В случае если принимается более одного документа, производится формирование нескольких файлов, с добавлением к имени исходного определенного в параметрах файла расширениях, например «_pageN».

Свойства:

Файл | Файл изображения для отправки. Окно выбора изображения. Допускаются статические файлы, хранящиеся вместе со сценариями, а также динамически прикрепляемые файлы, имя которых формируется в компоненте на этапе исполнения.
Имя файла в переменную | Аналогичено свойству Документ 1.
Возвращать полный путь | Аналогичено свойству Документ 1.
Таймаут, с | Числовой аргумент, определяющий время в секундах до принудительного разрыва сеанса. Если не задан или равен нулю, ограничение снимается.
Код ошибки в переменную | Переменная, в которую будет записан числовой код ошибки. Перечень в\озможных ошибок см. в описании аналогичного свойства компонента «Отправка факсимильного сообщения».
Переход, успех | Компонент, на который передается управление после успешно проведенной операции.
Переход, неудача | Компонент, на который передается управление, если прием завершился неудачей.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.


Сценарии диалога

Сценарии диалога используются системой в большей части для помощи операторам call-центра в обработке звонков. Одновременно оператор может участвовать в обработке вызовов по нескольким, совершенно различных задачам. Упрощению его деятельности служат сценарии диалога, создаваемые управляющим менеджером, который осуществляет руководство call-центром или front-офисом.

Каждый сценарий содержит некую логику действий, в соответствии с которой происходит взаимодействие с БД и осуществляются подсказки оператору. Наличие в сценарии возможности компоновать формы ввода/вывода позволяют в ходе массовой обработки звонков доносить до конкретного абонента большой объем персонифицированной информации, а также производить анкетирование и сохранять полученные оператором ответы в БД в различных вариантах. Полученные ответы могут быть как персонифицированными (сохраняться в подключаемых к задачам таблицах), так и статистическими (модифицировать общую статистическую информацию на основе настроек).

Основные направления работы обработчика сценария диалога:

· Всплывающие «PopUp» окна на компьютере оператора;
· Сбор информации, вводимой оператором в формы ввода ответов абонента, для последующего анализа руководством и получения расширенной статистики по интересующей задаче;
· Запуск процессов и приложений пользователя на сервере или на компьютере оператора (html Документы, web-сценарии и собственные приложения организации), использование произвольных web документов и сценариев в контексте звонка;
· Уведомления пользователям системы;
· Автоматические формирования заказов на встречные звонки;
· Обращение в БД и WEB за получением информации по звонку (абоненту);

Сценарии диалогов прикрепляются к внешнему звонку, но работают с операторами call-центра. Таким образом, при переключении звонка между операторами всплывающие формы ввода автоматически переходят от одного оператора к другому. В этом случае первый снимается с резерва задачи, а второй ставится. В диалоговых окнах операторам доступно поле комментария. Информация в этом поле по мере выполнения одного сценария может изменяться и дополняться и перетекает из одной карточки сценария в другую. Этим достигается возможность доносить информацию об основных моментах диалога с абонентом до оператора, на которого производится переключение. Диалоговые и web-формы при передаче между операторами сохраняют значения полей.

Несмотря на соответствие сценария и линии абонента, доступ к аппаратным ресурсам у сценария диалога заблокирован. Для работы с линией используются сценарии IVR, а диалоговый сценарий активируется при коммутации абонента с оператором и имеет среди своих задач только обеспечение удобного интерфейса для оператора по общению с БД, web-сервисами и смежные с этим. Уникальными средствами при создании сценария диалога являются редакторы форм. Речь о них пойдет ниже в данном разделе.

Обработчик сценария диалога запускается менеджером задачи при ее выполнении, если в ней задан существующий на сервере сценарий диалога. Момент запуска определяется администратором комплекса Oktell. По умолчанию – в момент перед коммутацией оператора с обслуживаемым абонентом. При переключении абонента на другого оператора/пользователя активный назначенный еще не завершенный сценарий диалога начинает/продолжает обрабатывать формы на рабочей станции последнего.

Альтернативное направление использования диалоговых сценариев - запрос на звонок. В исходящих задачах, где оператор на основании выбранной в таблице абонентов информации самостоятельно принимает решение звонить, пропустить звонок или удалить абонента из списка, существует возможность формировать более сложные методики, выводить больше информации, обрабатывать и заносить информацию в БД в момент и/или для принятия оператором решения.

Выполнение сценария начинается с объекта «Старт». Компонент «Старт» создается по умолчанию в сценарии при его редактировании.

Сценарии диалога могут, как и другие сценарии, храниться по проектам и в общей папке. Переключения между сценариями диалога не предусмотрено. При создании задачи в качестве прикрепленного сценария диалога можно выбрать из списка любой существующий в проекте сценарий, либо вписать руками название сценария из общей папки. Это имеет смысл, только если в ходе реализации множества различных проектов требуется один и тот же сценарий.

Основное время выполнения сценария диалога занимает отображение форм и ожидание ответа оператора. При обработке звонка сценарий может быть завершен (доведен до последнего элемента, преимущественно «Стоп»), или прерван (положенной трубкой или нажатием кнопки «СТОП» в окне диалоговой карточки). При успешном завершении сценария (как атрибута задачи на совершение или прием звонка) задача считается успешно выполненной, если в компоненте «Стоп» или в соответствующих служебных переменных не указано иное. В противном случае настройками администратора определяется, как будет продолжена обработка сценария:

· Возможность завершения заполнения диалоговых карточек в соответствии со сценарием;
· Возможность завершения текущей карточки с последующим обрывом ввода;
· Мгновенный обрыв ввода информации.

Если сценарий не был доведен до конца, у оператора на экране появляется окно, запрашивающее отметку оператора об успехе/неудаче совершения звонка (стоп-форма). В случае задач на исходящее оповещение — необходимости повторного дозвона через указанный промежуток времени, исключения абонента или отдельного его номера из списка и пр. Стоп-форма может быть принудительно вызвана, даже если сценарий был доведен до конца. Для этого служит флаг «отображать стоп-форму» в завершающем выполнение сценария компоненте «Стоп». Для решения обратной задачи — исключения показа стоп-формы, возможно в сценарии присвоить значения служебным переменным, соответствующим анализируемым полям.

Служебные переменные:

· Статус звонка. Позволяет в теле сценария указать на положительный или отрицательный исход звонка, который будет учтен менеджером задач и вывод СТОП-карточки будет пропущен. 0 – неуспех, 1 – успех. Обязательна к назначению при использовании других служебных переменных, определяющих результат звонка исходящей задачи (статус абонента, статус номера, пауза, дата, время). Только при значении «0» производится их дальнейший анализ и применение.
· Статус абонента. В случае отрицательного исхода исходящей задачи указывает статус абонента для учета звонка в статистике попыток дозвона на его номер. 0 – не перезванивать, 1 – перезвонить через N минут, 2 – перезвонить в указанное время.
· Статус номера. В случае отрицательного исхода исходящей задачи указывает статус номера для учета звонка в статистике попыток дозвона. 0 – не перезванивать, 1 – перезвонить через N минут, 2 – перезвонить в указанное время.
· Пауза до следующего звонка. Для определения результата звонка исходящей задачи. Устанавливает паузу в минутах, в ходе которой не будет осуществляться повторный дозвон до абонента (либо до номера, если статус абонента не задан). Для применения установленного в сценарии значения переменной должны быть также заданы переменные «Статус звонка» = 0 и одна из переменных (в зависимости от решаемой задачи) «Статус абонента» или «Статус номера» = 1.
· Дата следующего звонка. Устанавливает дату в формате DateTime или соответствующей его представлению строки, до наступления которой не будет осуществляться повторный дозвон до абонента (либо до номера, если статус абонента не задан). Используется совместно с переменной «Время», однако если время не задано отдельной служебной переменной, то оно берется из переменной «Дата». Для применения установленного в сценарии значения переменной должны быть также заданы переменные «Статус звонка» = 0 и одна из переменных (в зависимости от решаемой задачи) «Статус абонента» или «Статус номера» = 2.
· Время следующего звонка. Устанавливает время в формате DateTime или соответствующей его представлению строки, до наступления которого не будет осуществляться повторный дозвон до абонента (либо до номера, если статус абонента не задан). Используется совместно с переменной «Дата». Для применения установленного в сценарии значения переменной должны быть также заданы переменные «Статус звонка» = 0 и одна из переменных (в зависимости от решаемой задачи) «Статус абонента» или «Статус номера» = 2.
· Результат запроса. Используется сценарием в режиме запроса на дозвон. Устанавливает выбранный оператором вариант ответа на запрос. 0 – согласие на дозвон, 1 – пропуск абонента, 2 – удаление абонента. По умолчанию используется ответ «Пропуск». См. также раздел «Голосовые задачи», пункт «Общие настройки. Сценарий запроса на дозвон».

В этом разделе:

— Стоп-форма

— Компоненты сценариев диалога

— Редактор диалоговых форм

— Редактор web-форм


Стоп-форма

Стоп-форма – это служебное окно в контексте работы оператора в голосовой задаче. Служит для определения оператором состояния совершенного или обработанного звонка, в случае, если менеджер задач Oktell не может самостоятельно определить исход, либо если создателем проекта установлены параметры, принудительно указывающие на необходимость запроса исхода у оператора.

Стоп-форма появляется в случае, если:

· Сценарий диалога не назначен для задачи;
· Сценарий диалога завершился с ошибкой;
· Сценарий диалога не был доведен до конца;
· В компоненте «Стоп» сценария диалога установлен принудительный вызов стоп-формы;
· Значения служебных переменных установлены некорректно.

И не появляется в случае, если:

· Обработка задачи ведется в автоматическом режиме;
· Сценарий диалога назначен и доведен до конца (до компонента «Стоп», или до пустой ветки);
· В компоненте «Стоп» не установлен принудительный вызов стоп-формы;
· При реализации сценария служебным переменным состояния звонка корректно назначены значения.

Стоп-форма в зависимости от направления задачи (входящая или исходящая) принимает различные виды.

Во входящей задаче стоп-форма запрашивает у оператора исход звонка (успех или неудача), а также текстовое описание звонка или причины неудачи. Эти значения никак не влияют на работу менеджера задач и только лишь заносятся в соответствующие поля базы данных для последующего формирования статистики.

В исходящей задаче определение исхода непосредственным образом влияет на работу менеджера задач, обязывая его исключить соответствующего абонента из дальнейшей разработки или продолжить его реализацию. Для определения последующих действий менеджера задач в случае выбора состояния «неудача», оператор может выбрать один из пунктов:

· Не перезванивать этому абоненту. Абонент с неуспешным состоянием выводится из списка. Используется в случае, когда оператор по разговору (коммутации) однозначно понимает, что дальнейшая разработка абонента не имеет смысла. Альтернативой этому пункту может являться выбор состояния «Успех», однако разница все же есть и конкретный вариант зависит от способа представления последующей статистической информации.

· Перезвонить абоненту не ранее чем через «N» минут. Следующая попытка звонка абоненту по любому из его номеров откладывается до истечения установленного числа минут. Используется, если по разговору (коммутации) оператор получает сведения об отсутствии требуемого лица.

· Перезвонить абоненту не ранее чем в «установленное время». Следующая попытка звонка абоненту по любому из его номеров откладывается до установленного времени. Использование аналогично предыдущему пункту.

· Не звонить по этому номеру. Текущий номер абонента считается заблокированным и в разработке больше не участвует. Если у абонента был указан единственный номер, то абонент исключается из списка до следующей синхронизации и возможного появления других номеров. Используется, когда оператор получает сведения о необходимости исключения номера из списка номеров абонента, номер либо не принадлежит ему, либо номер не отвечает и пр.

· Перезвонить по этому номеру не ранее чем через «N» минут. Для этого номера выставляется таймаут, однако на другие номера абонента это никак не влияет и звонки по ним могут производиться системой. Используется, когда при звонке оператор попадает на факсимильный аппарат или автоответчик и прочие варианты, не указывающие явно на преобладание такого состояния у абонента в целом.

· Перезвонить по этому номеру не ранее чем в «установленное время». Для этого номера выставляется таймаут, однако на другие номера абонента это никак не влияет и звонки по ним могут производиться системой. Использование аналогично предыдущему пункту.

Стоп-форма позволяет занести в список абонентов дополнительные номера, полученные оператором в контексте разговора для осуществления звонков на них. Эти номера заносятся через запятую в поле типа «Номер телефона» прикрепленной таблицы абонентов.

ВНИМАНИЕ! Номер телефона заносится в таблицу, поэтому если к задаче прикреплена внешняя таблица абонентов, формируемая запросом, то для корректной работы функции необходимо также указать таблицу-основание с полем типа «Номер телефона», название которого совпадает с соответствующим полем, которое возвращает запрос.

Списки пользовательских состояний стоп-формы заполняются в момент отображения в соответствии с настройками проекта. В зависимости от выбранной в проекте совокупности состояний в поле отображаются либо общие состояния, либо проектные состояния, либо и те и другие (с возможным перекрытием по кодам).

Общие состояния заполняются из таблицы базы данных A_TaskManager_CardUserResults. При необходимости ее можно редактировать самостоятельно или в модуле общих настроек в разделе «Call-центр». Проектные состояния заполняются из таблицы A_TaskManager_CardUserResultsProject или на вкладке свойств соответствующего проекта.

Все пользовательские состояния делятся на состояния входящих задач и состояния исходящих задач, среди которых в обоих случаях есть положительные результаты и отрицательные результаты. Состояния по умолчанию активируются сразу при открытии формы. Например, все обработанные входящие звонки можно подразделять на соответствующие тематике и не соответствующие, или на обработанные и отказные.

Пользовательские состояния позволяют супервизору подразделять однотипные с точки зрения логики системы звонки на различные типы. Пользовательские состояния выставляются звонкам после коммутации абонента с оператором и попадают в пространственную бд в соответствующее поле.

Работа по их анализу, ведению статистики и формированию отчетов лежит полностью на плечах администраторов и супервизоров проектов.

При открытии стоп-формы в полях выбора пользовательского результата ничего не выбрано. Однако в ручном режиме в указанных таблицах для необходимых результатов может быть проставлено поле «По умолчанию». В этом случае при открытии стоп-формы в полях автоматически будут выбраны они, тем самым не требуя выбора оператором из списка и исключая закрытие формы без указания пользовательского результата. При задании результатов по умолчанию необходимо различать совокупности результатов для входящих и исходящих задач, а также для успешных и неуспешных звонков.

Служебные переменные сценария диалога дают возможность без вызова стоп-формы установить в автоматическом или полуавтоматическом режиме результаты звонка для менеджера задач. Следует иметь в виду, что применение значений служебных переменных в логике менеджера задач происходит только непосредственно перед вызовом стоп-формы и в случае корректности значений заменяют его. Таким образом, если без корректного назначения переменных стоп-форма не отображается, то и значения переменных применены не будут. Чаще это происходит, если назначение переменным производится непосредственно в конце сценария, при этом не выставляется принудительный показ стоп-формы в компоненте «СТОП». В этом случае сценарий считается доведенным до конца и выполненным успешно.

ВНИМАНИЕ! Анализ служебных переменных производится только в случае, если установлено значение переменной «Статус звонка». А в случае исходящих задач дополнительно одной из переменных «Статус абонента» и «Статус номера» (статус абонента имеет более высокий приоритет). Только после их определения производится применение параметров (дата + время или пауза).


Компоненты сценариев диалога

В данном разделе в справочном порядке приведены лишь узкоспециализированные компоненты, доступные только сценариям диалога. Наличие таких компонентов обусловлено тем, что в отличие от других типов сценариев, сценарий диалога имеет основной целью предоставление удобных интерфейсов оператору во время коммутации с абонентом. Обработчик сценариев диалога имеет доступ к клиентскому интерфейсу текущего оператора. Среди появляющихся в этой связи возможностей: отображение однокомпонентных форм ввода/вывода информации, отображение настраиваемых форм ввода/вывода, а также запуск на компьютере оператора произвольных приложений с передачей параметров. Остальные компоненты являются общими для всех типов сценариев и описаны выше в разделе «Общие компоненты сценариев».

Стоп

Компонент стоп по своему действию аналогичен соответствующему общему компоненту с той лишь разницей, что указывает обработчику сценариев на необходимость отобразить стоп-карточку по завершению звонка (окно ввода результата звонка по задаче). Если сценарий диалога завершается по пустой ветке из-за отсутствия компонента, звонок автоматически считается успешным. Однако в некоторых случаях, например при передаче управления внешнему приложению, необходимо прервать сценарий, а результат звонка в этот момент еще не определен. Компонент «стоп» настраивается на отображение стоп-карточки или автоматическое принятие решения об успешности звонка.

Свойства:

Отображать стоп-карточку | Да/нет.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Подсказка

Компонент выдает оператору на экран окно, в котором содержится информация, необходимая для донесения до абонента. Переход осуществляется по одному пути. Для задания внутренних свойств необходимо дважды щелкнуть на компоненте для отображения окна свойств.

Свойства:

Поверх других окон | Да/Нет. Влияет на способ отображения в момент показа. По умолчанию берется значение, установленное в разделе «Общие настройки. Менеджер задач».
Команда СТОП | Да/Нет. Допускает прерывание сценария по нажатию кнопки СТОП в форме. По умолчанию разрешено.
Переход | Компонент, на который передается управление после завершения работы оператора с формой.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Ввод текста

Выдает подсказку-вопрос и форму ввода ответа в текстовом виде. Информация попадает в БД. Переход осуществляется по одному пути. Для задания внутренних свойств необходимо дважды щелкнуть на компоненте для отображения окна свойств.

Свойства:

Поверх других окон | Да/Нет. Влияет на способ отображения в момент показа. По умолчанию берется значение, установленное в разделе «Общие настройки. Менеджер задач».
Команда СТОП | Да/Нет. Допускает прерывание сценария по нажатию кнопки СТОП в форме. По умолчанию разрешено.
Переход | Компонент, на который передается управление после завершения работы оператора с формой.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Выбор нескольких вариантов

Выдает подсказку-вопрос и форму ввода ответа путем выбора нескольких указанных в сценарии вариантов установкой соответствующих галочек. Информация попадает в БД. По данному виду форм ввода строится статистика, различные диаграммы. Переход осуществляется по одному пути. Для задания внутренних свойств необходимо дважды щелкнуть на компоненте для отображения окна свойств.

Свойства:

Поверх других окон | Да/Нет. Влияет на способ отображения в момент показа. По умолчанию берется значение, установленное в разделе «Общие настройки. Менеджер задач».
Команда СТОП | Да/Нет. Допускает прерывание сценария по нажатию кнопки СТОП в форме. По умолчанию разрешено.
Переход | Компонент, на который передается управление после завершения работы оператора с формой.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Выбор одного варианта

Выдает подсказку-вопрос и форму ввода ответа путем выбора одного из нескольких предложенных вариантов. Информация попадает в БД. По данному виду форм ввода строится статистика, различные диаграммы. Переход осуществляется по выбранному пути. Компонент выбора одного варианта предусматривает количество вариантов перехода, соответствующее предложенным значениям. При отображении окна кнопка «Далее» не доступна до тех пор, пока не будет выбран один из вариантов. Для задания внутренних свойств необходимо дважды щелкнуть на компоненте для отображения окна свойств.

Свойства:

Поверх других окон | Да/Нет. Влияет на способ отображения в момент показа. По умолчанию берется значение, установленное в разделе «Общие настройки. Менеджер задач».
Команда СТОП | Да/Нет. Допускает прерывание сценария по нажатию кнопки СТОП в форме. По умолчанию разрешено.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Диалоговая форма

Компонент предоставляет возможность настроить форму отображения информации с произвольным числом различных элементов. Настройка отображения производится не в стандартном инспекторе объектов, как это делается для прочих компонентов сценариев, а в специальном редакторе диалоговых форм. Редактор представляет собой один из видов традиционного способа работы с элементами управления, однако имеет свои отличительные особенности. Элементами управления в редакторе форм Oktell являются не традиционные элементы управления Windows, а их группировки. Например, традиционные элементы: текстовое поле, галочка, блокирующая доступ к полю, заголовок, подпись и комментарий – это один элемент управления «Текстовое поле» редактора форм. Каждая из перечисленных составляющих может быть скрыта или нагружена необходимым смыслом.

Редактор диалоговых форм будет подробно рассмотрен ниже в разделе «Редактор диалоговых форм», так как дает большие возможности по адаптации визуального представления данных к их представлению в БД.

Свойства:

Свойства | Доступ к вкладке редактора форм для настройки отображения и сохранения информации.
Уведомлять об ошибках | Форма выбора пользователей-получателей уведомлений об ошибках, возникающих в момент выполнения запросов. Необходимо в отладочных целях в первые дни работы новых проектов.
Поверх других окон | Да/Нет. Влияет на способ отображения в момент показа. По умолчанию берется значение, установленное в разделе «Общие настройки. Менеджер задач».
Команда СТОП | Да/Нет. Допускает прерывание сценария по нажатию кнопки СТОП в форме. По умолчанию разрешено.
Переход | Компонент, на который передается управление после завершения работы оператора с формой.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Web-форма

Компонент дает возможность настроить для ввода данных любой Web-документ. Использовать Web-формы можно аналогично диалоговой форме, таким же образом загружая в нее информацию на входе и извлекая в конце. При этом разработчик формы приобретает возможность использования языка HTML и его расширений для создания формы, а в редакторе Web-форм лишь назначить элементам управления (или текстовым данным) соответствующих значений на загрузку и сохранение. В этом случае обработкой информации полностью занимается сценарий диалога, передача данных происходит по стандартным каналам связи оператора с сервером Oktell, и способ работы для оператора остается прежним. При помощи тех же действий по настройке загрузки и сохранения данных в web-форме разработчик может в качестве источника указать и любую внешнюю ссылку, сформировав ее адрес и подставив в качестве аргумента. Однако web-форма имеет и более широкие возможности. В частности, загрузка данных в форму осуществляется из БД, сценарий имеет лишь идентификаторы абонента при поступлении звонка. Характер работы диалоговой формы определяется последовательным сбором информации и следующим за ним отображением. В случае использования сложных запросов это ведет к увеличению интервала времени при ожидании оператором появления формы.

Существуют несколько способов использования Web-формы Oktell.

· Описанный выше способ использования web-формы в качестве средства визуализации с произвольным Web-дизайном;
· Использование многостраничных интерфейсов без обращения к сценарию;
· Использование логики внешнего Web-сервера по формированию и отображению страниц с данными. Сценарий через компонент Web-формы лишь вызывает начальную страницу и передает необходимые параметры (код абонента, АОН и пр.), подставляя их в качестве значений элементов управления, или формируя ссылку на начальную страницу с их участием. С помощью такой реализации существенно освобождается канал данных и снижается время ожидания оператором формы. Web документ осуществляет загрузку изображений, таблиц и данных уже в процессе работы оператора с формой. Сценарий в этом случае определяет только разветвления, хотя и их можно переложить на web-сервис, оставив на долю сценария только определение успеха/неуспеха звонка;
· Get и Post методы передачи параметров;
· Настройка сбора компонентом Web-форма значений заполненных полей в web-страницах в процессе произвольного пути по их идентификаторам для последующего анализа в сценарии;
· Использование единого интерфейса для всех типов контактов. Звонок может отображать у оператора ту же самую страницу заполнения заявки на сайте, которую оператор заполняет при поступлении заявки по e-mail, полноценно преобразуя при этом Oktell в часть контакт-центра организации, осуществляющую контроль звонков и sms-сообщений;
· Использование функций java-script и прочих;
· С достоверностью можно утверждать, что любую задачу отображения данных (которая по тем или иным причинам не может быть реализована в диалоговой форме) можно реализовать в Web-интерфейсах.

Редактор web-форм будет подробно рассмотрен ниже в разделе «Редактор web-форм», так как дает большие возможности по адаптации визуального представления данных к их представлению в БД.

Свойства:

Источник | Форма, определяющая тип и доступ к первой web-странице, отображаемой у оператора.
Свойства | Доступ к вкладке редактора web-форм для настройки отображения и сохранения информации.
Уведомлять об ошибках | Форма выбора пользователей-получателей уведомлений об ошибках, возникающих в момент выполнения запросов. Необходимо в отладочных целях в первые дни работы новых проектов.
Поверх других окон | Да/Нет. Влияет на способ отображения в момент показа. По умолчанию берется значение, установленное в разделе «Общие настройки. Менеджер задач».
Команда СТОП | Да/Нет. Допускает прерывание сценария по нажатию кнопки СТОП в форме. По умолчанию разрешено.
Переход | Компонент, на который передается управление после завершения работы оператора с формой.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Внешнее приложение

Запускает на сервере или на клиенте внешний процесс. Также может открывать указанный документ в сопоставленном ему операционной системой приложении. На сервере используется чаще для запуска системных программ, а также учетных, сервисных, обслуживающих программ организации-клиента Oktell. На рабочем месте оператора (в случае выбора соответствующего значения свойства) могут быть запущены внешние программы-подсказки, анализаторы, web-сценарии, не требующие связи со сценарием после запуска и пр.

Свойства:

Имя файла

Строковый аргумент, определяющий имя файла, который необходимо запустить

Путь

Относительный/абсолютный. Определяет, какой путь будет подставляться впереди к имени файла. Относительный – от папки запуска серверного приложения Oktell.

Параметры

Строковый аргумент, определяющий параметры запуска, если необходимо.

Место выполнения

Клиент/сервер. Определяет, на каком из компьютеров будет произведена попытка запуска приложения (по умолчанию – клиент).

Контроль запуска

Да/нет. При выборе «да» производится асинхронный запуск указанного приложения и мгновенный возврат управления по ветке «успех». При выборе «нет» запуск производится в синхронном режиме. Управление в сценарий возвращается после непосредственного выполнения команды и получения кода возврата. В зависимости от успешности запуска возврат происходит по ветке «успех» или «неудача».

ВНИМАНИЕ! Некоторые программы могут запускаться достаточно долго, это неизбежно будет сказываться при выборе «да» на задержке выполнения других компонентов сценария диалога.

Ожидание выхода

Да/нет. При выборе «да» запуск указанного приложения будет произведен в синхронном режиме вне зависимости от установки свойства «контроль запуска», управление в сценарий будет передано только после того, как запущенный процесс окончит работу и завершится. В этом случае выход происходит по ветке «успех». Если при запуске возникают ошибки, возврат происходит по ветке «неудача». Значение «да» может быть использовано при специфической интеграции компонентов сценария с различными внешними приложениями в случае, когда после выполнения приложений сценарий должен получить доступ к результатам.

Переход, успех

Если приложение успешно стартовало.

Переход, неудача

Если файл не найден, отсутствует доступ, или по другой причине не удалось запустить приложение.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Plugin-форма

Компонент предоставляет возможность использовать форму из зарегистрированной в системе plugin-программы. Форма может быть оконной (полностью самостоятельным окном), либо контролом (окном, встраиваемым в стандартную форму диалоговой карточки Oktell).

В форму передаются любые определенные в ее настройках параметры, возвращаемые параметры сохраняются в указанные при настройке компонента переменные сценария. В общем случае входные и выходные параметры могут кардинально отличаться по составу и не иметь ничего общего с полями, редактирование которых производится. Это происходит из-за возможностей динамического взаимодействия с сервером и БД, предоставляемых для plugin-программы. Взаимодействие происходит через передачу XML-строк с произвольным содержимым по определенной структуре.

В ходе работы при переключении таких форм от одного оператора к другому форма может передавать произвольное число любых параметров (наполнение), которые будут переданы в такую же форму на компьютере другого оператора при отображении.

Подробно о возможностях plugin-программ в руководстве по интеграции. Раздел «Встраиваемые plugin-модули».

Свойства:

Модуль/Форма | Выбор конкретной плагина и одной из его форм, обозначенных для использования в диалоговом режиме.
Свойства | Доступ к вкладке редактора параметров формы для настройки передаваемых и сохраняемых параметров.
Уведомлять об ошибках | Форма выбора пользователей-получателей уведомлений об ошибках, возникающих в момент выполнения запросов. Необходимо в отладочных целях в первые дни работы новых проектов.
Поверх других окон | Да/Нет. Влияет на способ отображения в момент показа. По умолчанию берется значение, установленное в разделе «Общие настройки. Менеджер задач».
Команда СТОП | Да/Нет. Допускает прерывание сценария по нажатию кнопки СТОП в форме. По умолчанию разрешено. Применимо только в случае использования форм-контролов, внедряемых в стандартное окно диалоговой карточки.
Переход | Компонент, на который передается управление после завершения работы оператора с формой.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.


 Редактор диалоговых форм

Редактор диалоговых форм

 Содержание | Назад | Далее

Редактор форм это визуальная среда системы Oktell, позволяющая гибко настраивать отображаемые оператору формы ввода/вывода в соответствии с задачами call-центра. Вход в редактор форм осуществляется через редактор сценариев в ходе настройки компонента «Диалоговая Форма» сценария диалога. При его выделении сверху появляется дополнительная вкладка, на которой находится редактор диалоговых форм.

Редактор форм, как и редактор сценариев, состоит из трех основных частей: поле формы, окно с компонентами и инспектор объектов.

Компонентом редактора формы называется один из доступных элементов управления. Подробно все компоненты будет описан ниже. Каждый компонент при помещении в поле формы образует элемент формы своего типа. Число элементов на форме ограничено лишь системными ресурсами.

Процесс создания состоит из нескольких этапов:

· Определение информации, выводимой и/или вводимой через форму;
· Деление этой информации на куски согласно способу ее хранения в БД;
· Создание начальной визуализации формы с помощью существующих компонентов;
· Задание всем элементам свойств отображения (отступы, заголовки и пр.);
· Задание необходимым элементам значений или формата загрузки этих значений;
· Задание необходимым элементам формата сохранения значений;
· Проверка отображения формы;
· Проверка работы формы.

Компоненты редактора форм делятся на динамические и статические. К статическим компонентам относятся те компоненты, которые не предоставляют оператору возможности изменения данных. Это линейка-разделитель, метка, изображение и таблица. Остальные компоненты являются динамическими.

Элементы формы объединены в группы. Группа может быть свернута, тем самым все принадлежащие ей элементы исчезают с экрана и освобождают место. С помощью групп можно помещать в одну форму множество анкетных данных и избегать переполнения. Если элементы при открытии группы не помещаются на форме – появляется полоса прокрутки.

Компоненты редактора диалоговых форм представляют собой привычные элементы управления, такие как текстовые поля, галочки, группы выбора вариантов и пр. Однако, элементами управления в редакторе форм Oktell являются не традиционные элементы управления Windows, а их группировки. Например, объединенное текстовое поле, галочка, блокирующая доступ к полю, заголовок, подпись и комментарий – это один элемент управления редактора форм.

Чтобы создать на форме новый элемент, выделите соответствующую ему пиктограмму на форме компонентов и щелкните в одной из подсвеченных областей в поле формы. Между любыми двумя существующими на форме компонентами можно вставить пустую строку или ячейку, в которую впоследствии поместить интересующий элемент.

Под каждый элемент на форме выделяется определенная область. Высота этой области определяется автоматической подстройкой под отображаемые данные, либо фиксируется создателем. Ширина области зависит от количества единовременно присутствующих в строке элементов так, что общая ширина формы делится равномерно между ними. Таким образом организованная табличная структура позволяет компоновать практически любые формы, но в то же время и избежать излишней визуальной перегруженности.

В качестве начальных данных для элемента формы (загружаемых данных) может быть избран один из вариантов:

· Константа;
· Переменная сценария (значение);
· Поле прикрепленной таблицы абонентов, соответствующей текущему абоненту (значение);
· Запрос в БД;
· Выражение на основе переменных сценария;
· Загрузка может вовсе отсутствовать.

Загрузка может происходить как поэлементно, так и с использованием групповых запросов на основе идентификаторов элементов формы.

Если при загрузке значение берется из одного из перечисленных объектов, то сохранение данных формы может происходить одновременно в любой набор. Точно также доступно групповое сохранение на основе идентификаторов элементов.

Групповые загрузка и сохранения производятся в элементах «Группа» и имеют явный доступ через задаваемые пользователем идентификаторы как к элементам текущей группы, так и к элементам других групп. Для того чтобы получить доступ к элементам текущей группы, необходимо:

1. Задать идентификаторы для элементов, данные которых должны загружаться/сохраняться групповым запросом. В пределах группы идентификаторы должны быть уникальны.

2. Составить SQL запрос с использованием идентификаторов и переменных.

Примерный групповой запрос приведен на изображении.

Для того чтобы получить доступ к элементам текущей и других групп, необходимо:

1. Задать идентификаторы для всех элементов данные которых должны загружаться/ сохраняться групповым запросом. В пределах группы идентификаторы должны быть уникальны.

2. Задать идентификаторы для всех групп, содержащих элементы из п.1.

3. Составить SQL запрос с использованием идентификаторов и переменных. Обратиться к элементам других групп можно по следующей схеме: [Идентификатор группы].[Идентификатор элемента].

Примерный групповой запрос приведен на изображении.

Групповые загрузка и сохранение, при возможности их использования, рекомендуются как более быстрые. Запрос на выборку 10 простых значений вместе занимает в десять раз меньше времени, чем 10 запросов на выборку по одному значению.

Компоненты редактора форм

Созданную в редакторе форму можно оценить глазами оператора, нажав кнопку «Просмотр» в левом нижнем углу. Размещение объектов будет аналогично «рабочему». Однако данные не везде будут иметь их реальное значение, так как сценарий не выполняется, абонента на связи нет, соответственно нет и значений переменных и запросов с параметрами. Отображены окончательно будут только константные значения, изображения. А также будут скорректированы размеры всех полей.

В форме просмотра и в реальном времени и в режиме дизайна можно скрыть информацию для предоставления большего пространства под размещение элементов. При отображении на компьютере оператора форма запоминает последнее состояние, положение и размер.

После задания определенных свойств форме необходимо нажать кнопку «OK» в правом нижнем углу, чтобы форма действительно легла в сценарий и изменения не отменились.

В нижней части окна диалоговой формы находится поле «Переключение». В выпадающем списке доступны различные классификации номеров, на которые можно произвести переключение звонка непосредственно из формы в момент общения с абонентом. Доступны классификации «Пользователи», «Отделы», «Внутренние номера», «Операторы», «Операторы и супервизоры задачи». Также доступно переключение на любой городской (внешний) номер, набрав его в поле выпадающего списка. Фактом начала переключения служит нажатие кнопки с пиктограммой телефонной трубки.

ВНИМАНИЕ! Переключение на внешний номер с использованием «Быстрого» номера может вестись в обычном режиме. При переключении на внешний номер путем непосредственного ввода с клавиатуры в поле номера необходимо дожидаться соединения с внешним абонентом и лишь после этого класть трубку. В противном случае все относящиеся к звонку коммутации будут прерваны, и обработка звонка прекратится. Дальнейшая обработка сценария диалога будет производиться согласно настройкам.

В этом разделе:

— Компоненты редактора форм

— Инспектор объектов


 Компоненты редактора форм

Компоненты редактора форм

 Содержание | Назад | Далее

Как и при редактировании сценариев, свойства элементам назначаются с помощью инспектора объектов. Нажмите F11 или дважды щелкните по любому элементу в дизайнере форм, чтобы отобразить его на экране, если он скрыт. Выделите нужный элемент, и в инспекторе объектов вы увидите все присущие ему свойства. Чтобы выделить объект – щелкните мышью в любой точке его зоны в поле формы. Чтобы выделить группу, щелкните на ее названии.

Группа

Все элементы принадлежат группам, поэтому в любой форме существует хотя бы одна группа. Группы помогают разделять в одной форме зоны. Каждая группа при отображении может быть свернута и вновь развернута при необходимости, можно также установить запрет на сворачивание. Свернутая группа отображает свой заголовок, но скрывает все элементы.

Свойства:

Идентификатор | Текст. Используется для идентификации группы в групповых запросах
Заголовок | Текст, отображающийся сверху. При сворачивании группы виден только заголовок.
Развернута по умолчанию | Флаг, определяющий формат начального отображения. В случае установки, при открытии окна оператор не видит элементов группы, и ему необходимо развернуть ее для работы с ней. Имеет смысл при использовании более чем одной группы для упрощения начального восприятия оператором формы ввода.
Запрет сворачивания | Флаг, определяющий, сможет ли оператор по своему усмотрению свернуть группу при необходимости.
Размер шрифта | Число в диапазоне 7 - 20. Задает размер шрифта в пикселях текста заголовка группы, заколовков, подписей, комментариев и содержимого всех элементов группы.
Значения | Запрос SQL, обращающийся к идентификаторам всех элементов, принадлежащих web-форме. Осуществляет множественное чтение данных из элементов для сохранения в БД. Если у некоторого элемента назначено свойство «Сохранение», будет выполнено и индивидуальное и групповое сохранение.
Сохранение | Запрос SQL, обращающийся к идентификаторам всех элементов, принадлежащих группе. Осуществляет множественное чтение данных из элементов для сохранения в БД.

При групповой загрузке и сохранении, использующихся в группе, существует доступ к значениям элементов из других групп. Для этого в тексте запроса необходимо явно вписать «[IdGroup].[IdElement]».

Метка

В общем виде метка это нередактируемый текст. В качестве текста может использоваться константная величина или произвольный аргумент.

Свойства:

Идентификатор

Текст. Используется для идентификации метки в групповых запросах

Отступ слева

Число. Задает расстояние ( в пикселях ) от метки до левой границы формы

Переносить текст

Флаг, определяющий вариант переноса текста в метке. Если флаг установлен, то текст, который не поместился по ширине в пределах ячейки будет перенесен на следующие строки. Если флаг не установлен, то текст , который не поместился в одну строку будет заменен многоточием.

Текст

Аргумент, значение которого после вычисления подставляется в метку. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Линия

Линия представляет собой простой горизонтальный разграничитель зон внутри группы. Свойств не имеет.

Текстовое поле

Элемент в зависимости от настроек может выглядеть по-разному. Настройками определяются смещения по горизонтали, разнос на несколько строк, наличие заголовка, подписи, комментария, наличие галочки, а также количество строк в поле ввода. Основное назначение – ввод или ввод/вывод текстовой информации. Все прочие компоненты имеют ту же структуру (группировку) элементарных объектов, формирующих элемент управления диалоговой формы. Это:

· заголовок (текстовое значение);
· подпись (текстовое значение);
· комментарий (текстовое значение);
· галочка, блокирующая элемент управления (числовое значение: 0 – не установлена, любое другое число – установлена );
· поле ввода ( текстовое значение )

Любой из дополнительных объектов можно скрыть. Значения для галочки и поля ввода доступны для загрузки всеми способами, описанными выше, значения остальных объектов задаются задаются константами. Возможность сохранения имеют галочка и поле ввода.

Свойства:

Идентификатор

Текст. Используется для идентификации элемента в групповых запросах и запросах на сохранение

Тип отступа

Флаг, определяющий позицию отступа.

· фиксированный отступ означает, что элемент будет отображен на расстоянии от левой границы формы равном настройке «Отступ слева». Если перед элементом имеется заголовок, то его ширина будет изменена, а текст который не поместился будет заменен многоточием
· отступ за текстом позиционирует элемент сразу после текста заголовка, если заголовок размещен слева, работает аналогично фиксированному отступу, если заголовок расположен сверху

Отступ слева

Число. Задает расстояние ( в пикселях ) от элемента до левой границы формы. Настройка игнорируется, если заголовок расположен слева и выбран тип отступа «За текстом».

Размер

Флаг, определяющий способ задания размера.

· фиксированный - ширина элемента определяется настройкой «Ширина».
· растянутый - элемент растягивается по ширине до размеров ячейки. В случае изменения размеров формы ширина контрола будет изменяться автоматически.

Ширина

Число. Задает ширину элемента ( в пикселях ). Настройка игнорируется, если выбран размер «растянутый».

Кол-во строк

Число. Задает количество текстовых строк в элементе

Значение

Строковый аргумент, значение которого после вычисления подставляется в текстовое поле. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Сохранение

Набор настроек, определяющих способы сохранения заданного пользователем значения элемента. Настройки задаются с помощью формы сохранения

Заголовок

Аргумент, значение которого после вычисления подставляется в заголовок элемента. Может быть только константой. Заголовок в зависимости от настройки «Расположение заголовка» может располагаться над текстовым полем или слева от него. В качестве значения аргумента может быть задана пустая строка. В этом случае заголовок будет отсутствовать.

Расположение заголовка

Флаг, определяющий расположение заголовка.

· сверху - заголовок будет располоен над текстовым полем
· слева - заголовок будет расположен перед текстовым полем

Подпись

Аргумент, значение которого после вычисления подставляется в подпись элемента. Может быть только константой. В качестве значения аргумента может быть задана пустая строка. В этом случае подпись будет отсутствовать. Рекомендуется в качестве подписи не использовать строки большой длины.

Комментарий

Аргумент, значение которого после вычисления подставляется в комментарий элемента. Может быть только константой. В качестве значения аргумента может быть задана пустая строка. В этом случае комментарий будет отсутствовать.

Переносить текст

Флаг, определяющий вариант переноса текста в заголовке и комментарии элемента. Если флаг установлен, то текст, который не поместился по ширине в пределах ячейки будет перенесен на следующие строки. Если флаг не установлен, то текст , который не поместился в одну строку будет заменен многоточием. На текст, содержащийся в подписи элемента, установка флага не влияет.

Наличие галочки

Флаг, определяющий наличие галочки перед элементом.

Значение галочки

Целочисленный аргумент, значение которого после вычисления подставляется в текстовое поле. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Обязательно для заполнения

Флаг, определяющий необходимость ввода текста в поле ввода. Если флаг установлен, то в момент выполнения сценария кнопка «Далее» диалоговой формы будет недоступна до тех пор, пока не будет заполнено это поле. Флаг игнорируется, если элемент был заполнен при загрузке формы

Выпадающий список

Элемент в зависимости от настроек принимает разные формы и служит для различных целей. Основное отличие – возможность выбора значения из динамически формируемого списка. Настройками определяются смещения по горизонтали, наличие заголовка, подписи, комментария, наличие галочки, а также возможность редактирования. Элементом списка является пара (идентификатор, отображаемая строка), где идентификатор может принимать значение любого типа. При загрузке формы перечень возможных значений в список может быть загружен произвольной комбинацией вариантов: константы, значения переменных, выражения, а также запросы SQL, возвращающие выборку данных содержащую идентификаторы значений и их текстовые представления. Загрузка текущего активного значения происходит из произвольного источника (константа, переменная, поле прикрепленной таблицы, выражение, индивидуальный запрос SQL, групповой запрос SQL) и сопоставляется с загруженными элементами списка по соответствию идентификаторов. При сохранении значения также используется идентификатор элемента списка.

Свойства элемента «Выпадающий список» и всех последующих элементов по большей части аналогичны свойствам элемента «Текстовое поле», поэтому описания будут приводится только для основных свойств.

Основные свойства:

Идентификатор

Текст. Используется для идентификации выпадающего списка в групповых запросах

Редактировать

Флаг, определяющий возможность редактирования значения элемента. Если флаг установлен, то список может использоваться аналогично элементу «Текстовое поле», в противном случае выбрать значение можно только из списка элементов, определенных в настройке «Элементы»

Значение

Аргумент типа «строка», «число», «Дата и время», значение которого после вычисления подставляется в индекс списка. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

В случае, если значение аргумента отсутствует в списке вычисленных индексов коллекции элементов, список в зависимости от настройки «Редактировать» будет отображать перый элемент из коллекции, либо оставаться пустым.

Элементы

Коллекция, элементы которой после вычисления значений всех её аргументов будут использованы в качестве элементов выпадающего списка. Настройки задаются с помощью формы элементов

Сохранение

Набор настроек, определяющих способы сохранения выбранного пользователем индекса элемента. Настройки задаются с помощью формы сохранения

Отображать в статистике

Флаг, определяющий - будет ли выбранное или введенное пользователем значение элемента доступно для модуля статистики.

Обязательно для заполнения

Флаг, определяющий необходимость ввода текста в поле или выбора одного из элемнтов списка. Если флаг установлен, то в момент выполнения сценария кнопка «Далее» диалоговой формы будет недоступна до тех пор, пока не будет заполнено это поле или выбран элемент списка. Флаг игнорируется, если элемент был заполнен при загрузке формы

Галочка

Служит для выбора одного из двух вариантов. В качестве значения при загрузке и сохранении принимает числа «0» и «1». Загрузка осуществляется из произвольного источника, сохранение также произвольно. Свойства элемента в целом аналогичны свойствам элемента «Метка».

Основные свойства:

Идентификатор

Текст. Используется для идентификации галочки в групповых запросах

Значение галочки

Аргумент, значение которого после вычисления подставляется в значение галочки. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Сохранение

Набор настроек, определяющих способы сохранения заданного пользователем значения галочки. Настройки задаются с помощью формы сохранения

Отображать в статистике

Флаг, определяющий - будет ли выбранное или введенное пользователем значение галочки доступно для модуля статистики.

Дата/время

Элемент предоставляет в зависимости от настроек возможность выбора даты, времени, интервала дат и интервала времен внутри дня. Настройками определяются смещения по горизонтали, наличие заголовка, подписи, комментария, наличие галочки. Основное назначение – ввод или ввод/вывод временной информации. Загрузка осуществляется из произвольных источников (константа, переменная, поле прикрепленной таблицы, выражение, индивидуальный запрос SQL, групповой запрос SQL). Сохранение также произвольно.

Основные свойства:

Идентификатор

Текст. Используется для идентификации поля дата/время в групповых запросах

Значение1

Аргумент типа «строка», «Дата и время», значение которого после вычисления подставляется:

· в качестве значения поля, если настройка «Тип» установлена в «Фиксированная дата»
· в качестве значения нижней границы интервала дат, если настройка «Тип» установлена в «Интервал».

Может быть:

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Значение2

Аргумент типа «строка», «Дата и время», значение которого после вычисления:

· не используется, если настройка «Тип» установлена в «Фиксированная дата»
· подставляется в качестве значения верхней границы интервала дат, если настройка «Тип» установлена в «Интервал».

Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Сохранение1

Набор настроек, определяющих способы сохранения заданного пользователем значения элемента:

· значения поля, если настройка «Тип» установлена в «Фиксированная дата»
· значения нижней границы интервала дат, если настройка «Тип» установлена в «Интервал»

Настройки задаются с помощью формы сохранения

Сохранение2

Набор настроек, определяющих способы сохранения заданного пользователем значения элемента:

· значения поля, если настройка «Тип» установлена в «Фиксированная дата»
· значения верхней границы интервала дат, если настройка «Тип» установлена в «Интервал»

Настройки задаются с помощью формы сохранения

Отображать в статистике

Флаг, определяющий - будет ли выбранное или введенное пользователем значение элемента доступно для модуля статистики.

Обязательно для заполнения

Флаг, определяющий необходимость ввода текста в поле элемента. Если флаг установлен, то в момент выполнения сценария кнопка «Далее» диалоговой формы будет недоступна до тех пор, пока не будет заполнено это поле. Флаг игнорируется, если элемент был заполнен при загрузке формы

Спин (числовой ввод)

Элемент предоставляет несколько способов визуального представления. Помимо основного элемента управления в компоненте «Спин» настройками определяются смещения по горизонтали, разнос, наличие заголовка, подписи, комментария, наличие галочки. Основное назначение – ввод или ввод/вывод целочисленной информации. Загрузка осуществляется из произвольных источников (константа, переменная, поле прикрепленной таблицы, выражение, индивидуальный запрос SQL, групповой запрос SQL). Сохранение также произвольно.

Основные свойства:

Идентификатор

Текст. Используется для идентификации спина в групповых запросах

Минимальное значение

Аргумент типа «число» значение которого после вычисления подставляется в качестве нижней границы диапазона значений спина.

Может быть:

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Максимальное значение

Аргумент типа «число» значение которого после вычисления подставляется в качестве верхней границы диапазона значений спина.

Может быть:

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Значение

Аргумент типа «число» значение которого после вычисления подставляется в качестве значения спина.

Может быть:

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Сохранение1

Набор настроек, определяющих способы сохранения заданного пользователем значения спина. Настройки задаются с помощью формы сохранения

Отображать в статистике

Флаг, определяющий - будет ли выбранное или введенное пользователем значение элемента доступно для модуля статистики.

Обязательно для заполнения

Флаг, определяющий необходимость ввода текста в поле элемента. Если флаг установлен, то в момент выполнения сценария кнопка «Далее» диалоговой формы будет недоступна до тех пор, пока не будет заполнено это поле. Флаг игнорируется, если элемент был заполнен при загрузке формы

Группа опций

Позволяет реализовать выбор одного из перечисленных вариантов на основе элементов «радио». Настройками определяются смещения по горизонтали, разнесение на несколько столбцов, наличие заголовка, подписи, комментария. Основное назначение – ввод или ввод/вывод целочисленной информации. Загрузка значения осуществляется из произвольных источников (константа, переменная, поле прикрепленной таблицы, выражение, индивидуальный запрос SQL, групповой запрос SQL). Также произвольным образом загружаются перечни значений. Это может быть любая комбинация из константных элементов и элементов, определяемых запросами. Каждый элемент представляет собой идентификатор и подпись. Идентификатор это числовое значение.

Сохранение также произвольно. В качестве выходного значения принимается значение идентификатора выделенного элемента перечня.

Основные свойства:

Идентификатор

Текст. Используется для идентификации группы опций в групповых запросах

Число столбцов

Число. Определяет количство столбцов в группе опций.

Значение

Аргумент типа «строка», «число», значение которого после вычисления устанавливает индекс выбранного элемента группы. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

В случае, если значение аргумента отсутствует в списке вычисленных индексов коллекции элементов, в группе не будет выбрана ни одна опция

Элементы

Коллекция, элементы которой после вычисления значений всех её аргументов будут использованы в качестве элементов группы опций. Настройки задаются с помощью формы элементов

Сохранение

Набор настроек, определяющих способы сохранения выбранного пользователем индекса элемента. Настройки задаются с помощью формы сохранения

Отображать в статистике

Флаг, определяющий - будет ли выбранное или введенное пользователем значение элемента доступно для модуля статистики.

Обязательно для заполнения

Флаг, определяющий необходимость выбора одной из опций. Если флаг установлен, то в момент выполнения сценария кнопка «Далее» диалоговой формы будет недоступна до тех пор, пока не будет выбрана одна из опций. Флаг игнорируется, если опция была выбрана при загрузке формы

Группа галок

Позволяет реализовать выбор нескольких из перечисленных вариантов на основе элементов «галочка». Настройками определяются смещения по горизонтали, разнесение на несколько столбцов, наличие заголовка, подписи, комментария. Основное назначение – ввод или ввод/вывод целочисленной информации. Загрузка осуществляется из произвольных источников (константа, переменная, поле прикрепленной таблицы, выражение, индивидуальный запрос SQL, групповой запрос SQL). Сохранение также произвольно. В качестве выходного значения принимается битовая маска в строковом или числовом виде (0001011101). Отсчет идет с начала в случае строкового значения, но с конца (с нулевого бита) в случае целочисленного. Целочисленное значение может быть сохранено в базе для последующего анализа в отчетах, а также арифметическими операциями обработано в сценарии.

Основные свойства:

Идентификатор

Текст. Используется для идентификации группы галок в групповых запросах

Число столбцов

Число. Определяет количство столбцов в группе галок.

Значение

Аргумент типа «строка», «число», значение которого после вычисления устанавливает бинарную маску выбранных элементов группы. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

В случае, если значение аргумента отсутствует в списке вычисленных индексов коллекции элементов, в группе не будет выбрана ни одна галка

Элементы

Коллекция, элементы которой после вычисления значений всех её аргументов будут использованы в качестве элементов группы галок. Настройки задаются с помощью формы элементов

Сохранение

Набор настроек, определяющих способы сохранения выбранных пользователем индексов элемента. Настройки задаются с помощью формы сохранения

Отображать в статистике

Флаг, определяющий - будет ли выбранное или введенное пользователем значение элемента доступно для модуля статистики.

Обязательно для заполнения

Флаг, определяющий необходимость выбора одной из галок. Если флаг установлен, то в момент выполнения сценария кнопка «Далее» диалоговой формы будет недоступна до тех пор, пока не будет выбрана одна из галок. Флаг игнорируется, если галки были выбраны при загрузке формы

Изображение

Позволяет отобразить любую картинку, пиктограмму, фотографию и прочие графические данные. Информация об изображении может быть передана статически из прикрепленного файла (например, логотип компании – заказчика кампании), может быть динамически подгружен по переданному пути из размещенных на сервере графических файлов, а также получен как image-поток из базы данных. Изменения изображений не предусмотрено. Изображение может быть размещено в его реальных размерах или сжато до фиксированного размера. Также доступна фиксация только высоты или только ширины для сохранения пропорций изображения.

Основные свойства:

Идентификатор

Текст. Используется для идентификации элемента «Изображение» в групповых запросах

Тип отображения

Число. Определяет способ отображения элемента на форме:

· «по размеру рисунка» - элемент принимает размеры рисунка
· «фиксированный» - элемент в качестве размеров использует настройки «Ширина» и «Высота»
· «фиксированная высота» - элемент в качестве высоты использует настройку «Высота», ширина изображения вычисляется пропорционально размерам рисунка, настройка «Ширина» игнорируется
· «фиксированная ширина» - элемент в качестве ширины использует настройку «Ширина», высота изображения вычисляется пропорционально размерам рисунка, настройка «Высота» игнорируется
· «растянутый» - элемент в качестве ширины использует ширину ячейки, высота вычисляется пропорционально размерам рисунка, настройки «Ширина» и «Высота» игнорируются

Ширина

Число, определяющее ширину изображения

Высота

Число, определяющее высоту изображения

Изображение

Аргумент, значение которого после вычисления устанавливает источник изображения для элемента. Может быть

· константой - путь к файлу с рисунком;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных. Запрос может возвращать путь к файлу с рисунком, либо рисунок в бинарном формате.

Таблица (grid)

Позволяет отобразить данные из множества, возвращаемого отдельным запросом SQL. Настройками определяются высота, ширина, а также столбцы с указанием соответствия столбцам выборки. Все поля выборки приводятся к текстовому виду. Таблица служит только для отображения информации, изменения данных не предусмотрено.

Основные свойства:

Идентификатор | Текст. Используется для идентификации элемента «Таблица» в групповых запросах. В текущей версии это свойство не используется
Ширина | Число, определяющее ширину таблицы
Высота | Число, определяющее высоту таблицы
Значения | Аргумент, значение которого после вычисления устанавливает источник данных для таблицы. Может быть запросом SQL в базу данных. Запрос должен возвращать набор данных ( recordset ).
Столбцы | Коллекция, элементы которой после вычисления значений всех её аргументов будут использованы в качестве параметров столбцов таблицы. Настройки задаются с помощью формы «Столбцы таблицы»

Кнопка

Позволяет реализовать переключение на заданный номер. Настройками определяются надпись на кнопке, номер (внешний или внутренний), но который должно быть выполнено переключение. Кнопка служит только для переключения на внешний или внутренний номер, привязка других обработчиков не предусмотрена.

Основные свойства:

Идентификатор | Текст. Используется для идентификации элемента «Кнопка» в групповых запросах.
Ширина | Число, определяющее высоту таблицы
Надпись на кнопке | Аргумент, значение которого после вычисления подставляется в текст надписи на кнопке.
Номер | Аргумент, значение которого после вычисления используется в качетсве номера для переключения.


Инспектор объектов

Инспектор объектов редактора диалоговых форм служит для задания свойств элементам. В целом он аналогичен инспектору редактора сценариев. Ниже приведены всплывающие формы инспектора объектов, с помощью которых определяются некоторые из свойств.

Форма «Сохранение»

Форма используется для задания настроек, определяющих способы сохранения заданного пользователем значения элемента.

Закладка «Переменные сценария» - предоставляет возможность указать новые или уже существующие в сценарии переменные для сохранения значения элемента и значения галочки элемента (если установлен флаг «Наличие галочки»).

Закладка «SQL» представляет собой конструктор SQL запроса для сохранения . В качестве переменных запрос могут быть использованы идентификаторы элемента и переменные сценария. Для того чтобы в запросе сослаться на значение элемента, выбранный индекс (для групповых элементов) или значение галочки элемента необходимо задать идентификатор. В списке «доступные идентификаторы» в этом случае будут перечислены один или несколько идентификаторов вида:

· «имя_идентификатора_значение» - возвращает значение элемента
· «имя_идентификатора_галочка» - возвращает значение галочки элемента
· «имя_идентификатора_индекс» - возвращает значение выбранного индекса элемента (для элемента «Выпадающий список»)

В списке доступных переменных перечислены переменные сценария, которые могут быть использованы в запросе.

Формы для задания групповой подстановки «Подстановка значений» и группового сохранения «Сохранение» имеют только одну закладку «SQL». В списке «доступные идентификаторы» в этом случае будут перечислены идентификаторы всех элементов текущей группы.

Форма «Элементы»

Форма используется для создания и редактирования коллекций групповых элементов таких как радиогруппа, группа галок и выпадающий список. Для выпадающего списка коллекция определяет набор элементов списка, для радиогруппы и группы галок коллекция определяет параметры радиокнопок и галок. Каждый элемент коллекции представяляет собой пару (значение, подпись) .

Значение - это аргумент, который может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Значение аргумента после вычисления используется как идентификатор, по которому будет однозначно определяться элемент коллекции.

Подпись - это аргумент, который может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Значение аргумента после вычисления используется в качестве подписи элемента коллекции.

Кнопки «Добавить»/«Удалить» позволяют редактировать коллекцию элементов. Кнопки «Вверх», «Вниз» позволяют управлять последовательностью, в которой элементы будут отображаться. С помощью выпадающего списка «Сортировка» также можно определить последовательность отображения элементов коллекции:

· По приоритетам расстановки - элементы будут отображены в порядке их нумерации;
· По значениям - элементы будут отображены в порядке возрастания их значений;
· По алфавиту - элементы будут отображены в порядке возрастания их подписей;

Форма «Столбцы таблицы»

Форма используется для создания и редактирования коллекции столбцов таблицы. Каждый элемент коллекции определяет настройки столбца таблицы и представляет собой совокупность атрибутов (Подпись, Ширина, Видимый, ПОле БД) .

Подпись - это аргумент, который может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Значение аргумента после вычисления используется в качестве подписи элемента коллекции.

Видимый - флаг, определяющий видимость столбца таблицы. Все остальные атрибуты являются числовыми или строковыми.

Кнопки «Добавить»/«Удалить» позволяют редактировать коллекцию столбцов. Кнопки «Вверх», «Вниз» позволяют управлять последовательностью, в которой столбцы будут отображаться.

Все компоненты имеют вспомогательные поля: заголовок, комментарий, подпись, галка блокировки. Все они отключаются при помощи соответствующих свойств компонента в инспекторе объектов. В случае, если производится массовая вставка, и оптимальнее было бы вставлять компоненты с отключенными вспомогательными полями, можно использовать пункт контекстного меню «Сохранить как шаблон». Задайте необходимые значения свойств объекта и выберите в контекстном меню этот пункт. В дальнейшем при вставке к компонентам соответствующего типа будут автоматически применяться сохраненные в шаблоне значения.


 Редактор web-форм

Редактор web-форм

 Содержание | Назад | Далее

Редактор web-форм это визуальная среда системы Oktell, позволяющая настраивать существующие web-документы для отображения оператору. Вход в редактор web-форм осуществляется через редактор диалоговых сценариев в ходе настройки компонента «Web-форма». При его выделении сверху появляется дополнительная вкладка, на которой находится редактор web-форм.

Web-форма в терминологии среды системы Oktell - это одна или несколько html-страниц. В ряде случаев (будет рассмотрено ниже) термин web-форма отождествляется с единственной html страницей.

От диалоговых форм редактор web-форм коренным образом отличает следующее: этот редактор задает только загрузку/сохранение (и иногда блокировку ввода) данных. Внешний вид формы целиком определяет web-дизайнер с помощью таких программных средств как MS FrontPage, HomeSite, Dreamweaver и т.д.

Oktell поддерживает работу с локальными документами и со ссылками на web-содержимое различных Web и Xml сервисов. Для корректной работы редактора рекомендуется настроить браузер MS Internet Explorer:

· Свойства обозревателя, вкладка «Дополнительно», группа настроек «Обзор» - установить галку «Отключить отладку сценариев (Internet Exporer)»
· Свойства обозревателя, вкладка «Дополнительно», группа настроек «Обзор» - установить галку «Отключить отладку сценариев (другие)»

Для начала работы в редакторе web-форм необходимо указать источник. Это делается в свойствах компонента web-форма в инспекторе объектов редактора сценариев. Укажите источник:

· Локальный файл. Выберите файл, он будет автоматически прикреплен к сценарию. Помимо самого HTML документа к сценарию будет прикреплена папка «документ».files (если она существует), содержащая изображения, стили и другие используемые в документе элементы. Подобная схема работы используется в браузере MS Internet Explorer. При сохранении документа полностью, он создает папку *.files рядом с сохраненным документом.

· Ссылка. Используется стандартный тип «аргумент» сценариев Oktell. Ссылка может быть указана явно или вычислена на основе переменных или выражений сценария. Вычисление может иметь смысл для указания параметров в «Get» режиме для доступа к персональным страницам операторов и/или абонентов. При использовании ссылочного метода и отсутствии прямого выхода в интернет возможно указание Proxy сервера для доступа к странице. Среди возможных вариантов использовании Proxy сервера:

o Операторские настройки. При открытии начальной страницы у оператора возникнет окно подключения, куда ему будет предложено ввести свои авторизационные данные. Адрес и порт в этом случае будут взяты из настроек Internet Explorer на компьютере оператора.
o Общие настройки. При открытии начальной страницы у оператора возникнет окно подключения, куда ему будет предложено ввести свои авторизационные данные. Адрес и порт в этом случае будут взяты из стандартных настроек Internet Explorer на компьютере оператора.. Адрес и порт будут взяты из общих настроек системы
o Индивидуальные. Параметры подключения к proxy-серверу необходимо указать непосредственно для настраиваемой web-формы в окне выбора источника.

Редактор web-форм, как и редактор сценариев, состоит из двух основных частей: поле формы и инспектор объектов. Настройка загрузки данных в web-форму может производиться:

· из сценария;
· в строке подключения к сервису;
· без участия Oktell самим web-сервисом;
· комбинированным способом.

Из перечисленных способов рассмотрению подлежит только первый. Остальные способы очевидным образом не касаются системы Oktell непосредственно.

Локальные документы

Загрузка данных из сценария в форму и сохранение из формы в сценарий могут производиться без ограничений при работе с формами, источниками которых являются web-документы, прикрепленные к сценарию. Это обусловлено тем, что локальный файл поддается редактированию со стороны дизайнера web-форм Oktell.

В поле формы в открытом документе выделяйте мышью интересующие элементы (поля, заголовки и другие части, имеющие в тексте HTML обрамление тэгами) Выделенный элемент обрамляется рамкой или закрашивается оранжевым цветом, что означает его активность. Инспектор объектов отображает свойства активного элемента web-формы. Свойства зависят от типа активного элемента, но в основном касаются только загрузки значения и сохранения.

Обязательное поле – «Идентификатор». Только при наличии идентификатора возможна загрузка значений из сценария в форму при открытии и сохранение в обратную сторону при закрытии формы.

Идентификатор – это атрибут «Id» в теге элемента внутри тела HTML-документа. При выделении компонента в поле идентификатор инспектора объектов будет подставлено соответствующее атрибуту «Id» значение. При его отсутствии будет подставлено соответствующее атрибуту «name» значение. Если же элемент не имеет ни Id, ни Name, то атрибут будет создан, и в него автоматически занесется уникальный 128 битный идентификатор, который можно заменить на более внятный и понятный создателю.

Все поля, для которых были назначены идентификаторы, обрамляются в дизайнере желтой рамкой или закрашиваются желтым цветом. Необходимо иметь в виду, что web-формы со ссылками дают возможность переходить с одной страницы на другую. В разных страницах могут присутствовать поля с одинаковыми идентификаторами. В этом случае при загрузке значений такие элементы будут распознаны как один и тот же элемент, и загрузка произведется в них одинаковым образом. При сохранении подобных элементов будет использовано значение последнего отображенного элемента с последней отображенной страницы с указанным идентификатором.

Загрузка и сохранение значений элементов производится способом, аналогичным соответствующим элементам дизайнера диалоговых форм. Списки значений, галочки, поля ввода текста, заголовки, метки, группы настроек, таблицы и другие. Для детального изучения обратитесь к разделу «Редактор диалоговых форм»

Для удаления выделенного элемента можно использовать клавишу Delete. Элемент при этом не удаляется из дерева HTML.

Для выделения вышестоящего элемента в дереве HTML можно использовать клавишу CTRL.

Для выделения самого верхнего элемента в дереве HTML ( как правило это элемент с тегом body ) можно использовать комбинацию клавиш Shift + Ctrl. Это будет иметь смысл, если планируется производить групповую загрузку или групповое сохранение значений.

Для перехода по ссылке из дизайнера щелкните по ней с нажатой клавишей CTRL.

При сохранении на сервер сценария, в котором используются локально прикрепленные web-документы, производится формирование веб-архивов. Веб-архив – это «*.mht» файл, содержащий в себе тело документа и все содержимое из папки «*.files». Формирование архива – достаточно трудоемкая операция, и может потребовать некоторого времени. Тем больше, чем больше подобных форм используется в сценарии.

Удаленные документы

При работе с удаленными веб-документами в качестве содержимого web-формы, изменение документа и идентификаторов его элементов невозможны.

Кроме того, невозможно устанавливать атрибуты для:

· html-изображений (тег «IMG»);
· загруженного в IFRAME содержимого.

Автоматическая подстановка идентификаторов при их отсутствии не производится. Однако загрузка и сохранение значений могут быть произведены для тех элементов HTML документа, где создателем страницы установлены идентификаторы. При настройке собственного сайта или сервиса для работы из Call-центра имейте это в виду. В остальном настройка web-форм на основе ссылок ничем не отличается от локально прикрепленных к сценарию.

По кнопке «Содержимое» во внешнем текстовом редакторе открывается настраиваемый документ в формате HTML. Он доступен для просмотра и модификации. Модифицировать веб-страницу таким образом без наличия необходимой квалификации не рекомендуется. Сохранение HTML-содержимого, если web-форма с источником в виде локально прикрепленного документа, непосредственным образом влияет на отображение.

В редакторе web-форм по кнопке «Просмотр» доступна диалоговая форма с настроенным web-документом. Как и в редакторе диалоговых форм, разница отображения итоговой формы в режиме просмотра и в режиме работы оператора заключается в отсутствии значений переменных и невозможности загрузки из таблицы абонентов, прикрепленной к задаче.

После задания определенных свойств web-форме необходимо нажать кнопку «OK» в правом нижнем углу, чтобы форма действительно легла в сценарий и настройки не отменились.

В нижней части окна web-формы находится поле «Переключение». В выпадающем списке доступны различные классификации номеров, на которые можно произвести переключение звонка непосредственно из формы в момент общения с абонентом. Доступны классификации «Пользователи», «Отделы», «Внутренние номера», «Операторы», «Операторы и супервизоры задачи». Также доступно переключение на любой городской (внешний) номер, набрав его в поле выпадающего списка. Фактом начала переключения служит нажатие кнопки с пиктограммой телефонной трубки.

ВНИМАНИЕ! Переключение на внешний номер с использованием «Быстрого» номера может вестись в обычном режиме. При переключении на внешний номер путем непосредственного ввода с клавиатуры в поле номера необходимо дожидаться соединения с внешним абонентом и лишь после этого класть трубку. В противном случае все относящиеся к звонку коммутации будут прерваны, и обработка звонка прекратится. Дальнейшая обработка сценария диалога будет производиться согласно настройкам.

В этом разделе:

— Компоненты редактора web-форм

— Инспектор объектов


Компоненты редактора web-форм

Как и при редактировании сценариев, свойства элементам назначаются с помощью инспектора объектов. Кроме того, некоторым элементам основные свойства можно установить прямо в браузере.

Нажмите F11 или дважды щелкните по любому элементу в дизайнере web-форм, чтобы отобразить его на экране, если он скрыт. Выделите на форме нужный Html объект (далее - элемент), и в инспекторе объектов вы увидите все присущие ему свойства. Чтобы выделить элемент – щелкните мышью в любой точке его зоны в поле формы. Выделенный элемент обводится оранжевой рамочкой или выделяется оранжевым фоном. Элементы, для которых были установлены свойства (далее - установленные элементы), обводятся желтой рамочкой или выделяются желтым фоном.

Каждому установленному элементу автоматически сопоставляется идентификатор. Значение идентификатора назначается в следующем порядке:

· атрибут id элемента;
· атрибут name элемента;
· автоматически сформированный GUID (уникальный глобальный идентификатор );

Идентификатор можно установить самостоятельно. Если идентификатор не уникален в пределах web-формы, то назначенные элементу свойства будут автоматически присвоены всем элементам с совпадающим идентификаторм в пределах:

· html-страницы, если установлен тип источника «Локальный файл»;
· web-формы, если установлен тип источника «Ссылка»;

Для того чтобы удалить элемент из списка установленных, нужно либо очистить поле «Идентификатор» в инспекторе объектов, либо выбрать соответствующий пункт в контекстном меню. Контекстное меню элемента:

· «Удалить» - удалить выбранный элемент из списка установленных элементов. Удалить выбранный элемент также можно с помощью клавиши Delete;
· «Перейти к родительскому элементу» - выделить элемент, который содержит текущий элемент в качестве дочернего ( клавиша Ctrl );
· «Перейти к web-форме» - выделить всю web-форму целиком ( комбинация клавиш Shift + Ctrl );
· «Удалить и перейти к родительскому элементу» - удалить выбранный элемент из списка установленных элементов и выделить элемент, который содержит текущий элемент в качестве дочернего;
· «Удалить и перейти к web-форме» - удалить выбранный элемент изсписка установленных элементов и выделить всю web-форму целиком

Web-форма

Все html элементы размещены на web-форме. Редактор автоматически определяет web-форму при наличии на web-странице html тегов: <html>, <body>. Рекомендуется учитывать этот факт при самостоятельной разработке html страниц. В свойствах web-формы c помощью SQL запроса можно задать общий для всех элементов web-формы источник данных, общий запрос на сохранение введенной пользователем информации.

Свойства:

Значения | Запрос SQL, обращающийся к идентификаторам всех элементов, принадлежащих web-форме. Осуществляет множественную загрузку значений. Однако, если у некоторого элемента назначено свойство индивидуальной загрузки, оно будет иметь приоритет.
Сохранение | Запрос SQL, обращающийся к идентификаторам всех элементов, принадлежащих web-форме. Осуществляет множественное чтение данных из элементов для сохранения в БД. Если у некоторого элемента назначено свойство «Сохранение», будет выполнено и индивидуальное и групповое сохранение.

При составлении общих SQL запросов следует учитывать, что заданные в свойствах web-формы правила подстановки и сохранения данных будут применены ко всем html-страницам, которые пользователь посетит. В частности, если на страницах имеются элементы с дублирующимися идентификаторами, то данные будут подставляться в html-элементы, и сохраняться для всех этих элементов одновременно.

Метка

Как и в случае диалоговых форм: метка - нередактируемый текст на web-форме. Редактор считает меткой любую текстовую последовательность, заключенную между парными html тегами: <label>, <span>, <h1>, <h2>, <h3>, <h4>, <h5>. Более подробно об этих и других html тегах можно узнать в любом справочнике по языку гипертекстовой разметки - HTML.

Свойства:

Идентификатор

Текст. Используется для идентификации метки в пределах web-формы и групповых запросах

Текст

Аргумент типа «строка», значение которого после вычисления подставляется в метку. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Гиперссылка

Редактор считает гиперссылкой, элемент, заключенный между парными html тегами: <a>.

Свойства:

Идентификатор

Текст. Используется для идентификации гиперссылки в пределах web-формы и групповых запросах

Текст

Аргумент типа «строка», значение которого после вычисления подставляется в отображаемый текст гиперссылки. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

URL

Аргумент типа «строка», значение которого после вычисления подставляется в качестве значения атрибута url гиперссылки. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Подсказка

Аргумент типа «строка», значение которого после вычисления подставляется в текст всплывающей подсказки. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Текстовое поле

Редактор считает текстовым полем, html элемент «Поле ввода», заключенный между парными html тегами вида: <input type = text>, <input type = password>, <textarea>.

Свойства:

Идентификатор

Текст. Используется для идентификации текстового поля в пределах web-формы и групповых запросах

Значение

Аргумент типа «строка», значение которого после вычисления подставляется в текстовое поле. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Свойство можно установить непосредственно в браузере. Для этого просто введите текст в элемент. При этом для аргумента будет автоматически установлен тип «Константа».

Активирован

Аргумент типа «число». Если вычисленное значение - нуль, то элемент будет неактивным. В противном случае элемент будет активным.

Аргумент может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Сохранение

Набор настроек, определяющих способы сохранения текстового поля. Настройки задаются с помощью формы сохранения

Галочка

Редактор считает галочкой html-элемент, заключенный между парными html тегами вида: <input type = check>.

Свойства:

Идентификатор

Текст. Используется для идентификации галки в пределах web-формы и групповых запросах

Значение

Аргумент типа «число», «строка», значение которого после вычисления подставляется в качестве значения (атрибут value) галочки. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Активирован

Аргумент типа «число». Если вычисленное значение - нуль, то элемент будет неактивным. В противном случае элемент будет активным.

Аргумент может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Отмечен по умолчанию

Аргумент типа «число». Если вычисленное значение - нуль, то галочка не будет выбрана (атрибут «checked»). В противном случае галочка будет выбрана.

Аргумент может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Сохранение

Набор настроек, определяющих способы сохранения текстового поля. Настройки задаются с помощью формы сохранения

Радио-кнопка

Редактор считает радио-кнопкой html-элемент, заключенный между парными html тегами вида: <input type = radio>. Свойства элемента полностью совпадают со свойствами элемента «Галочка».

Выпадающий список

Редактор считает выпадающим списком html элемент, заключенный между парными html тегами <select>.

Свойства:

Идентификатор

Текст. Используется для идентификации выпадающего списка в пределах web-формы и групповых запросах

Выбранное значение

Аргумент типа «строка», «число», «дата и время», значение которого после вычисления подставляется в качестве значения выбранного индекса элемента. Может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Свойство можно установить непосредственно в браузере. Для этого выберите в списке любое значение. При этом для аргумента будет автоматически установлен тип «Константа».

Элементы

Коллекция, элементы которой после вычисления значений всех её аргументов будут использованы в качестве элементов выпадающего списка. Настройки задаются с помощью формы элементов

Активирован

Аргумент типа «число». Если вычисленное значение - нуль, то элемент будет неактивным. В противном случае элемент будет активным.

Аргумент может быть

· константой;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением
· запросом SQL в базу данных

Сохранение

Набор настроек, определяющих способы сохранения выбранного значения выпадающего списка. Настройки задаются с помощью формы сохранения

Картинка

Редактор определяет элемент «Картинка» как html элемент, заключенный между парными html тегами <img>. Другие картинки html-страниц (в том числе, картинки элементов <button>) недоступны в редакторе текущей версии. Картинки недоступны также, если выбран тип источника web-формы - «Ссылка».

Свойства:

Идентификатор

Текст. Используется для идентификации выпадающего списка в пределах web-формы и групповых запросах

Изображение

Аргумент, значение которого после вычисления устанавливает источник изображения для элемента. Может быть

· константой - путь к файлу с рисунком;
· переменной сценария;
· полем прикрепленной к задаче таблицы;
· выражением;
· запросом SQL в базу данных. Запрос может возвращать путь к файлу с рисунком

В отличие от диалоговых форм рисунок в бинарном формате из базы в элемент вставить нельзя

Таблица

Редактор определяет элемент «Таблица» как html элемент, заключенный между парными html тегами <table>. Для того чтобы выделить таблицу, достаточно выделить границы любой её ячейки.

Свойства:

Идентификатор

Текст. Используется для идентификации выпадающего списка в пределах web-формы и групповых запросах

Значения

Аргумент, значение которого после вычисления устанавливает источник данных для таблицы. Может быть запросом SQL к базе данных. Запрос должен возвращать набор данных ( recordset ).

Заголовки столбцов

Число. Определяет источник для заголовков столбцов таблицы:

· «отсутствуют» - таблица не имеет строки заголовков. Если такая строка (строки) предусмотрены web-дизайнером, то в них будут подставлены данные из первой строки источника данных;
· «из web-формы» - используются заголовки, предусмотренные дизайнером. Если их нет, то первая строка таблицы останется пустой;
· «из базы данных» - в строку заголовков подставляются названия столбцов из источника данных таблицы. Если такой строки дизайнером не предусмотрено, то названия столбцов будут подставлены в первую строку таблицы.

Данные в таблицу вставляются в 2 этапа:

На первом этапе сущестующие ячейки таблицы заполняются данными из указанного источника по следующим правилам:

· Значения ячеек таблицы, которые были до вставки будут замещены данными источника за исключением, быть может, строки заголовка (в зависимости от установленной настройки «Заголовки столбцов»)
· Сначала заполняются имеющиеся строки. Если столбцов данных больше чем столбцов в таблице, то соответствующая часть данных вставлена не будет (макет html страницы определяется дизайнером). Если столбцов даных меньше чем в таблице, то «лишние» столбцы таблицы останутся неизмененными.
· Если где-либо в таблице ячейки имеют атрибут colspan, то в строке с такими ячейками заполняются только имеющиеся ячейки. Данные, для которых не хватило ячеек, в таблицу вставлены не будут.
· Если где-либо в таблице ячейки имеют атрибут rowspan, то в таких ячейках значение каждой последующей строки будет затирать предыдущее.

Не рекомендуется использовать таблицы, перегруженные атрибутами rowspan и colspan.

На втором этапе к таблице добавляются дополнительные строки в том случае, если строк в источнике данных больше чем в таблице. Правила вставки данных в добавленные ячейки совпадают с вышеперечисленными. При добавлении новым ячейкам назначаются все атрибуты ячеек из:

· предыдущих: чётной и нечётной строки (если такие строки имеются в таблице)
· предыдущей строки (если такая строка имеется в таблице)

Если таблица не имеет строк (в зависимости от настройки «Заголовки столбцов» первая строка может игнорироваться, или использоваться для копирования атрибутов), то новые ячейки используют стили принятые по умолчанию.

Двухэтапная организация вставки данных позволяет работать не с конечной таблицей (которая будет отражена в web-форме), а с макетом, который подготовил дизайнер.


Инспектор объектов

Инспектор объектов редактора web-форм служит для задания свойств html-элементам, расположенным на web-странице. В целом он аналогичен инспектору редактора диалоговых форм. Ниже приведены всплывающие формы инспектора объектов, с помощью которых определяются некоторые из свойств.

Форма «Сохранение»

Форма используется для задания настроек, определяющих способы сохранения заданного пользователем значения элемента.

Закладка «Переменные сценария» - предоставляет возможность указать новые или уже существующие в сценарии переменные для сохранения значения элемента

Закладка «SQL» представляет собой конструктор SQL запроса для сохранения . В качестве переменных запрос могут быть использованы идентификаторы элемента и переменные сценария. Для того чтобы в запросе сослаться на значение элемента, выбранный индекс (для элемента «выпадающий список») или значение галочки элемента необходимо задать идентификатор. В списке «доступные идентификаторы» в этом случае будут перечислены один или несколько идентификаторов вида:

· «имя_идентификатора» - возвращает значение элемента;
· «имя_идентификатора_url» - возвращает значение url html-элемента «гиперссылка»;
· «имя_идентификатора_checked» - возвращает значение атрибута checked галочки или кнопки выбора варианта

В списке доступных переменных перечислены переменные сценария, которые могут быть использованы в запросе.

Формы для задания групповой подстановки «Подстановка значений» и группового сохранения «Сохранение» имеют только одну закладку «SQL». В списке «доступные идентификаторы» в этом случае будут перечислены идентификаторы всех элементов текущей группы.


Служебные сценарии

Служебные сценарии – это процедуры, выполняемые на сервере Oktell. В отличие от других типов сценариев, служебные не осуществляют руководства ни над линиями, ни над приложениями пользователей, поэтому имеют в своем распоряжении только общие компоненты с небольшим расширением для узкоспециализированных задач. Служебные сценарии могут обращаться в БД, посылать уведомления, осуществлять проверки, заниматься приемом и рассылкой SMS-сообщений и инициировать звонки.

Существуют несколько направлений, активно использующих служебные сценарии:

· Обработка собранного по звонку контента. В ходе звонка по внешней линии сервер собирает так называемый контент, к которому относится вся информация о линии, абоненте, времени звонка и другая идентификационная информация, а также перечень действий произведенных за время звонка с абонентом и информация о всех коммутациях с подробным их описанием. Все сценарии, все операторы, с которыми был коммутировался абонент, будут перечислены с идентификаторами, именами, а также временем начала, временем конца и продолжительности коммутации. После завершения звонка собранный контент передается в виде параметра в запущенный служебный сценарий обработки контента. В служебном сценарии в компоненте «старт» при необходимости параметр сохраняется для дальнейшего пользования. В сценарии-обработчике контента есть возможность разобрать контент по составляющим для последующего сохранения в удобоваримом виде в БД, либо сохранить непосредственно в файлы в виде текста или XML документа.

· Текстовые задачи на рассылку сообщений или обработку данных по абонентской таблице. После запуска такой задачи, прикрепленный к ней служебный сценарий осуществляет необходимые действия, чаще связанные с рассылкой сообщений по абонентам из прикрепленного списка. В зависимости от настроек задачи на каждого абонента может быть запущена отдельная реализация сценария (если информация персонифицирована), либо один сценарий, предполагающий массовую рассылку. Способ получения отчетов о доставке определяется и корректируется в сценарии. Флаг успеха и неуспеха также выставляется сценарием в установленное поле таблицы абонентов.

· Активация контрольного события.

· Запуск по таймеру служебных действий, определенных администратором системы.

· Асинхронный запуск служебного сценария из других сценариев.

· Сценарий дозвона, запускамый при соответствующих настройках менеджером задач или менеджером автодозвона для преобразования номера абонента в особую команду и отправки его в одну из указанных внешних линий или необходимое направление (например вывод мобильных на GSM-шлюз).

· Преобразования строк.

Для каких бы действий ни использовался сценарий, ему на вход в компонент старт передается строковый параметр. В случае обработки контента – строка содержащая контент, для сценария преобразования номера в команду - начальный номер и т.д.

Служебные переменные:

· Статус отправленного сообщения. Используется при автоматической обработке исходящей задачи в многопоточном режиме для определения состояний отправленных SMS-сообщений. Среди возможных значений 0 – не отправлено, 1 – отправлено, 2 – доставлено. В результате заполнения переменной менеджер задач принимает решение об успехе, необходимости повтора отправки, либо о необходимости получения отчета о доставке в автоматическом режиме в конце выполнения задачи.
· PushId отправленного сообщения. В случае фиксации состояния «отправлено» необходимо указать PushId сообщения, чтобы активировать функцию получения отчета о доставке в автоматическом режиме.
· Возвращаемое значение. Используется в сценариях, осуществляющих преобразования. Например в сценариях преобразования номера в команду направления, где на вход в компонент старт передается номер, а итоговая команда возвращается через эту служебную переменную.

В этом разделе:

— Компоненты служебных сценариев


Компоненты служебных сценариев

В данном разделе в справочном порядке приведены лишь узкоспециализированные компоненты, доступные только служебным сценариям. Остальные компоненты являются общими для всех типов сценариев и описаны выше в разделе «Общие компоненты сценариев».

Сохранение контента

Компонент служит для сохранения переданного ему на старт контента в файл. Сбор таких файлов может быть необходим для последующих задач обработки и тарификации. Файлы могут быть сохранены в текстовом и xml виде. Их дальнейшую обработку может взять на себя или отдельный процесс, или служебный сценарий с таймерной активацией.

Свойства:

Контент | Переменная, содержащая переданный в сценарий контент. Заполняется в компоненте «Старт».
Тип файла | Текст / XML.
Файл | Аргумент, определяющий путь к файлу. Доступна генерация случайных имен (включающих время).
Добавлять в конец | Да/нет. Определяет способ формирования файла. Включение режима дописывает в конец к выбранному файлу информацию. Работает только при сохранении в текстовые файлы. Актуально только при настройке записи в один и тот же файл с целью избежания затирания предыдущей информации. Поле доступно только при выборе значения «Текст» в свойстве «Тип файла».
Имя файла в переменную | В указанную переменную будет занесено название файла (или путь), в который было произведено сохранение.
Возвращать полный путь | Да/нет. При выборе пункта «Да» в переменную будет сохранен полный путь, иначе только имя файла.
Переход | Компонент, на который передается управление.
Имя | Название компонента для отображения в визуальной среде и выбора в списке.

Парсинг контента

Компонент служит для принятия решения в сценарии на основе содержащейся в контенте информации. Производит выделение из контента интересующего значения, такого как номер линии, время звонка и др.

Свойства:

Контент

Переменная, содержащая переданный в сценарий контент. Заполняется в компоненте «Старт».

Параметр

Одна из множества содержащихся в контенте величин:

· Направление звонка;
· Время начала;
· Время окончания;
· Идентификатор линии;
· Номер линии;
· Идентификатор цепочки коммутаций;
· Номер абонента (CallerId);
· Внешний номер;
· Количество коммутаций;
· Количество коммутаций с оператором;
· Количество коммутаций с IVR;
· Общее время в секундах;
· Обработка в задаче;
· Идентификатор проекта;
· Идентификатор задачи;
· Имя задачи;
· Код задачи;
· Время в задаче в секундах;
· Время начала задачи;
· Код абонента в списке задачи;

Тип возвращаемого значения строковый или числовой.

Переменная

Переменная, в которую производится выгрузка значения.

Переход

Компонент, на который передается управление.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.

Дозвон

Служебный сценарий не связан ни с какой линией, однако он может инициировать звонок на внешнее направление. Компонент позволяет осуществить вызов абонента и в зависимости от свойств передать управление линией в сценарий IVR или во внешний управляющий модуль (например менеджер задач). В ходе дозвона производится поиск свободной внешней линии в соответствии с установленным списком, резервирование, набор номера. Далее в случае передачи управления внешней линией в сценарий IVR осуществляется ожидание ответа в течение установленного интервала времени (по умолчанию 40 секунд) и дальнейший запуск указанного обслуживающего сценария. В случае передачи управления в вышестоящий менеджер, ожидание ответа абонента осуществляется уже в нем, а сценарий после отправки номера на набор сразу сразу переходит к следующему компоненту.

Использование в режиме вышестоящего управляющего модуля происходит при активации режима набора номеров через сценарий в сервисе автодозвона или в голосовых задачах. Например, может стоять задача жесткой маршрутизации звонков. В задаче указывается перечень равноправных линий, однако мобильные номера необходимо набирать через GSM-шлюз, внутригородские через городскую АТС, междугородние через SIP-соединения или через городскую АТС с использованием городской IP-телефонии. Для решения этой задачи может быть организован служебный сценарий, который в соответствии с переданным на его старт номером осуществляет маршрутизацию, выбор направлений, преобразование номера в команду, резервирование и отправку строки-команды на набор. Сценарий устанавливается как способ набора номеров в задачах (могут быть установлены различные сценарии в разных задачах) или при автодозвоне. После отправки команды-номера на набор управляющий модуль берет на себя задачу ожидания ответа линии, а сценарий либо завершается, либо производит дальнейшие необходимые действия, связанные с контекстом своего исполнения. Естественно, сценарий для определения способа маршрутизации и преобразования может использовать всю доступную информацию: время, номер, задача/пользователь, информация во внешних источниках (web, БД) и т.д.

В компоненте устанавливается список внешних линий и направлений, отсортированных в соответствии с приоритетом выделения. Может быть задействован дополнительный фильтр по правам внешнего объекта (задачи или пользователя), то есть могут быть исключены те линии, которые не присутствуют в ресурсах инициирующей дозвон задачи или в правах инициирующего автодозвон пользователя.

Преобразование номера в команду может быть произведено направлением, в котором зарезервирована свободная линия. Также преобразование может быть выполнено предварительно в текущем сценарии, а на набор передано без изменений.

В одном обработчике сценария может быть успешно выполнено сколько угодно компонентов «Дозвон» с режимом обслуживания в IVR, но только один с режимом обслуживания в вышестоящем управляющем модуле. Остальные будут фильтроваться.

Свойства:

Обслуживание

IVR / Управляющий модуль.

Вариант использования компонента. Различие в режимах описано выше.

Номер/команда

Аргумент, определяющий номер, по которому производить дозвон.

В качестве номера может быть принята команда (строка, содержащая DTMF символы и командные спец. символы w, q, z, {, }). Подробнее о командах в разделе «Администрирование. Направления».

Тип команды

Определяет способ преобразования номера в команду, отсылаемую на набор. По умолчанию без преобразования.

· Без преобразования. Отправляет номер как есть в зарезервированную линию.
· Использовать команду направления. Если зарезервированная линия взята из направления, и в нем настроено преобразование номера, то перед отправкой на набор номер будет преобразован в строку-команду по указанной в направлении схеме. Подробно здесь.

В некоторых случаях преобразование номера в команду может быть произведено предварительно в самом сценарии, или вовсе команда как итог может быть указана в таблице абонентов (номер в чистом виде - частный случай команды). В этом случае дополнительно преобразовывать команду не следует, и стоит оставить режим "без преобразования". Конечный режим реализации зависит от задач и целей.

Линии, направления

Осуществляет выбор линий и направлений для осуществления звонка.

На вкладке «Список объектов» предоставляется возможность указать явно последовательность существующих в системе линий и направлений для осуществления звонка. Можно отключить использование некоторых элементов, а для выбранных установить последовательность поиска свободной линии.

Поиск свободной будет осуществляться в соответствии с установленной последовательностью. По каждому направлению анализируются все линии, входящие в его состав. Если линия присутствует в нескольких направлениях, то при обнаружении ее свободной и установленном в компоненте режиме преобразования номера в соответствии с командой направления, будет применена команда того направления, которое в перечислении находится выше по приоритету.

На вкладке «Аргумент» возможно динамическое указание линии через ее Guid-идентификатор в строковом представлении. Также здесь может быть указан идентификатор направления, потока или шлюза. В этом случае будут последовательно перебираться все линии указанного объекта до обнаружения свободной и готовой к совершению вызова. Режим введен для использования совместно со шлюзами с динамической регистрацией потоков и компонентом сценариев «Регистрация потока».

Фильтровать по правам

Да/нет. При задействовании режима в случае, если осуществляется обработка канала пользователя системы, может быть осуществлена дополнительная фильтрация перечисленных в компоненте линий в соответствии с настройками прав выхода на внешние линии для пользователя. По умолчанию «Да» - фильтровать.

CallerId

Подставляемый для звонка номер. При отсутствии или некорректном значении будет взят номер по умолчанию для канала.

Сценарий IVR

Параметр запуска IVR

Время ожидания, сек

Аргумент определяет, сколько секунд необходимо ожидать соединения перед отбоем.

Переход

Компонент, на который передается управление в случае успешного выполнения поставленной задачи (в соответствии с режимом - либо ответ абонента и соединение со сценарием IVR, либо отправка команды на набор и передача линии на обслуживание в управляющий модуль).

Переход, занято

Компонент, на который передается управление, если номер занят.

Свойство доступно только если установлен режим обслуживания в сценарии IVR.

Переход, не отвечает

Компонент, на который передается управление, если время ожидания ответа истекло.

Свойство доступно только если установлен режим обслуживания в сценарии IVR.

Переход, линия не найдена

Компонент, на который передается управление, если не обнаружена доступная для совершения вызова внешняя линия из списка направлений.

Переход, ошибка

Компонент, на который передается управление, если в ходе проверки корректности установки свойств, набора номера, ожидания событий или передачи управления возникли сбои.

Имя

Название компонента для отображения в визуальной среде и выбора в списке.


Задачи

Модуль доступен администраторам БД, супервизорам и пользователям, имеющим соответствующее право. Для пользования модулем необходимо зарегистрироваться в call-центре системы. Служит для создания и редактирования задач, а также управления их состоянием.

Целью задачи Oktell является проведение массовых акций по коммутации абонентов с операторами call-центра или IVR по определенным в ее настройках правилам, либо рассылка текстовых сообщений (SMS, e-mail, ICQ). Последние могут быть использованы для проведения и других служебных действий с данными на основании прикрепленной таблицы абонентов.

Задачи в системе Oktell делятся на входящие и исходящие.

Входящие задачи активируются при поступлении звонка из сценария обработки IVR и ее действие определяется как сценарием, так и собственными настройками. Входящая задача инициируется при состоявшемся и ожидающем ответа звонке со стороны внешних линий. Ход исполнения задачи состоит из нескольких этапов:

· Определение доступного оператора (по настройкам задачи и статистике работы call-центра);
· Коммутация с оператором;
· Помощь в проведении разговора, определяющаяся соответствующим сценарием разговора (доведение до абонента персональной информации и занесение ответов абонента в базу);
· Внесение информации о результатах звонка и при необходимости запрос у оператора результатов;

В качестве оператора может выступать автоматическое голосовое меню (IVR) Oktell согласно прикрепленным к задаче сценариям IVR.

Исходящие задачи имеют собственный список номеров для совершения звонков, и активируются при обнаружении возможности произвести звонок. Детали сильно зависят от настроек задачи, но в общем виде возможность включает в себя наличие доступных операторов, наличие свободных линий для звонка, время, дата, результаты предыдущих звонков и т.д.

Ход проведения исходящего оповещения зависит от типа. В общем виде этапы можно описать следующим образом:

· Определение момента необходимости набора номера;
· Определение одной или нескольких комбинаций (абонент, номер) из установленного списка, подходящего для звонка в конкретный момент (по настройкам и предыдущим попыткам);
· Если оповещение с резервированием оператора, то определение доступного для исполнения задачи оператора (по настройкам задачи и статистике работы call-центра), его резервирование и уведомление или запрос на звонок;
· Дозвон до одного из номеров в установленном списке
· Коммутация с оператором или помещение в очередь, если операторы не зарезервированы (в случае прогрессивных и предиктивных схем).
· Помощь в проведении разговора, определяющаяся соответствующим сценарием разговора (доведение до абонента персональной информации и занесение ответов абонента в базу);
· Внесение информации о результатах звонка и при необходимости запрос у оператора результатов;

Аналогично входящим задачам в качестве оператора в исходящей задаче может выступать IVR.

В приведенном списке всех существующих задач вы можете видеть их свойства и состояние. Среди состояний: пассивные (помечаются серым индикатором), активные (помечаются красным индикатором), завершенные (помечаются зеленым индикатором).

Сразу после создания задачи ей выставляется пассивное состояние. Для старта или возобновления выполнения исходящей задачи, а также для получения доступа к входящей задаче из сценария IVR, необходимо перевести ее в активное состояние. Выделите ее в списке и нажамите кнопку «В активные» внизу. Чтобы временно приостановить выполнение задачи – переведите ее в пассивные путем выделения в списке и нажатия кнопки «В неактивные» внизу.

Исходящая задача может перейти в состояние завершенной после отработки всего предоставленного ей списка абонентов и получения окончательного результата по каждому из них, если у нее установлено соответствующее свойство завершения. Завершение может также быть произведено по временной границе или вовсе не производиться. Незавершающиеся исходящие задачи полезны в случаях использования динамических таблиц абонентов. Например там, где осуществляется пополнение списка абонентов через сайт, или существует жесткое условие на состояние счета для осуществления звонка.

Слева в списке выделите интересующий проект. При этом справа увидите все принадлежащие ему задачи. Вы можете редактировать и удалить те из них, что находятся в неактивном состоянии. При удалении задачи из основной базы данных удаляется вся статистика попыток дозвона, собранная в ходе ее выполнения, однако таблицы абонентов, а также база данных статистики, содержащая представление статистики call-центра в виде схем OLAP, оставляют в себе историю до момента принудительного удаления администратором. В основной базе данных остаются лишь только записанные разговоры и статистика коммутаций, доступные в модуле «Офис. Статистика». Для предотвращения потери информации перед удалением задачи убедитесь в ее сохранности.

В режим редактирования задач помимо нажатия соответствующей кнопки внизу вы также попадаете автоматически при ее создании. Редактирование задачи состоит из указания ее свойств на 4 вкладках режима. Каждая вкладка предоставляет доступ к отдельным по смысловому наполнению настройкам.

В этом разделе:

— Голосовые задачи

— Текстовые задачи


 Голосовые задачи

Голосовые задачи

 Содержание | Назад | Далее

Основные параметры

Вкладка предоставляет доступ к основным определяющим поведение задачи свойствам.

· Название задачи.

· Код задачи. Параметр применяется для взаимодействия с внешними базами данных, ведущихся по проектам во многих аутсорсинговых call-центрах. Параметр доступен в любом сценарии, выполняющемся в ходе реализации каждого звонка по конкретной задаче.

· Направление (исходящее/входящее). Отличия входящей и исходящей задачи указаны выше в описании данного модуля.

· Тип задачи. Определяет каким способом ведется обработка звонка – автоматическим (IVR) или с помощью оператора. Среди исходящих задач существует несколько типов организации массового оповещения с участием операторов:

o Оповещение оператором с резервированием и уведомлением;
o Оповещение оператором с резервированием и запросом;
o Оповещение оператором с ручным выбором абонентов;
o Прогрессивный обзвон операторами;
o Предиктивный обзвон операторами;
o Прогрессивно-предиктивный обзвон операторами;

Оповещение с резервированием. Начинает дозвон до одного конкретного номера телефона, предварительно найдя и зарезервировав оператора. Оператору выводится уведомление или запрос на проведение обозначенного звонка, который в этом случае он может принять, отложить или отклонить.

Оповещение с выбором абонентов. Кардинальное отличие от простого резервирования состоит не только в предоставлении оператору возможности выбора абонента, но и в использовании пула дозвона до абонентов по распределенному списку. Каждому оператору выделяется определенная группа абонентов, с которыми он работает индвивидуально (звонки абонентам осуществляются только им). При настройке этого типа задачи на вкладке «Абоненты» появляются элементы для задания правил разбиения списка по операторам (подробнее об этом далее в разделе). Супервизору при создании подобной задачи необходимо в обязательном порядке провести распределение списка, в противном случае задача не найдет подходящих условий для совершения вызовов. Допускается равномерное деление, а также деление по правилам (количеству, процентному соотношению, начальным буквам названия абонента). Нераспределенные абоненты, а также абоненты, появившиеся в списке после разбиения не будут автоматически присоединены к обработке. Подобный тип задачи предусматривает полный контроль ситуации супервизором. На вкладке «Абоненты» модуля «Ресурсы» для задач с распределенным списком предоставляется возможность управления текущим разбиением на основе статусов звонков, и для полноты информации предоставляются доступ к дополнительным служебным статусам. Абонентов с определенными состояниями супервизор имеет возможность перетащить от одного оператора к другому, тем самым скорректировав разбиение списка. Также см. «Принципы работы логики. Менеджер голосовых задач. Задачи с распределенным списком».

Прогрессивно-предиктивные схемы. Подобные механизмы имеют большое значение при проведении массовых акций с целью сэкономить время оператора, производя служебные действия в параллельном режиме. Разумное решение лежит между двумя крайностями: «все операторы ждут дозвона в зарезервированном состоянии» и «все звонки ждут освобождения операторов в очереди». Существуют два подхода к поиску оптимального решения.

Прогрессивный дозвон. При обнаружении свободного оператора, задача помещает его в очередь и осуществляет одновременно несколько звонков. Первый успешный вызов сразу коммутируется. Остальные звонки в зависимости от настроек задачи (лояльность, очередь прогрессивного набора) остаются в очереди для других операторов, или прекращаются. Априори достоверно, что прогрессивная схема менее лояльна к абонентам, чем схема с резервированием. Если в очереди ожидающих дозвона находятся несколько операторов, то первый успешный звонок выделяется для первого оператора в очереди. Очевидный факт, что абоненты при исходящем оповещении ждать ответа в основном не намерены. Сервер Oktell при использовании прогрессивной схемы пытается минимизировать время ожидания операторов, взяв в расчет именно этот принцип и практически не давая вырастать очереди абонентов.

Однако существуют настройки задач, при которых абоненты ждут операторов. Такие задачи редко представляют интерес. В этом случае очереди компенсируют друг друга, но лояльность к абонентам существенно снижается.

Прогрессивный дозвон имеет больший смысл, если число линий, выделенных для задачи больше числа операторов, единовременно обрабатывающих задачу. Разумно настроенная прогрессивная схема – крайне эффективный инструмент. В качестве примера можно привести следующий результат в самых крайних условиях: Оповещение одним оператором по двум линиям списка из 10 абонентов, где у каждого абонента от 1 до 5 телефонных номеров и ситуация усугубляется тем, что половина номеров в итоге не отвечает. Для оператора наличие «битых» номеров остается незаметным до самого конца, когда на обеих линиях остаются только абоненты, не имеющие ни одного нормального номера. При увеличении числа линий и числа операторов качество заметно повышается. Более эффективно и менее лояльно прогрессивный дозвон можно настраивать, если число операторов достаточно велико, а время обработки одного звонка достаточно мало.

В схемах, где число линий и операторов, назначенных в задачу, практически одинаково и значительно (20, 30, 40, 50, ...) прогрессивный дозвон экономит время поствызывной обработки и набора номера, производя работу в параллельном режиме, что в некоторых случаях приводит практически к тем же результатам что и в случае с числом линий, превышающим число операторов, обладая вместе с этим преимуществом, делая невозможным рост очереди абонентов.

Использование прогрессивного набора в массовых кампаниях накладывает дополнительные требования, подробнее в разделе «Принципы работы логики. Менеджер голосовых задач. Прогрессивный набор».

Задачи с прогрессивным набором очень эффективное средство, дающее наибольшую производительность при рационально назначенных количественных и ресурсных свойствах. Ориентировочная занятость операторов в зависимости от длительности разговора, соотношения операторы / линии и качества телефонной базы может достигать 90% и более.

Предиктивный дозвон. Такой способ организации задачи опирается на статистику по задаче. Применяя вероятностную модель к накопленной статистике менеджер задач может начать осуществлять дозвон еще до того, как оператор освободится, подгадывая момент получения успеха по звонку к моменту освобождения конкретного оператора. Можно повышать лояльность, сдвигая момент начала дозвона на заданное время относительно прогнозируемого. Каждый формируемый таким образом звонок рассчитывается для конкретного оператора. Однако, при включении предиктивного механизма используется общий механизм очередей. Таким образом, первый полученный звонок получит первый оператор из очереди, вне зависимости для кого он готовился. Предиктивная схема в общем случае менее эффективна и менее лояльна, чем прогрессивная. Но все же при достаточной статистической равномерности предиктивная схема может принести заметную выгоду.

Возможно использование комбинированной прогрессивно-предиктивной схемы. В этом случае за базу берется прогрессивная, и включается механизм прогнозирования. В общем случае при неизвестном проценте «битых» номеров это наиболее продуктивная схема. При большом числе операторов неровности статистики, использованные в расчете неточного прогноза и понижающие теоретическую лояльность, сглаживаются.

· Сценарий IVR. Используется в задачах, обрабатываемых автоматическим сервисом голосовых меню. Выберите один из элементов списка существующих в текущем проекте пользовательских сценариев IVR для прикрепления его к редактируемой задаче. После дозвона до абонента ему будет воспроизведен выбранный сценарий голосового меню с полным функционалом и доступом к таблице с информацией об абоненте, если она назначена (раздел «Call-центр. Сценарии. Сценарии IVR»).

· Сценарий диалога. Используется в задачах, обрабатываемых операторами call-центра. Выберите один из элементов списка существующих в текущем проекте пользовательских сценариев разговора для прикрепления его к редактируемой задаче. После коммутации абонента с оператором система начнет выполнение указанного сценария диалога. В сценарии могут присутствовать элементы-подсказки оператору, элементы запросы ответов абонента, заполняемые оператором в открывающихся формах ввода, а также прочие произвольные формы ввода (раздел «Call-центр. Сценарии. Сценарии диалога»). Сценарии диалогов являют собой наиболее общую и гибко настраиваемую систему всплывающих окон, известных в терминологии call-центров как «PopUp».

· Служебный сценарий. Используется голосовыми задачами в конце обработки вызова c передачей собранного контента для его обработки, сохранения и других служебных действий (раздел «Call-центр. Сценарии. Служебные сценарии»).

· Рабочий график задачи. Определяет время активности задачи. Исходящая задачи не производит звонков вне графика, входящая задача не принимает звонки, возвращая управление обратно в сценарий обработки входящих звонков по ветке «Вне графика». Таким образом, задача, даже находясь в активном состоянии, при наличии всех условий будет ожидать начала очередного периода актуальности в соответствии с установленным графиком. График представляет собой недельный срез. Для установки активности – щелкните мышью в соответствующем пересечении дня недели и часа, или растяните рамку выделения необходимой области. Элемент является инверсивным, то есть при двойном выделении переходит в первоначальный вид.

· Дата активации задачи. Определяет время, до которого исходящая задача не приступает к действию, даже будучи активной. Входящая задача до наступления этой границы при входе возвращает управление в сценарий обработки входящего вызова по ветке «вне периода актуальности». Время активации можно не назначать, отключив галочку.

· Дата прекращения выполнения. Дополнительное условие, подобное рабочему графику, определяющее интервал времени, за пределами которого задача не выполняется и возвращает управление в сценарий по ветке «вне периода актуальности».

· Остановить задачу. Способ завершения исходящей задачи. Среди вариантов:

o После завершения всех абонентов;
o После наступления времени деактивации;
o Не останавливать никогда.

При выборе пункта «не останавливать никогда», после завершения обзвона исходящая задача становится в ожидание и производит постоянную синхронизацию с таблицей абонентов на предмет появления новых записей. Период ожидания перед очередной синхронизацией задается на вкладке «Абоненты». Задача может быть остановлена только супервизором путем перевода в неактивное состояние.

· Расписание праздников. Указывает, будет ли применяться поправка на праздничное расписание (выходные и праздники и исключения, настраиваемые для комплекса в модуле общих настроек). В случае, если в расписании праздников день является исключением (праздник или наоборот рабочий день), то расписание задачи корректируется с учетом него, в противном случае применяется стандартное расписание задачи. Корректировка производится следующим образом: если день объявлен праздником - задача не запускается, а если день объявлен рабочим по какому-либо дню недели, то задача активируется в соответствии с ее расписанием для этого дня недели.

Ресурсы

Вкладка определяет ресурсы, выделяемые на задачу системой. С помощью управления ресурсами производится многостороннее ограничение производительности задачи. Это по-разному используется в случае организации аутсорсинговых и корпоративных call-центров.

· Операторы. Доступно для задач, обрабатываемых операторами call-центра. В списке операторов выделите галочками необходимых операторов и пользуясь стрелками установите необходимый порядок (если будет использован способ выбора операторов «по cписку»). Оператор может одновременно быть назначен на множество задач, предоставляя автоматике менеджера задач Oktell управление ресурсами (см. «Администрирование. Общие настройки. Менеджер задач. Приоритет исходящих задач».

· Вариант обхода операторов. Доступно для задач, обрабатываемых операторами call-центра. Предоставляет создателю задачи возможность максимально эффективно подходить к выделению ресурсов. В случае, если во входящей задаче дефицит операторов и звонок попадает в очередь, алгоритм выбора не включается, и производится коммутация с первым освободившимся оператором. В других случаях (а также в исходящих задачах) существуют несколько алгоритмов, выбор одного из которых должен производиться после учета всех факторов работы конкретного call-центра:

o По списку (по компетенции). Выделяется первый свободный оператор из установленного списка, то есть основная нагрузка ложится на операторов в начале списка.
o Поочередно. Организуется список, выбор оператора из которого производится поочередно, например 2, 1, 3, 2, 1, 3, 2, 1, 3.
o По минимальному времени, потраченному на задачу. Ищется оператор, участвовавший в задаче минимальное время среди операторов, назначенных в задачу. Таким образом, из двух операторов, один из которых обработал 5 вызовов по 5 минут каждый, а другой 1 вызов длительностью 0,5 часа, будет выбран первый. Стоит аккуратно использовать этот режим, так как при присоединении к задаче новых операторов весь поток звонков по задаче устремится на них.
o По минимальной общей загрузке. Учитывая не только контекст данной задачи, а общую работу в организации, будет выбран оператор, который провел в коммутациях меньше всего времени за текущий день. Стоит аккуратно использовать этот режим, так как при присоединении к call-центру новых операторов весь поток звонков по задаче устремится на них.
o По максимальному времени простоя. Среди операторов будет выбран тот, со времени окончания последнего разговора которого прошло больше всего времени.
o Случайный выбор. Система пытается найти одного из свободных операторов с помощью равномерного распределения. Таким образом, имитируя равномерность загрузки в случае, если у создателя нет четкой уверенности в корректности применения одного из предыдущих вариантов.
o Пользовательская процедура. Используется хранимая процедура A_TaskManager_OperatorsAll_Get_Custom в основной БД. При необходимости формирования динамических списков администратору необходимо сформировать в ней выходную таблицу с кодами операторов, отсортированную в приоритетном порядке от более приоритетных к менее. Будет зарезервирован свободный оператор, код которого располагается в выходном наборе выше всех остальных. Итоговый список фильтруется в соответствии со списком установленных операторов для обработки в конкретной задаче. Отсутствующие же в выходном наборе операторы не подлежат резервированию на текущий вызов ни в каком случае. При использовании этого режима во входящих задачах в процедуру передаются помимо кода задачи также код абонента в списке (если список прикреплен) и код внешней линии, по которой произошел текущий звонок (по нему в БД можно достать в таблице коммутаций или во временной таблице, ранее заполненной в сценарии IVR). По умолчанию процедура возвращает всех операторов в каком-то определенном произвольном порядке.

· Супервизоры. Выделите галочками в списке необходимых супервизоров. Они будут получать уведомления при возникновении критических ситуаций, а также будут рассматриваться получателями контрольных событий, назначенных на задачу.

· Внешние линии. Доступно только для исходящих задач. При назначении этого свойства для исходящей задачи отметьте галочками выделяемые для использования задачей внешние линии. Задача при возможности совершения очередного вызова будет использовать только те из указанных линий, которые находятся в активном состоянии и согласно их свойств доступны для использования в автоматическом оповещении.

· Ограничивать количество. При необходимости, выставив флаг, можно ограничить использование линий задачами. Для входящей задачи укажите максимальное число подключений к задаче. При поступлении очередного звонка, превышающего число подключений к задаче, будет произведен возврат управления в сценарий обработки входящего вызова по ветке «превышено число подключений». Для исходящей задачи число совершаемых вызовов будет дополнительно ограничиваться указанным количеством линий, что может быть использовано, например, на линиях потока Е1 для разделения ресурсов несколькими задачами при их совместном использовании.

Абоненты

Вкладка определяет прикрепленную таблицу абонентов и формат общения задачи с ней.

· Таблица абонентов. Указывает на прикрепленную к задаче таблицу абонентов (из существующих в текущем проекте). Исходящие задачи используют таблицу для осуществления звонков. Входящие задачи могут корректно использовать только ту таблицу абонентов, в основе которой лежит таблица БД. Входящие задачи по выбору могут искать абонента по определившемуся номеру в таблице или для каждого звонка создавать новую запись. В соответствии с настройками таблицы абонентов, часть информации из списка будет отображена во всплывающих «PopUp» окнах на рабочем месте оператора, в случае если рабочее место оператора компьютеризировано. Номера абонента для дозвона берутся из столбцов, отмеченных свойством «Телефон». При смене списка у существующей задачи, статистика по произведенным звонкам не теряется, но задача полностью синхронизирует свой внутренний список с таблицей абонентов. Аналогично задача ведет себя при изменениях, вносимых в назначенную ей таблицу абонентов в модуле «Таблицы абонентов».

· Метод работы с таблицей. Доступно только для исходящих задач. Определяет один из нескольких вариантов кэширования данных. По умолчанию выставляется метод «Загрузка в оперативную память». В этом случае в оперативной памяти создается кэш с данными по идентификаторам и телефонам всех абонентов таблицы. Периодически производится полная синхронизация с БД. Следует иметь в виду, что ресурсы системы ограничены, и поэтому использование этого метода ограничено определенными объемами данных в таблице абонентов. Рост объема влияет как на время синхронизации, так и на общее время обработки. При объеме таблицы более 20 тысяч абонентов рекомендуется использовать метод кэширования в БД. В зависимости от производительности и объема оперативной памяти сервера указанное число может возрастать до 1 млн (на все активные задачи). Методы кэширования в БД существенно снижают нагрузку и могут быть использованы в любом случае и на любых объемах. Однако при этом исключается возможность использования уникальных приоритетов обхода таблицы, приведенных ниже. Активный в этом случае приоритет обхода аналогичен комбинации {По абонентам, поочередно, поочередно}. В случае массовых задач это не играет большой роли, поскольку оповещение занимает достаточно длительный период.
ВНИМАНИЕ! В обязательном порядке проверяйте наличие индексов по полю идентификатора прикрепленной таблицы абонентов. Особенно это важно при выборе метода работы с таблицей через кэш в БД на больших объемах (более 100 тысяч записей).

· Заполнение таблицы. Доступно только для входящих задач. Определяет формат поиска строки в таблице абонентов. Среди вариантов:

o Каждый звонок модифицирует информацию. При поступлении вызова в таблице по определившемуся номеру ищется запись с информацией об абоненте и в случае обнаружения запись используется (отдает на модификацию в формах ввода, используется при маршрутизации). Если запись не найдена, или номер не определился – создается новая запись с пустыми значениями, куда сразу подставляются только новый идентификатор абонента и телефон, а работа аналогична.
o Каждый звонок создает новую запись. Вне зависимости от того, определился номер или нет, существует номер в таблице или нет, создается новая запись с новым идентификатором и сценарий происходит независимо от истории абонента и его предыдущих звонков.

· Пытаться соединять с оператором, обслуживавшим предыдущий звонок абонента. Доступно для входящих задач, обслуживаемых операторами. При задействовании метода во время поступления звонка производится анализ статистики и установка оператора, который последним обслуживал текущего абонента. Если оператор оказывается свободным, производится соединение с ним, в противном случае происходит постановка звонка в общую очередь задачи. Поиск последнего звонка в зависимости от выбранного типа будет производиться по статистике текущей задачи, либо по всей статистике call-центра. Текущий абонент идентифицируется определившимся при звонке номером, либо кодом в прикрепленной таблице абонентов (в этом случае одному абоненту может принадлежать несколько номеров).

· Интервал синхронизации. Доступно только для исходящих задач. Определяет промежуток времени до следующей обязательной синхронизации. От 1 минуты до 1 суток. Синхронизация проводится периодически и без учета интервала, в том случае, если список обработан до конца и необходим повторный проход.

· Интервал синхронизации при отсутствии активности. Доступно только для исходящих задач, остановка которых не предусматривается (параметр «завершить задачу» установлен в «никогда»). В случае, если в списке не осталось ни одного абонента, куда бы задача могла позвонить, она переходит в ожидание с учащенной синхронизацией. Период этой синхронизации указан в данном свойстве. От 1 минуты до 2 часов.

· Синхронизировать со списком при каждой активации. Доступно только для исходящих задач. При использовании больших списков с механизмом кэширования в БД процедура синхронизации может занимать некоторое достаточно длительное время. В этой связи синхронизация принудительно проводится лишь при первом обращении к таблице-кэшу после запуска системы (для активных задач при обнаружении возможности совершения звонка, для неактивных задач после первой активации). В задачах, где допускается изменение данных в таблице, использование этого флага позволяет не пользоваться контекстным меню для запуска процедуры синхронизации, а автоматически проводить ее после очередной активации задачи.

Несколько следующих параметров определяют большое множество вариантов обхода абонентов. Практически любую постановку можно приближенно настроить в задаче, выставив их соответствующим образом. После описания будет приведено несколько примеров для более четкого понимания. Приоритеты обхода доступны только для задач, осуществляющих дозвон до абонентов по единому списку (все типы кроме задач с ручным выбором абонентов и распределенным списком).

· Приоритет обхода абонентов. Доступно только для исходящих задач. Определяет способ поиска очередного абонента в таблице при необходимости осуществить звонок на иных абонентов.

o Строгий. Список абонентов всегда обрабатывается с самого начала. Второй абонент не будет обрабатываться, пока по первому абоненту не будет получен конечный результат (положительный или отрицательный).
o Нестрогий. Список абонентов всегда обрабатывается с самого начала. Обрабатывается тот абонент, который находится ближе всех к началу списка и на который есть возможность осуществить звонок (результат по абоненту еще не достигнут, на абонента не установлены таймауты ожидания).
o Отсутствует. Производится обработка следующего по списку абонента (циклический обход).
o Случайный. Производится случайная выборка из равномерного распределения по таблице абонентов.

· Приоритет обхода номеров. Доступно только для исходящих задач. Определяет способ поиска очередного номера абонента в таблице при необходимости осуществить звонок на иные номера конкретного абонента.

o Строгий. Список номеров текущего абонента всегда обрабатывается с самого начала. Второй номер не будет обрабатываться, пока по первому номеру не будет получен конечный результат (положительный или отрицательный).
o Нестрогий. Список номеров абонента всегда обрабатывается с самого начала. В реализацию идет тот номер, который ближе всех к началу списка и на который есть возможность осуществить звонок (результат по абоненту еще не достигнут, номер не отбракован, ни на абонента, ни на номер не установлены таймауты ожидания).
o Отсутствует. Производится обработка следующего по списку номера абонента (циклический обход).
o Случайный. Производится случайная выборка из равномерного распределения по номерам абонента.

· Общий приоритет обхода. Доступно только для исходящих задач. При необходимости (или если угодно возможности) произвести очередной звонок, определяет каким способом искать номер – отдать предпочтение выбору нового абонента или попробовать другие номера текущего абонента. Возможные варианты:

o Абоненты;
o Номера.

· Прогрессивный обход. Доступно только для исходящих задач с активированной прогрессивной схемой. Определяет способ выбора множества номеров при необходимости произвести одновременно несколько звонков: возьмутся несколько номеров у одного абонента, либо по одному номеру у разных абонентов. Возможные варианты:

o Абоненты;
o Номера.

· Лояльность к абонентам. Определяет для логики принятия решений, каким образом проводить действия, где затрагивается время абонента, отличное от разговора с оператором. На итоговую лояльность влияет множество других параметров задачи, в частности настройки очереди, тип выбранной задачи (как было отмечено выше, прогрессивная схема менее лояльна, чем резервирующая операторов). Несмотря на большой диапазон, для простоты среди возможных вариантов в списке приведены только три:

o Отсутствует;
o Средняя лояльность;
o Полная лояльность;

Словами их можно описать так: Отсутствующая лояльность не помнит причиненных абоненту неудобств, средняя лояльность ограничивает неудобства определенным значением, полная лояльность после первого неудобства берет абонента в отдельную категорию и работает с ним как с единственным.

Задачи с ручным выбором абонентов и распределенным списком имеют несколько индивидуальных свойств и возможностей. При создании такой задачи супервизору необходимо провести разбиение списка по операторам.

Распределение абонентов. Поровну или вручную. В первом случае список делится на всех операторов задачи равномерно. Во втором случае супервизору необходимо задать правила распределения.

Таблица распределения. Доступно указание начальных букв, диапазонов букв, количества абонентов (берется подряд после операций с буквами) или процента. После нажатия кнопки «Перераспределить» в БД создается кэш-таблица, согласно которой производится обработка задачи модулем управления.

ВНИМАНИЕ! Добавление операторов в реальном времени в задачу с распределенным списком в модуле управления ресурсами не даст результата, если при разбиении списка оператор не присутствовал в задаче. Необходимо также произвести переброс части абонентов на оператора. Это можно сделать в модуле управления ресурсами на вкладке «Абоненты».

ВНИМАНИЕ! После выполнения одним из операторов всех своих заданий (в соответствии с установками задачи) супервизоры получат соответствующее уведомление

Дополнительно

Все числовые элементы вкладки доступны только для исходящих задач. Здесь указываются параметры, определяющие не характер, а влияющие на ход выполнения задачи. Позволяют регулировать нагрузку на ресурсы конкретного call-центра наиболее оптимальным способом.

· Максимальное число звонков при прогрессивном наборе на каждого оператора. Ограничивает прогрессивный набор установленным числом разрешенных дозвонов. Например, при стандартном значении 5 для трех операторов, ожидающих соединения, будет осуществлено не более 15 дозвонов. При выходе одного из операторов или при получении им звонка, оставшиеся 4 не урезаются, а остаются в очереди. Однако при получении негативных ответов от линий, новые дозвоны не будут осуществляться, пока их больше 10.

· Величина запаздывания предиктивного набора. Корректирует прогноз системы на заданную величину в секундах в сторону увеличения лояльности.

· Ограничение на вероятность преждевременного звонка. Принуждает систему тщательно анализировать статистику, не переступая за рамки заданного значения вероятности (или в этом случае частоты).

· Пауза после получения сигнала «Занято». Устанавливает минимальный таймаут ожидания до следующей попытки набора номера этого же абонента после получения от линии сигнала «Занято».

· Число попыток при ответе «Занято». Устанавливает число попыток дозвона до абонента, если система постоянно получает сигнал «Занято», несмотря на установленные таймауты. После проведения последней из указанного числа попыток, система переводит абонента в «Завершенные» с пометкой «Занято».

· Пауза после получения сигнала «Не отвечает». Устанавливает минимальный таймаут ожидания до следующей попытки набора номера этого же абонента после получения от линии сигнала «Не отвечает», или истечении времени ожидания ответа абонента

· Число попыток при ответе «Не отвечает». Устанавливает число попыток дозвона до абонента, если система постоянно получает сигнал «Не отвечает», несмотря на установленные таймауты. После проведения последней из указанного числа попыток, система переводит абонента в «Завершенные» с пометкой «Не отвечает».

· Время ожидания коммутации. Устанавливает время ожидания, после которого звонку будет присвоен статус «Абонент не отвечает» и увеличен счетчик числа попыток при сигнале «Не отвечает»

· Подставляемый номер телефона. При осуществлении исходящих задач на потоке E1 с множеством зарезервированных за ним номеров, система будет подставлять установленный здесь телефонный номер в качестве CallerId.

· Пропускать обработку вызова при ответе факс-автомата. Доступна только для исходящих задач. При выключенном флаге любой ответ абонента считается корректным и переводится в обработку - оператором или IVR, даже если он распознан как факс-автомат. Активировав свойство такие вызовы (распознан факс) по задаче не считаются корректно отвеченными и прекращаются, не попадая в обработку на коммутацию с оператором или IVR. В статистику попыток попадает результат «Факс».

· Поведение при переключении абонента на сценарий IVR.

o Продолжать выполнение в рамках задачи с освобождением оператора. Стандартный режим, при котором после перевода оператор освобождается, а сценарий диалога продолжает выполняться у пользователя, на которого произведено переключение, если настройки позволяют передавать диалоговые формы данному пользователю (задача, права, присутствие в списке операторов, наличие клиентского интерфейса и т.д.), либо диалоговый сценарий прекращает свое исполнение в момент переключения. В случае, если перевод осуществляется на очередь, диалоговый сценарий сворачивается у переводившего вызов оператора, а принятие решения о дальнейшем его поведении ожидает снятия трубки абонентом, на которого было произведено переключение. Переключение на IVR также производит вывод текущего оператора из задачи с обрыванием сценария диалога.
o Осуществлять выход из задачи (с возможностью входа в другую задачу). Устанавливает режим, при котором любая коммутация с IVR после перевода на него звонка оператором будет автоматически прерывать выполнение текущей задачи, что даст возможность осуществить вход в другую задачу в контексте текущей цепочки коммутаций. Если организовывать таким образом многозадачную реализацию обработки звонка, то в конечном счете в пространственную таблицу коммутаций будет помещена информация по всем коммутациям и служебным предкоммутационным состояниям (ожидание в очереди) со ссылкой на одну и ту же цепочку. Это необходимо иметь в виду при построении сложных отчетов, опирающихся на данные по цепочкам. Все последующие задачи в цепочке - входящие, так как запуск их обработки осуществляется из сценария IVR. Также этот режим может быть использован для перевода звонка на пользователя с сохранением диалоговой формы у оператора, осуществившего перевод. Режим выхода работает только если переключение осуществляется посредством сценария IVR вне зависимости от того, была ли коммутация абонента непосредственно со сценарием, или сначала было произведено соединение оператора с пользователем через IVR и последующий перевод на абонента.
o Оставлять оператора ожидающим обратного вызова. Режим используется для организации сервисов, в ходе обработки звонка в которых необходимо производить переключение абонента на внешний источник (сценарий, внешнего абонента, некоторого пользователя системы и т.д.) и оставлять оператора со сценарием диалога ожидать соединения с абонентом вновь. Для возврата абонента на оператора в сценарии IVR после успешного соединения с внешним источником необходимо не останавливать сценарий компонентом СТОП, а осуществлять ожидание (пауза, DTMF, появление в БД каких то данных и т.п.), и далее компонентом сценария IVR «Переключение» с установленным свойством Назначение => Возврат к оператору производить обратный вызов сквозь резервирование.

· Режим набора номеров. Доступно только для исходящих задач. Позволяет задать индивидуальные значения, либо сослаться на общие настройки. Определяет режим набора номеров по списку абонентов. Используется для гибкой маршрутизации звонков. Подробнее в разделе «Администрирование. Общие настройки. Менеджер задач. Сценарий набора номера».

· Служебный сценарий набора номера абонента. Доступно только для исходящих задач. Используется только в случае индивидуальной установки режима набора номеров «через сценарий». В этом случае для набора номеров именно по настраиваемой задаче будет использован указанный служебный сценарий. Ищется в проектном каталоге задачи, если не обнаружен - в общем. В случае ошибочного указания используетя обычный режим прямого набора номеров без преобразования и маршрутизации.

· Использовать очередь. Активирует очередь. Без очереди во входящих задачах, если все операторы заняты, управление будет возвращено в обрабатывающий звонок сценарий IVR по ветке «Занято». Исходящие задачи при неактивной очереди полностью исключают возможность ее использования. В этом случае невозможна полноценная работа предиктивного набора, а также невозможно сохранение недовведенных до конца звонков в очереди для еще пока занятых операторов в случае прогрессивного набора.

· Помещать в очередь при прогрессивном наборе. Оставляет очередь абонентов для предиктивного механизма, но отрезает возможность использования ее при прогрессивном наборе.

· Ограничивать максимальное число абонентов в очереди. Для исходящих задач с активированным прогрессивным набором устанавливает порог на количество помещаемых в очередь абонентов.

· Ограничивать время в очереди. При превышении времени нахождения в очереди больше заданного, происходит выход в управляющий сценарий IVR по ветке «Таймаут очереди ожидания».

· Альтернативная мелодия очереди. Позволяет назначить произвольный звуковой файл для ожидания в очереди задачи.

· Использовать случайный выбор мелодии из каталога. Позволяет включить режим и указать абсолютный путь к каталогу с мелодиями для случайного выбора (на сервере). При ожидании абонента в очереди настраиваемой задачи в указанном каталоге среди файлов *.wav, подходящих по формату, выбирается случайный. По окончании воспроизведения выбирается другой случайный файл и т.д.

· Задача не выполнена при времени коммутации менее. Для сценариев автоматического голосового меню устанавливает время, необходимое сценарию, для донесения основной информации. В случае, если абонент кладет трубку раньше установленного времени, дозвон считается неуспешным, в статистику по такому звонку проставляется описание «Время в сценарии недостаточно», и абонент в ходе реализации задачи будет оповещен вновь.

· Максимальная продолжительность разговора. Задает время (от начала обработки вызова), по истечению которого наступает контрольное событие, а в диалоговых формах оператора отображается признак превышения установленного времени.

· Переводить сценарий диалога только на операторов задачи. При переключении звонка оператором (или IVR) на другого пользователя системы устанавливает режим перевода сценария диалога. При установке флага (по умолчанию установлен) текущая отображаемая диалоговая форма переходит к оператору, на которого произошло переключение, только в том случае, если он назначен в данную задачу. В противном случае сценарий диалога завершается и обработка звонка продолжается без него. Если флаг не установлен, то диалоговая форма отображается и сценарий продолжается у любого пользователя в случае, если его рабочее место оснащено клиентским интерфейсом.

· Поведение сценария диалога после разрыва коммутации. Действует для задач, обслуживаемых оператором. Позволяет индивидуально для задачи выставить значение параметра, задаваемого в модуле общих настроек. («Общие настройки. Менеджер задач»)

· При нажатии СТОП в диалоговой форме. Действует для задач, обслуживаемых оператором. Позволяет индивидуально для задачи выставить значение параметра, задаваемого в модуле общих настроек. (Подробнее см. «Общие настройки. Менеджер задач»)

· Момент запуска сценария диалога. Действует для задач, обслуживаемых оператором. Позволяет индивидуально для задачи выставить значение параметра, задаваемого в модуле общих настроек. (Подробнее см. «Общие настройки. Менеджер задач»)

· Резервирование внешней линии. Действует для задач, обслуживаемых оператором в режиме с запросом на дозвон. Позволяет индивидуально для задачи выставить значение параметра, задаваемого в модуле общих настроек. (Подробнее см. «Общие настройки. Менеджер задач»)

· Сценарий запроса на дозвон. Действует для задач, обслуживаемых оператором в режиме с запросом на дозвон. При установке флага и назначении диалогового сценария, принадлежащего проекту, вместо стандартного окна запроса на дозвон с информацией об абоненте из полей прикрепленной таблицы, обозначенных как «Информационное поле», запускается выбранный сценарий диалога с произвольным наполнением. Решение оператора определяется значением служебной переменной «Результат запроса»: 0-дозвон, 1-пропуск абонента, 2-удаление абонента из списка (отказ).

Для применения изменений задачи нажмите кнопку «Сохранить» внизу.

Некоторые моменты, касающиеся работы менеджера задач и не связанные явно с модулем редактирования задач приведены в разделе «Принципы работы логики. Менеджер задач».

Для повторного запуска исходящей задачи голосового оповещения необходимо очистить ее оперативную информацию. Убедитесь, что задача завершила свое выполнение и в контекстном меню выберите пункт «Очистить оперативную статистику». После активации задача вновь приступит к выполнению.

В контекстном меню исходящих задач также доступна команда «Синхронизировать с БД» для принудительной синхронизации кэша с таблицей абонентов в базе данных.


Текстовые задачи

Текстовые задачи служат для поабонентной обработки прикрепленных таблиц абонентов в служебном сценарии. В служебном сценарии, запускаемом для каждого абонента по отдельности может производиться любая обработка: отправка SMS, отправка электронной почты, отправка ICQ сообщений, любая обработка данных в таблице абонентов и вне, подключение к WEB-ресурсам. Служебный сценарий текстовой задачи может даже активировать дозвон на интересующий номер (это может быть использовано в редких случаях при обнаружении сценарием определенных условий в данных).

При автоматической обработке для определения состояний отправленных сообщений в многопоточном режиме (речь большей части касается SMS) в служебном сценарии существуют служебные переменные «Статус отправленного сообщения» и «PushId отправленного сообщения». Среди возможных значений 0 – не отправлено, 1 – отправлено, 2 – доставлено. В результате заполнения переменных менеджер задач принимает решение об успехе, необходимости повтора отправки, либо о необходимости получения отчета о доставке в автоматическом режиме в конце выполнения. В последнем случае необходимо указание PushId отправленного сообщения. Статус сообщения равный «1» следует использовать только для задач, связанных с отправкой SMS. В других же случаях различать только статусы «0» - не отправлено и «2» - отправлено без необходимости осуществлять проверку доставки.

Основные параметры

Вкладка предоставляет доступ к основным определяющим поведение задачи свойствам.

· Название задачи.

· Код задачи. Параметр применяется для взаимодействия с внешними базами данных, ведущихся по проектам во многих аутсорсинговых call-центрах. Параметр доступен в любом сценарии, выполняющемся в ходе реализации каждого звонка по конкретной задаче.

· Служебный сценарий. Используется задачами автоматической обработки sms-сообщений

· Таблица абонентов. Указывает на прикрепленную к задаче таблицу абонентов (из существующих в текущем проекте). Исходящие задачи используют таблицу для осуществления рассылки. Входящие задачи могут корректно использовать только ту таблицу абонентов, в основе которой лежит таблица БД. Входящие задачи по выбору могут искать абонента по определившемуся номеру в таблице или для каждого сообщения создавать новую запись. В соответствии с настройками таблицы абонентов, часть информации из списка будет отображена во всплывающих «PopUp» окнах на рабочем месте оператора, если задача обрабатывается операторами. В качестве номера берется первый попавшийся номер абонента из столбцов, отмеченных свойством «Телефон». При смене списка у существующей задачи, статистика по произведенным звонкам не теряется, но задача полностью синхронизирует свой внутренний список с таблицей абонентов. Аналогично задача ведет себя при изменениях, вносимых в назначенный ей список в модуле «Списки».

· Интервал синхронизации. Частота синхронизации задачи со списком в случае активности

· Интервал синхронизации при неактивности. Если задача ждет появления новых записей, частота синхронизации может отличаться в меньшую сторону.

· Рабочий график задачи. Определяет время активности задачи. Исходящая задачи не производит рассылку вне графика, входящая задача не принимает sms, возвращая управление обратно в сценарий обработки входящих sms по ветке «Вне графика». Таким образом, задача, даже находясь в активном состоянии, при наличии всех условий будет ожидать начала очередного периода актуальности в соответствии с установленным графиком. График представляет собой недельный срез. Для установки активности – щелкните мышью в соответствующем пересечении дня недели и часа, или растяните рамку выделения необходимой области. Элемент является инверсивным, то есть при двойном выделении переходит в первоначальный вид.

· Дата активации задачи. Определяет время, до которого исходящая задача не приступает к действию, даже будучи активной. Входящая задача до наступления этой границы при входе возвращает управление в сценарий обработки входящего сообщения по ветке «вне периода актуальности». Время активации можно не назначать, отключив галочку.

· Дата прекращения выполнения. Дополнительное условие, подобное рабочему графику, определяющее интервал времени, за пределами которого задача не выполняется и возвращает управление в сценарий по ветке «вне периода актуальности».

· Остановить задачу. Способ завершения исходящей задачи. Среди вариантов:

o После завершения всех абонентов;
o После наступления времени деактивации;
o Не останавливать никогда.

При выборе пункта «не останавливать никогда», после завершения рассылки исходящая задача становится в ожидание и производит постоянную синхронизацию с таблицей абонентов на предмет появления новых записей. Период ожидания перед очередной синхронизацией задается параметром «Интервал синхронизации при неактивности». Задача может быть остановлена только супервизором путем перевода в неактивное состояние.

· Расписание праздников. Указывает, будет ли применяться поправка на праздничное расписание (выходные и праздники и исключения, настраиваемые для комплекса в модуле общих настроек). В случае, если в расписании праздников день является исключением (праздник или наоборот рабочий день), то расписание задачи корректируется с учетом него, в противном случае применяется стандартное расписание задачи. Корректировка производится следующим образом: если день объявлен праздником - задача не запускается, а если день объявлен рабочим по какому-либо дню недели, то задача активируется в соответствии с ее расписанием для этого дня недели.

Ресурсы

· Операторы. Для входящей операторской задачи определяет ответственных операторов, которым задача будет рассылать входящие текстовые сообщения и ожидать обработки и/или отправки ответа.

· Вариант обхода операторов. Определяет принцип распределения задач по операторам.

· Супервизоры. Список супервизоров, получающих уведомления от менеджера задач о состоянии и критических ситуациях.

· Поабонентное исполнение. Для исходящей текстовой задачи определяет, будет ли сценарий запущен с передачей параметра абонента (из списка) или будет массовая однотипная рассылка (один сценарий).

· Количество потоков. В случае поабонентного исполнения рассылка может идти неограниченным числом обращений к серверу (sms-серверу, smtp-серверу, icq-серверу и пр.). Ограничение установленное системой Oktell – 30 потоков на задачу, администратор с целью экономии ресурсов сервера может снизить это значение.

В контекстном меню исходящих задач доступна команда «Синхронизировать с БД» для принудительной синхронизации кэша в памяти с таблицей в базе данных.


Ресурсы

Модуль доступен супервизорам и другим пользователям, имеющим соответствующее право. Для пользования модулем необходимо зарегистрироваться в call-центре системы. Дает возможность в реальном времени следить за состояниями операторов, очередей, загрузкой линий и распределением загрузки между задачами. На нескольких вкладках представлены разные подходы к оценке ситуации: по операторам и по задачам.

Задачи, Операторы, Линии

На основе этих данных супервизору предоставляется возможность в визуальной среде модуля принимать решения, адекватные ситуации, и мышью перетаскивать объекты в задачу и из нее, тем самым в реальном времени перераспределяя ресурсы (операторов и линии) по задачам.

При расчете показателей используется установленный в верхней части окна интервал времени:

· Процент полезной загрузки каждого оператора в call-центре;
· Процент загрузки линий;
· Процент загрузки ресурсов задачами;
· Проценты распределения полезной загрузки операторов по задачам;
· Проценты распределения загрузки линий по задачам;
· Очередь звонков по задачам.

На вкладке задач все объекты (пользователи и внешние линии) отображены в виде квадратов с наполнением, соответствующим текущей загрузке объекта в процентном отношении к его рабочему времени за установленный интервал времени до текущего момента. Выделив нужный объект во всплывающем окне будет отображено название/имя. В целях экономии визуального пространства объекты не имеют постоянных подписей на вкладке задач. Однако все объекты отсортированы по названиям/именам, а также доступен быстрый поиск (комбинации Ctrl+F и F3 на клавиатуре). Кнопкой F3 осуществляется перебор всех объектов, удовлетворяющих условию поиска.

В соответствии с правами доступа к проектам, установленными в свойствах проекта, пользователю может быть запрещено редактирование ресурсной схемы отдельных задач (входящих в недоступные проекты). В этом случае будет отображено соответствующее уведомление.

В панели задач отображаются только активные действующие задачи (для которых актуально управление ресурсами). Фильтр элементов в верхней части окна позволяет пользователю выбирать/фильтровать проекты и задачи, оставляя среди отображаемых только необходимые. В выпадающем дереве фильтра перечислены все существующие проекты и задачи системы. В случае перезагрузки клиентского модуля последние установки фильтра сохраняются. При следующем запуске все вновьсозданные проекты и задачи будут отображены.

При выделении оператора в контекстном меню доступны команды обмена сообщениями между пользователями внутри системы, а также просмотра текущего содержания экрана выбранного оператора. Команды доступны только супервизорам, обладающим соответствующими правами. Подробнее о возможности просмотра экранов в разделе «Администрирование.Мониторинг подключений».

На вкладках «операторы» и «линии» производится отображение распределения нагрузки соответствующих объектов по активным задачам системы в реальном времени (за выбранный интервал времени вплоть до текущего момента).

Абоненты

Вкладка используется для контроля за распределением базы абонентов задачи по полученным пользовательским статусам (подробно в разделе «Сценарии диалога. Стоп-форма») и операторам.

Для задач с распределенным списком и ручным выбором абонентов модуль позволяет перераспределять группы абонентов, перетаскивая мышью абонентов от одного оператора к другому на основании приведенных состояний. При перетаскивании группы возникает окно, позволяющее выбрать количество переназначаемых абонентов.

Данные в таблице не обновляются автоматически. Для обновления необходимо нажать кнопку «Обновить» в фильтре.


Индикаторы

Модуль индикаторов call-центра доступен супервизорам, администраторам и другим пользователям, обладающим соответствующим правом. Для пользования модулем необходимо зарегистрироваться в call-центре системы. Служит для построения отчетов реального времени по произвольным показателям.

Подобные отчеты предоставляют информацию по заданным интервалам времени (1 минута, 5 минут, 10 минут, 20 минут, 30 минут, 1 час) и визуально представляют ее либо в виде временной шкалы, либо в виде значения последнего интервала времени. Соответственно, обновление данных происходит в соответствии с установленным интервалом времени.

Каждый индикатор может представлять информацию по одной из нескольких категорий:

· Задачи. Супервизору предлагается выбрать набор задач из списка, для которых его интересует соответствующий показатель. В этом случае индикатор будет строить отдельную шкалу для каждой задачи по заданным интервалам времени.

· Операторы. Супервизору предлагается выбрать набор операторов из списка, для которых его интересует соответствующий показатель. В этом случае индикатор будет строить отдельную шкалу для каждого оператора по заданным интервалам времени.

· Статусы операторов. Супервизору предлагается выбрать набор из существующих в системе состояний операторов, для которых его интересует соответствующий показатель. В этом случае индикатор будет строить отдельную шкалу для каждого состояния по заданным интервалам времени. Каждое состояние объединяет информацию по всем операторам, если только в теле запроса индикатора явно не установлен фильтр.

· Call-центр. Объединяющий всю статистику показатель. Возможно показатель, в теле запроса которого явно указан фильтр. В этом случае индикатор строит единственную шкалу для получаемого показателя.

Индикатор предоставляет доступ к показателям различной сложности, основанных на статистических данных из БД и прикрепленных к временным интервалам. Начальным интервалом всегда покрывается текущее время. В этой связи настройка индикаторов проходит почти аналогично настройке хронологических отчетов (модуль «Статистика» раздел «Диаграммы и настройка»). Разницу составляет отсутствие фильтра и, соответственно, произвольных входных параметров. Обязательными входными параметрами является величина выбранного интервала в минутах (параметр «@interval»), а также таблица «@elements», содержащая набор выделенных при отображении индикатора объектов (задач, операторов или статусов). Для удобства администратора БД, создающего отчеты, в невидимой шапке запроса на основе текущего времени и значения величины установленного интервала строится также таблица «@times (id int, start datetime, stop datetime)». Пользуясь операциями «JOIN» в SQL можно без дополнительных предварительных расчетов пересекать ее с таблицами, содержащими интересующие данные, для их деления по группам соответствия интервалам. Ее использование в запросе не является обязательным, и администратор БД может по своему усмотрению формировать совершенно разнообразные выборки.

ВНИМАНИЕ! В качестве показателей индикатора необходимо выбирать процентные соотношения, где минимум всегда не менее 0, а максимум не превосходит 100.

При создании индикатора можно указать пороговые значения для «зеленой зоны». При превышении значения показателя в последнем интервале времени заданной верхней границы график окрашивается в красный цвет, при пересечении нижней границы – в желтый.

Индикаторы можно импортировать и экспортировать для внешнего обмена и хранения вне системы.


 Статистика

Статистика

 Содержание | Назад | Далее

Модуль статистики call-центра доступен супервизорам, администраторам и другим пользователям, обладающим соответствующим правом. Для пользования модулем необходимо зарегистрироваться в call-центре системы. Служит для построения хронологических отчетов различной формы и содержания.

Журнал звонков

Самым основным отчетом является журнал звонков. Полученная с помощью фильтра, накладываемого на выборку, информация дает возможность прослушать любую из перечисленных в таблице коммутаций. Дважды щелкните на записи для отображения проигрывателя.

Данные, отображаемые пользователю, помимо установленного им фильтра будут отфильтрованы согласно правам на проекты. Информация по задаче в журнале видна только ее супервизорам и имеющим доступ к ее проекту.

ВНИМАНИЕ! При запросе больших объемов данных необходимо учитывать, что это создает дополнительную нагрузку на процессорное время сервера БД и сетевой трафик. В некоторых случаях это может отразиться на качестве разговоров, осуществляющихся через VoIP шлюз сервера.

Полученные результаты доступны для экспорта в текстовые файлы, в файлы MS Excel и HTML. Также доступна выгрузка записей всех разговоров, попадающих под условие фильтра. Необходимо иметь в виду, что выгрузка записей осуществляется в их текущем состоянии. Используйте предварительное микширование, чтобы гарантировать объединение разговоров в один файл.

Диаграммы и настройка

Содержание и количество прочих отчетов не ограничено. По умолчанию модуль содержит ряд предустановленных отчетов, оценивающих основные показатели работы call-центра на основе полной статистики, собираемой системой в отдельную БД. Статистичская БД Oktell хранит данные в виде пространственной модели (OLAP-кубов), данные в которую попадают в процессе работы. Перечень существующих в ней кубов продолжает расширяться. Это и куб коммутаций, попыток звонков по задачам, куб состояний операторов, куб состояний очереди ожидания. Подробнее в разделе «Структура пространственной БД».

Пользователи системы могут редактировать существующие отчеты и создавать новые. Также доступны функции экспорта и импорта отчетов, позволяющими вести динамический обмен со сторонними пользователями и разработчиками. На сайте www.telsystems.ru на странице зарегистрированных клиентов производится подобный обмен.

Технология OLAP в простом виде позволяет получить из пространственных таблиц любые срезы. Несмотря на простоту использования звездной схемы пространственной БД, большинство сложных отчетов строятся не путем среза данных OLAP-куба, а на основе отдельных различной степени сложности алгоритмов. При создании отчетов администратор баз данных может подключить в качестве источника данных любой запрос как из всех баз данных Oktell, так и из любых других баз данных. Таким же образом можно производить анализ полученных данных в каждом конкретном проекте, строя отчеты под конкретные задачи, в частности на основе таблиц абонентов.

Этот механизм полной произвольности отчетов предоставляет широкие возможности как для администраторов БД, так и для супервизоров.

В основе любого отчета лежит выборка данных, в которой есть одно или несколько полей с показателями, а также поля категорий, по которым эти показатели строятся. В зависимости от типа отображения отчета, категории объединяются в одну или несколько осей.

Среди вариантов отображения:

График | Одна ось, каждый элемент оси имеет 1-5 показателей. На одном изображении разным цветом строятся графики соответствующих показателей. Масштаб отображения показателей может быть общим или раздельным на усмотрение создателя отчета. Поддерживает выгрузку в файл изображения.
Точки | Одна ось, каждый элемент оси имеет 1-5 показателей. На одном изображении разным цветом отображаются точки, соответствующие значениям своих показателей. Масштаб отображения показателей может быть общим или раздельным на усмотрение создателя отчета. Поддерживает выгрузку в файл изображения.
Шкала | Одна ось, каждый элемент оси имеет 1-5 показателей. Напоминает статистическую гистограмму. Масштаб столбиков может быть общим или раздельным на усмотрение создателя отчета. Поддерживает выгрузку в файл изображения.
Диаграмма | Одна ось, для каждого элемента из которых выводится только один показатель (первый из показателей в запросе). Суммарная величина показателей всех элементов образует 100%. На круговой диаграмме строятся сектора, соответствующие процентным соотношениям. Поддерживает выгрузку в файл изображения.
Плоскость | Две оси. Отображается только один показатель (первый из показателей в запросе). На пересечении осей (горизонтальной и вертикальной) выводится значение показателя с подсветкой, интенсивность которой соответствует величине соответствующего показателя. Поддерживает выгрузку в MSExcel в виде транспонированной таблицы
Таблица | Оси отсутствуют, каждая категория данных рассматривается отдельно. Произвольное число показателей. Наиболее общий способ вывода информации. Поддерживает выгрузку в MSExcel виде таблицы данных, соответствующей полученной выборке.
Динамическая таблица | Аналогична таблице. Оперирует произвольным числом столбцов. Отсутствует раздел назначения типов выходных данных. Все, что возвращает запрос, автоматически выводится на экран, однако за исключением столбцов, имена которых начинаются с символа подчеркивания «_».

Каждый отчет может содержать произвольный фильтр.

Выбрав в списке интересующий отчет, супервизору необходимо задать значения для установленного в отчете фильтра (даты, время, операторы, задачи и произвольный набор других параметров, использованных создателем отчета при его формировании). После нажатия кнопки «Отобразить» отчет примет вид в соответствии с его настройкой на основе данных, полученных из БД. Нажав кнопку «Экспортировать» супервизор может выгрузить отчет в MS Excel в том виде, в котором он представлен в его клиентском модуле Oktell.

Создание отчетов должно вестись людьми, имеющими представление о структуре данных.

· Описание. Краткое или полное описание отчета. Доступно супервизору на вкладке диаграммы по щелчку на пиктограмме с вопросительным знаком. В случае, когда супервизору по соображениям безопасности запрещен доступ к вкладке настроек, это единственный способ доступа к описанию.

· Группа. Перечень групп, к которым относится редактируемый отчет. На этапе редактирования прямым заданием текста могут быть созданы новые группы. Используются для фильтрации на вкладке настроек.

· Тип диаграммы. Один из приведенных выше вариантов отображения результатов отчета.

· Тип формирования. Пользовательский режим создания отчетов дает возможность формирования простых агрегирующих срезов OLAP. Доступны также обобщенные механизмы формирования отчетов на основе текста запросов SQL и на основе хранимых процедур.

Для создания отчета на базе текста запроса SQL в режиме редактирования на вкладке «Свойства» выберите тип формирования «Запрос SQL». Перейдите на вкладку «Данные» и заполните поле запроса в соответствии со своей задачей. Запрос может быть практически любой сложности с единственным ограничением: весь запрос будет передан на обработку одним пакетом. При необходимости задайте входные параметры, подставляемые из фильтра.

Для создания отчета на базе хранимой процедуры в режиме редактирования на вкладке «Свойства» выберите вариант «Хранимая процедура». После перехода на вкладку данных в выпадающем дереве необходимо выбрать базу и хранимую процедуру (также можно ввести полное имя процедуры в ручном режиме). Автоматически будут загружены все ее параметры, для которых необходимо назначить типы. Параметры попадут в фильтр при построении отчета. Отчеты на основе хранимых процедур позволяют удобно отлаживать сложные запросы, а также использовать весь функционал, доступный для них.

Автообновление отчетов. В некоторых случаях необходимы отчеты, которые постоянно выводят на экран свежие данные. Для этого в свойствах отчета необходимо установить период автообновления. При запуске расчета будет запущен процесс обновления информации (перерасчета) через установленные промежутки времени.

Сохраните запрос, и он сразу же станет доступным для использования.

Для экспорта отчета в файл выделите необходимые отчеты и нажмите кнопку «Экспорт» слева внизу (или выберите соответствующий пункт в контекстном меню), а в предложенном окне укажите путь.

Для импорта отчетов нажмите «Импорт» (или выберите соответствующий пункт в контекстном меню) и в окне выбора файлов выделите один или несколько файлов отчетов. При неуспешном импорте во всплывающем окне будет подведен итог количества успешно и неуспешно импортированных отчетов. Импорт может быть осуществлен с заменой идентификаторов отчетов. В обычном режиме при обнаружении в системе отчета с совпадающим кодом он будет перезаписан. При импорте с заменой идентификатора при обнаружении совпадения код импортируемого отчета заменяется на уникальный новый.

Если в системе установлено очень много отчетов, и они мешают восприятию, часть редко используемых специфических отчетов можно экспортировать и хранить отдельно, удалив из системы.

В запросе могут быть использованы параметры, которые необходимо будет ввести пользователю перед формированием отчета (перед отправкой запроса на выполнение). Все параметры в запросе (как это принято в MS SQL) обозначаются через одинарный символ «@», например @paramname. Используйте их в тексте запроса по своему усмотрению. Помимо переданных извне параметров в запросе могут присутствовать и внутренние переменные, обозначающиеся таким же способом. Отличие переменной от параметра в том, что переменная в тексте запроса однократно объявляется перед использованием с помощью директивы «Declare», например «DECLARE @var1 INT, @var2 nvarchar(200)». Если в запросе отрезок текста начинается с однократного @, и не является переменной, он автоматически считается параметром. Все параметры должны быть объявлены. Для этого используется верхнее поле в интерфейсе настройки отчета. Задайте необходимое число параметров: укажите их идентификаторы, типы и заголовки (для удобного восприятия пользователем при формировании фильтра). Если все корректно, то после нажатия кнопки «Выполнить» запрос считается компилируемым и поля затеняются. Любое изменение в любом из двух полей (поля фильтра и SQL-запрос) автоматически снимет флаг компилируемости.

Следите за тем, чтобы не использовались одинаково именованные параметры. Это не приведет ни к чему адекватному.

Стоит отметить, что каждый тип параметра в фильтре представляет собой переменную определенного типа. Среди них int, nvarchar, bit, datetime. Однако существуют в перечне и более сложные параметры: временнЫе интервалы и врЕменные таблицы (наборы).

Временной интервал представляет для пользователя поле с выпадающим вниз инструментом Oktell «Календарь». Выбрав период, пользователь указывает на две даты – начало и конец интервала. В параметрах фильтра они задаются двумя разными идущими подряд строчками, а отображаются в фильтре единым полем.

Категория «Набор» для пользователя, заполняющего фильтр, представляет собой совокупность галочек соответствующего множества элементов (операторы, состояния, задачи, проекты, результаты задач). Для администратора БД, создающего отчет в виде SQL-запроса подобный идентификатор является не параметром-переменной, а параметром-таблицей с единственным полем «Id» внутри. Именно в ней будут сохранены строки, соответствующие элементам, включенным в набор. В отчетах на базе текста SQL обращение к этим таблицам осуществляется с префиксом «@», в отчетах на базе хранимых процедур - с префиксом «#».

Перечень всевозможных типов параметров с указанием соответствующих им типов в SQL, которые можно использовать в фильтре:

· Целое число (int)
· Вещественное число (float)
· Строка (nvarchar)
· Галочка (bit)
· Галочка с 3 состояниями (int)
· Дата (datetime)
· Интервал дат (начало) (используется в паре с «интервал дат-конец») (datetime, datetime)
· Интервал дат (конец) (используется в паре с «интервал дат-начало») (datetime, datetime)
· Время (datetime)
· Временной интервал (начало) (используется в паре с «временной интервал-конец») (datetime, datetime)
· Временной интервал (конец) (используется в паре с «временной интервал-начало») (datetime, datetime)
· Оператор (uniqueidentifier)
· Набор операторов ( table ( Id uniqueidentifier ) )
· Задача (uniqueidentifier)
· Набор задач ( table ( Id uniqueidentifier ) )
· Проект (uniqueidentifier)
· Набор проектов ( table ( Id uniqueidentifier ) )
· Статус оператора (int)
· Набор статусов операторов ( table ( Id int ) )
· Результат задачи (int)
· Набор результатов задачи ( table ( Id int ) )
· Пользовательский список ( тип, соответствующий запросу пользователя на определение списка, или sql_variant )
· Пользовательский набор ( table ( Id sql_variant ) )

Пользовательские типы фильтров (список и набор) требуют задания SQL-запроса для формирования списка доступных значений. Для задания или изменения текущего запроса какого-либо элемента фильтра с пользовательским типом необходимо щелкнуть в правой части таблицы параметров (в последнем столбце, содержащем «...»), в строке интересующего элемента. В открывшемся окне скорректировать запрос, после чего закрыть окно. Запрос должен представлять собой один пакет (batch) и может иметь любую сложноcть. Однако следует учитывать, что постоянное его выполнение в ходе создания фильтра может привести к длительным задержкам, в случае, если время выполнения созданного запроса достаточно велико. В качестве результатов берется первый возвращаемый набор данных. Первый столбец считается идентификатором, значение (или таблица значений) которого будет передано в основной запрос отчета на этапе его построения. Второй столбец - описания, подставляемые в визуальные компоненты для отображения. А качестве идентификаторов могут выступать любые типы, за исключением TEXT, NTEXT, TIMESTAMP.

Примеры запросов на формирование пользовательского фильтра:

Select [Id], [Caption] From dbo.[ClientTypes]

Declare @dttoday DateTime

Set @dttoday = Cast ( Floor ( Cast ( GetDate() as float ) ) as DateTime )

Select [Id], [Name]

From dbo.[Clients] cl

Inner join dbo.[ClientCalls] cc on cl.[Id] = cc.[IdClient]

Where [LastCall] > @dttoday

Group By [Id], [Name]

После формирования запроса и успешной его проверки выставляется флаг компилируемости. Из получающейся в результате выполнения запроса выборки выделяются столбцы и помещаются в нижнюю часть интерфейса в таблицу «Назначение». Здесь в зависимости от типа выбранного визуального представления запроса необходимо проставить нужным столбцам соответствующие типы и задать описания (для удобного восприятия отчета пользователем)

Среди типов уже рассмотренные выше «Ось» и «Значение». Тип «Не отображается» указывает построителю отчета на отсутствие необходимости использовать поле. Для отчета типа «Плоскость» среди типов вместо «Ось» появляются два «Горизонтальная ось» и «Вертикальная ось». Для табличных отчетов все поля типа «Ось» будут подсвечены в результирующем поле. Не отображаемые поля будут пропущены при выводе данных и при экспорте.

ВНИМАНИЕ! При использовании временных таблиц # в отчетах на основе текстового запроса, необходимо в начале тела запроса помещать команду SET FMTONLY OFF, иначе использование # не будет возможным. В других случаях не рекомендуется использовать указанную команду. При обнаружении некорректных ситуаций при использовании # или других команд рекомендуется преобразовать отчет в хранимую процедуру.

ВНИМАНИЕ! В некоторых отчетах могут понадобиться данные из прикрепленной таблицы абонентов. Операция обращения к ней тривиальна в случае работы с внешней таблицей, и может быть проблематична при работе с локальной таблицей в силу специфики ее хранения (если для нее выбрана автоматическая генерация имени). Это необходимо учитывать при формировании проекта. Для удобства работы с отчетами внутри системы рекомендуются к использованию внешние таблицы, а также локальные таблицы с явным указанием имени и типов полей. Ниже приведен пример кода для формирования временной таблицы с полями Id и Name с данными из произвольной (в том числе и локальной) прикрепленной таблицы абонентов.

-------------------------------------------------------------------

-- Формирование временной таблицы @tmpic ( Id, Name ) с данными

--    из прикрепленной к задаче с кодом @idtask таблицы абонентов.

-------------------------------------------------------------------

SET FMTONLY OFF

Declare @emptyname nvarchar ( 30 )

Set @emptyname = ''

Declare @hasnames bit

Set @hasnames = 0

Declare @idlist uniqueidentifier

Select @idlist = ListId From A_TaskManager_Tasks t where Id = @idtask

if ( @idlist is null )

       Set @emptyname = '<список удален>'

Declare @abons table ( Id int, Name nvarchar ( 200 ) )

Declare @type int

Declare @query nvarchar ( 4000 )

Declare @jtable nvarchar ( 1000 )

Declare @colname nvarchar ( 50 )

Declare @colid nvarchar ( 50 )

Select @type = Type, @query = Query, @jtable = JoinedTable, @colid = ColumnId, @colname = ColumnName

From A_TaskManager_Lists

Where Id = @idlist

Declare @tmpic table ( Id int, Name nvarchar ( 1000 ) )

if ( Len ( @colid ) > 0 ) and ( Len ( @colname ) > 0 ) and ( not @type is null )

  begin

       Declare @extquery nvarchar ( 4000 )

       if exists ( Select * From tempdb..sysobjects Where Id = object_id ( 'tempdb..#tmpic' ) )

               Drop Table #tmpic

       Create table #tmpic ( id int, name nvarchar ( 1000 ) )

       if ( Len ( @jtable ) > 0 ) and ( @type in ( 1, 2 ) )

          begin

               Set @extquery = 'Select ' + @colid + ' as Id, Cast ( IsNull ( ' +

@colname + ', ''' + @emptyname +

''' ) as nvarchar ( 1000 ) ) as Name From ' + @jtable

               Insert into #tmpic

                       Exec sp_sqlexec @extquery

               Set @hasnames = 1

          end

       else if ( Len ( @query ) > 0 ) and ( @type = 3 )

          begin

               Set @extquery = 'Select ' + @colid + ' as Id, Cast ( IsNull ( ' +

@colname + ', ''' + @emptyname +

''' ) as nvarchar ( 1000 ) ) as Name From (' + @query + ')a'

               Insert into #tmpic

                       Exec sp_sqlexec @extquery

               Set @hasnames = 1

          end

       Insert into @tmpic

               Select * From #tmpic

       Set @emptyname = '<не найден>'

       Update @tmpic

       Set Name = @emptyname

       Where Name = ''

       Drop Table #tmpic

       Set @emptyname = '<не задано>'

  end

-------------------------------------------------------------------

-- Далее можно пользоваться таблицей @tmpic с полями Id и Name

-------------------------------------------------------------------


Контрольные события

Модуль доступен супервизорам, администраторам и другим пользователям, обладающим соответствующим правом. Дает возможность создавать, настраивать, управлять активностью контрольных событий, а также просматривать журнал их истории.

Контрольное событие - заранее определенная ситуация в работе call-центра (или других блоков), по наступлении которой система производит установленные в ходе настройки действия (уведомляет пользователей и/или выполняет служебные действия, определяемые служебным сценарием).

Типы контрольных событий

Контрольные события (далее КС) делятся на типы. Типом КС называется параметризованная совокупность/последовательность системных событий, приводящих к наступлению КС.

Одновременно в системе может быть настроено и использоваться произвольное количество контрольных событий одного и того же типа. Например, установка слежения за превышением времени предвызывной обработки звонка может потребовать различных детальных настроек для разных задач: для одной задачи - 1 минута, для другой - 5 минут. Таким образом, в системе появляются два контрольных события с типом Превышение допустимого времени предвызывной обработки», но с разными параметрами - каждое настроено на свой список задач и имеет свое контрольное время.

В системе существует ряд предопределенных типов КС, оперирующих исключительно системными событиями и не обращающихся к долговременной истории в БД. Отдельным типом являются КС на основе пользовательских SQL-запросов к БД.

· Превышение времени обработки звонка в задаче

Отсчет ведется с момента начала обработки звонка первым оператором и до окончания поствызывной обработки последним оператором. При использовании в цепочке IVR как оператора функциональность сохраняется в случае, если не производится принудительный выход из задачи согласно ее соответствующей настройке. Отсчет времени обработки звонка задачи отображается в модуле «Телефон» текущего оператора, где после превышения цвет меняется на красный. Максимально допустимое время задается в настройках задачи. Таким образом одно контрольное событие данного типа может отслеживать несколько задач с их различными значениями.

Параметры: набор задач, набор операторов.

· Пропуск оператором входящего вызова

Пропущенным вызовом считается ситуация, при которой происводится звонок оператору (в задаче или из АТС) и истечение установленного времени вызова, после которого дозвон прекращается системой (для вызовов задач настраивается в модуле «Администрирование. Общие настройки. Менеджер задач», по умолчанию 20 секунд, для вызовов внутри АТС определяется настройкой внутреннего номера, посредством которого происходит вызов, не более 90 секунд).

Параметры: набор задач, набор операторов.

Если указан ограниченный список задач, система фокусирует внимание только на установленных задачах. В случае, если задачи не выбраны, происходит слежение за операторами равно во всех задачах, а также в АТС.

· Превышение допустимого времени предвызывной обработки

Параметры: набор задач, набор операторов, контрольное время.

· Превышение допустимого времени обратного вызова

Параметры: набор задач, набор операторов, контрольное время.

· Превышение допустимого времени поствызывной обработки

Параметры: набор задач, набор операторов, контрольное время.

· Превышение допустимого времени в статусе перерыва

Отсчет времени перерыва ведется начиная с 0:00 часов текущего дня. Допустимым временем считается суммарная величина перерывов, определенных расписанием, к текущему моменту времени с поправкой на величину установленного в контрольном событии дополнительного времени превышения. В случае, если расписанием перерывы для оператора не заданы, считается, что максимально допустимое время в перерыве на весь день составляет установленную параметром величину.

Параметры: набор операторов, контрольное время дополнительного превышения.

· Выход оператора из call-центра или из системы в рабочее время

Выход оператора влечет невозможность дальнейшего контроля его показателей и управления им в ресурсах. Подобные случаи могут потребовать незамедлительной корректировки требований к оператору.

Параметры: набор операторов.

· Звонок от/к оператору вне задачи

Осуществление личных звонков оператором может быть ограничено рабочим распорядком, так как оператор в этом случае считается занятым и не может быть зарезервирован на выполнение задач.

Параметры: набор операторов.

· Оператор первым положил трубку

Параметры: набор задач, набор операторов.

· Оператор выбрал пропуск вызова по запросу исходящей задачи

Параметры: набор задач, набор операторов.

· Число активных операторов задачи менее установленного

Параметры: набор задач, минимальное количество операторов (число).

· Число активных операторов задачи менее определенного расписанием (в процентах)

Расписанием задачи, а также расписанием всех операторов на каждый момент времени определено число обрабатывающих задачу операторов. Процентом задается порог, ниже которого генерируется контрольное событие.

Параметры: набор задач, число в процентах.

· Число абонентов в очереди задачи более установленного

Параметры: набор задач, максимально допустимое количество абонентов очереди (число).

· Максимальное время ожидания абонента в очереди задачи более установленного

Параметры: набор задач, максимально допустимое время ожидания.

· SQL-базированное КС

В установленные моменты времени осуществляется пользовательский запрос в БД, возвращающий некий набор данных, состоящий из совокупностей: {код задачи, код оператора, определенное в запросе значение, описание}. Система фильтрует полученный набор данных в соотвествии с параметрами, после чего производит сравнение значения каждой совокупности (строки из набора данных) с установленным контрольным значением на основе выбранного типа сравнения. В случае неудачи генерирует контрольное событие для каждой совокупности.

SQL-КС концептуально возможны двух вариантов:

а) запрос возвращает весь набор совокупностей со значениями, которые оцениваются менеджером контрольных событий с использованием выбранной операции сравнения, после чего подошедшие по условию генерируют соответствующее контрольное событие. В этом случае описание может быть пустым, так как КС жестко связано с запросом и все генерируемые на базе этой настройки события технологически имеют один тип.

б) в теле запроса на уровне БД производятся различные действия, сравнения и анализ, после чего возвращается некоторый набор подошедших совокупностей, которые все полностью передаются на генерацию событий. В этом случае одна настройка КС может сгенерировать принципиально разные контрольные события (согласно тексту SQL). В этом случае используется возвращаемое запросом описание для конкретной совокупности. Cравнение также производится, однако его можно исключить, например, принудительно выставив сравнение на равенство с константным значением, которое также явно выходит как результат запроса в поле значений.

Параметры: набор задач, набор операторов, текст запроса, контрольное значение, тип сравнения результата, периодичность осуществления запросов, интервал (параметр, передаваемый в запрос).

При создании нового контрольного события определяется и фиксируется его тип, который впоследствии не может быть изменен. Контрольные события, существующие в системе, могут быть активированы или деактивированы. Деактивированные события не участвуют в процессе слежения за работой call-центра и нисколько не отнимают вычислительные ресурсы сервера.

Действия при возникновении контрольных событий

При наступлении КС система производит установленные администратором или супервизором действия.

Среди возможных действий:

· рассылка уведомлений супервизорам "виновной" задачи;
· рассылка уведомлений выбранным при настройке пользователям системы;
· запуск произвольного служебного сценария с передачей в него параметров возникшего КС. Параметры в сценарии доступны через встроенные функции с маркировкой «КС».

Уведомления по контрольным событиям не скрываются автоматически.

Модуль настройки и просмотра контрольных событий

На вкладке «Журнал» супервизор может просматривать, искать, фильтровать возникшие за интересующий период контрольные события.

На вкладке «Настройка» происходит работа по созданию, редактированию, удалению, а также активации и деактивации контрольных событий.


Отчеты

Модуль доступен супервизорам, администраторам и другим пользователям, обладающим соответствующим правом. Дает возможность строить «легкие» отчеты по статистическим данным, полученным в ходе реализации сценариев call-центра. Эта информация накапливается с помощью счетчиков системы и карточек запроса вариантов ответа в сценариях диалога по задачам.

Счетчик – это некоторая величина, доступная в соответствующем компоненте «Счетчик» в сценариях всех типов. При обработке компонента сценария осуществляется автоматическое увеличение указанного счетчика. Информация о состоянии счетчиков находится в БД. Создаются, изменяются и анализируются в модуле «Отчеты». Несколько вкладок предоставляют доступ к различным режимам работы.

Счетчики

В списке находится перечень всех существующих счетчиков системы с указанием текущего значения, начального значения, а также даты создания. Для создания нового счетчика или удаления существующего воспользуйтесь соответствующей кнопкой внизу. Также можно сбросить значение счетчика (указав при этом величину начального значения).

В поле настройки отображения необходимо указать необходимые для построения совместной диаграммы счетчики. В диаграмме отображаются значения, а также процентные соотношения значений соответствующих счетчиков на основании их суммарного значения. Вы можете выбрать также базовый счетчик из списка существующих. В этом случае процентные соотношения анализируемых счетчиков будут рассчитываться на основании значения базового счетчика. Нажмите кнопку «Показать» в поле задания значений для отображения диаграммы. Вы можете распечатать полученную диаграмму нажатием на кнопку «Печать» внизу.

Карточки

Выберите необходимую задачу. Прикрепленный к задаче сценарий диалога предстанет на обозрение без возможности редактирования.

Дважды щелкнув по элементу, соответствующему интересующей карточке, Вы осуществите переход к диаграмме или гистограмме. Карточки типа «Выбор одного варианта» в виде диаграмм предоставляют статистику накопленных ответов при прохождении конкретных компонентов. Карточки типа «Выбор нескольких вариантов» предоставляют статистику в виде столбцов предпочтений. Дважды щелкните на интересующем блоке для перехода к журналу звонков, отфильтрованных по соответствующему ответу.

Формы

Выберите необходимую задачу. Прикрепленный к задаче сценарий диалога предстанет на обозрение без возможности редактирования. После выбора диалоговой формы, в которой присутствуют элементы с установленным свойством «Отображать в статистике», будет отображен полный их перечень.

Для отображения распределения значений интересующего поля необходимо выделить в списке соответствующее ему название. Аналогично вкладке «Карточки» доступен фильтр , включающий период дат, времени, операторов, ведущих диалоги, а также существует возможность перехода к журналу звонков по задаче, отфильтрованному по выбранному значению поля.


Администрирование

Раздел предоставляет доступ к системной информации и настройкам сервера. Раздел доступен только пользователям-администраторам. Отдельные ветви раздела могут быть блокированы установленными ролями.

При первом запуске системы под учетной записью встроенного системного администратора пользователь получает доступ только к разделу «Администрирование» главного меню.

Системный администратор с логином «Администратор» и пустым паролем доступен для использования в момент настройки комплекса. Его запись автоматически блокируется при успешном старте сервера состояний при условии существования среди учетных записей пользователей по крайней мере одного с ролью «Администратор».

ВНИМАНИЕ! Блокировка системного администратора производится с целью исключить возможность несанкционированного доступа к настройкам комплекса. Если существует вероятность утраты пароля пользователя-администратора, заранее создавайте дублирующие учетные записи.

ВНИМАНИЕ! При крайней необходимости включить запись системного администратора можно принудительно установкой в конфигурационном файле сервера значения ключа «EnableEmptyAdmin» в «1» .

В этом разделе:

— Пользователи

— Карта сети

— Права

— Линии

— Внутренние номера

— Общие Настройки

— Настройки оборудования

— Сценарии

— Мониторинг

— Внешние модули

— Мобильная статистика


 Пользователи

Пользователи

 Содержание | Назад | Далее

Модуль служит для проведения операций над учетными записями пользователей системы. Здесь происходит создание, удаление, а также редактирование основных свойств пользователей.

В этом разделе:

— Учетные записи пользователей

— Роли


Пользователи

В текущем разделе модуля «Пользователи» на одноименной вкладке приведен список существующих в системе учетных записей пользователей и происходит их создание, модификация и удаление. В общей таблице пользователей по каждой записи можно увидеть логин, отдел, роли, и список номеров, назначенных на пользователя (в которых он участвует), включая групповые номера. Для создания новой учетной записи пользователя, удаления или редактирования существующей используйте соответствующие кнопки внизу.

В режиме редактирования пользователя доступны три вкладки, каждая из которых отделяет логически независимый блок свойств:

· Карточка;
· Доступ;
· Номера.

Карточка

На вкладке «Карточка» происходит назначение основных свойств пользователя:

· Имя;
· Логин;
· Пароль;
· Отдел. Участие в отделе влияет на рассылку уведомлений, голосовой почти, а также на отображение информации в модуле «Офис. Сотрудники» в режиме «Отделы».
· Флаг «Оператор», определяющий, доступен ли пользователь для назначения его в задачи в качестве обслуживающего оператора;
· Подчинения. Для текущего выбранного (создаваемого) пользователя определяется, кто может контролировать пользователя, и кого может контролировать пользователь. Контроль включает в себя возможность просмотра статистики по пользователю, возможность постановки задач и пр. В приведенном списке слева отметьте контролирующих пользователей (тех существующих пользователей системы, которым будет доступно управление данным пользователем, а также прослушивание записей его разговора). В списке справа отметьте тех пользователей, по отношению к которым редактируемый пользователь сможет обладать аналогичными правами. Допускается взаимный контроль. Доступ к этому элементу свойств также присутствует в модуле «Администрирование. Права».

Доступ

На вкладке «Доступ» производится выбор ролей и установка доминирующей роли. Пользователю может быть предоставлено несколько ролей. Некоторая привилегия становится доступной пользователю, если она включена хотя бы в одну роль из назначенных на него. Исключением может явиться принудительное выключение некоторых привилегий в доминирующей роли. Это позволяет для отдельновзятого пользователя не формировать особые роли, и лишать при этом его некоторых прав.

В списке имеющихся ролей следует выбрать одну или несколько ролей, в соответствии с которыми пользователь осуществляет свою работу в системе.

В списке привилегий задается доминирующая роль для пользователя. Каждая привилегий доминирующей роли может быть включена (и будет всегда доступна пользователю при любых условиях), выключена (и не будет доступна пользователю никогда), а также может быть наследуема (то есть будет определяться в соответствии с назначенными на пользователя ролями).

На приведенном изображении пользователю доступны привилегии из объединения двух ролей - «Администратор без редактирования пользователей», и «Оператор call-центра». Однако в доминирующей роли принудительно отключен режим «Анти-скриншот».

Подробнее о ролях и привилегиях в разделе «Администрирование. Пользователи. Роли».

Внутренние номера

Сразу при создании пользователя (а также при редактировании) можно задать внутренние номера. Более общий способ настройки внутреннего номерного плана предоставлен в модуле «Администрирование. Внутренние номера», здесь же удобно для создаваемых вновь пользователей не откладывая на будущее сразу задавать номера. Здесь же можно фильтровать и видеть, в какие групповые номера назначен пользователь. При необходимости корректировать эти номера.

В таблице сверху представлен список существующих и назначенных на редактируемого пользователя номеров. Нажмите кнопку «Создать» справа от таблицы для создания нового номера. В соответствующих полях задайте номер и описание. В дальнейшем описание будет отображаться в модуле «Офис. Персонал» как подпись для групповых номеров.

О блоке редактирования номера подробнее в разделе «Администрирование. Внутренние номера».

Для сохранения измененных данных пользователя нажмите кнопку «Сохранить» внизу. Вы автоматически вернетесь в режим просмотра таблицы учетных записей пользователей. После сохранения данных сервер продолжает работать на старых настройках. Ряд настроек применится только при перезапуске сервера, но часть из них можно применить в процессе работы путем нажатия кнопки «Применить» внизу. Часть нововведений, влияющих на работу сервера, будет применена в текущем сеансе работы сервера.

При создании нескольких учетных записей пользователей одновременно, а тем более большого их числа, рекомендуется применять изменения к серверу после окончания редактирования последнего из них, поскольку процедура применения каждый раз приостанавливает работу сервера на несколько секунд.


Роли

В текущем разделе модуля «Пользователи» на вкладке «Роли» приведен список пользовательских ролей и происходит их создание, модификация и удаление.

Привилегией называется отдельное право доступа (определяемое одной галочкой в таблице свойств роли).

Роли определяют некоторые наборы привилегий, и соответственно доступ пользователя к отдельным сервисам и модулям системы. На каждого пользователя может быть назначено одновременно несколько независимых ролей, а также сформирована уникальная доминирующая роль. Таким образом некоторая привилегия становится доступна пользователю тогда, когда она присутствует хотя бы в одной роли и не блокируется доминирующим набором прав.

По умолчанию доминирующая роль пользователя, задаваемая в разделе редактирования учетной записи пользователя, не переопределяет привилегий. Таким образом обладание некоторой привилегией определяется лишь набором назначенных на пользователя ролей.

В системе существует набор предустановленных ролей: Администратор, Менеджер проектов, Супервизор, Оператор, Пользователь системы. Эти роли имеют фиксированные идентификаторы и пересоздаются системой в случае отсутствия каждый раз при запуске сервера. Их привилегии также постоянны. При необходимости модификаций следует создавать собственные роли.

По умолчанию каждая привилегия роли может быть включена или выключена. Однако при создании и модификации роли для нее может быть выбрана базовая роль. В этом случае каждая привилегия роли может быть включена, выключена и выставлена в режим наследования от базовой роли. Например, существующая предустановленная роль «Администратор» с полными правами может быть модифицирована путем создания наследуемой роли «Администратор без права X», в которой все привилегии наследуются от базовой роли администратора, но принудительно выключается несколько привилегий. И наоборот, роли могут быть добавлены права путем создания новой наследуемой роли с принудительным включением некоторых привилегий.

При изменении свойств роли, набор привилегий, выставленных для нее, применяется для всех пользователей, для которых она назначена после перезапуска сервера состояний кнопкой «Применить». Однако для всех уже подключенных пользователей на текущий сеанс работы не изменяется набор прав. Для применения необходимо перезапустить одного, нескольких или всех пользователей в модуле мониторинга подключений, либо перезагрузкой серверной службы.

Итоговый набор привилегий пользователя, формируемый на основании назначенных на пользователя ролей определяет права доступа к модулям системы. В частности определяет вид главного меню для пользователя: какие модули ему доступны, а какие нет. Основное право визуализации – «Расширенное рабочее место». При отсутствии этого права у пользователя вовсе не появляется клиентский интерфейс, и приложение лишь управляет USB-телефонами и гарнитурами, применяет настройки прав пользователя на звонки и в некоторых случаях выдает диалоговые формы обработки звонков call-центра. Вход и выход из call-центра осуществляется в этом случае через контекстное меню строки состояния. При установке свойства «Является оператором» в карточке учетной записи пользователя в контекстном меню такого рабочего места появляется соответствующая команда входа/выхода из call-центра.

Среди прочих прав:

· Показывать системные сценарии, названия которых начинаются со строки "(Служебный)"
· Возможность удалять записанные разговоры из статистики
· Право видеть системные сценарии
· Возможность редактировать отчеты статистики call-центра
· Возможность редактировать индикаторы call-центра
· Доступ к служебным задачам
· Доступ к сервису автодозвона
· Возможность отправки сообщений
· Возможность использования факса через интерфейс
· Отображение софт-телефона в диалоговых формах
· Возможность просматривать содержание экрана подчиненных пользователей
· Безусловное блокирование режима просмотра собственного экрана


Карта сети

Модуль предоставляет доступ к определению и базовой настройке серверов, каналов связи и рабочих мест сотрудников. Карта сети – визуальный интерфейс, в котором администратору предоставляется возможность в интуитивно понятном графическом режиме описать схему взаимодействия компьютеров сети, телефонных аппаратов, их местоположения и начальные свойства.

Именно в этом модуле происходит настройка IP-инфраструктуры, определяются внешние устройства и интернет-серверы для доступа к SIP-сети, задаются аккаунты и определяется ширина каналов.

В этом разделе:

— Редактор карты сети

— Свойства компонентов

— Проверка и сохранение карты


Редактор карты сети

Создание карты происходит в графической оболочке системы Oktell, которая состоит из 2 основных элементов управления:

· Среда визуального представления;
· Панель инструментов;

Среда визуального представления сценария – это поле, в котором пользователь располагает объекты карты, группирует их и связывает между собой соответствующими линиями-связями. В дальнейшем «поле карты».

Окно с компонентами (открывается и закрывается нажатием F10 на клавиатуре). В этом окне перечислены все варианты доступных в данной категории сценариев компоненты. Выделите любой компонент (пользуйтесь всплывающими подсказками) и щелкните в любое пустое место поля сценария. Соответствующий выбранному компоненту объект с назначенными по умолчанию свойствами появится в поле.

Панель инструментов

В карте сети существуют компоненты-объекты, компоненты-связи и компоненты-регионы. Объекты визуально мышью заносятся в карту из окна объектов и соединяются соответствующими линиями.

Каждый компонент-объект в карте представляет некий существующий в организации объект:

· Сервер;
· IP-шлюз;
· Компьютер;
· Аналоговый телефонный аппарат интерфейса FXS;
· USB телефонный аппарат (или usb/jack гарнитура).
· SIP телефон.
· Виртуальный телефон.

Компоненты-связи в карте представляют линии, каналы взаимодействия и, собственно, связи между объектами:

· LAN – для соединения компьютеров между собой;
· FXS – для соединения сервера с аналоговыми аппаратам;
· USB соединения между компьютерами и usb-телефонами (признак использования звукового устройства компьютера).
· Виртуальные связи объектов карты (сервера и шлюза) с виртуальными телефонами.
· Логические неявные связи, указывающие на объединение компьютера и телефонного аппарата в одну логическую единицу.

В панели инструментов представлен один тип связи - общее соединение. В зависимости от типа соединяемых объектов она приобретает то или иное значение.

ВНИМАНИЕ! В случае, если объекты могут быть соединены несколькими видами связей (например сервер и аналоговый телефон могут быть соединены FXS и логически), то один из видов считается основным (в этом примере основным является FXS, а дополнительным - логический). Протянуть логическую вспомогательную связь возможно в случае, если основной тип связи уже задан, а вспомогательный еще нет. Возможны варианты, связанные с множественным выделением.

Компоненты-регионы предоставляют возможность визуально отделять группы объектов друг от друга для упрощения работы с большими картами, насчитывающими сотни объектов:

· Комната
· Регион

Работа с графической средой

Объекты на карте можно объединять в комнаты (на изображении – цветные зоны). Неважно, в каком порядке создавались объекты и комнаты. Перемещение комнаты производится одновременно с перемещением всех принадлежащих ей объектов. Комнаты можно называть именами, задавать для них цвета. Удаляя комнату – можно на выбор оставить на карте существующие и принадлежащие ей объекты, или удалить вместе с ней.

Комнаты можно объединять в регионы, для которых также можно задавать названия и цвета. Перемещение региона производится со всеми принадлежащими ему комнатами. На объекты регион не влияет никаким способом.

Смысловой нагрузки на работу системы объекты-регионы не несут. Они лишь помогают администратору легче и понятнее оперировать с создаваемой им картой.

Объекты компоненты вставляются щелчком в поле карты после выбора соответствующего типа в окне компонентов. Вы можете вставить сразу несколько объектов, не прибегая к повторному выбору типа в окне компонентов. Двойным щелчком мыши на объекте вы попадете на вкладку «Свойства» для назначения свойств объектов. Также это можно сделать, выделив объект в поле карты, после чего щелчком мыши выбрав указанную вкладку (подробнее о свойствах объектов ниже).

Чтобы провести линию необходимо выделить ее в окне компонентов, щелкнуть на объекте, от которого необходимо ее тянуть, и, не отпуская кнопки мыши, протянуть до объекта, с которым необходимо соединить. Если соединение указанных объектов возможно, будет протянута прямая линия возможного типа. Если выбор некорректен – линия не появится. Вы можете тянуть множественные линии, для этого выделите несколько однотипных объектов, и протяните линию от одного из них.

В отличие от редактора сценариев линии-связи в редакторе карты сети являются объектами, доступны для выделения, трансформации и удаления из карты.

Возможно проведение ломаных линий. Для этого нужно выделить линию, при этом появятся все существующие на ней узлы. Двойным щелчком мыши (или выбором пункта контекстного меню) создаются новые или убираются существующие узлы. После этого узлы можно тянуть в любое место на карте.

Если объекты расположены далеко друг от друга, или вне прямой досягаемости, что часто происходит на картах, описывающих крупные офисные сети, можно облегчить работу с картой. При создании линии, необходимо щелкнуть на начальном объекте, и вести линию по карте, поочередно щелкая в местах, где нужно образовать новые узлы. Линию можно привести либо к конечному объекту, либо прилепить к любой другой существующей линии того же типа. В случае корректности объект-назначение автоматически обнаружится, и появится новая линия.

В поле карты вы можете, пользуясь графической средой и мышью, изменять положения объектов и, в отличие от редактора сценариев, изменять вид и положение линий связи, которые здесь не просто определяют логику связей-переходов, а в отдельных случаях проецируют реально существующие каналы связи и кабели. Также вы можете растягивать объекты-регионы.

Для выделения объекта щелкните по нему левой кнопкой мыши. Щелчок с одновременным нажатием кнопки Shift на клавиатуре инвертирует текущее выделение.

Для выделения группы объектов растяните прямоугольную рамку от одной точки к другой (подобно векторным графическим редакторам). Щелчками по объектам с одновременно нажатой кнопкой Shift вы можете добавить/исключить соответствующие объекты из выделения. Также с нажатой кнопкой Shift вы можете растянуть инвертирующую текущее выделение рамку.

Для перемещения выделенных объектов по полю нажмите и удерживайте левую кнопку мыши на выделении и тащите в необходимую область на поле карты. При подведении к краям поля оно автоматически перематывается в сторону движения. После отпускания левой кнопки мыши все объекты переместятся, при этом все их связи сохранятся.

В ходе настройки сети используется мышь и клавиши Alt, Ctrl, Shift:

· Alt позволяет двигать объекты попиксельно, а не по сетке, как это делается в обычном режиме;
· Ctrl позволяет двигать объекты и линии строго по вертикалям/горизонталям/диагоналям;
· Shift позволяет выделять несколько объектов.

Кнопка ESC на клавиатуре прерывает текущее активное действие.

Тестовый дозвон на аналоговые телефоны

При формировании карт с большим количеством аналоговых телефонных аппаратов, где разводка телефонов начинает путаться, можно использовать режим тестирования. Щелкните правой кнопкой мыши на зеленом телефонном аппарате (объекте аналогового телефона) и в контекстном меню выберите пункт «Тестировать». Если телефон подключен соответствующими линиями к серверу, то в реальном офисе зазвонит тот телефонный аппарат, который соответствует выделенному объекту карты.

Таким образом, Вы можете сначала обжимать и разводить реальную сеть, а потом создавать ее аналог в карте офиса. В противном случае, создайте карту, и потом поочередным перебором ищите те выходы на плате, которые соответствуют созданным объектам – аналоговым телефонам. Существует и третий вариант. Вы можете менять названия, а также линии в свойствах телефонных аппаратов. Смена линий приводит к смене контактов на плате, ответственных за интересующий объект-телефон.

Обзор, поиск и автоматическое выстраивание

В распоряжении администратора помощник обзора карты. Подведите курсор в правый нижний угол поля к пиктограмме с изображением ладони. Нажмите и удерживайте левую кнопку мыши для отображения формы обзора карты. На ней карта представлена полностью в уменьшенном виде. Используйте ее для быстрого перемещения, а также для визуальной оценки зон.

В карте офиса доступен поиск объекта. Согласно текстовой информации, введенной администратором, поиск осуществляется по названию, описанию, адресу, номеру линии, названию отдела, имени пользователя по умолчанию и другим свойствам объектов. Для этого используется сочетание клавиш «Ctrl+F» на клавиатуре. О результате поиска дополнительно сообщит всплывающее уведомление. Если найден один объект, он автоматически попадет в поле видимости и станет выделенным. Если по заданному условию будут найдены два или более объектов, все они одновременно выделятся, при этом локализации не произойдет.

При формировании карт в целях сохранения ориентации рекомендуется формировать области и модифицировать карту, неуклонно подчиняясь изначально установленным правилам. Так например, если используются регионы, размещение новых рабочих мест производить согласно их структуре.

Администратор может воспользоваться режимом автоматического выстраивания карты. В контекстном меню содержатся три пункта, каждый из которых соответствует одному из возможных способов. Использование режима может понадобиться, если карта разрослась без поддержания заложенной структуры.


Свойства компонентов

Сервер

Свойства:

Название

Отображается в карте как подпись к изображению

Описание

Описание необходимо только для самого администратора.

Имя или адрес

Адрес компьютера в сети. Используйте имя или IP адрес компьютера. При построении карты на базе 1 компьютера учитывайте, что в некоторых особых случаях компьютер с неактивным подключением к сети (или не вставленном кабеле RJ45 в сетевой разъем) не обладает IP адресом.

ВНИМАНИЕ! В качестве адреса нельзя использовать стандартное название localhost и внутренний порт 127.0.0.1, так как они не являются уникальными в пределах сети и, соответственно, не могут быть идентификаторами.

Флаг «Сервер состояний»

Определяет, является ли данный сервер хранилищем информации системного КЭШа Oktell. В карте может быть только один сервер состояний. Вычислительная нагрузка на сервер состояний возрастает по сравнению с простыми серверами логики.

Внешние и внутренние линии плат CTI, потоки

Для получения списка этих линий необходимо внизу нажать кнопку «Обновить». Произведется запрос на сервер с указанным в поле «Адрес» адресом. Если сервер включен и запущен – в эти поля автоматически подставятся все линии. Далее для них можно указать свойства. Свойства можно выставить также в модуле «Настройка линий».

Также в эти списки попадут все линии-транки соединенных с сервером шлюзов.

IP шлюз

Шлюз используется для задания SIP аккаунтов для подключения к внешнему устройству (шлюзу, IP-АТС или серверу). Внутри назначаются адреса, логины, пароли, используемые кодеки, способ и направление подключения (регистрации), а также количество транков, используемых сервером Oktell для взаимодействия с устройством. После подключения шлюза к серверу, у последнего становятся доступны линии соответствующих SIP-аккаунтов. Шлюз может содержать один или несколько потоков (аккаунтов) для подключения к устройству.

Например, для подключения к сервису sipnet.ru могут быть использованы несколько аккаунтов. Для этого в одном шлюзе создаются несколько потоков, авторизационные данные каждого из которых настраиваются отдельно, также для каждого определяется необходимая ширина канала.

Свойства шлюза:

Название

Отображается в карте как подпись к изображению, присутствует с этим именем в параметрах аппаратуры.

Описание

Описание необходимо только для самого администратора.

Тип регистрации

Способ взаимодействия с устройством. Доступны следующие варианты:

· Без регистрации. Система работает в фиксированном поле адресов, считает адрес устройства постоянным, устройство также настроено на взаимодействие с сервером Oktell. Аккаунты (потоки) и соответствующие им линии системы считаются всегда доступными. В режиме без регистрации шлюз может содержать только один поток (аккаунт).
· Регистрация на стороне шлюза. Система для данного шлюза ведет себя аналогично простому SIP-телефону. В случае, если устройство является более независимым чем сервер Oktell, например это интернет-сервер, предоставляющий доступ к сети SIP (sipnet.ru), системе необходимо предварительно зарегистрироваться у него с указанием своего адреса. Регистрация может происходить в открытом режиме, а может быть защищена логином и паролем на подключение. Oktell может использовать несколько различных аккаунтов (потоков) для подключения к внешнему устройству, каждый из которых многоканальный. Операция логина повторяется в установленные промежутки времени. Линии системы для работы с устройством активируютя (переходят в готовность) только после успешного прохождения очередного логина, в противном случае они переходят в состояние отключенных.
· Регистрация на стороне сервера. Система для данного шлюза ведет себя аналогично интернет-серверу, предоставляющему SIP-аккаунты для доступа к сети. Линии системы для связи со шлюзом становятся доступны только после прохождения логина со стороны устройства. В противном случае они остаются в отключенном состоянии.
· Входящие из COM-клиента с XML. Все каналы потока данного шлюза используются только для приема входящих вызовов из собственного интеграционного модуля SipClient (подробнее в руководстве по интеграции, раздел «Звонок разработчику»). Эти каналы недоступны при выборе в задачах, в ресурсах, а также в правах на исходящие и компонентах сценариев «Набор номера» и «Переключение». Невозможно изменение свойств этих каналов в модуле «Линии». Звонок из внешнего приложения, использующего интегральный модуль SipClient происходит с передачей произвольного XML (умеренных размеров), который может быть подвергнут разбору в сценарии при получении входящего вызова. В соответствии с параметрами XML может быть произведена условная маршрутизация любой сложности. Для получения XML используется функция сценария «XML-INFO».
· Динамическая регистрация на шлюзе. Это аналог режима с регистрацией на стороне шлюза. Основное отличие в том, что потоки используются только для совершения исходящих вызовов, задаются однотипно общим количеством, и их регистрация производится по запросу сценариев (компонент «Регистрация потока»). Информация об аккаунтах в них подается в момент проведения регистрации в сценарии. Все потоки такого шлюза однотипны и используют одни настройки за исключением регистрационной информации. После сохранения карты и при загрузке сервера потоки не размещаются в очередь на регистрацию до момента использования шлюза в сценарии. После проведения звонка осуществляется автоматическая разрегистрация потока. Шлюз предназначен для организации сервисов совершения звонков под различными учетными записями, информация о большом количестве которых хранится в БД или на стороне. Как правило потоки содержат по 1-2 транка для совершения звонков. Например обратный дозвон и дозвон по направлению с их последующей коммутацией.

Имя домена или IP адрес устройства

Доступно только для режимов регистрации на стороне шлюза и точка-точка (без регистрации). Адрес устройства в сети.

В случае работы в режиме с регистрацией на стороне шлюза это может быть IP-адрес, имя компьютера в локальной сети, или адрес сервера в интернет. Имя домена в этом случае используется лишь для проверки входящих вызовов как составная часть sip-адреса. Отправка пакетов производится по адресу SIP-proxy.

В случае работы в режиме без регистрации «точка-точка» здесь должен быть указан IP-адрес устройства, по которому система будет производить отправку пакетов. Адрес может быть задан с указанием порта (192.168.11.2:5065). В этом случае отправка пакетов при вызове шлюза по инициативе сервера будет производиться именно на указанный порт. Если порт не указан - на стандартный порт 5060.

Адрес также используется при анализе входящего пакета для поиска шлюза/потока, которому предназначается вызов. Если в адресе указан порт, то он участвует в поисковом фильтре. Если пакет приходит с порта, отличного от указанного, то шлюз считает этот пакет чужим. Однако, если в адресе не указано порта, а адреса отправителя и шлюза совпадают, то пакет считается принадлежащим шлюзу.

IP адрес SIP-proxy сервера

Доступен только в режиме с регистрацией на стороне шлюза. IP-адрес или URI sip-proxy сервера, которому система будет производить отправку пакетов для устройства. В случае отсутствия sip-proxy как отдельного устройства здесь должен быть указан IP-адрес или URI самого устройства (например, «192.168.0.11» или «sipnet.ru»).

Принимать на поток неизвестные входящие

Доступно только в режиме без регистрации. Единственный поток шлюза с активированным режимом приема неизвестных входящих будет использован системой в случае, когда вызов приходит по неизвестному направлению или с неизвестного адреса в режиме «точка-точка».

В системе может существовать только один шлюз с активированным режимом приема неизвестных входящих.

В случае отсутствия таких шлюзов система будет отклонять все запросы на входящие соединения «точка-точка» от неизвестных адресов.

Период перерегистрации

Доступно только в режиме с регистрацией на стороне шлюза. Определяет интервал времени в секундах между отправками регистрационных данных на шлюз для поддержания соединения.

В режиме с регистрацией на стороне сервера Oktell сам является регистратором. В случае отсутствия регистрационных пакетов по истечении определенного времени он удаляет регистрационную информацию. В качестве таймаута используется присылаемая устройством информация о следующем времени посылки регистрационных данных, увеличенная на 60 секунд.

Потоки

Настройки одного потока (аккаунта) или таблица со списком нескольких потоков с возможностью настройки каждого из них по отдельности. Несколько потоков возможно в случае, если шлюз работает в режиме с регистрацией в любом из направлений.

Свойства потока (аккаунта):

Название

Имя потока, отображаемое в настройках, в мониторинге, в описании линий системы, работающих с данным шлюзом через данный поток.

Количество потоков

Доступно только в режиме динамической регистрации на шлюзе. Задает общее количество используемых потоков такого шлюза.

Отображаемое имя (DisplayName)

Доступно только в режиме с регистрацией на стороне шлюза. Составная часть DISPLAYNAME заголовка:

«From DISPLAYNAME <sip:USERNAME@DOMAIN>»

Например, "Alex Petrov".

Имя пользователя (UserName)

Доступно только в режимах с регистрацией. Составная часть USERNAME адреса:

«<sip:USERNAME@DOMAIN>»

Например, "101".

Логин (Authorization Id),

Пароль

Доступны только в режимах с регистрацией. Авторизационные данные для осуществления регистрации на стороне шлюза, а также для проверки передаваемых шлюзом авторизационных данных при регистрации на сервере Oktell.

Имя домена или адрес устройства

Адрес устройства в сети. Это может быть IP-адрес, имя компьютера в локальной сети, или адрес сервера в интернет.

Тип линий

Внутренние/внешние. Определяет способ доступа от устройства к серверу при входящих вызовах, а также формат использования потока устройства для доступа к нему на исходящих вызовах.

В случае, если линии считаются внешними - входящий вызов попадает в главный сценарий IVR. Все каналы внешнего потока доступны при выборе внешних линий в режимах call-центра, компонентах сценариев IVR.

Если линии внутренние, то входящий вызов попадает во внутреннюю АТС Oktell с возможностью донабора номера из внутреннего номерного плана. Внутренний поток становится доступен при настройке стандартных внутренних номеров с указанием номера донабора.

Особенности внешних линий:

Стандартная настройка способа подключения для внешних линий - регистрация на шлюзе или режим без регистрации «точка-точка». При стандартной схеме подключения внешние линии ведут себя привычным способом. Вариант регистрации на сервере возможен, однако накладывает определенные требования. В этом случае вызов абонента из Oktell осуществляется посредством предварительного набора префикса в канал для вызова станции с последующим набором номера абонента через голосовое меню или DISA.

Особенности внутренних линий:

Стандартная настройка способа подключения для внутренних линий - режим без регистрации «точка-точка». При стандартной схеме подключения внутренние каналы потока ведут себя привычным образом. Вариант регистрации на шлюзе возможен, однако накладывает определенные требования. В этом случае абоненты за внутренними потоками могут донабирать номер только после установления соединения (при других способах подключения передаваемый с устройства номер (UserId) будет сразу передан во внутреннюю АТС). Вариант регистрации на сервере также возможен с ограничениями. В этом случае для осуществления звонков пользователями Oktell на устройство посредством внутреннего потока необходимо, чтобы устройство обладало поствызывным маршрутизатором (голосовое меню или DISA) для донабора (при других способах подключения устройству достаточно иметь возможность передавать или анализировать UserId для прямых вызовов).

Количество транков

Количество транков, которым может оперировать система Oktell для работы с абонентами устройства. По установленному количеству транков в системе создаются линии соответствующего типа, работа АТС и call-центра осуществляется на их основе. Количество транков - параметр, зависящий от ширины канала между сервером Oktell и устройством. Система не контролирует и не ограничивает устанавливаемое количество транков (и в целом шлюзов и потоков), однако администратор должен иметь в виду, что нормальный режим работы сохранится только в случае, если количество одновременных подключений с учетом выбранных для них кодеков в сумме образуют меньший трафик, чем способен пропустить канал. Таким образом, в системе может существовать множество различных настроек аккаунтов, однако одновременно использовать можно не более фиксированного числа транков.

Тип сигнализации DTMF

Один из способов передачи DTMF сигналов из системы на устройство:

· SipInfo
· RFC2833
· InbandAudio

Кодеки

Набор кодеков с установленным внутренним порядком перебора, которые система может использовать для организации звукового канала с устройством посредством данного потока (аккаунта).

Компьютер

Свойства:

Название

Отображается в карте как подпись к изображению

Описание

Описание необходимо только для самого администратора.

Имя или адрес

Адрес компьютера в сети. Используйте имя или IP адрес компьютера.

ВНИМАНИЕ! В качестве адреса нельзя использовать стандартное название localhost и внутренний порт 127.0.0.1, так как они не являются уникальными в пределах сети и, соответственно, не могут быть идентификаторами.

При использовании терминального режима работы операторов с сервером, объекты-компьютеры проецируются в отдельные терминальные интерфейсы. В этом случае в качестве адреса необходимо указать имя или IP адрес сервера с добавлением в конец строки «/[терминальный адрес]», где [терминальный адрес] – строка, уникально идентифицирующая отдельное терминальное подключение. На клиентском рабочем месте необходимо в файл конфигурации внести значение строки [терминальный адрес] в значение соответствующего ключа «TerminalAddress». По умолчанию он пуст.

ВНИМАНИЕ! При использовании терминального режима невозможно использование VoIP телефонов.

Аналоговый телефон

Представляет собой категорию устройств, подключенных к FXS интерфейсам установленных в сервер CTI плат телефонии (Synway, Ольха). Терминальное устройство - любой аналоговый телефон - подключается отдельным телефонным кабелем к любому свободному порту одной из установленных плат.

Свойства:

Название

Отображается в карте как подпись к изображению, а также проставляется автоматически в качестве названия линий (Модуль «Администрирование. Линии»)

Описание

Описание необходимо только для самого администратора.

Отдел

Значение поля влияет на отображение данных в модуле «Офис. Сотрудники» в режиме «Отделы». Номера, назначенные не на пользователей, а на отдельные линии, приобретают принадлежность к соответствующим выбранным отделам и попадают в общий перечень номеров по отделу.

Пользователь по умолчанию

При назначении этого свойства телефон всегда считается связанным с активным пользователем. Указанный пользователь всегда считается активированным и зарегистрированным в системе. Дает возможность

· получать статистику по пользователям,
· более точно активировать правила переадресации,
· назначать на выполнение задач линии, не связанные с компьютерами (через имена пользователей по умолчанию),
· одинаково проводить работу системы при использовании настройки «работа аналоговых телефонов при незарегистрированных пользователях»
· прочие действия.

При входе указанного пользователя в систему происходит перенастройка и, если линия не принадлежит компьютеру, на котором пользователь вновь зарегистрировался, она теряет владеющего ей «пользователя по умолчанию». При выходе из системы – вновь устанавливает.

Один пользователь может быть назначен в качестве «пользователя по умолчанию» только на один телефон.

ВНИМАНИЕ! Необходимо аккуратно использовать эту возможность, так как можно задействовать нежелаемые функции.

Выбор линии

Предлагается из перечня доступных внутренних аналоговых линий сервера выбрать ту, которая будет соответствовать данному телефонному аппарату. Линии, уже назначенные на телефонные аппараты в списке не появляются. По умолчанию при установлении связи путем соединения FXS-связью в поле карты, они назначаются в порядке следования на сервере.

Свойства линии

Доступные для просмотра и изменения свойства одной линии, соответствующей телефонному аппарату. Идентичны свойствам в модуле «Настройка линий».

Отображаются, только если аналоговый телефон в карте связан FXS-связью с сервером.

SIP-телефон

Представляет собой общую категорию устройств, подключаемых по протоколу SIP. Работа и взаимодействие устройства с сервером телефонии Oktell происходит согласно спецификациям протокола SIP с возможностью частичных настроек. Физически терминальным устройством для данной категории может являться одноканальный SIP-телефон, отдельновзятый канал многоканального SIP-телефона, отдельный канал шлюза-преобразователя SIP <-> FXS и др. Сервером Oktell поддерживается два режима подключения устройств этой категории: прямой доступ по адресу без регистрации и регистрация устройства на стороне сервера.

Свойства:

Название

Отображается в карте как подпись к изображению, а также проставляется автоматически в качестве названия линий (Модуль «Администрирование. Линии»)

Описание

Описание необходимо только для самого администратора.

Способ подключения

Без регистрации / с регистрацией на сервере. В зависимости от настроек телефона, а также от предпочитаемого режима работы с ним.

Регистрация подразумевает ожидание подключения (логина) телефона к SIP-регистратору модуля поддержки оборудования комплекса. Логин производится телефоном в установленные промежутки времени с указанием своего текущего IP-адреса. До момента логина система считает телефон недоступным (отключенным).

Режим без регистрации предполагает, что IP-адрес телефона фиксирован и не изменяется со временем. Телефон без регистрации доступен всегда, и после запуска сервера система автоматически переводит его канал в готовность.

Имя пользователя (UserName)

Составная часть USERNAME адреса: <sip:USERNAME@DOMAIN>. Номер, задаваемый в настройках телефона, который совместно с адресом используется для осуществления звонков с Oktell на телефон.

Также используется как логин (Authorization Id) для проверки передаваемых телефоном авторизационных данных в режиме с регистрацией.

Например, "102".

Пароль

Доступен только в режиме с регистрацией. Значение, которое совместно с UserName будет использовано системой в режиме регистрации для сверки передаваемых устройством авторизационных данных.

IP адрес

Доступен только для режима без регистрации («точка-точка»). IP-адрес устройства (телефона), на который необходимо производить передачу пакетов, в частности производить вызов с передачей номера аккаунта.

Отдел

Значение поля влияет на отображение данных в модуле «Офис. Сотрудники» в режиме «Отделы». Номера, назначенные не на пользователей, а на отдельные линии, приобретают принадлежность к соответствующим выбранным отделам и попадают в общий перечень номеров по отделу.

Пользователь по умолчанию

При назначении этого свойства телефон всегда считается связанным с активным пользователем. Указанный пользователь всегда считается активированным и зарегистрированным в системе. Дает возможность

· получать статистику по пользователям,
· более точно активировать правила переадресации,
· назначать на выполнение задач линии, не связанные с компьютерами (через имена пользователей по умолчанию),
· одинаково проводить работу системы при использовании настройки «работа аналоговых телефонов при незарегистрированных пользователях»
· прочие действия.

При входе указанного пользователя в систему происходит перенастройка и, если линия не принадлежит компьютеру, на котором пользователь вновь зарегистрировался, она теряет владеющего ей «пользователя по умолчанию». При выходе из системы – вновь устанавливает.

Один пользователь может быть назначен в качестве «пользователя по умолчанию» только на один телефон.

ВНИМАНИЕ! Необходимо аккуратно использовать эту возможность, так как можно задействовать нежелаемые функции.

Свойства линии

Доступные для просмотра и изменения свойства одной линии, соответствующей телефонному аппарату. Идентичны свойствам в модуле «Настройка линий».

Отображаются только если телефон в карте связан с сервером. В противном случае линия телефону не назначается, и, соответственно, ее свойства недоступны.

Кодеки

Набор кодеков с установленным внутренним порядком перебора, которые система может использовать для организации звукового канала с данным телефоном

Способ отбоя

В момент разрыва коммутации по инициативе сервера возможны различные варианты отбоя, посылаемого на устройство, подключенное как пользовательский IP-телефон:

· Дисконнект;
· Генерация сигнала «Отбой» (занято).

В случае, если за телефонным аппаратом находится человек, рекомендуется оставлять режим генерации сигнала отбой. Это является разрывом коммутации, но продолжением IP-соединения сервера с устройством c 30-секундной задержкой перед разрывом по инициативе сервера. В этом случае человек самостоятельно кладет трубку и IP-соединение разрывается по его инициативе.

Однако, если устройство является автоматическим (или с настроенным автоматическим переходом в IDLE состояние при получении DISCONNECT, или с отсутствием трубки, которую необходимо положить каким-либо переключателем), необходимо выставлять режим «Дисконнект» во избежании лишней в этом случае 30-секундной задержки.

USB-телефон

Представляет собой общую категорию устройств, поддержку которых осуществляет аппаратный модуль клиентского приложения. Базируется на одной из звуковых подсистем пользовательского компьютера (встроенная или вынесенная в телефонный аппарат звуковая карта), доступ к клавиатуре осуществляется через устройство или через пользовательский интерфейс приложения. Работа и взаимодействие этого типа устройства с сервером телефонии Oktell происходит по внутреннему протоколу.

Свойства:

Название

Отображается в карте как подпись к изображению, а также проставляется автоматически в качестве названия линий (Модуль «Администрирование. Линии»)

Описание

Описание необходимо только для самого администратора.

Отдел

Значение поля влияет на отображение данных в модуле «Офис. Сотрудники» в режиме «Отделы». Номера, назначенные не на пользователей, а на отдельные линии, приобретают принадлежность к соответствующим выбранным отделам и попадают в общий перечень номеров по отделу.

Свойства линии

Доступные для просмотра и изменения свойства одной линии, соответствующей телефонному аппарату. Идентичны свойствам в модуле «Настройка линий».

Отображаются только если USB-телефон в карте связан с компьютером, который в свою очередь связан LAN-каналом с сервером, либо если USB-телефон связан непосредственно с сервером. В противном случае линия телефону не назначается, и, соответственно, ее свойства недоступны.

Виртуальный телефон

Представляет собой общую категорию устройств для создания рабочих мест сотрудников на базе внешних по отношению к системе Oktell телефонов. Подобные рабочие места могут находиться за пределами офисной АТС, совместно с которой производится эксплуатация сервера Oktell, в отдаленных офисах, на мобильных или домашних телефонах, доступ к которым производится посредством набора номера по одному из указанных внешних направлений.

Свойства:

Название

Отображается в карте как подпись к изображению, а также проставляется автоматически в качестве названия линий (Модуль «Администрирование. Линии»)

Описание

Описание необходимо только для самого администратора.

Номер донабора (аккаунт)

Номер, который необходимо набирать в одну из установленных линий для доступа к абоненту (пользователю или оператору), предположительно находящемуся за данным телефоном.

Используемые линии / потоки

Перечень линий из совокупности аналоговых линий FXO (внешних), потоков Е1 и SIP-аккаунтов, используя которые необходимо производить дозвон до абонента (пользователя или оператора), предположительно находящемуся за данным телефоном.

Отдел

Значение поля влияет на отображение данных в модуле «Офис. Сотрудники» в режиме «Отделы». Номера, назначенные не на пользователей, а на отдельные линии, приобретают принадлежность к соответствующим выбранным отделам и попадают в общий перечень номеров по отделу.

Пользователь по умолчанию

При назначении этого свойства телефон всегда считается связанным с активным пользователем. Указанный пользователь всегда считается активированным и зарегистрированным в системе. Дает возможность

· получать статистику по пользователям,
· более точно активировать правила переадресации,
· назначать на выполнение задач линии, не связанные с компьютерами (через имена пользователей по умолчанию),
· одинаково проводить работу системы при использовании настройки «работа аналоговых телефонов при незарегистрированных пользователях»
· прочие действия.

При входе указанного пользователя в систему происходит перенастройка и, если линия не принадлежит компьютеру, на котором пользователь вновь зарегистрировался, она теряет владеющего ей «пользователя по умолчанию». При выходе из системы – вновь устанавливает.

Один пользователь может быть назначен в качестве «пользователя по умолчанию» только на один телефон.

ВНИМАНИЕ! Необходимо аккуратно использовать эту возможность, так как можно задействовать нежелаемые функции.

Свойства линии

Доступные для просмотра и изменения свойства одной линии, соответствующей телефонному аппарату. Идентичны свойствам в модуле «Настройка линий».

Отображаются только если телефон в карте связан с сервером или шлюзом. В противном случае линия телефону не назначается, и, соответственно, ее свойства недоступны.

Комнаты и регионы

Настройка свойств комнат и регионов включает в себя:

· задание цвета для отображения в поле карты;
· задание названия.


Проверка и сохранение карты

Редактирование происходит в монопольном режиме, не давая доступ для редактирования одновременно двум администраторам комплекса. Вход в монопольный режим осуществляется автоматически при входе в модуль, а отменяется при сохранении или отмене изменений в карте. При попытке переключиться в другой модуль из карты, находящейся под монопольным редактированием, будет произведено соответствующее уведомление.

Перед сохранением изменений карты, ее необходимо проверить на корректность на вкладке «Сохранение». При изменении карты могут быть допущены ошибки, которые способны привести сервер к недееспособному состоянию, и в некоторых случаях к блокированию доступа администратора к системе. Поэтому без проверки сохранение недоступно.

Кнопка «Проверить» внизу запускает процедуру проверки. Анализируются все свойства, адреса, корректность и уникальность. По окончанию проверки список заполнится строками трех типов: ошибки (красные), предупреждения (коричневые) и замечания (серые). В конце списка приведена итоговая строка со статистикой ошибок и предупреждений. Ошибки в обязательном порядке подлежат устранению, к предупреждениями необходимо отнестись также с должным вниманием. Все ошибки и замечания можно классифицировать на 2 типа:

· Общие замечания и ошибки, относящиеся к системе и карте в целом (например, наличие двух серверов состояний) необходимо тщательно проанализировать и устранить. Общие замечания выводятся перед началом проверки свойств объектов, и вы их увидите в самом начале списка.
· Ошибки и замечания по значениям свойств объектов.

При установленном в модуле «Общие Настройки. Клиентское приложение» флаге «Пытаться пинговать компьютеры» система параллельно с оценкой корректности вводимых адресов будет пытаться посылать тестовые пакеты. Все объекты карты офиса, адреса которых не доступны с сервера, будут выведены в проверочный список в качестве замечаний. Это никак не влияет на работоспособность сервера, однако может помочь устранить возможные ошибки ввода адресов, так как при внесении неправильных данных соответствующие компьютеры не смогут получить доступ к системе. Тем более это касается сервера.

Двойным щелчком мыши на замечаниях и ошибках, которые относятся к отдельным объектам, вы задействуете процедуру автоматического выделения и центрирования соответствующего объекта и осуществите переход на вкладку карты офиса. Аналогичными действиями устраните все ошибки, после чего вновь нажмите кнопку «Проверить».

После успешной проверки карты, не выявившей ни одной ошибки, становится доступным сохранение изменений. Сохранение производится на той же вкладке «Сохранение». В любой момент можно перейти на вкладку «Сохранение» и нажать кнопку «Отменить все». При этом все изменения будут потеряны, и из базы загрузится текущая действующая карта.

При сохранении происходит изменение БД, после чего производится автоматическая попытка применения изменений в текущем сеансе работы сервера, меняются свойства и производится изменение динамической IP-структуры (шлюзы, потоки, транки, ip-телефоны). Но в ряде случаев, когда сильно затрагиваются уже работающие блоки (например, смена сервера состояний, изменение последовательности линий, перераспределение уже созданных и работающих линий) недостаточно просто перезагрузить информационные блоки. В этих случаях необходимо перезагрузить сервер для корректного применения изменений. После проверки сервер в любом случае напоминает надписью внизу о необходимости перезагрузки. Администратору же рекомендуется самостоятельно оценивать глубину вносимых изменений.

ВНИМАНИЕ! Не рекомендуется сохранять значительные изменения в карте в процессе активной работы, так как это может привести к необходимости срочного незапланированного перезапуска. В частности это касается динамической IP-структуры.


Права

Назначение прав пользователям на контроль других пользователей, на прослушивание линий и на выделение внешних линий для исходящих звонков. Несколько вкладок предоставляют различные настройки прав.

Пользователи

На вкладке производится назначение прав контроля пользователей в расширенном режиме. Похожий блок управления содержится в модуле «Администрирование. Пользователи» в несколько ином виде.

В приведенном дублированном списке перечислены все пользователи системы с указанием отделов, в которых они числятся. Левое поле – руководители, правое поле – подчиненные. Выделите необходимого пользователя щелчком на его имени в левом или правом поле (выделение дублируется).

Используйте флажки для установки прав контроля:

· Щелкните в левом поле на квадрате слева от имени пользователя, которому необходимо установить или исключить право на контроль выделенного пользователя;
· Щелкните в правом поле на квадрате слева от имени пользователя, право на контроль которого необходимо установить или исключить выделенному пользователю.

Цветная подсветка квадратов-флажков помогает четче фиксировать иерархию предприятия. Подсветка в левом поле подсказывает, какие пользователи сообразно логике должны контролировать выделенного пользователя, так как контролируют одного из его руководителей. И наоборот, подсветка в правом поле подсказывает, какие пользователи сообразно логике должны быть контролируемы выделенным пользователем, так как контролируемы одним из его подчиненных.

Линии

Право контроля отдельных линий учитывается системой при построении статистики разговоров. Просмотр и прослушивание разрешается, когда у пользователя есть право контроля одного из пользователей или одной из линий, участвовавших в разговоре. Таким образом, право контроля линий в состоянии перечеркнуть отсутствие права контроля пользователя. Внимательнее назначайте эти свойства. Рекомендуется выставлять право контроля только руководству, но по своему усмотрению Вы можете варьировать комбинации прав, с проверкой результатов во избежание недоразумений.

Выделите в левом списке необходимого пользователя. Справа поле линий заполнится в соответствии с настройками его прав на контроль линий. Если линия в правом поле подсвечена, это указывает на логичную рекомендацию включения права выделенного пользователя на ее контроль, так как один из его подчиненных обладает таким правом. Подсветка в левом поле помогает увидеть, какие пользователи находятся в подчинении выделенного пользователя, и могут обладать правом на контроль подсвеченных линий.

Выделите в правом поле интересующую линию. Слева поле пользователей заполнится в соответствии с их правами на контроль линии. Подсветка пользователя в левом поле таким же образом указывает на логичную рекомендацию включения его права на контроль выделенной линии, так как один или несколько из его подчиненных имеют соответствующее право.

Установите или снимите крестики в необходимых полях сообразно желаемым правам контроля.

Исходящие

Устанавливает права пользователя на использование различных внешних линий для совершения исходящих звонков, а также устанавливает приоритетную последовательность выделения.

Выделите в левом списке необходимого пользователя. Справа поле линий заполнится в соответствии с настройками его прав на использование внешних линий для совершения исходящих звонков. Установите крестики в полях тех внешних линий, которые хотите сделать доступными пользователю при совершении звонков на внешние номера. Нажимая стрелки-индикаторы, находящиеся справа от наименования линии, установите требуемый порядок приоритетов выделения. Он будет использован при поиске доступной для звонка внешней линии.

Если линия в правом списке подсвечена, это указывает на логичную рекомендацию включения права на ее использование при совершении исходящих звонков выделенным в левом списке пользователем, так как один из его подчиненных обладает таким правом. Все подчиненные выделенного пользователя подсвечиваются в левом поле.

Кнопка «Применить» внизу применяет изменения в текущем сеансе работы сервера. В противном случае изменения будут использованы после перезапуска сервера.


Линии

В разделе редактируются свойства для внешних и внутренних линий, настроенных в соответствии с текущей картой сети. А также осуществляется создание/редактирование направлений.

Внешние, внутренние

На двух вкладках «Внешние» и «Внутренние» перечислены все соответствующие линии системы. Таблицы со списком линий аналогичны тем, которые были в свойствах сервера в редакторе карты сети.

Свойства внешних линий:

Сервер

Название сервера (из свойств объекта карты офиса), который обслуживает данную линию. Доступно только для чтения.

Идентификатор линии

Уникальный номер линии, которым оперирует визуальная часть комплекса Oktell. Именно этот номер выступает в качестве возвращаемого значения встроенной функции обработчика сценариев IVR (для обслуживаемой линии) и диалога (для линии абонента) . Доступно только для чтения.

Поток

Название потока, составной частью которого является линия. Доступно только для чтения.

Включена

Выключение приводит к запрету использования на любых типах звонков. Применяется, если линия неактивна, не подведена к серверу или по каким то причинам не работает.

Тип набора

Тоновый/импульсный. Если одна или несколько ваших внешних линий подключены к АТС, не обладающей обработчиком тоновых сигналов, установите значение в «Импульсный». Такой способ набора ограничивает гибкость комплекса, но в большинстве случаев решает поставленную задачу. Используется в режимах набора номера с клиентского интерфейса, USB-телефонов, а также аналоговых телефонов в режиме резервирования внешней линии. При использовании режима набора с аналогового телефона с предварительной коммутацией тип набора определяется установками самого аппарата.

Начиная с версии 2.3 задается в параметрах аппаратуры для внешних линий.

Исходящие разрешены

Разрешает или запрещает совершать прямые исходящие звонки в город пользователями с участием линии. Используется в служебном номере «Выход в город», в компоненте сценария IVR «Переключение», а также в быстрых номерах.

Подключена к АТС

Внешняя линия, подключенная к внутренней линии офисной АТС. Используется в служебном номере типа «Выход в АТС», а также в быстрых номерах, работающих в направлении АТС.

Линия с установленным свойством становится недоступной при совершении звонков с использованием служебного номера «Выход в город», а также компонента сценария IVR «Переключение», однако доступна в компоненте «Переключение с указанием внешних линий».

Также в соответствии с настройкой «Пропускать вход в задачу для внешних линий, подключенных к АТС» модуля «Общие настройки. Менеджер задач» для линии, помеченной данным флагом, может блокироваться работа менеджера задач, тем самым автоматически разделяя поступающие вызовы на внутриофисные и внешние. В этом случае происходит выход из компонента «Вход в задачу» по ветке «Параметры не подходят».

Автодозвон

Разрешает или запрещает использование линии для выполнения исходящих задач в автоматическом и полуавтоматическом режимах.

Доступна в call-центре

Линии, у которых не установлен флаг, становятся недоступными и невидимыми в настройках задач, а также в модуле «Ресурсы».

Префикс

Номер, необходимый для набора при выходе во внешнюю среду. Чаще используется, если выше системы установлена АТС.

Номер

В случае невозможности определения номера абонента, на который шел входящий вызов, подставляется указанная в этом поле строка.

Подставляется также как описание линии в клиентских интерфейсах в том случае, если линия не является составной частью какого-либо потока и не участвует ни в одном направлении.

Свойства внутренних линий:

Сервер

Название сервера или операторского компьютера (из свойств объекта карты офиса), который обслуживает данную линию. Доступно только для чтения.

Идентификатор линии

Уникальный номер линии, которым оперирует визуальная часть комплекса Oktell. Именно этот номер выступает в качестве возвращаемого значения встроенной функции обработчика сценариев IVR (для обслуживаемой линии) и диалога (для линии абонента). Доступно только для чтения.

Поток

Название потока, составной частью которого является линия. Доступно только для чтения.

Название

Исключительно информационная расшифровка линии. Название появляется при назначении ее на внутренние номера, а также там, где идут операции с линиями при назначении прав, отображении статистики и пр. Название аналоговых линий также используется при звонках внутри офиса, когда линия работает без управления компьютером оператора и отображается во всплывающем окне.

Название линии совпадает с названием объекта телефонного аппарата в карте, которому она сопоставлена.

Включена

При отключении линии звонки на нее не поступают, звонить с нее становится также невозможно.

Город

Определяет, коммутировать ли сразу с внешней линией после подъема трубки.

Направления

Направлением в системе Oktell называется упорядоченная совокупность внешних линий, объединенных по какому-либо признаку. Одни и те же внешние линии могут участвовать в нескольких направлениях одновременно. Может использоваться любое количество направлений.

Направления задействуются при исходящих звонках, осуществляемых вовне (при задании соответствующих свойств в компонентах сценариев, связанных со звонками на внешние линии - «Дозвон» и «Переключение на внешние линии»).

Для каждого направления может быть задана команда преобразования набираемого номера. Номер, набираемый во внешнюю линию любого типа, представляет собой строковую команду, содержащую помимо DTMF-символов служебные символы w, q, z и {}. w - пауза при наборе в 1 секунду, q - ожидание соединения с абонентом перед дальнейшей отправкой DTMF символов, z - ожидание соединения с абонентом перед дальнейшей отправкой DTMF символов с задержкой дальнейших действий (коммутации, воспроизведения) до момента окончания набора номера. Фигурными скобками выделяется та часть команды, которая будет подставлена в статистику коммутаций как номер абонента.

Таким образом, при наборе номеров в направления (в отличие от набора в линии) может быть произведено преобразование, влекущее использование особого маршрута. Для этого в соответствующих компонентах сценариев (Дозвон, Переключение с использованием внешних линий) необходим выбор соответствующего свойства. Подобные свойства введены, так как преобразование может производиться в самом сценарии безотносительно команд, указанных при создании направления.

Пример. Предположим, цель - позвонить на номер 89172123456. Набор мобильных номеров необходимо производить во внешнюю линию, подключенную к АТС, у которой номер 508 - канал с подключенным GSM-шлюзом. Соответственно, нужно осуществить дозвон на номер 508 и дальнейшую передачу DTMF-символов, составляющих номер абонента. В статистику необходимо подставить непосредственно номер абонента. Для реализации в качестве номера (команды) в одну из подключенных к АТС внешних линий может быть отправлена строка 508zw{89172123456}. Преобразование номера в указанную команду может быть произведено средствами сценария, либо например, в системе может быть задано направление "мобильные" с командой-выражением '508zw{' + [Номер] + '}'. При звонке через сценарий выбирается направление "мобильные", тип команды "использовать команду направления". Номер подставляется в направление, расчитывается выражение и в линию, входящую в направление, посылается преобразованная команда. В итоге после отправки в набор номера 508 будет осуществлено ожидание ответа абонента (в данном случае GSM-шлюза), задержка коммутации в сценарии до окончания DTMF-трансляции, пауза в 1 секунду и последующая генерация DTMF символов номера 8, 9, 1, 7, 2 ... Выделенная фигурными скобками часть подставится в статистику соединений как номер абонента.

Направление может не использовать команду преобразования, использовать указанное выражение для расчета итоговой команды, или использовать служебный сценарий, принимающий на вход (в компонент старт) исходный номер, и возвращающий результат в служебную переменную "(сл) возвращаемое значение". Сценарий в данном случае может помочь набором условных операторов и внешних данных для принятия решения о преобразовании.

Направление может быть временно отключено в настройках. При этом система будет считать направление несуществующим, несмотря на то, что линии, входящие в его состав могут участвовать в других направлениях или использоваться отдельно. Соответственно, если отключается линия, то в момент использования направления система считает ее отсутствующей.

У направления может быть задан код, который возвращается функцией сценария IVR «Код направления».

Кнопка «Применить» внизу применяет изменения в текущем сеансе работы сервера. В противном случае изменения будут использованы после перезапуска сервера. Рекомендуется перезапускать сервер после изменения значения флага "Линия включена", так как он существенно влияет на процесс загрузки комплекса.


 Внутренние номера

Внутренние номера

 Содержание | Назад | Далее

В модуле происходит работа над внутренним номерным планом организации. В приведенной таблице существующих номеров вы можете увидеть их типы и действия.

Для создания номера или входа в режим редактирования существующего номера нажмите соответствующую кнопку внизу.

В режиме редактирования в соответствующих полях отредактируйте номер, укажите его тип и описание, которое будет использовано для групповых стандартных номеров в модуле «Офис. Сотрудники».

Номера в системе Oktell подразделяются на 4 типа:

· Стандартные;
· Специальные;
· Быстрые;
· Запуск сценария IVR.

Стандартные номера

Стандартным называется номер, производящий вызов внутренних линий системы (абонентов системы). В теле стандартного номера лежит правило осуществления звонка на назначенные ему объекты системы, которых может быть 1 и более. Среди объектов могут быть:

· Линии;
· Пользователи;
· Внутренние SIP потоки;
· Другие внутренние стандартные номера.

Номер, на который назначено более одного объекта, называется групповым. В модуле «Офис. Сотрудники» групповые номера не отображают состояние составляющих их объектов.

Определите перечень тех объектов, которые хотите использовать для дозвона при наборе редактируемого номера. Добавьте эти объекты в список правила звонка. Для этого нажмите на кнопку «Добавить», в открывшемся списке в нужном разделе найдите и дважды щелкните на интересующем элементе. Вы можете воспользоваться встроенным поиском по дереву; для этого наберите в поле поиска некоторую строку, и в дереве останутся только те пункты, в названии которых она обнаружена, в частности если найдена группа, то останутся также все ее элементы. Таким образом, в поле правила звонка появятся одна или несколько строк с именами объектов. Каждому типу объекта стандартного номера соответствует свой цвет, помогая таким образом ориентироваться при создании групповых номеров.

ВНИМАНИЕ! Если объектом является SIP-поток, то помимо его указания необходимо задать также номер донабора, который будет передан на внешний шлюз. Поток является единственным типом объектов, который может присутствовать в теле стандартного номера несколько раз, однако все номера донабора для одного потока должны отличаться. Номер донабора указывается непосредственно при вставке потока в правило и может быть изменен только путем удаления и новой вставки.

Правило осуществления группового звонка может быть сколь угодно сложным. Для осуществления вызова выделяется 90 секундный интервал времени, после чего будет автоматически включена очередь или выдан сигнал отбоя в вызывающую линию (в зависимости от настроек системы). Для каждого из объектов с помощью визуального компонента создания правила установите начало и продолжительность дозвона.

Примеры стандартных реализаций групповых номеров из трех объектов.

1. При звонке на номер вызов поочередно будет переходить от объекта к объекту, осуществляя вызов каждого по 30 секунд. При этом вызов номера прекратится после того, как кто-либо из операторов снимет трубку. Объекты, время вызова которых истекло, по настройке системы будут переведены в состояние «Отсутствует» и при последующих вызовах дозвон на них производиться не будет, и номер начнет реализовываться с места первого активного объекта.

2. При звонке на номер первые 30 секунд будет вызываться один, после чего к нему будет присоединен объект 2, и последующие 30 секунд они будут вызываться вместе. Через 60 секунд после начала к ним присоединится объект 3, и вызов будет производиться одновременно на трех линиях. При этом вызов номера прекратится после того, как кто-либо из операторов снимет трубку.

3. Вызов начнется одновременно на двух объектах, а через 40 секунд к вызываемым объектам присоединится еще один, и они будут вызываться до конца.

Если по истечении 90 секунд ни один из операторов не снял трубку, производится обрыв связи на вызывающей линии или перевод звонка в очередь ожидания.

Управлением набора номеров и вызова внутренних линий системы занимается менеджер очередей Oktell. Подробнее о нем в разделе «Принципы логики Oktell»

Специальные номера

Специальные номера используются системой для проведения назначенных на них действий. Выбрав тип номера «специальный», укажите действие.

Среди возможных действий:

Выход в город

При поднятии трубки на телефонном аппарате внутри системы по умолчанию (если не выставлено свойство город для внутренней линии в модуле «Администрирование. Линии») абонент оказывается во внутренней сети и слышит двухтоновый сигнал АТС.

Действие, производимое при наборе номера, приводит к резервированию внешней линии и выдает городской сигнал. При последующем наборе номера, он набирается в зарезервированную внешнюю линию. Традиционно назначается на номер «9».

Выделяется первая свободная линия из списка внешних линий, назначенных в правах на пользователя.

При необходимости можно использовать компонент сценария IVR «Переключение с использованием внешних линий» для аналогичного действия с указанием уникальной последовательности внешних линий.

Выход в АТС

Действие аналогичное «Выход в город» с разницей в линиях. Использует только те внешние линии системы, которые указаны среди «подключенных к офисной АТС» в модуле «Общие настройки. АТС»

Разрыв связи (Flash)

Для телефонов с отсутствующей кнопкой Flash задается номер, осуществляющий аналогичное ей действие.

На аналоговых и USB каналах разрыв flash можно также сгенерировать нажатием на кнопку HOOK под трубкой телефона и отпусканием ее в установленный в системе интервал (по умолчанию 600 мс).

В момент коммутации любая набранная комбинация DTMF символов, обозначенная как FLASH номер, приведет к Flash-разрыву и постановке абонента на удержание. В случае необходимости возврата к абоненту из любого другого состояния, если невозможно набрать служебный номер, достаточно просто положить трубку. Система АТС сгенерирует обратный вызов; после снятия трубки в коммутации будет находиться абонент, помещенный на удержание.

Перехват номера

Осуществляет перехват звонка. При поступлении звонка на телефонный аппарат и неснятой на нем трубки у других пользователей системы (в зависимости от настроек) есть возможность обработать звонок, перехватив управление.

В системе существует несколько вариантов настройки способа перехвата, но в любом случае перехват начинается с набора служебного номера «Перехват». Подробнее о настройках в разделе «Общие настройки. АТС»

SIP hotline

Специальный номер для работы SIP-телефонов в режиме hotline. При снятии трубки на телефонном аппарате может быть установлен режим автоматического набора номера в линию для установления соединения с АТС. При наборе такого номера сервер Oktell после установки соединения с телефонным аппаратом фильтрует такой номер и не посылает его на дальнейший набор внутрь АТС.

Быстрые номера

Быстрые номера существуют в системе для обеспечения автоматического набора длинных городских номеров. Таким образом, с помощью быстрого номера можно, например, нажав «00» дозвониться до мобильного номера или IP телефонии. Укажите тип номера «Быстрый» и номер, на который осуществить дозвон.

Также при помощи флага «Использовать внешние линии, подключенные к офисной АТС» можно установить режим набора номера по тем внешним линиям, которые указаны в модуле «Общие настройки. АТС».

Установка флага «Отображать в сотрудниках» приводит к отображению быстрого номера в модуле «Офис. Сотрудники».

Для номера может быть задан отдел, к которому он будет отнесен при отображении в модуле «Сотрудники».

Запуск сценария IVR

Осуществляет запуск сценария IVR в линию. Это один из трех способов запуска сценариев IVR.

Используется для переключения на сценарии IVR позвонивших абонентов, а также для отладочных и демонстрационных действий. Выберите тип «Запуск IVR», после чего выберите из списка существующий в системе сценарий. Если сценарий после создания номера будет удален или переименован, при дозвоне на указанный номер абонент получит отбой.

Установка флага «Отображать в сотрудниках» приводит к отображению ivr-номера в модуле «Офис. Сотрудники».

Для номера может быть задан отдел, к которому он будет отнесен при отображении в модуле «Сотрудники».

Для переключения абонента на голосовое меню нажмите Flash, после чего наберите номер необходимого сценария IVR и положите трубку. Несмотря на то, что номер IVR был набран с операторского телефонного аппарата, после flash-коммутации IVR переключится на обработку линии абонента.

ВНИМАНИЕ! При переключении на сценарии IVR абонентов с помощью FLASH команды, абонент будет переключен на текущий выполняемый сценарий с самого начала с сохранением входного параметра.

Если необходимо задействовать режим переключения абонента на какую-либо конкретную ветвь меню путем ввода оператором символов, имеет смысл осуществлять переключение на сценарий с компонентом ВВОД и последующий запуск вложенного сценария, принимающего на вход выбранный оператором номер.

Для сохранения изменений нажмите кнопку «Сохранить» внизу. Система проверит корректность введенных данных на наличие закрывающих друг друга значений (как например 12 и 123) и в случае успеха сохранит новую информацию о редактируемом номере, иначе выдаст уведомление и предложит изменить номер.

Кнопка «Применить» внизу применяет изменения в текущем сеансе работы сервера. В противном случае изменения будут использованы после перезапуска сервера.


Общие настройки

Модуль предоставляет доступ администраторам для детальной настройки комплекса. После установки все параметры поведения системы выставлены по умолчанию, но доступны для изменения. Большая часть из них находится в модуле «Общие настройки». Все настройки разбиты по группам в соответствии с направлением действия.

В этом разделе:

— Системные настройки

— Запись разговоров

— Служебные задачи


 Системные настройки

Системные настройки

 Содержание | Назад | Далее

Выберите из предложенного списка необходимый раздел и разверните его нажатием на треугольник после заголовка или двойным щелчком на заголовке.

Установите необходимые значения и нажмите сохранить для мгновенного применения их на сервере. При нажатии кнопки «По умолчанию» будут загружены все настройки на момент установки системы, но не сохранятся на сервер до нажатия кнопки «Сохранить», давая таким образом подсматривать начальные настройки и возвращаться в режим редактирования собственных настроек без потери данных.

В этом разделе:

— Параметры АТС

— Временные параметры АТС

— Параметры автодозвона

— Параметры очереди

— Параметры менеджера задач

— Call-центр

— Мобильная статистика

— E-mail серверы

— SMS-сервис

— ICQ-сервис

— Клиентское приложение

— График работы офиса

— Управление записями разговоров

— Управление сервером

— Сборка лог-журналов

— Информация


 Параметры АТС

Параметры АТС

 Содержание | Назад | Далее

Переводить пользователя в состояние «Отсутствует» при неснятой трубке

Влияет на поведение менеджера очередей (подробнее раздел «Принципы работы логики») при неснятой трубке на телефоне пользователя, исключая дальнейшие дозвоны до пользователя или на его линию до момента его прихода и принудительного выставления состояния «Готов». Смена состояния на «Готов» может быть произведена в строке состояния окна приложения или путем снятия трубки телефонного аппарата.

Переводить отдельную линию в состояние «Отсутствует» при неснятой трубке

В некоторых случаях построения карты телефонной инфраструктуры офиса, внутренние аналоговые телефонные аппараты остаются без управления каким-либо из операторских компьютеров. Звонок на такую линию осуществляется путем набора номера, в правиле которого среди объектов эта линия значится непосредственно. Настройка влияет на поведение менеджера очередей (подробнее раздел «Принципы работы логики») при неснятой трубке на независимом телефонном аппарате. Смена состояния на «Готов» производится путем снятия трубки телефонного аппарата.

Блокировать аналоговую линию при неавторизованном пользователе

Аналоговые телефонные аппараты могут быть одновременно как зависимыми от операторских компьютеров, так и независимыми. Это влияет на записи в статистике разговоров, а также при отображении описания звонящего абонента. В случае объединения в карте офиса логической связью телефонного аппарата с компьютером, телефонная линия не будет реагировать на любые запросы при незапущенном клиентском приложении. При снятии флага аналоговая линия остается доступной для совершения звонков в любом случае. При запуске клиентского приложения звонки с ее участием приобретают идентификаторы авторизованного пользователя.

Применять резервирование при выходе на внешние аналоговые линии

По умолчанию флаг установлен. Определяет способ коммутации при использовании специальных номеров «Выход в город» и «Выход в АТС». Способ с резервированием линии ведет работу по набору номера без прямой коммутации. Коммутация осуществляется в момент получения от внешней линии сигнала КПВ (BackRing). В некоторых случаях такой способ не совсем удобен, так как при быстром снятии трубки на противоположном конце (в случае пропуска сигнала КПВ), коммутация осуществляется при обнаружении в линии голоса, то есть возможна потеря начальных тихих звуковых данных.

Противоположностью является прямая коммутация непосредственно после набора специального номера.

Следует учитывать, что запись звуковых данных, а также помещение в статистику производится в любом случае сразу после коммутации. Прямая коммутация попадает в статистику даже если вызываемый абонент занят, а в записанный разговор попадают нажатия цифровых кнопок и ожидание ответа.

ВНИМАНИЕ! При установке прямого выхода на внешние линии без использования механизма резервирования становится невозможным применение режима запроса пин-кода при звонках на мобильные телефоны, определенные в модуле «Мобильные маски».

Ожидать появления сигнала DialTone

По умолчанию флаг установлен. Определяет характер работы с внешними линиями. Если флаг установлен, то автоматический набор номера (из менеджера задач, быстрые номера, автодозвон, компоненты сценариев IVR и др.) производится только после получения сигнала DialTone от внешней линии. В противном случае (если флаг не установлен), автонабор производится через 1 секунду после снятия трубки. В случае ручного набора (с использованием специальных номеров «Выход в город» и «Выход в АТС») флаг используется только при коммутациях через резервирование внешней линии (см. предыдущее свойство). Значение флага определяет момент выдачи в линию, совершающую звонок, сигнала DialTone.

Фильтровать сигналы DTMF

В сигнале DTMF помимо цифр, «*» и «#» могут присутствовать также символы «A», «B», «C», «D». На многих телефонных аппаратах цифры отсутствуют, и весь комплекс настраивается без их участия. Однако в речи человека иногда возникают тоны, совпадающие с соответствующими тонами сигналов DTMF. При определении системой подобных тонов, она начинает реагировать как при нажатии соответствующей кнопки. Флаг позволяет исключить из анализа полученных тонов все, что отличается от стандартных цифровых сигналов.

Сохранять в БД все получаемые по внешним линиям DTMF-символы

При активации режима все поступающие в систему DTMF символы будут сохраняться в таблице основной базы данных A_Stat_DTMF (символ, время, Guid-идентификатор линии).

Отправлять номер на набор в Е1 символами

При исходящем звонке в город по каналу данных Е1, система начинает набор номера после условного сигнала начала, подобного кнопке «Позвонить» в сотовых телефонах. Одним из вариантов сигнала является набор указанной в настройке последовательности символов. По умолчанию это «*».

ВНИМАНИЕ! Отключение возможности отправки номера последовательностью символов влияет на работу пользовательских телефонных аппаратов, производящих набор целиком кнопкой «SEND». Если необходимо заблокировать функцию, оставив работающим режим SEND, вместо отключения режима следует внести фиктивную последовательность символов, отсутствующую на телефонном аппарате, например «ZZZ».

Отправлять номер на набор в Е1 по таймауту, c

При исходящем звонке в город по каналу данных Е1, система начинает набор номера после условного сигнала начала, подобного кнопке «Позвонить» в сотовых телефонах. Одним из вариантов сигнала является пауза заданной длины после набора очередного символа.

Количество гудков перед входом в главный сценарий (аналог)

Определяет необходимое количество гудков, которое система должна пропустить при поступлении входящего вызова на аналоговую линию перед тем как запустить главный сценарий и снять трубку. В сценарии перед снятием трубки однако может стоять пауза или набор других действий, влекущих дополнительную задержку перед снятием. По умолчанию для аналоговых линий 1 (вход в главный сценарий в конце первого длинного гудка).

Разрывать SIP-соединение при отсутствии входящего звука, мин

Определяет поведение АТС при обнаружении ситуации, когда некоторое время перестает поступать голос по SIP-каналу. По умолчанию сип соединение остается активным неограниченно до разрыва соединения по инициативе одного из абонентов. Однако в случае коммутации в сценариями, и "падения" внешнего устройства или шлюза - такие коммутации могут подвиснуть до принудительного разрыва администратором. Настройкой включается режим слежения и принудительного разрыва по отсутствию входящего звука (в некотором роде признак отсутствия внешнего устройства), однако в случаях, когда внешнее устройство в целях экономии трафика не отсылает пустые звуковые пакеты (с тишиной), необходимо осмотрительно задействовать режим, выставляя заведомо большие интервалы реагирования на отсутствие звука. Интервал задается в минутах.

Формат CallerId для SIP каналов

При поступлении входящего вызова на сип-канал в систему по умолчанию передается полный составной номер абонента в формате «sip:username@domain». В некоторых случаях подобный формат может быть неудобен для обработки. Установкой этого параметра можно выбрать режим передачи в систему только USERNAME части составного номера.

Формат transfer-номера на SIP-каналах

При поступлении команды от IP-телефона на совершение transfer-переключения, в запросе указывается номер адресата в полном формате. Например, если с клавиатуры телефонного аппарата набирался номер 425, то номер для переключения будет передан с телефона в виде «sip:425@domain». В большинстве случаев это бессмысленно, однако все же остается возможность передать его в АТС в неизменном виде путем изменения значения данного парамера. По умолчанию из этой строки будет вырезается номер аккаунта (в примере - «425»).

Способ перехвата звонка

Перехват звонка осуществляется путем набора служебного номера типа с действием «Перехват». При перехвате звонка мгновенно осуществляется коммутация оператора, перехватывающего звонок, с абонентом, вызывающим перехватываемый номер.

Среди способов организации перехвата существуют:

· Перехват по группам. Перебираются в поиске вызываемой линии все объекты, участвующие в групповых номерах одновременно с перехватывающим объектом (линией или пользователем);
· Перехват по номеру. При наборе номера перехвата осуществляется ожидание ввода перехватываемого номера, в котором осуществляется поиск вызываемых в данный момент объектов;
· Объединенный перехват. Начинается с перехвата по группам, после чего в случае неуспеха происходит переход к перехвату по номеру.

Момент коммутации с аналоговыми каналами

Определяет, в какой момент система будет производить коммутацию с аналоговой внешней линией при использовании служебных номеров типа «выход в город» и «выход в атс», а также при использовании компонента IVR «Переключение на внешние линии» с передаваемым пустым номером. В момент обнаружения голоса, или в момент подачи сигнала «BACKRING».

Момент коммутации с каналами потока E1

Определяет, в какой момент система будет производить коммутацию с каналом потока Е1. Режим используется при звонках на служебные номера «выход в город» и «выход в атс», при использовании компонента IVR «Переключение на внешние линии» во всех случаях, при автодозвоне, в менеджере задач. После сигнала «E1CONNECT» или сигнала «BACKRING».

Момент коммутации с цифровыми каналами SIP

Определяет, в какой момент система будет производить коммутацию с SIP-каналом при использовании служебных номеров типа «выход в город» и «выход в атс», а также при использовании компонента IVR «Переключение на внешние линии» с передаваемым пустым номером. После сигнала «CONNECT» или сигнала «PROGRESS».

Путь к папке для записи разговоров

Здесь задается путь к текущей установленной папке для записи. Запись по умолчанию ведется в корень сервера в папку «RecordedFiles». Эта папка разрастается со временем и может образоваться дефицит дискового пространства. При переходе через границу остаточного места на диске для записи в 600 МБ, при записи файлов раз в час будет происходить уведомление всех администраторов системы, при переходе через границу в 300 МБ запись принудительно останавливается и все последующие разговоры не записываются до момента освобождения места на диске. Однако имеется возможность изменить путь для записи. При этом система запомнит предыдущий путь, и статистика останется доступной, если файлы не перемещать в ручную, или перемещая не уведомить систему.

Служебный сценарий преобразования CallerId

В некоторых случаях при организации системы на разных типах каналов для общей картины в статистике, а также для возможности осуществления обратных вызовов "одним щелчком мышью" может потребоваться приведение определившегося номера в соответствующий нормальный вид. Если при определении номеров с некоторых направлений номеру требуется преобразование, необходимо активировать параметр и выбрать соответствующий служебный сценарий преобразования. В этом сценарии на вход (в компонент «Старт») передается определившийся номер, в функции "номер линии" доступен соответствующий индекс канала. Результат выполнения необходимо сохранить в служебной переменной "Результат".

ВНИМАНИЕ! Сценарий должен быть максимум простым и быстрым, поскольку вызывается синхронно в обслуживающем потоке канала. Если в течение 2 секунд ответа получено не будет, то сценарий автоматически деактивируется и больше не будет применяться до пересохранения настроек.

Служебный сценарий обработки контента

В ходе обработки внешнего звонка сервером производится сбор так называемого контента. Это идентификационная информация по линии, абоненту, времени, а также перечень всех коммутаций с указанием имени сценария, идентификатора и имени оператора, времени начала, времени конца, продолжительности и пр. После завершения звонка запускается указанный в этом поле служебный сценарий (если таковой найден) и в него на вход передается собранный контент в строковом виде. Дальнейшие действия производятся в служебном сценарии. За подробным описанием обратитесь в раздел «Call-центр. Сценарии. Служебные сценарии».

Сценарий IVR запроса пароля

При активации режима «Мобильная статистика» путем указания множества масок номеров, вызовы на которые необходимо фиксировать, контролировать и подсчитывать, система при наборе попадающего под установленный набор масок номера и невозможности определения инициатора звонка (пользователя) осуществляет запрос пароля и переадресацию посредством указанного сценария (по умолчанию «(Служебный) Запрос пароля»).

Сценарий IVR управления переадресацией

При указании существующего в системе сценария система его использует для осуществления переадресации на внешние номера. В противном случае переадресация происходит автоматически с выделением внешних линий в обратном порядке. В сценарии можно настроить индивидуальные или общекорпоративные параметры переадресации на основе настроек комплекса, а также всех функций сценария и других дополнительных параметров. Номер для переадресации передается в переменную компонента «Старт». См. также «Клиентское приложение. Офис. Переадресация».

Сценарий IVR sip-transfer-переключения

IP-телефоны позволяют осуществлять переключение командой XFER (Transfer). На различных моделях телефонов комбинации могут отличаться. Однако в любом случае в момент подачи команды IP-телефон передает системе номер. В обычном режиме этот номер применяется линией переключаемого абонента для прямого набора в систему. Направление вызова (внешний или внутренний номер) определяется в этом случае системой на основании присутствия/отсутствия указанного номера во внутреннем номерном плане.

Указанием сценария sip-transfer-переключения активируется режим набора номера через сценарий. Для обработки линии абонента запускается обработчик сценария, на вход которого (в переменную на старте) передается номер, полученный с IP-телефона.

Сценарий IVR для входа в АТС

В некоторых случаях особенности инфраструктуры требуют организовывать маршрутизацию исходящих звонков особым образом. Параметр позволяет задействовать режим входа в АТС через сценарий. В этом случае любой вход в АТС, при котором в обычном режиме выдается тон АТС и ожидается ввод цифр для набора внутреннего номера, будет осуществлять запуск служебного IVR-сценария, указанного в текстовом поле текущего параметра. Ожидается, что сценарий организован таким образом, что оценивает набранный номер (функция CalledId), а также осуществляет ожидание ввода при необходимости.

Необходимо иметь в виду, что разные режимы входа в сочетании с разными возможными типами устройств создают различные окружения перед запуском сценария. Например, снятая трубка на аналоговом или USB аппарате приведет к запуску сценария с пустым значением функции CalledId. В то же время дозвон с IP телефона в качестве функции CalledId будет возвращать всю последовательность цифр, набранную на аппарате до нажатия CALL. Перевод же звонка с помощью клиентского интерфейса будет запускать сценарий и в качестве CalledId выдавать номер, на который запрошен перевод (внешний или внутренний).

По умолчанию использование такой схемы со сценарием входа отключено.

ВНИМАНИЕ! Переключение работы в этот режим и обратно кардинально изменяет алгоритмы маршрутизации и требует тщательной проработки концепций и настройки всех соответствующих режимов. Также при включении режима необходимо помнить, что менеджер задач и автодозвон тоже скорее всего должны быть переведены на усложненный набор номеров через служебный сценарий дозвона.

При активации режима следует иметь в виду, что ряд переключений (для которых не заданых отдельные сценарии обработки) осуществляются также через этот сценарий. В случае, если переключающий пользователь не дожидается соединения с абонентом, а кладет трубку во время обработки в сценарии, перевод абонента будет осуществлен на начало текущего активного сценария. Именно так происходит при переводе на активную очередь, а также при TRANSFER-переключении с IP телефона. Сценарий лучше организовать по вложенной схеме, где в основном сценарии входа происходит анализ и определение номера, а переключение происходит во вложенном сценарии, куда управление передается с параметром, содержащим номер. Переключающий пользователь разницы не ощущает, но если он кладет трубку в момент переключения, то абонент попадет в обработку уже в финальный вложенный сценарий переключения, в который передался итоговый номер, и на который необходимо переключение осуществить.

При написании сценариев, в том числе вложенных, вставляйте в начало отладочные уведомления с отображением канала, значения функции callerid и входного параметра. Это поможет быстрее понять принцип переключений и достичь желаемого результата.

Очевидно, чем больше используется различных устройств и возможных номеров и направлений переключения, тем масштабнее совокупность сценариев входа в АТС.


Временные параметры АТС

Время ожидания нажатия кнопок после поднятия трубки, секунды

Устанавливает таймаут ожидания нажатия кнопок, после которого переводит линию в состояние отбоя. Это время сбрасывается после нажатия кнопок, но таймаут также ожидается. Не рекомендуется выставлять слишком маленькое значение, так как это может повлечь невозможность совершения исходящих вызовов в случае, если ответ от городской АТС задерживается.

Время ожидания набора во FLASH-режиме, секунды

Устанавливает таймаут ожидания нажатия кнопок после постановки абонента на удержание. По истечению временипереводит линию в состояние отбоя. Это время сбрасывается после нажатия кнопок в начальное значение времени ожидания нажатия кнопок после поднятия трубки (предыдущее свойство). По умолчанию 30 секунд. Может быть отключено, тогда засекается 30 минут во избежание возможных проблем.

Время звучания коротких гудков, секунды

Устанавливает время, в котором может находиться линия в состоянии отбоя, после чего, если трубка не будет положена, осуществляет перевод линии в «неопределенное» состояние, и в модуле «мониторинг линий» появляется вопросительный знак.

Время flash-паузы, миллисекунды

Для телефонных аппаратов с отсутствующей кнопкой FLASH существует возможность кратковременного разрыва с сохранением звонка путем нажатия основной кнопки HOOK и отпусканием ее в пределах интервала времени, заданных данной настройкой. По умолчанию – 600 мс.

Время ожидания поднятия трубки, секунды

Время, допустимое для входящего звонка и неснятой трубки. Действует во всех случаях, где не участвует менеджер очередей, самостоятельно определяющий допустимое время в зависимости от правила стандартного внутреннего номера. По истечении времени в зависимости от настройки поведения происходит переход в состояние «Отсутствует».

Время ожидания нажатия кнопок перед сбросом буфера, секунды

При установлении величины, меньшей времени ожидания нажатия кнопок после снятия трубки, задействуется механизм очистки буфера. По истечении установленного времени система сбрасывает буфер набранных символов-тонов DTMF, и ввод осуществляется с самого начала.

Допустимое время ожидания отклика от клиента, секунды

Клиентское приложение находится в постоянной связи с сервером, осуществляя периодическую регистрацию во избежание очистки сервером из списка активных. Сервер в свою очередь занимается очисткой «потерявшихся» клиентов, что может произойти в случае снятия клиентского приложения из процессов или обрыве сети. После очистки сервер считает пользователя неактивным, и при его вызове действует согласно состоянию «Отключен». Время выставляет допустимый таймаут ожидания после чего следует очистка.

Ограничивать максимальное время коммутации, минуты

При включении этой функции все начинающиеся коммутации ограничиваются установленным временем. По истечению времени коммутация принудительно разрывается. По умолчанию ограни


Музыкальное сопровождение

Все настраиваемые в разделе параметры указывают абсолютные или относительные пути к музыкальным файлам или каталогам с музыкальными файлами (wav) для воспроизведения в различных ситуациях и очередях ожидания. При указании файла в соответствующий момент осуществляется его цикличное воспроизведение. При указании каталога осуществляется случайный выбор и воспроизведение мелодий, после завершения одного файла начинается воспроизведение другого. В случае если параметр указан неверно, воспроизводится соответствующий стандартный файл из каталога SND (относительный путь от стартуемого модуля).

Мелодия ожидания в очереди

Воспроизводится любому абоненту, ожидающему соединения с пользователем в очереди ожидания.

Мелодия ожидания во FLASH-буфере

Воспроизводится любому абоненту, помещенному на удержание (во флеш-буфер).

Мелодия ожидания IVR-переключения

Воспроизводится любому абоненту, ожидающему соединения, осуществляемого компонентами «Переключить» сценария IVR без явного указания альтернативной мелодии.

Мелодия ожидания соединения с оператором

Воспроизводится абоненту, вызов которого осуществлен системой в автоматическом режиме. Воспроизводится до момента соединения с оператором.

Мелодия для занятого в задаче оператора

Воспроизводится оператору, снявшему трубку в момент зарезервированного в задаче состояния (предвызывная или поствызывная обработка).

Мелодия ожидания ФАКС-сеанса

Воспроизводится пользователю, инициировавшему факс-сеанс на оппозитном канале.

Мелодия прочих ожиданий

Воспроизводится в альтернативных местах и в случае сбоев.


Автодозвон

Количество попыток при звонке на внешний номер

Определяет ограничение количество осуществляющихся попыток во избежание бестолкового блокирования одной из внешних линий, а также осуществляющего дозвон оператора. По истечении последней попытки пользователь возвращается в состояние «Готов» и к анализу собственной очереди ожидания.

Пауза при отсутствии свободных внешних линий

Определяет время ожидания перед повторной попыткой, в случае отсутствия свободных для осуществления автодозвона внешних линий.

Пауза при получении ответа «Занято»

Определяет время ожидания перед повторной попыткой, в случае получения из внешней линии сигнала «занято».

Пауза при получении ответа «Не отвечает»

Определяет время ожидания перед повторной попыткой, в случае таймаута ожидания ответа при отсутствии сигнала в линии или длинных вызывных гудках.

Пауза при прочих ответах внешних линий

Определяет время ожидания перед повторной попыткой, в случае непредвиденных сбоев.

Служебный сценарий набора номера в АДЗ

Задействует режим набора внешних номеров сервисом автодозвона через служебный сценарий. В обычном режиме набор осуществляется непосредственно в одну из внешних линий, доступных пользователю по правам. В условиях настройки сложных маршрутов может потребоваться разбор номера и, в зависимости от различных параметров, перенаправление и индивидуальное определение маршрута с указанием команды на набор. См также «Администрирование. Линии. Направления», «Сценарии. Служебные. Компоненты. Дозвон».


 Очередь

Очередь

 Содержание | Назад | Далее

Выставлять на начало очереди при неснятой трубке

В случае вызова групповых номеров и истечения 90-секундного таймаута ожидания снятия трубки на одном из вызываемых операторах переводит текущий звонок в очередь ожидания остальных объектов номера, пребывающих в занятом состоянии. Подробно о менеджере очередей в разделе «Принципы работы логики».

Ограничивать очередь по времени

Флаг определяет существование ограничения очереди, одновременно с этим доступная шкала времени указывает на значение этого ограничения. Ограничение влечет выход обработчика очереди из реализации дозвона по указанному ему номеру и возврат ответа «Занято». Максимум – 30 минут. По умолчанию ограничение отсутствует.

Приоритет по умолчанию (внешние)

Значение приоритета звонка для размещения в очереди, которое устанавливается каждый раз при сбросе состояний внешних линий. Изменение приоритета происходит с использованием служебной переменной сценария IVR «Приоритет очереди». Подробнее в разделе «Сценарии IVR» в пункте «Служебные переменные». Текущий установленный приоритет сбрасывается в значение по умолчанию каждый раз после завершения звонка (трубка положена). Используется при размещении в очередях и при определении актуального звонка.

Приоритет по умолчанию (внутренние)

Аналогично предыдущему свойству для внутренних линий и внутренних звонков. Выставление значения, меньшего чем приоритет по умолчанию для внешних линий, влечет постановку внутренних звонков в очереди перед звонками с внешних линий, для которых приоритет не повышался в сценарии.

Период озвучивания позиции в очереди, секунды

При нахождении звонящего абонента в очереди система может периодически прерывать мелодию ожидания для озвучивания некоторой информации: номер текущей позиции абонента в очереди и/или ориентировочное время до соединения с оператором. Также возможно воспроизведение любых других файлов (параметры воспроизведения настраиваются в других пунктах, описанных ниже). Частота таких прерываний задается данным параметром. При отключении галочки озвучивания не происходит. По умолчанию 60 секунд.

ВНИМАНИЕ! Необходимо оценивать длительность воспроизведения с тем, чтобы гарантировать относительно больший период озвучивания. В противном случае одно озвучивание будет прерывать другое.

ВНИМАНИЕ! В целях ускорения работы модуля расчет времени ожидания соединения производится на основе статистики текущего сеанса работы, хранящейся в оперативной памяти сервера, собранной с момента последнего запуска службы (не из БД). Поэтому несколько первых звонков по каждому направлению (очередь внутреннего номера, очередь каждой задачи), оказавшихся в очереди, из-за отсутствия каких бы то ни было адекватных данных не осуществляют воспроизведения времени ожидания.

ВНИМАНИЕ! При использовании режима озвучивания позиции рекомендуется в качестве мелодии ожидания не использовать звуковые файлы с текстом, так как разрыв может произойти внутри текстового блока, что будет психологически восприниматься как некорректное действие.

Голос озвучивания позиции

Одна из стандартных папок с набором голосовых файлов, в которой осуществляется поиск требуемых для озвучивания позиции и ожидаемого времени в очереди файлов (см также Перечень. Размещаются в каталоге сервера в подпапке ..\Scripts\IVR\_StandardExpressions. Возможно создание своих каталогов с голосами.

Формат озвучивания позиции (для позиций >= 2)

Перечень разделенных пробелами или запятыми файлов (без расширения), которые используются при озвучивания позиции текущего размещения абонента в очереди. При наличии в строке символов «[%s]», вместо них подставляются файлы, озвучивающие числовое значение позиции. Если флаг не установлен, при размещении абонента далее 2 позиции включительно воспроизведения текста позиции не производится.

Формат озвучивания времени (для позиций >= 2)

Перечень разделенных пробелами или запятыми файлов (без расширения), которые используются при озвучивания ожидаемого времени до соединения с оператором. При наличии в строке символов «[%s]», вместо них подставляются файлы, озвучивающие вычисленное значение времени. Если флаг не установлен, при размещении абонента далее 2 позиции включительно воспроизведения текста ожидаемого времени не производится.

ВНИМАНИЕ! Для расчета оставшегося времени в очереди используется статистика текущего сеанса работы сервера по каждому из направлений вызовов. При отсутствии статистики по очереди какого-либо направления (до ее наполнения) время не озвучивается для звонков, ожидающих в очереди данного направления.

Формат озвучивания позиции (для 1 позиции)

Перечень разделенных пробелами или запятыми файлов (без расширения), которые используются при озвучивания позиции текущего размещения абонента в очереди. При наличии в строке символов «[%s]», вместо них подставляются файлы, озвучивающие числовое значение позиции (в данном случае 1), в противном случае воспроизводятся только указанные файлы при их обнаружении. Если флаг не установлен, при размещении абонента в 1 позиции воспроизведения текста позиции не производится.

Формат озвучивания времени (для 1 позиции)

Перечень разделенных пробелами или запятыми файлов (без расширения), которые используются при озвучивания ожидаемого времени до соединения с оператором. При наличии в строке символов «[%s]», вместо них подставляются файлы, озвучивающие вычисленное значение времени, в противном случае воспроизводятся только указанные файлы при их обнаружении. Если флаг не установлен, при размещении абонента в 1 позиции воспроизведения текста ожидаемого времени не производится.

ВНИМАНИЕ! Для расчета оставшегося времени в очереди используется статистика текущего сеанса работы сервера по каждому из направлений вызовов. При отсутствии статистики по очереди какого-либо направления (до ее наполнения) время не озвучивается для звонков, ожидающих в очереди данного направления.


Менеджер задач

Поведение сценария диалога после разрыва связи с абонентом

При разрыве связи в зависимости от этой настройки сценарий может себя вести одним из трех способов, тем самым влияя и на исход задачи:

· Прервать ввод сценария и отобразить карточку завершения разговора;
· Прервать ввод сценария после завершения ввода текущей карточки;
· Дать возможность провести сценарий до конца;

При завершении выполнения сценария диалога по причине отсутствия очередного элемента (конец ветки сценария) результат выполнения звонка по задаче считается успешно завершенным. В противном случае оператору предлагается ввести информацию в карточку завершения разговора, где он может указать явно: успешна ли реализация звонка, или нет. Это в большей степени актуально для исходящих звонков, где в случае неуспеха необходимо повторить попытку дозвона.

Разрыв коммутации при нажатии «СТОП»

На выбор можно включить или отключить.

Отображать карточку сценария поверх других окон

Влияет на клиентское приложение. По умолчанию флаг установлен.

В некоторых случаях реализации обработки разговора собственными средствами (например, web-сценарии), оператору могут помешать всплывающие окна. В то же время вообще исключить окно из сценария диалога может быть не желательно по причине того, что в этом случае сценарий автоматически дойдет до завершения, и звонок в любом случае будет считаться успешным. Для этого можно отключить помещение основной карточки сценария диалога поверх окон, и вернуться к ней в конце диалога.

Отображать карточку завершения разговора поверх других окон

Почти аналогичное тому, что было описано про отображение основной карточки сценария поверх других окон, можно описать и для карточки завершения разговора.

Максимальное время обратного вызова оператора

Время, по истечении которого оператор считается неснявшим трубку, вызов прекращается, звонок переводится в общую очередь задачи.

Пауза после освобождения оператора перед следующим резервированием

Определяет время в секундах, в течение которого оператор будет находиться в состоянии «Готов» и не зарезервирован исходящей задачей. Эта пауза позволяет оператору сменить состояние и обеспечить себе перерыв.

Пауза перед набором номера в исх. задачах

Определяет паузу в секундах перед снятием трубы и набором номера на внешней линии в пуле исходящих задач. Используется, если АТС не успевает сбросить состояния после звонка. Осторожно применяйте параметр, так как увеличение паузы повышает вероятность входящего звонка на линию, что может повлечь некорректную работу в течение одной коммутации.

Форма успешного завершения разговора

Флаг необходимости отображения формы и текст в ней (по умолчанию «Теперь Вы можете повесить трубку»). Форма отображается при завершении сценария диалога (конец одной из веток сценария) и до разрыва коммутации, после чего автоматически исчезает.

Приоритет исходящих задач

Значение параметра применяется при поиске данных для осуществления звонка в исходящих кампаниях. В случае, если комплекс одновременно обслуживает несколько исходящих голосовых задач, оперирующих некоторым общим множеством ресурсов (операторов и внешних линий), данный параметр помогает решить проблему их распределения по задачам в соответствии с выставленным приоритетом. Различные варианты значений позволяют организовать произвольные схемы распределения: случайные, фиксированные по приоритету, установленному пользователем, равномерно распределенные по объему задач.

· В порядке определенном менеджером задач. При создании/загрузке задач в начале работы они размещаются в менеджере задач в определенном (неизвестном) порядке. Самый простой и быстрый способ, исключающий всяческие распределения. Приоритет достается задачам, находящимся ближе к началу списка. При организации работы call-центра в режиме исключения использования одних ресурсов разными задачами одновременно, этот способ при своей скорости ничем не отличается от других.
· Сортировка по имени задач. Приоритет получают задачи, имена которых в списке находятся выше. Имитирует пользовательскую сортировку с жестко назначенными приоритетами.
· Сортировка по коду задач. Приоритет получают задачи, код которых в списке находится выше (в строковом представлении). Имитирует пользовательскую сортировку с жестко назначенными приоритетами.
· Случайная сортировка (равномерно по задачам). Полное отсутствие приоритетов в задачах. Каждый раз приоритетной выбирается одна из задач согласно равномерному распределению.
· Сортировка по возрастанию объема ресурсов. Приоритет получают задачи, в которые назначен наименьший перечень ресурсов. Имитирует случай псевдо-равномерности, пытаясь задействовать все задачи (все общие ресурсы используются задаче с наименьшим их числом, остаточные ресурсы при сохранении возможности звонка используются в других задачах).
· Сортировка по убыванию объема ресурсов. Приоритет получают задачи, в которые назначен наибольший перечень ресурсов. Имитирует выставление наиболее жесткого приоритета в задачи, где в конкретный момент времени перенасыщение ресурсами, жертвуя выполнением задач с минимальным числом ресурсов. Рекомендуется к использованию совместно с режимом «Call-центр. Ресурсы».
· Выборка пропорционально объему ресурсов. Сортировка производится равномерно по ресурсам. Так например, если в двух задачах используется 3 оператора (все три в одной, и два из них в другой), то стоит ожидать, что при достаточно большом числе испытаний распределение приоритетов будет около 60% к 40% соответственно.

Резервировать линию до запроса на звонок у оператора

По умолчанию флаг не установлен. В голосовых задачах исходящего оповещения с запросом у оператора используется обособленный пул звонков. В любом случае перед попаданием задачи в пул осуществляется проверка наличия всех необходимых ресурсов (свободные операторы, свободные линии). С точки зрения пула звонков запрос у оператора - это неизвестный заранее промежуток времени. За этот промежуток может произойти ряд событий, изменяющих ситуацию. Например, свободная линия будет занята неким пользователем системы для совершения звонка. При избытке внешних линий это не имеет особого значения, так как будет применена любая другая свободная линия. В случае ее отсутствия у оператора появится уведомление и он будет снят с резерва задачи.

Флаг позволяет установить режим предварительного резервирования внешней линии. Следует внимательно относиться к выбору значения флага, так как режим резервирования не предусматривает поступления входящих звонков по линии во время нахождения в стадии резервного ожидания ответа оператора. При использовании одних и тех же линий для входящих и исходящих звонков рекомендуется не устанавливать флаг. Однако на потоке Е1 можно производить выдачу линий в задаче с обратной стороны для снижения вероятности поступления по ней звонка.

Пропускать вход в задачу для внешних линий, подключенных к АТС

Если при настройке внешней линии в модуле «Линии» или в «Карте офиса» для нее выставлен флаг «Подключена к АТС», то для поступающих нее звонков по умолчанию блокируется возможность обработки во входящей задаче. Если архитектура требует одновременно использования разделения внешних линий (на АТС и городские) и обработки поступающих звонков со всех линий в задачах, необходимо снять данный флаг.

Очищать кэш при деактивации, объем более N абонентов

Менеджер задач при активной работе с исходящими задачами, имеющими кэш в памяти, использует ресурсы сервера для размещения данных в оперативной памяти. При работе с большим числом задач и абонентов из-за нехватки ОЗУ может происходить замедление по причине свопа. Включение режима очистки кэша при деактивации помогает снизить актуальность проблемы переполнения, так как при хранении и приостановке задачи с большим числом абонентов (указывается в параметре) будет производиться принудительная выгрузка их кэша из памяти. При активации задачи соответственно будет производиться синхронизация с БД и загрузка информации в кэш. По умолчанию режим очистки включен для задач, число абонентов которых превышает 3000.

Числовое значение можно изменять в меньшую сторону при возникновении подозрения на некорректные данные в кэше, чтобы без перезагрузки сервера деактивацией задачи произвести его сброс.

Служебный сценарий набора номера в МЗ

Задействует режим набора внешних номеров менеджером задач через служебный сценарий. В обычном режиме набор осуществляется непосредственно в одну из внешних линий, входящих в состав ресурсов соответствующей задачи. В условиях настройки сложных маршрутов может потребоваться разбор номера и, в зависимости от различных параметров, перенаправление и индивидуальное определение маршрута с указанием команды на набор, например маршрутизация мобильных номеров на GSM-шлюз, набор междугородних номеров через городскую IP-телефонию, набор международних номеров через SIP и т.д.. Указанный сценарий (по имени) ищется в проектном каталоге той задачи, которая активировала набор, а в случае отсутствия - в общем. Если же сценарий не найден, осуществляется обычный набор без преобразования и маршрутизации. В задачах могут быть установлены индивидуальные настройки использования сценариев (отключение, указание иного сценария), однако по умолчанию установлен режим использования общих настроек.

См также «Администрирование. Линии. Направления», «Сценарии. Служебные. Компоненты. Дозвон».


Call-центр

Период таймера обработки БД call-центра

Расчет пространственной таблицы состояний операторов в базе данных call-центра производится по умолчанию один раз в минуту. Этот процесс при достаточно большом числе операторов происходит длительное время с большой загрузкой процессора. В большинстве случаев это не сказывается на работе системы, однако с помощью данного свойства можно увеличить промежуток между расчетами. Это отразится на индикаторах и статистике, строящихся на базе пространственной таблицы состояний операторов, включающих еще не рассчитанное время.

Уведомлять о начале графика, мин

При установке свойства каждый находящийся в call-центре оператор будет получать уведомление о начале его рабочего времени. Уведомление производится раз в минуту. Уведомление производится заранее с учетом установленного значения времени опережения. При выставлении значения 0, уведомление производится сразу после события.

Уведомлять о завершении графика, мин

При установке свойства каждый находящийся в call-центре оператор будет получать уведомление о завершении его рабочего времени. Уведомление производится раз в минуту. Уведомление производится заранее с учетом установленного значения времени опережения. При выставлении значения 0, уведомление производится сразу после события.

Уведомлять о начале перерыва, мин

При установке свойства каждый находящийся в call-центре оператор будет получать уведомление о начале запланированного для него перерыва. Уведомление производится раз в минуту. Уведомление производится заранее с учетом установленного значения времени опережения. При выставлении значения 0, уведомление производится сразу после события.

Уведомлять о завершении перерыва, мин

При установке свойства каждый находящийся в call-центре оператор будет получать уведомление о завершении запланированного для него перерыва. Уведомление производится раз в минуту. Уведомление производится заранее с учетом установленного значения времени опережения. При выставлении значения 0, уведомление производится сразу после события.

Принудительно выводить в перерыв, мин

При установке свойства каждый находящийся в call-центре оператор будет переведен в статус перерыва принудительно за установленное в данном свойстве время до запланированного факта перерыва. Перевод заранее имеет смысл, если расчетное время разговора с абонентом достаточно велико. При выставлении значения 0, перевод в статус перерыва производится непосредственно в запланированный в графике момент времени.

Список предустановленных перерывов

В таблице задаются предустановленные варианты перерывов, доступные операторам для выбора в окне ввода причины перерыва. Таблица является визуальным отображением таблицы БД A_TaskManager_CardLunchStates. Каждый из перерывов должен иметь уникальный код и название. Контроль уникальности кодов должен производиться администратором, занимающимся редактированием.

Список пользовательских результатов звонков по задачам

В таблице задаются варианты перерывов пользовательских результатов, доступные операторам для выбора в стоп-форме или для назначения в теле диалогового сценария служебным переменным. Пользовательские состояния являются альтернативными результатами звонков по задачам, позволяющими оператору уточнить результат звонка для отображения и/или фильтрации в статистике. Таблица является визуальным отображением таблицы БД A_TaskManager_CardUserResults. Каждый из находящихся в списке результатов должен иметь уникальный код, название, а также флаги, определяющие принадлежность данного результата: исходящая/входящая задача, а также успешный/неуспешный звонок. Контроль уникальности кодов должен производиться администратором, занимающимся редактированием.


Мобильная статистика

Задействовать проверку набираемых номеров на соответствие маскам

Флагом включается режим проверки набираемых операторами номеров на соответствие маскам, определенным как маски мобильных номеров. После ввода PIN кода в статистику помимо линии попадает информация и о пользователе, совершившем звонок, давая наиболее четкое представление, а также поименное распределение затрат на звонки при построении отчета. В случае отсутствия проверки на соответствие маскам в момент совершения звонков в статистику попадет только информация о линии. В ряде случаев этого вполне достаточно, поэтому обременять операторов вводом PIN кодов не имеет смысла.

В любом случае запрашивать PIN-коды

Принцип работы фильтра мобильных номеров включает в себя запрос PIN кода при звонках с аналоговых телефонных аппаратов, независимых от операторских компьютеров в момент совершения звонка. Это делается для подстановки правильных значений в статистику, и как следствие для получения корректных и неоспоримых отчетов. Флаг определяет, нужно ли запрашивать PIN коды пользователей даже при звонках с аппаратов, находящихся под контролем операторских компьютеров. Скорее это необходимо только тогда, когда имеются подозрения на недобросовестность сотрудников.

Стоимость минуты исходящего звонка на мобильный телефон

Значение участвует при получении статистики (расчета) звонков сотрудников на мобильные телефоны по личным целям. В модуле «Мобильная статистика» вы можете просмотреть, прослушать, и распечатать статистику звонков с указанием итоговых затраченных на это сумм.

ВНИМАНИЕ! При установке прямого выхода на внешние линии без использования механизма резервирования («Общие настройки. Параметры АТС») запрос пин-кода невозможен и соединение происходит в любом случае. В статистику АТС попадает стандартная строка.


E-mail серверы

Отправка и прием электронной почты осуществляется с помощью соответствующих компонентов сценариев из группы E-mail. По умолчанию в компонентах используются параметры подключения, настроенные в данном разделе. Однако каждый компонент может уникально быть настроен на специфический способ подключения.

Отправка почты может происходить как в автоматическом режиме, так и с использованием почтового клиента оператора (в сценариях диалога). В текущем разделе производится настройка подключения к серверам POP и SMTP для работы компонентов. Параметры являются стандартными для настройки почтовых клиентов, и их детальное описание за рамками руководства.

Протокол сервера входящей почты.

Адрес сервера входящей почты.

Порт сервера входящей почты.

Использовать SSL-авторизацию на сервере входящей почты.

Логин.

Пароль.

Адрес сервера исходящей почты (SMTP).

Порт сервера исходящей почты (SMTP).

Использовать авторизацию на сервере исходящей почты (SMTP).

Использовать SSL-авторизацию на сервере входящей почты (SMTP).

Логин (SMTP).

Пароль (SMTP).

Папка для вложений входящей почты.

При получении в сценариях почтовых сообщений, содержащих вложения, в соответствующем компоненте приема e-mail сообщений может быть установлен режим сохранения в папку с автоматически генерируемым названием. Для вложений каждого письма при этом будет создана отдельная папка внутри общей папки, установленной этим параметром. В соответствующую переменную компонентом будет записан полный путь к папке.


SMS-сервис

Система использует web-интерфейс для подключения к SMS-сервису. Среди провайдеров, предоставляющих услуги, ZANZARA (получить логин и пароль можно здесь) и MessageGroup (Украина). Взаимодействие осуществляется посредством компонентов сценариев из группы SMS. В разделе настройкам подвергаются нижеперечисленные параметры.

SMS-провайдер.

Логин для подключения к сервису.

Пароль для подключения к сервису.

Номер по умолчанию, на который приходят сообщения.

Номер по умолчанию, подставляемый при отправке сообщений.

Подключаться через Proxy-сервер.

Адрес proxy.

Порт proxy.

Логин к proxy.

Пароль к proxy.


ICQ-сервис

Система использует web-интерфейс для подключения к ICQ-сервису. Взаимодействие осуществляется посредством компонентов сценариев из группы ICQ.

По умолчанию в компонентах используются параметры подключения, настроенные в данном разделе. Однако каждый компонент может уникально быть настроен на специфический способ подключения. В текущем разделе настройкам подвергаются нижеперечисленные параметры.

Адрес сервера ICQ.

Порт сервера ICQ.

Время пребывания в пуле.

При работе с ICQ необходимо длительное подключение к серверу. При организации работы аналогично сервисам электронной почты и SMS в режиме "подключиться, синхронизировать, отключить", сервер ICQ производит временное отключение аккаунта от сети за превышение лимита подключений. Для решения этой проблемы в Oktell создан пул подключений, где некоторое время находятся и поддерживаются подключения различных ICQ-аккаунтов. В пул подключение попадает сразу при первом использовании (доставке или отправке) и находится там установленное текущим параметром время. Если в течение этого времени происходит повторное обращение к аккаунту, повторного подключения не происходит. Система использует имеющееся и продляет время пребывания в пуле.

Логин (UIN).

UIN учетной записи для использования в режиме "по умолчанию". В каждом компоненте по работе с ICQ существует выбор между уникальным UIN и общим.

Пароль.

Пароль учетной записи "по умолчанию".

Подключаться через proxy-сервер.

Протокол proxy-сервера.

В зависимости от настроек прокси-сервера, через который происходит работа может быть выбран один из вариантов (Socks5 или HTTPS).

Адрес proxy.

При выборе в компонентах режима работы с прокси-сервером "общий", соответствующие настройки берутся из текущих параметров.

Порт proxy.

Использовать авторизацию на proxy.

Логин к proxy.

Пароль к proxy.


Клиентское приложение

Отображать запрос сохранения свойств формы при смене вкладки в редакторе сценариев.

Сохранение свойств объектов, назначенных на вкладке «Свойства» в соответствующих редакторах (редакторе диалоговых форм, редакторе web-форм, редакторе карты офиса) осуществляется при нажатии кнопки «Сохранить» внизу. При переключении вкладок (без нажатия кнопки внизу) сохранение свойств, назначенных в редакторе форм, не производится. Иногда это может привести к потере данных. После установки флага при смене вкладки будет осуществляться соответствующий запрос необходимости сохранения назначенных свойств.

Пытаться пинговать компьютеры при проверке карты офиса

Установка флага задействует механизм тестовых пингов всех адресов, используемых в карте. После неудачной посылки тестовых пакетов на адрес в таблицу проверки будет выведено соответствующее уведомление, носящее информационный характер. Отсутствие доступа к адресу не является ошибкой, и карта может быть корректно сохранена и применена. Однако компьютеры, адрес которых указан неверно, не смогут быть использованы в комплексе. Процедура тестового пингования занимает дополнительное время при проверке.

Не производить расчет статистики в БД для модуля «Ресурсы»

При активной работе менеджера задач на больших объемах данных выполнение запросов, выполняющих расчет статистики для отображения в модуле «Ресурсы», в зависимости от различных условий может производиться длительное время и влиять на общую работу call-центра. При возникновении проблем с загрузкой модуля можно установить данный флаг, тем самым отказавшись от расчета статистики в реальном времени для отображения в модуле ресурсы, и пользоваться модулем по назначению.

Запрещать выход в перерыв без указания причины

При установке флага оператору в форме выхода в перерыв будет недоступна кнопка «OK» до тех пор, пока он не заполнит поле с описанием.

Запрещать изменение режима автоподнятия трубки на гарнитуре

Режим может быть задействован, когда необходимо исключить возможную смену неквалифицированными операторами режима автоподнятия трубки на гарнитуре (что в отсутствие оператора может привести к потере большого числа звонков абонентов, фактически оказавшихся в коммутации с пустым рабочим местом). Для блокировки режима необходимо произвести установку на клиентских местах нужных настроек и установить флаг. При этом все рабочие места будут использовать свои последние настройки.

Режим уведомлений при входящем вызове

При поступлении вызова пользователю (или оператору) системы в его клиентском приложении отображается уведомление с информацией об абоненте (об инициаторе вызова). Это может быть другой пользователь системы, менеджер задач, сценарий, осуществляющий переключение и т.д. В некоторых случаях уведомления, поступающие в стандартном режиме, могут потребовать корректировки или вовсе исключения. Например, если звонки осуществляются сценариями или вовсе вход в АТС организован через сценарий, то уведомления могут осуществляться непосредственно сценарием с индивидуально настроенным текстом, и дублировать уведомления не имеет смысла. Или в случае обработки входящих звонков операторами может потребоваться скрыть информацию о номере абонента каким либо способом. Все это позволяет настроить этот параметр. Возможные варианты:

· Отображать всегда.
· Не отображать никогда.
· Не отображать при вызове из сценариев.
· Не отображать при вызове операторов из задач.
· Не отображать при вызове из сценариев и задач.
· При вызове из задачи менять номер на '****'.
· При вызове из задачи не отображать абонента.
· При вызове из задачи менять номер на код и имя.

Показывать в меню модули мобильной статистики

При снятом флаге модули «Мобильные маски» и «Мобильная статистика» не отображаются в главном меню раздела «Администрирование» ни у кого из пользователей, даже если стоит разрешение в правах. Этот раздел программы используется крайне редко и по умолчанию исключен.

Дополнительный пункт меню

При необходимости администратору предоставляется возможность внедрять собственный пункт меню в раздел «Офис». Отображение настроенной веб-страницы производится во встроенном браузере. Включение дополнительного пункта и его настройка производится в текущем разделе. Необходимо заполнить значения свойств «Наименование пункта меню» и «Адрес страницы веб-сервиса». При формировании адреса допускается использовать параметры в формате GET, а также использовать динамически подставляемые системой параметры: идентификатор пользователя, его имя, логин и пароль. Для этого в теле строки адреса должны присутствовать соответствующие служебные имена в квадратных скобках, например:

http://www.companyhelpdesk.com/login.aspx?id=[user_guid]&login=[user_login]

Заголовок пункта меню списка дополнительных модулей

При необходимости в стандартное приложение внедряются сторонние модули (формы), подключенные как страницы веб-сервисов, либо как plugin-формы. Все они отображаются согласно настройкам прав доступа пользователя и установленному порядку следования внутри дополнительного раздела в главном меню клиентского приложения, расположенного между разделами «Офис» и «Колл-центр».

Название модулей задается при их настройке, а заголовок объединяющего раздела задается текущим пунктом. По умолчанию «Внешние модули».


График работы офиса

 Содержание | Назад | Далее

Рабочее время сотрудников

В таблице рабочего времени устанавливается режим работы офиса. В последующем настроенный график будет применен в режиме планировщика задач в виде подсветки выходных дней и рабочих часов.

Выходные и праздники

В таблице задаются исключения для рабочих и выходных дней на неопределенный срок вперед. Итоги используются в менеджере задач для приостановки работы (если рабочий день устанавливается выходным) или для корректировки расписания (если выходной значится как рабочий по конкретному дню недели).


Управление записями разговоров

Микшер-упаковщик

Система внутри офиса производит запись разговоров в формате G711. Каждый разговор пишется в 2 файла – по одному на каждого абонента. Микшер позволяет в фоновом режиме паковать записи и микшировать в один файл для экономии дискового пространства. Сжатие осуществляется приблизительно в 10 раз по сравнению с G711. Минута запакованного разговора занимает около 100 КБ.

В разделе упаковки записей производится настройка графика работы фонового микшера, а также существует возможность запустить проверку в реальном времени. Микшер пакует только записи, находящиеся в текущей директории записи. Поэтому перед изменением папки для записи вручную запустите микшер, если пользуетесь его услугами.

Хранение записей

Количество записей, способных храниться на сервере, зависит от объема жестких дисков. Размещение может производиться по разным дискам и папкам, это настраивается в разделе «Параметры АТС». При достижении лимита остаточного свободного пространства на текущем диске для хранения записей производится уведомление всех администраторов (менее 600Mb). При достижении лимита (менее 300Мb) останавливается сервис записи.

Многие задачи не требуют хранения больших объемов, например в call-центре запись актуальна до периода отчетности (обычно это не более 2х месяцев), в офисных задачах же период актуальности год-два. Систему можно настроить на автоматическое удаление и очистку статистики коммутаций. Удаление производится отдельно для офисных задач и для call-центра. Настраивается период актуальности, а также флаги, определяющие формат очистки. Допустимо удаление либо только файлов, либо только записей в таблице коммутаций, либо совместно файлов с соответствующими им записями в таблице коммутаций БД.


Управление сервером

Поведение сервера после получения критической ошибки оборудования

Критической ошибкой оборудования считается получение кода возврата «ErrorDevice». Это происходит, если одна из плат, или один из серверов при обращении получил соответствующий код возврата от драйвера. Это возможно, если сбой произошел на одном из каналов, а также если сбой носит массовый характер.

Один из трех вариантов поведения: перезапуск серверного приложения, перезапуск аппаратного модуля, бездействие. По умолчанию выбирается перезапуск приложения.

Адрес web-сервера обновлений

Адрес сервера, на который система будет обращаться в случае необходимости обновить файлы через интернет. По умолчанию www.oktell.ru

Порт web-сервера обновлений

Порт web-сервера, по которому происходит обновление комплекса. По умолчанию «4058».

Идентификатор службы обновлений

Идентификатор службы, занимающейся обновлением комплекса Oktell. По умолчанию «UpdateServer».

Обновлять автоматически, время дня

Установка флага повлечет ежедневный запуск процедуры сверки версий и закачки, если будет обнаружено наличие файлов более новых версий. Временной параметр устанавливает время дня, когда процедура автоматического обновления будет инициирована.

Обновлять после запуска сервера, пауза, сек

Установка флага повлечет запуск процедуры сверки версий с web-сервером и закачки архива при наличии более новых файлов каждый раз при перезапуске сервера. Числовой параметр определяет паузу в секундах, которая пройдет с момента запуска комплекса до запуска процедуры обновления. После перезапуска сервера клиентские приложения начинают свою загрузку, а VoIP-гарнитуры и телефоны работают по UDP. Паузу необходимо использовать в случае, если после запуска сервера трафик достаточно высок и не следует усугублять ситуацию.

Перезапускать сервер автоматически после загрузки обновлений

Установка флага повлечет автоматическое применение загруженных модулей и автоматический перезапуск серверного приложения. В зависимости от установки следующего флага, перезапуск может быть отложен до более подходящего момента.

Ожидать момента завершения всех коммутаций и служебных сценариев перед перезапуском

В случае установки флага автоматический перезапуск будет произведет только по достижению момента, когда Oktell не обрабатывает ни одной коммутации и не выполняется служебных сценариев. Если флаг не установлен, автоматический перезапуск прервет все существующие коммутации. Коммутацией является как соединение двух линий, так и обработка линии в IVR. В случае, если существуют активные сессии, производится запрет запуска новых сессий и периодическое отслеживание на предмет завершения всех активных.

Сценарий IVR входа в ожидании перезапуска

Если установлен флаг ожидания завершения всех коммутаций и служебных сценариев, все входящие вызовы с внешних линий и входы в АТС с внутренних линий в момент ожидания завершения активных сессий могут либо игнорироваться, либо обрабатываться в указанном специальном IVR-сценарии. Ожидается, что в нем воспроизведется соответствующее звуковое уведомление в канал или будет отправлено текстовое уведомление соответствующему пользователю - владельцу канала.

Принудительный перезапуск сервера

Нажатие на кнопку разместит задание на перезапуск. Стандартная процедура перезапуска включает в себя отключение всех пользователей (в дальнейшем подключатся автоматически) и перезагрузку приложения. Если существуют скаченные обновления, они применятся в момент перезапуска.

Закрытие клиентов

Нажатие на кнопку разместит задание на завершение работы всех подключенных клиентских приложений. Выполняется моментально.

Обновление комплекса в полуавтоматическом режиме из файла

По нажатию на кнопку будет запрошен файл-архив обновлений, из которого будет произведено копирование файлов и мгновенный перезапуск с применением новых сборок. В случае если установлен и сохранен параметр «Ожидать завершения всех коммутаций», сервер будет перезагружен в момент, когда число коммутаций будет нулевым. Запрета коммутаций самостоятельно сервер не производит. При необходимости самостоятельно на время переведите входящие вызовы в главном сценарии на файл с содержанием «Сервис временно недоступен, перезвоните через несколько минут», и осуществите запрет выхода в город через блокирование соответствующих служебных номеров.

Автоматическое обновление комплекса с сайта производителя

Нажатие на кнопку принудительно запустит процедуру сверки версий и закачку, если будет обнаружено наличие файлов более новых версий. Автоматический перезапуск не последует и для применения необходимо будет нажать кнопку «Перезапуск» или дождаться времени автоматического обновления. При этом новые версии с сайта не будут закачиваться повторно.

Обновление версии любым способом произведет копирование замещаемых файлов в каталог «SavedOldVersions», соответствующий текущей дате. Рекомендуется также проводить резервное копирование БД, поскольку обновление может повлечь изменения в БД и откат к предыдущей версии при существующей версии БД будет невозможен.

Размер скачиваемого архива зависит от того, насколько сильно различаются версии. В максимальном варианте архив может достигать 10МБ. В этой связи при некачественной интернет-связи не рекомендуется использовать метод обновления через интернет. Вместо этого лучше воспользоваться механизмом обновления из файла-обновления, который можно предварительно скачать с ftp-сервера ftp.oktell.ru или в разделе «Партнеры» на сайте www.telsystems.ru

Автоматическая профилактика базы данных

Принудительно запускает процедуру переиндексации основных таблиц базы данных, с которыми менеджером задач производится непрерывная плотная работа. После переиндексации сервер сжимает базы до минимально возможного размера и очищает логи транзакций.

ВНИМАНИЕ! При реализации массовых кампаний рекомендуется регулярно пользоваться режимом профилактики.

ВНИМАНИЕ! Не стоит только лишь уповать на автоматику. При плотной работе необходимо размещать базу на нескольких жестких дисках, регулярно производить оценку состояния базы, сохранять резервные копии, очищать данные при возможности и т.д. При сильном разрастании базы снижается производительность системы и в отдельных особых случаях возможно появление некорректных ситуаций в АТС.

Автоматическая профилактика базы данных и очистка

Помимо вышеописанного режима профилактики производит очистку таблиц для снижения общего размера базы данных. Подобная фукнция может потребоваться при реализации массовых кампаний для сохранения скорости обработки информации в БД. В случае необходимости удаляемые данные можно предварительно переносить в сторонние БД.

Удаление оперативной статистики по задачам

Осуществляет очистку оперативной базы данных от информации, связанной с работой задач. Аналогично вызову команды «Очистить оперативную статистику» для каждой задачи.

Задействовать ограничение на количество одновременных потоков пакетной обработки БД

Устанавливает режим, при котором внутри комплекса производится принудительное разграничение доступа к БД с использованием очереди. Пропускная способность (количество потоков) задается параметром. Включение режима рекомендуется во избежание регламентированного замедления работы ядра MS SQL SERVER, если его версия имеет ограничение на количество потоков (Desktop Edition и Personal Edition). В случае интенсивной работы с доступом к БД (например прогрессивный набор номеров на значительном числе каналов) возможна блокировка ресурсов и замедление работы, что сказывается на стабильности работы системы и появлении пауз. Ситуация усугубляется тем, что блокировка ресурсов, происходящая в замедленных подключениях может приводить и к торможению выполнения запросов основных 5-8 потоков. Подробнее об ограничениях в документации к MS SQL Server.

Оптимизировать работу для больших объемов БД

При использовании параметра исключает из работы ряд запросов, непринципиально влияющих на работу системы.

Состав сервисного лог-журнала

Сервисный лог включает в себя все этапы работы сервера логики. Данным параметром регулируется его состав: какие режимы и модули производят логирование, а какие нет. Параметр представляет собой строку, каждая из позиций которой содержит «0» или «1» и отвечает за включение логирования конкретного режима.

Сервисный лог нужен при обращении в тех.поддержку по проблемам, касающимся работы сервера. В обычном режиме его можно держать отключенным (или включенным неполностью), так как плотная работа сервера в непрерывном режиме может создавать файлы журнала в объеме до нескольких гигабайтов в сутки. Для отладки в реальном времени необходимо включить исследуемые режимы, произвести определенные действия, после чего вновь отключить. Сформированный файл в совокупности с другими журналами отправить в тех.поддержку. См. также модуль «Сборка лог-журналов».

Логирование использования ресурсов

С помощью параметра можно настроить вывод в лог журнал WATCHER информации по использованию процессом (процессами, в случае разделения) ресурсов системы. Объем используемой памяти, количество открытых дескрипторов, количество потоков, пользовательские системные ресурсы, ориентировочное среднее процессорное время по всему процессу и отдельно по всем его потокам.


Сборка лог-журналов

 Содержание | Назад | Далее

Во время работы системы все ее показатели записываются в лог-журналы. По истечении срока актуальности журналы очищаются. Настройки для лог журналов находятся в конфигурационных файлах приложений (серверного оконного, серверной службы и клиентского отдельно).

Oktell ведет несколько журналов, каждый из которых принадлежит отдельному сервису или группе сервисов. В случае возникновения сбоев или непредвиденных ситуаций, вынуждающих обратиться в службу технической поддержки, необходимо предоставить лог-журналы давшего сбой сервиса. Лог журналы в полном объеме могут занимать до 500МБ / день. При возникновении критической ситуации в клиентском приложении на одном из пользовательских компьютеров необходимо собрать журналы событий с соответствующего компьютера. Чтобы упростить процедуру сбора лог журналов, в систему Oktell встроен сборщик.

Укажите необходимую дату и опросите сервер. В полученном дереве отметьте все необходимые по запросу технической поддержки файлы с сервера и необходимых клиентских мест. Среди клиентских компьютеров присутствуют только те, которые подключены в данный момент (в скобках указано имя пользователя, авторизованного за рабочим местом).

Установите интервал времени и нажмите кнопку «Собрать». В открывшемся окне заполните заявку и выберите путь к файлу, в который желаете собрать архив. Сборка журналов может занять некоторое время. Она ведется с пониженным приоритетом, чтобы не влиять на работу систем сервера. По завершении архивации на рабочем месте появится всплывающее окно с отчетом сборщика. С помощью конфигурационных файлов серверного и клиентского приложений можно включать/отключать функцию логирования отдельных служб.


Информация

 Содержание | Назад | Далее

Нажмите кнопку «Обновить» для вывода информации о версии продукта, базы данных, а также о номере ключа и его ограничениях. Информация о ключе защиты доступна только при работающем сервере состояний.


Запись разговоров

 Содержание | Назад | Далее

На вкладке записи разговоров определяются правила, согласно которым осуществляется или не осуществляется запись разговоров. По умолчанию все разговоры записываются, однако создав несколько правил и выставив им приоритеты можно указать детально кого и в каких случаях записывать, а кого пропускать. Все правила анализируются в соответствующем порядке. При обнаружении подходящего правила принимается установленное в нем действие и поиск завершается.


Служебные задачи

На вкладке настраивается расписание автоматического запуска служебных сценариев, лежащих в общем разделе («Администрирование. Сценарии»). Создание задачи требует указания ряда параметров, используемых менеджером служебных задач.

Основные параметры:

· Служебный сценарий, запускаемый по настройкам редактируемой задачи;
· Тип запуска (однократный и периодический).
o Однократный запуск будет произведен в установленное время. В случае невозможности запуска в настроенное время, например, при выключенном сервере, сценарий будет запущен в ближайшее возможное время, но до истечения срока актуальности. Сдвигом даты и/или времени конца актуального периода можно отказаться от выполнения сценария при неудаче. После окончания выполнения задача автоматически удаляется.
o Периодический запуск производится внутри установленного интервала дат в соответствии с настроенным недельным графиком и периодом ожидания перед следующим запуском. Период ожидания будет проигнорирован при перезапуске сервера, так как все параметры менеджера служебных задач хранятся исключительно в оперативной памяти. Для организации более точных схем рекомендуется устанавливать более короткий интервал ожидания следующего запуска, а оценку актуальности дополнительно производить в теле служебного сценария. При настройке периодических служебных задач также рекомендуется в отладочных целях вставлять компоненты «пауза» и «уведомление». Первый помогает увидеть сценарий в мониторинге, второй убедиться в корректности выполнения.

· Дата/время выполнения и крайний срок (для однократных задач);
· Период актуальности (для периодических задач);
· Недельный график выполнения (для периодических задач);
· Интервал ожидания перед следующим запуском (для периодических задач).

После создания задача появляется в списке в неактивном состоянии. Выставив галочку активности задача активируется и начинает выполняться в соответствии с указанным расписанием.

Среди широко распространенных примеров использования служебных задач:

· Опрос SMS-сервера с установленной частотой и распределение полученных SMS по задачам и пользователям;
· Проведение периодических действий в БД;
· Опросы web-сервисов и активация задач.


Настройки оборудования

Модуль предоставляет доступ к настройкам подключенных к системе служб управления аппаратными средствами. В древовидном списке слева представлено дерево аппаратных ресурсов. Например, для плат CTI эта структура представляет собой подобное дерево узлов: «Система / Сервер / Плата / Мезонин / Канал».

Каждый из узлов обладает своими параметрами, подлежащими настройке. После установки все настройки выставлены по умолчанию и в большинстве случаев не требуют переопределения. Однако, выделив один или одновременно несколько интересующих узлов, можно изменить любые параметры и мгновенно применить их на сервере.

ВНИМАНИЕ! Кнопки «Отменить» и «По умолчанию» проводят соответствующие им операции для выделенных узлов и их подпунктов. Таким образом для загрузки значений по умолчанию (или отмены изменений) для всей конфигурации необходимо выделить корневой пункт дерева «Конфигурация».

Важный параметр для CTI плат – индекс группы. Каналы плат из одной группы коммутируются аппаратно используя CT-BUS, каналы плат из разных групп и 0 группы коммутируются через программный шлюз. Платы, не имеющие CT-BUS по умолчанию имеют индекс группы 0, прочие - 1.

Перечень настроек достаточно объемен и очень узко зависит от типа используемого оборудования и не подлежит детальному рассмотрению в настоящем руководстве. При необходимости обращайтесь с вопросами в техническую поддержку или к описаниям оборудования.

Среди настроек конфигурации (основной пункт дерева) находятся параметры, отвечающие за лог-журналы аппаратного модуля. Включение всех лог-журналов дает максимальную информацию, однако существенно расходует место на жестком диске, а также производит дополнительную нагрузку на процессор. Рекомендуется включать полную трассировку только при необходимости (по просьбе технической поддержки или при возникновении проблем с подозрением на аппаратное обеспечение и модуль управления). По умолчанию включен только режим общей трассировки.

SIP каналы

SIP-сервер требует настройки параметров подключения. В конфигурационный файл необходимо добавить стандартную строку загрузки сервера, активирующую SIP-сервер.

<add key="START_SERVER_XX" value="SIP Server;oktell.HALSipSrv.dll;SIP" />

В карте офиса задаются шлюзы для подключения Oktell к внешним устройствам и серверам с настройкой параметров. После сохранения карты в параметрах аппаратуры становятся доступны соответствующие шлюзы и потоки. Их доступные настройки аналогичны соответствующим настройкам шлюзов и потоков в карте офиса. Однако здесь невозможно изменить количественные показатели ширины потоков, а также типы регистраций. Настройки SIP сервера, вынесенные в модуль параметров аппаратуры служат более быстрому и простому доступу к регистрационным данным.

Отдельным шлюзом в настройках (пунктом в дереве) считается модуль подключения SIP-телефонов.

Дополнительно у всех потоков есть параметр «Разрешить работу», позволяющий остановить активные действия потока по осуществлению и проведению регистрации, опросу сети.

После сохранения настроек аппаратуры или карты офиса в случае успешной регистрации/перерегистрации на SIP-сервере в мониторинге линий канал приобретет состояние готовности. В противном случае канал останется в отключенном состоянии, однако попытки регистрации / ожидания регистрации будут продолжены. Каналы «точка-точка» всегда считаются доступными.

Платы CTI семейства «Ольха»

Свойства аппаратных серверов «Ольха», их плат и каналов представлены в дереве устройств данного модуля. Они аналогичны настройкам в отладочных приложениях МА9 и МА14, поставляемых на установочных дисках с платами.

Для работы комплекса на базе плат Ольха необходима активация соответствующего сервера оборудования в файле конфигурации сервера:

Сервер плат «Ольха 9»:

<add key="START_SERVER_XX" value="Alder9 Server;oktell.HALAlder9Srv.dll;Alder9;_Loaders\" />

Сервер плат «Ольха 14»:

<add key="START_SERVER_XX" value="Alder14 Server;oktell.HALAlder9Srv.dll;Alder14;_Loaders\" />

По умолчанию выставленные значения параметров полностью работоспособны в стандартных условиях российских телефонных сетей. Однако в некоторых случаях могут потребоваться их изменения. Чаще всего требуют изменения уровни громкости воспроизведения и записи (выставляются отдельно на все каналы). Также на аналоговых внешних линиях может потребоваться изменение частоты выдаваемого тона АТС. Частота выдаваемый тона должна отличаться от частоты сигнала «Занято», воспроизводимого городской АТС. В противном случае возможна ситуация, когда плата не сумеет корректно определить появление в линии сигнала «Занято». В некоторых случаях это может повлечь подвисание линии в сценариях голосового меню.

Часть параметров, таких как уровень громкости и частота, применяется на лету. Другая часть требует перезагрузки серверной службы.

Среди индивидуальных параметров плат семейства «Ольха», используемых в системе Oktell, следует отметить следующие:

· Режим работы со звуком. Канальный/функциональный. Изменять параметр рекомендуется в случае обнаружения проблем с воспроизводимым голосом при VOIP коммутациях.
· Факс-ключ (для плат «Ольха-9»). Используемая библиотека для работы с факсимильными сообщениями лицензируется производителем плат ООО «КБ Агат-РТ».
· Количество факс-каналов (для плат «Ольха-9»). Лицензия на использование библиотеки для работы с факсимильными сообщениями ограничивает число одновременно происходящих факс-сеансов. Во избежание аппаратных ошибок из-за превышения установленного числа лицензий, комплекс отслеживает количество сеансов, не допуская превышения установленного в данном свойстве числа.
· Использовать джиттер-буфер. По умолчанию «Да». В некоторых редких случаях возможна ситуация, когда использование буфера приводит к проблемам прерывистости голосового потока, поступающего с сервера VOIP-телефонии на плату, обусловленного спецификой работы драйвера платы.

При использовании плат, работающих с потоком Е1, необходимо указать номер (CALLERID) для потока или для отдельных линий. Он будет подставляться при исходящих звонках в случае, если не задан отдельно компонентами сценария. В противном случае (для некоторых типов внешних АТС) поток может быть заблокирован для исходящих звонков.

Платы CTI Synway

Для работы комплекса на базе плат Synway необходима активация соответствующего сервера оборудования в файле конфигурации сервера:

<add key="START_SERVER_XX" value="Synway Server;oktell.HALSynwaySrv.dll;ShCti;" />

При использовании в качестве аппаратной платформы плат «Synway» их работа протекает в соответствии с настройками, находящимися в конфигурационных файлах «ShConfig.ini» и «ShIndex.ini». Они размещаются в каталоге с драйверами и приложениями для плат «Synway» (выбирается при установке драйвера, по умолчанию «C:\ShCTI»).

Для их настройки используется программа «ShCtiConfig.exe». Эти настройки не дублируются в дереве устройств серверов «Synway» данного модуля.

Среди большого перечня параметров, доступных для модификации, только несколько параметров требуют обязательной настройки при использовании в российских телефонных сетях. Остальные должны оставаться со значениями по умолчанию и изменяться только при необходимости детальной настройки под конкретную ситуацию.

Следуйте приведенным ниже инструкциям для базовой настройки файлов конфигурации плат «Synway».

На вкладке «Advanced setup» необходимо:

· выставить флаг «Enable GSM format»;
· выставить флаг «Use mini-size record/play buffer»;
· убедиться, что в поле «Event output mode» выставлена единица;
· для драйверов начиная с версии 4.7.3.1 снять галочку в поле «Set_Output Event Mod».

На вкладке «Advanced tone setup» необходимо в поле «Period of busy tone» занести значения «200,400,700», соответствующие длительностям получаемых сигналов отбоя.

При использовании плат на потоке E1 необходимо дополнительно настроить фильтр префиксов телефонных номеров. На вкладке «Basic setup» нажмите кнопку «ISDN». В открывшемся окне в разделе «Rules of receiving phone number» выберите один из режимов фильтрации входящих номеров: по длине («Fixed length mode») или по префиксам («Prefix mode»). При некорректной настройке, если входящий вызов осуществляется на номер, не подходящий по параметрам (соответственно по длине или по начальному префиксу), он будет отфильтрован и заблокирован.

Пример: Если внешние номера потока 5269600 - 5269699, то в качестве префикса можно использовать строку «52696».

Нажмите кнопку «Apply» или «OK».

Работоспособность сгенерированных конфигураций можно проверить в программах «test.exe» и/или «newtest.exe».

После успешной настройки полученные файлы «ShConfig.ini» и «ShIndex.ini» необходимо скопировать в каталог серверного приложения комплекса Oktell.


Сценарии

Модуль доступен администраторам, обладающим соответствующим правом.

Создание, изменение и удаление сценариев в настоящем модуле происходит аналогично модулю сценариев call-центра с разницей в отсутствии привязки к проектам. Менеджер задач имеет доступ к сценариям лежащим внутри проекта обрабатываемой задачи и к сценариям лежащим в общей папке. Также общие сценарии IVR могут быть назначены в качестве внутренних номеров.

Подробно редактор сценариев описан в разделе «Call-центр. Сценарии».

Пользователям, являющимся администраторами системы с установленным правом доступа к системным сценариям, будут отображены соответствующие системные сценарии Oktell, хранящиеся в общей папке.

Главным сценарием IVR называется сценарий, который автоматически запускается при поступлении звонка извне (из города). Название главного сценария отображено в таблице красным цветом. Чтобы сделать выбранный сценарий главным – выделите его в таблице и нажмите кнопку «Главный».


 Мониторинг

Мониторинг

 Содержание | Назад | Далее

Модуль предоставляет эксклюзивное право просмотра и управления состояниями в реальном времени. На вкладке «Линии» происходит работа с каналами связи (линиями), на вкладке «Служебные сценарии» соответственно отображаются выполняемые в данный момент служебные сценарии, на вкладке «Подключения» - все подключенные клиентские приложения. Модуль доступен только администраторам, обладающим соответствующим правом.

Линии

В таблице перечислены все линии сервера Oktell. По свойству контекстного меню можно отключать и включать отображение неактивных линий. По умолчанию выключено. Каждая строка в реальном времени предоставляет информацию о состоянии линии:

· Номер и тип линии (внешняя, внутренняя, USB-пользовательская)
· Состояние
· Время, которое линия находится в активном состоянии
· Индикатор запись/воспроизведение
· Слева от таблицы находится поле, в котором отображаются текущие коммутации различных линий между собой.
· Активная последовательность набора цифр с клавиатуры телефона
· Информация об абоненте, находящемся на противоположном к серверу конце линии (текущий выполняемый сценарий)

С помощью контекстного меню из режима мониторинга пользователь (администратор) может прервать текущее активное состояние линии и перевести ее в готовность. Это имеет смысл при организации различных голосовых сервисов, для принудительного разрыва коммутации внешних линий из сервиса IVR. Пользование этим режимом в АТС при существующей коммутации возможно, но в общем случае не гарантирует корректности завершения операции.

Там же в контекстном меню доступна команда перерегистрации IP-каналов. В этом случае будет осуществлена внеочередная попытка регистрации, не дожидаясь ни таймаута регистрационной сессии, ни таймаута ожидания до следующей попытки регистрации сервера на шлюзе. Отправка команды на перерегистрацию для одного из каналов потока приводит к перерегистрации потока целиком. Команда имеет смысл только для потоков с регистрацией на стороне шлюза.

В режиме мониторинга доступны фильтры типа линий и состояний.

Значения пиктограмм модуля

Пиктограммы состояний:

Описание

Линия не подключена или в состоянии "не доступна"

Готовность

Снятая трубка

для внутренних линий: набор номера или состояние занято

для внешних линий: набор номера или отсутствие подключения к телефонной сети.

Входящий вызов

Коммутация. При коммутации линий слева от таблицы изображается связь каналов. При коммутации с IVR рядом изображена пиктограмма IVR.

Ожидание ответа

Неопределенное состояние, чаще всего возникает в случае, если пользователь во время прослушивания сигнала отбоя в течение 20 секунд не положил трубку.

Под резервированием другой линии или задачи, состояние ожидания в резерве

Обслуживание в IVR

Обслуживание в задаче

Удержание линии во flash-буфере

Ожидание в очереди

Различные комбинации состояний влекут появление комбинаций пиктограмм состояний

Линии связи каналов:

Описание

Связь линий резервированием

Связь линий коммутацией

Многоканальный вызов

Связь линий через Flash-удержание

Прочие пиктограммы:

Описание

Производится воспроизведение звуковых файлов в линию (из сценария IVR)

Производится запись звука в канале (в коммутации или из сценария IVR)

Признак внешней аналоговой линии

Признак канала потока Е1

Признак внешнего SIP канала

Признак внутренней аналоговой линии

Признак VoIP канала

Признак внутреннего (локального) SIP канала

Аппаратный канал CTI, который не был загружен в текущем сеансе сервера (подмена плат, отключение загрузки сервера плат в конфигурационном файле, урезание ключом защиты и др.)

Служебные задачи

В списке перечисленных сценариев указаны только те сценарии, которые выполняются в реальном времени. Доступны для просмотра имя сценария, время его выполнения на текущий момент, тип запуска (определяет характер работы сценария) и имя владельца (задачи, пользователя, линии и пр.).

Если обработка сценария зациклилась, зависла или по неизвестным причинам выполняется слишком долго, можно прервать его выполнение. Для этого необходимо выделить его в списке и в контекстном меню выбрать пункт «Прервать выполнение».

Подключения

В списке подключений перечислены все клиентские приложения, работающие в данный момент с сервером. По каждому из подключений доступна информация о компьютере-владельце, о зарегистрированном на нем пользователе, о состоянии пользователя в данный момент, линии, принадлежащей пользователю, а также времени, которое пользователь находится в системе.

С помощью контекстного меню существует возможность отправить команду на перезапуск или на завершение клиентского приложения, а также отправить сообщение пользователю или группе пользователей. В таблице доступен множественный выбор и отправка групповых команд.

Если пользователь обладает правом просмотра экранов подчиненных, то в контекстном меню ему доступна соответствующая команда. Для отображения экрана подчиненного необходимо иметь права контроля либо должностные, либо на уровне связки в задачах: супервизоры могут просматривать экраны операторов, участвующих в их задачах. У любого пользователя может быть выставлен режим (право) безусловного блокирования просмотра экрана.

Просмотр экрана также может быть осуществлен из модулей «Сотрудники», «Операторы», «Ресурсы».

Изображение, полученное с экрана монитора или серии мониторов интересующего пользователя, отображается в специальном окне просмотра. В нем доступен выбор запрашиваемого размера, а также сохранение изображения в файл (в контекстном меню). Если изображение превышает размеры окна, то мышью осуществляется его перемещение.


Внешние модули

Основная проблема, решаемая подключением внешних модулей, - доступ пользователей к информации с отображением в специфичном виде, не имеющем возможности быть настроенным средствами стандартного приложения Oktell.

Например, возможны случаи, когда средствами встроенного редактора форм не удается «красиво» решить поставленную задачу обработки звонков операторами, а применение веб-технологий затруднено по тем или иным причинам. В частности с этой потребностью можно столкнуться, когда необходимо в зависимости от выбираемых оператором значений отображать сильно отличающиеся по структуре данные в форме и при этом оставлять возможность перевыбора. Или когда в операторскую форму необходимо загружать большой объем данных (это замедляет отображение формы), тем более это нехорошо, если часть данных может вовсе не потребоваться в соответствии с выбором оператора. Может понадобиться отображение специфичных элементов управления, или возможность редактирования данных в таблице. Все эти задачи позволяет решить технология подключения plugin-программ.

В то же время другой вариант применения описываемой plugin-технологии основывается на необходимости доступа операторов к данным в БД по своей инициативе. Данные, редактируемые при поступлении или осуществлении вызовов по голосовым задачам средствами операторских диалоговых форм (любого типа), недоступны пользователю стандартного приложения Oktell для редактирования в любое время по его инициативе. Для этого необходимы услуги администратора, имеющего доступ к БД, или разработка специальных отчетов, что в общем случае неудобно. Plugin-технология дает возможность разработки специальных подпрограмм, запускаемых из меню клиентского приложения Oktell и работающими по аналогии со стандартными модулями приложения. В визуальных формах plugin-программы известным ее разработчику способом программируется некоторая модель взаимодействия пользователя с данными в БД. Часть пользователей получают доступ к форме, которая в общем случае может быть очень сложной и содержать в себе несколько различных вариантов наполнения. В зависимости или вне зависимости от того какой пользователь ее открывает, она может принимать или не принимать тот или иной вид. В общем случае таким образом организованная plugin-программа позволяет реализовывать и другие задачи, не связанные явно с редактированием данных в БД.

Модуль служит для регистрации plugin-программ, а также для настройки главного меню Oktell на отображение внешних модулей, представленных в виде ссылок на веб-сервисы или ссылок на отдельные формы, содержащиеся в plugin-программах.

Plugin-программа представляет собой некоторую совокупность файлов (сборок, библиотек, данных), содержащих некоторые программные разработки. Их создание производится отделом разработки ПО или службой внедрения на основании поставленных задач. Также создание может производиться пользователями системы. Однако для разработки необходимы базовые знания в части программирования в среде Windows.

Подробно о создании plugin-программ можно узнать в руководстве по интеграции. Раздел «Встраиваемые plugin-модули».

Plugin-модули

Plugin-программа поставляется в виде архива или как совокупность отдельных файлов. Система Oktell хранит информацию о подключенных plugin-программах в базе данных, обеспечивает соответствие версий программ на всех клиентских рабочих местах, и дает возможность настраивать и использовать содержащиеся внутри них формы. Plugin-формой называется разработанное в plugin-программе окно, задекларированное для использования в Oktell. Фактически, plugin-форма может быть любой сложности: конструкция визуального отображения может быть динамической, изменяемой, связанной с запуском некоторых алгоритмов, осуществлением запросов к серверу телефонии, к серверу БД, взаимодействием с клиентским приложением.

Для использования содержимого plugin-программы необходимо ее зарегистрировать. Это делается на вкладке «plugin-модули». В режиме регистрации (добавления) задаются название, описание, подключается основная сборка, в которой реализован интерфейс взаимодействия, а также дополнительные сборки и файлы, необходимые plugin-программе дла корректной работы.

Возможно также указание архивных пакетов с plugin-программами. При этом производится их распаковка и тестовое подключение. Перед тем, как станет доступна возможность сохранения, приложение осуществляет временную загрузку plugin-программы и проверку корректности интерфейса, после чего выгружает ее.

Все дополнительные связанные файлы размещаются рядом с основной сборкой в подкаталоге, указанном в столбце «Относительное размещение».

Впоследствии при редактировании регистрационной информации plugin-программы возможно изменение (подмена) основной сборки. Вместе с этим возможно дополнение, изменение, удаление, перемещение дополнительных файлов.

Тип загрузки определяет режим, в котором будет использоваться plugin-программа. Режим, поддерживающий динамическое обновление, имеет недостаток - более длительное исполнение кода, в частности заметное торможение ёмких визуальных интерфейсов. Режим ускоренного исполнения позволяет обновлять plugin-программы только перезагрузкой клиентского приложения Oktell.

После всех необходимых модификаций необходимо сохранить изменения. Приложение переводит интерфейс в режим списка зарегистрированных plugin-программ, параллельно запускается асинхронная процедура сохранения на сервере. Осуществляется сохранение данных в БД, а также пересылка всех файлов на сервер с формированием архива для обновления клиентских рабочих станций. О полном завершении процедуры сохранения сообщит соответствующее уведомление, и в списке будут отображены изменения (это происходит не сразу при переходе в режим списка). После этого все вновь подключаемые клиентские станции смогут скачать последние версии plugin-программ.

Администратору доступен режим форсированного обновления plugin-программ на клиентских компьютерах. Для этого после завершения процедуры сохранения необходимо нажать кнопку «Применить». Если не дождаться завершения сохранения, часть клиентских мест не произведет обновления.

Необходимо иметь в виду, что форсированное обновление проходит без выгрузки приложения Oktell, но с выгрузкой plugin-программы. Все её открытые формы будут закрыты, а несохраненные данные потеряются.

Режим форсированного обновления доступен только для программ, зарегистрированных с выставлением типа загрузки «С поддержкой динамического обновления» или незагруженных. Другие plugin-программы будут отображать уведомления пользователю о необходимости перезагрузки приложения для обновления.

С момента сохранения plugin-программы и обновления на клиентских компьютерах становятся доступны сервисы настройки использования ее форм в комплексе:

· среди стандартных модулей Oktell-клиента в отдельном разделе, по умолчанию именуемом «Внешние модули»;
· в диалоговом режиме (в сценариях диалога в качестве компонента plugin-форма).

Разделы меню

Вкладка позволяет осуществить настройку содержимого раздела главного меню «Внешние модули». В составе его пунктов находятся ссылки на внешние модули, подключаемые как страницы веб-сервисов или plugin-формы (формы зарегистрированных в системе plugin-программ).

Состав отображаемых внутри раздела модулей определяется настройками и установленными правами доступа и может различаться для разных пользователей. Их порядок определяется соответствующими индексами и настраивается при отображении списка, отсортированного по возрастанию значений столбца («Порядок»).

Любой модуль можно временно скрыть из доступных у всех пользователей, сняв флаг доступности в столбце «Статус».

Создания и/или редактирование производится в режиме редактирования, куда можно зайти двойным щелчком по таблице в строке с интересующей формой или нажатием соответствующей кнопки внизу.

На вкладке «Свойства» помимо текста для отображения модуля в меню и стартового заголовка (который может меняться в ходе работы модуля) необходимо указать тип подключаемого модуля и соответствующую ему ссылку. Не запрещается использовать несколько экземпляров одной и той же plugin-формы в меню.

Для модулей, отбражающих plugin-формы необходимо из списка зарегистрированных plugin-программ выбрать интересующую, а затем в поле с указанием формы - одну из заявленных объектом управления стартовых plugin-форм, отмеченных для использования в режиме пунктов меню (CRM).

В описании plugin-формы (непосредственно в plugin-программе) может быть задан адрес на страницу со справкой. Она становится доступна по щелчку мышью на пиктограмме с вопросительным знаком в поле пункта меню. Если адрес справка не задан, пиктограмма не отображается.

Результат отображения в клиентском приложении Oktell формы plugin-программы в общем виде может быть абсолютно разным, даже динамически изменяющимся. На примере демонстрационной plugin-программы:

Для модулей, отображающих страницы веб-сервисов, необходимо указать строку с адресом страницы. Допускается использование параметров в качестве составляющих частей строки с адресом, которая в общем случае представляет собой GET-запрос с параметрами.

При настройке веб-модуля может быть указана индивидуальная страница справки, которая будет отображена при щелчке мышью на пиктограмму с вопросительным знаком в поле элемента меню. Адрес может быть как web-адресом, так и ссылкой на chm или html файл. В последнем случае файл ищется в каталоге приложения (попадая туда через обновление клиентских приложений из каталога LiveUpdate серверной службы). При необходимости задания ссылок на внутренние страницы файла справки необходимо задавать адрес в формате «manual.chm::/topic.htm#anchor».

Результат отображения в клиентском приложении Oktell страницы веб-сервиса будет выглядеть примерно таким образом:

Выставление прав доступа к пункту меню производится на вкладке «Права доступа». Каждый модуль может быть заявлен по умолчанию как доступный всем пользователям или как недоступный никому. Дополнительно здесь же рядом выставляются исключения. Соответственно те, кому модуль недоступен, если он доступен всем по умолчанию, или те, кому модуль доступен, если модуль недоступен по умолчанию.

В итоге после сохранения необходимых свойств и перезагрузки клиентских приложений каждому пользователю станет доступен тот набор внешних модулей, который определен для него.

Следует заметить, что будут дополнительно исключены неактивные модули (у которых статус «скрыт»), а также plugin-формы, регистрация которых удалена из системы.


Мобильная статистика

Звонки пользователей на мобильные телефоны в системе Oktell могут быть поставлены на учет. В связи с поправками к закону «О связи» от 01.07.2006 это может быть целесообразно в целях экономии или регламентного использования средств предприятия.

Система при наборе номера во внешнюю линию ведет себя согласно настройкам блока «Мобильная статистика» модуля «Общие настройки». Для работы используются таблицы масок мобильных номеров, подлежащих контролю. В некоторых случаях использование некоторых мобильных номеров является регламентированным. Среди таких номеров могут быть, например, номера руководителей отделов, сотрудников предприятия, находящихся в постоянном удаленном взаимодействии с компанией. При настройке системы из перечня контролируемых номеров, определяемых мобильными масками, подобные номера могут быть исключены, и звонки на них не будут учитываться при построении статистики.

Модуль доступен только имеющим соответствующее право доступа пользователям. Одновременно модуль должен быть подключен («Администрирование. Общие настройки. Клиентское приложение»).

Заполните список масок на вкладке «Маски сотовых номеров» в модуле «Мобильные маски», определяемых как мобильные номера города. Среди них могут быть также 7-значные (городские) номера, являющиеся услугой сотовых операторов.

Заполните список масок и номеров на вкладке «Маски разрешенных номеров», которые требуется исключить из проверки.

Маска представляет собой строку, состоящую из цифровых символов и знаков «?». Например, «89050??????», «89?????????». Номер «89050123456» также будет являться маской, покрывающей ровно один номер. Количество символов в маске должно быть идентично количеству цифр в номерах, которые планируется покрывать маской.

В соответствии с настройками в блоке «Мобильная статистика» модуля «Общие настройки» может быть задействован или опущен механизм запроса пин-кода при наборе номера. Пользователь-владелец соответствующего пин-кода попадет в статистику как инициатор звонка. После набора номера, попадающего под категорию «личный звонок», обработка звонка использует специальный служебный сценарий IVR с названием «(Служебный) Запрос пароля» (или иного, определенного в модуле общих настроек), который, собственно, запрашивает пароль. В случае ввода корректного пин-кода осуществляется дозвон. Переключение производится с помощью компонента «Переключение» и передачей в него в качестве служебного параметра «Параметр переключения» введенного значения пароля. Переданный пароль используется системой для идентификации пользователя и подстановке его данных в статистику.

Раздел «Мобильная статистика» предоставляет доступ к отчетам по произведенным звонкам на сотовые номера в личных целях. Фильтр звонков позволяет исключить из перечня осуществленных звонков данные, не попадающие в выбранные условия. Фильтрация производится по промежутку дат, времени, а также по пользователям системы и/или конкретным номерам. Доступны три режима, определяющиеся соответствующими вкладками:

Журнал

Вкладка «Журнал» позволяет просмотреть список всех разговоров, попадающих под категорию «Исходящих звонков на мобильные телефоны по личным целям». В журнале звонков в случае наличия записи соответствующего разговора в последнем столбце появляется красный круг. Двойным щелчком на такой строчке можно воспроизвести запись разговора.

ВНИМАНИЕ! При запросе больших объемов данных необходимо учитывать, что это создает дополнительную нагрузку на процессорное время сервера и сетевой трафик. В некоторых случаях это может отразиться на качестве разговоров, осуществляющихся через VoIP шлюз сервера.

Диаграммы

Вкладка «Диаграммы» дает возможность пользуясь дополнительными настройками отображения выводить диаграммы, графики и гистрограммы выбранных показателей. Работает подобно режиму «Диаграммы» модуля «Офис. Статистика».

Отчет

Вкладка «Отчет» позволяет согласно фильтру звонков строить отчет по сотрудникам, и, в случае установки отдельных видов настроек, по линиям. Сводная таблица отображает итоговые значения в минутах, а также в рублях за установленный в фильтре интервал времени (стоимость минуты настраивается в модуле «Общие настройки. Мобильная статистика»). Полученный отчет доступен для распечатки на принтере. Для этого нажмите кнопку «Печать» внизу.


Телефон

В разделе «Телефон» непосредственно в главном меню находится модуль управления звонками, факс-сеансами и гарнитурами. Для пользователей, имеющих соответствующее право, модуль также предоставляет доступ к информации о конференциях.

Звонки и сервис автодозвона

Пользователи, имеющие в своем распоряжении аналоговый или IP-телефон (а не управляемый компьютером модуль подключения Voip-телефонов) через модуль «Телефон» имеют доступ к сервису автодозвона. При наборе номера и нажатии единственной в этом случае кнопки «Позвонить», сервер начинает дозвон до указанного номера. Если набранный номер существует среди внутренних стандартных номеров АТС Oktell, то сервер встанет в очередь до момента снятия трубки на той стороне. В противном случае осуществляется набор номера в город (наружу), используя свободную и доступную текущему пользователю внешнюю линию. При этом если номер занят или не отвечает, сервер осуществляет повтор набора. Число попыток, а также длительность ожидания в различных ситуациях настраиваются администратором в модуле «Общие настройки. Параметры автодозвона».

Чтобы позвонить, используя сервис автодозвона:

· Выберите из выпадающего списка набранных номеров необходимый номер и нажмите «Позвонить»;
· Наберите номер с помощью клавиатуры в поле «Номер» выпадающего списка и нажмите «Позвонить»;
· Наберите номер, щелкая мышью на цифровых кнопках модуля, и нажмите «Позвонить»;
· В модуле «Офис. Сотрудники» выберите необходимый номер и нажмите кнопку «Позвонить» или выберите соответствующий пункт контекстного меню;
· В модуле «Офис. Клиенты» выберите необходимого клиента и нажмите кнопку «Позвонить» или выберите соответствующий пункт контекстного меню.

Активация автодозвона при снятой трубке не производится, вместо этого осуществляется одиночный набор указанного номера, аналогичный набору с клавиатуры телефона.

Снятием трубки при активном сеансе автодозвона производится прекращение работы сервиса и перевод текущего вызова на линию пользователя. В линию пользователя в любом случае выводится сигнал КПВ до момента получения ответа на вызываемом канале. Режим не действует для SIP без назначенного номера hotline.

Сеанс автодозвона можно прервать в любой момент подняв и положив трубку телефонного аппарата (не действует для SIP без назначенного номера hotline) или нажатием кнопки «Отменить», появляющейся на панели в момент активности сервиса.

Факсы

Во время любой коммутации на панели телефона отображена информация о текущем звонке: абонент на другой стороне и время разговора.

При коммутации пользователя с использованием линии, поддерживающей факсимильную передачу, ему становится доступным сервис управления передачей факсимильных сообщений (у пользователя должно быть выставлено право на работу с факсами). При коммутации появляется кнопка «Факс» с меню из элементов «Принять» и «Отправить».

При отправке в диалоговом окне выбираются файлы изображений, конвертируются при необходимости в правильный формат и после разрыва текущей коммутации начинается передача факсимильного сообщения. В любой момент операцию можно прервать и вновь перейти в разговор, нажав в появившемся на панели модуля телефона кнопку «Отмена», либо кнопку FLASH на телефоне. Для завершения операции без возвращения в разговор достаточно положить трубку.

Принимая факсимильное сообщение, в диалоговом окне выбирается файл для сохранения изображения в формате *.bmp или *.tiff (в зависимости от типа CTI плат). При получении более чем одного документа сформируется несколько файлов, где к имени выбранного файла будут добавлены строки «_page1», «_page2» и т.д. В любой момент операцию можно прервать и вновь перейти в разговор, нажав в появившемся на панели модуля телефона кнопку «Отмена», либо кнопку FLASH на телефоне, при этом полученные к этому моменту части документов сохранены не будут. Для корректного сохранения необходимо дождаться полного завершения сеанса. Для прерывания операции без возвращения в разговор достаточно положить трубку.

ВНИМАНИЕ! Уточняйте формат работы факс-модуля в каждом конкретном случае программного и аппаратного обеспечения, так как детали зависят от типа плат, от версии драйвера, а также от версии ПО. Среди зависимых параметров: формат передаваемых страниц, разрешение, способ именования полученных документов, лицензии на факс-сеансы (для плат семейства Ольха-9).

Гарнитуры

При работе с гарнитурами, USB-телефонами и прочими устройствами, управлением которых занимается модуль подключения VoIP-телефонов (программный шлюз Oktell), функционал модуля расширяется. При этом все описанные выше сервисы остаются также доступны.

В левом нижнем углу появляется пиктограмма гарнитуры, нажатием на которую вызывается диалоговое окно выбора устройств.

Среди перечня устройств отображены те из них, модули управления которыми найдены в корневом каталоге клиентского приложения. Существует возможность менять устройства «на лету». Исключение составляет случай, когда ведется разговор. В этом случае необходимо его завершить, и только потом переназначить устройство. Однако система не блокирует переключение в этом случае, но весьма возможна потеря звука.

В окне выбора устройств для всех видов VoIP-модулей доступен выбор кодека. Использование того или иного кодека зависит от инфраструктуры рабочего места. Кодеки серии G.711 обеспечивают наибольшее качество и минимальные затраты на перепаковку, однако их объем передаваемых данных достаточно велик (64 кБит/с в каждую сторону). В локальной Ethernet сети это не играет большого значения. Кодек MS GSM 0610 существенно снижает трафик и способен работать в более узких каналах данных (13 кБит/сек в каждую сторону), однако производит дополнительную нагрузку на процессор (упаковка звука) и имеет более низкое качество звука по сравнению с G.711. Использование MS GSM 0610 рекомендуется на удаленных клиентских рабочих местах, подключенных через сеть Internet, через узкие, а также через тарифицируемые по трафику каналы. Установка кодека влияет как на входящий поток данных, так и на исходящий. При коммутации каналов, у которых установлены различные кодеки, приоритет отдается кодеку с меньшим трафиком.

Выпадающие списки «Динамик» и «Микрофон» позволяют назначать в качестве устройств вывода и ввода звука существующие в системе звуковые устройства. Категорически не рекомендуется в целях обеспечения стабильности работы приложения менять эти параметры во время активности устройства (разговора, воспроизведения и т.п.).

Флаг «Использовать DirectX» позволяет изменить способ работы со звуком. Использование DirectSound возможно в случае, если на компьютере установлены библиотеки DirectX версии не ниже 8.

Выбрав в качестве устройства аналоговую гарнитуру, подключаемую к jack разъему звуковой карты, за отсутствием у нее всяческих элементов управления (цифровых кнопок, кнопки снятия трубки / сброса ), модуль телефона приобретает несколько дополнительных кнопок:

· Поднять трубку;
· Положить трубку;
· Завершить;
· Flash;
· Ответить

и переходит в режим работы по обслуживанию гарнитуры. В качестве устройств ввода и вывода могут быть назначены любые звуковые устройства, существующие в системе, в частности, даже несоответствующие тому типу телефона, который выбран.

Для jack-гарнитуры доступны параметры автоматического реагирования при поступлении вызова или при поступлении сигнала отбоя.

Также при работе с jack-гарнитурой для набора цифр и управляющих команд можно использовать цифровую часть клавиатуры (NumPad). Для этого в окне выбора устройств необходимо выставить соответствующий флаг. Следует отметить, набор цифр производится только в режиме снятой трубки, а клавиши «+» и «-» на цифровой клавиатуре заменяют собой основные кнопки действий. Поскольку команды взаимоисключены и контекстно-зависимы, кнопка «+» заменяет команды «Поднять трубку», «Завершить / положить трубку» и «Ответить», а кнопка «-» заменяет команду «Flash».

ВНИМАНИЕ! Для включения режима управления гарнитурой с клавиатуры необходимо выставить галку в настройках, проконтролировать отсутствие или отключенное состояние флага в конфигурационном файле клиентского приложения, блокирующего перехват действий клавиатуры, а также включить режим SCROLL LOCK. При активации режима управления любое нажатие кнопки на цифровой клавиатуре будет приводить к соответствующему действию с телефоном вместо стандартных действий в том приложении, которое активно в данный момент (например, «+» будет приводить к снятию трубки или завершению разговора в зависимости от того, какая команда доступна в данный момент). Режим управления активен в любых приложениях и окнах. Для его деактивации достаточно отключить режим SCROLL LOCK. Для набора цифр необходимо также чтобы был включен режим NUM LOCK (автоматически включается вместе с включением SCROLL LOCK).

ВНИМАНИЕ! Категорически не рекомендуется в целях обеспечения стабильности работы приложения менять устройства ввода и вывода звука во время активности устройства (разговора, воспроизведения и т.п.).

Конференц-связь

Конференция - особый режим коммутации, при котором в один разговор объединяется произвольное число каналов. Различаются два основных вида конференц-связи: собственно конференция (все каналы имеют одновременно равные права и осуществляют передачу голоса) и селекторное совещание (пользователь, управляющий конференцией, определяет, кто может говорить, а кто только слушать).

Управляющий - пользователь системы, который имеет монопольный доступ к настройкам конференции. Он производит необходимые изменения свойств, выставляет права последующего доступа к записи конференции, осуществляет приглашения, разрешает или отклоняет запросы на вход в конференцию. Также ему доступно право передать свои обязанности управляющего другому пользователю.

У конференции также есть создатель. Это свойство не подлежит изменению. Создателем является тот пользователь, который инициировал конференцию любым способом (через модуль управления в клиентском интерфейсе или через IVR-сценарий) и задал начальные настройки.

Создатель обладает возможностями управляющего в то время, когда управляющий пользователь не присутствует в конференции. Таким образом, например, поддерживается сбор участников закрытого селекторного совещания секретарем.

Управляющий - свойство селекторного совещания. В конференции его роль выполняет создатель. Создатель может сменить свойства конференции, перевести ее в селекторное совещание и назначить управляющего.

В системе может существовать одновременно произвольное число конференций. С точки зрения коммутаций, каждый канал может одновременно находиться лишь в одной конференции, однако логически пользователь может быть вовлечен в несколько конференций и находиться в них в разных состояниях. Например, нажав FLASH, он может дозвониться до другой открытой конференции. В то же время поступающее приглашение из третьей конференции в этот момент застанет его занятым, но тем не менее сделает участником.

Каждая конференция помимо идентификатора имеет числовой номер, являющийся номером комнаты, в которой происходит конференция. В один момент времени не может существовать двух конференций с одинаковым номером. Указание этого номера дает возможность осуществлять вход в конференцию из сценария IVR. В случае, если конференции с таким номером не существует, и пользователь имеет соответствующие права, установленные в компоненте сценария и в привилегиях, происходит создание новой конференции.

По режиму доступа конференции разделяются на свободные, закрытые и с подачей запроса управляющему. Последний режим доступен только для селекторных совещаний, так как требует обязательного наличия управляющего. При запросе входа управляющий селекторного совещания получает уведомление и может по своему усмотрению решить, пускать пользователя в конференцию или блокировать его вход. При этом если вход осуществляется из сценария IVR, то соответствующий компонент сценария в течение настроенного интервала ожидания подтверждения находится в пассивном состоянии. У управляющего в клиентском интерфейсе в строке с именем участника, запросившего право на вход, находятся две кнопки-пиктограммы - разрешающая и запрещающая.

Создание и подключение к конференциям.

Создание конференций может происходить в клиентском интерфейсе и из сценариев IVR.

Для создания конференций необходимо наличие у пользователя соответствующей привилегии. Для создания конференций из клиентского интерфейса пользователю также необходимо право доступа к модулю управления конференциями.

Создание конференций через сценарии IVR подробно рассмотрено в разделе «Сценарии IVR. Компоненты. Вход в конференцию».

Модуль управления конференциями клиентского интерфейса позволяет при создании задавать свойства конференции, рассылать приглашения участникам, выставлять права доступа к записи и прочие права. В любой момент времени свойства конференции могут быть изменены управляющим или создателем в его отсутствие.

Конференция существует, пока в ней есть хотя бы один участник с активным состоянием (вызываемый конференцией, находящийся в коммутации, или осуществляющий размещение конференции во flash-буфере). Однако управляющий конференции через контекстное меню модуля управления конференциями клиентского интерфейса может в любой момент завершить конференцию. При этом все активные каналы получат отбой.

Подключение к конференции может быть осуществлено несколькими способами.

· Подключение по инициативе пользователя. Любой пользователь, которому доступен модуль управления конференциями, может видеть список активных конференций. В случае, если доступ к конференции не закрыт, у пользователя имеется возможность входа в конференцию щелчком мыши на соответствующей ссылке. Если в конференции настроен вход по разрешению управляющего, то при этом будет произведен запрос. В случае разрешения (или свободного доступа к конференции) на привязанный к рабочему месту телефон поступит вызов из модуля управления конференциями. Канал должен быть свободен, в противном случае приглашение будет положено в его очередь.
· Подключение через сценарий по инициативе абонента. Любой абонент, (как пользователь системы, так и внешний) может осуществить вход в конференцию по своей инициативе (с проверкой прав) через сценарий IVR. Для этого в сценарии IVR существует компонент «Вход в конференцию». Разумеется, логика сценария может быть реализована различным образом. Например, пользователи системы могут иметь внутренний номер, запускающий сценарий IVR, который осуществляет распределение или запрос номера комнаты для подключения к конференции. В то же время внешние абоненты могут подключаться таким образом к конференциям исходя из алгоритма сценария.
· Подключение по инициативе управляющего. Управляющий (или создатель в его отсутствие) в модуле настройки конференции может рассылать приглашения пользователям. В окне выбора участников конференции (вкладка «Участники») отображаются все пользователи системы и их состояния в реальном времени, а также состояния относительно конференции. При отправке приглашения какому-либо пользователю системы ему отсылается уведомление и в очереди канала размещается вызов из конференции. Как только канал получит вызов, пользователь будет введен в конференцию и в его клиентском интерфейсе (в случае наличия) будет отображен состав участников. Если канал недоступен, пользователь автоматически будет выведен из конференции. Управляющему в окне приглашений будет отображено состояние и причина неудачного приглашения.
· Подключение по инициативе участника конференции. Управляющий, создатель и любой другой участник конференции (при соответствующим образом настроенном свойстве конференции) может приглашать других участников с помощью телефона путем размещения конференции во Flash-буфере, соединения с другим абонентом и переключением конференции на него (нажимает FLASH, набирает номер абонента, соединяется с ним, кладет трубку). При наличии у участника конференции клиентского модуля управления в модуле «телефон» будет активна кнопка включения абонента в конференцию, в этом случае не будет необходимости снова осуществлять вход - после ее нажатия оба (и участник и абонент) окажутся в конференции. В общем случае также существует возможность обратного переключения, когда из коммутации с абонентом через Flash-буфер производится переключение его на конференцию.
· Подключение через модули клиентского интерфейса. Из контекстного меню модуля «Сотрудники» управляющий или участник конференции в случае установленного на то разрешения может пригласить в конференцию любого абонента. При этом вызов осуществляется на внутренний номер. В случае, если номер занят, приглашение будет размещено в его очереди.

Настройка конференций при создании и в ходе проведения.

При создании конференции из клиентского интерфейса у пользователя открывается окно свойств с возможностью задать начальные настрйоки, выбрать участников, а также установить права на доступ к записи.

В ходе проведения конференции у управляющего (или создателя в его отсутствие) имеется возможность изменения свойств и приглашения новых участников.

В момент создания конференции участники приглашаются отложенно, их фактический вызов происходит только после создания конференции. В момент же настройки уже активной конференции вызовы происходят моментально. В окне выбора участников доступен поиск, фильтрующий имена пользователей по введенным в строке поиска символам. В окне представлены состояния всех пользователей системы с отслеживанием изменений в реальном времени.

Селекторное совещание.

Используется для проведения совещаний с контролируемым режимом допуска к проведению разговора. Селекторное совещание может управляться только из клиентского интерфейса. Управляющий (или создатель в его отсутствие) определяет кто из участников в данный момент может говорить и включает/выключает микрофон микшера конференции щелчком мыши на пиктограмме с громкоговорителем. При одновременно нажатой клавише Ctrl включение микрофона у произвольного участника приводит к выключению микрофонов у всех, кроме самого управляющего, оставляя тем самым активными только двух участников.

Все абоненты, подключающиеся к селекторному совещанию по умолчанию не имеют права голоса до соответствующего разрешения. При наличии у участника клиентского интерфейса и отсутствия на момент времени права голоса он может выразить свое желание высказаться нажатием кнопки «Хочу сказать». Также произоводится и отмена. Управляющий (а также все участники конференции) увидят мигающую пиктограмму в строчке с именем участника, активировавшего режим.

При переводе селекторного совещания в конференцию у всех участников автоматически активируются микрофоны.

Прослушивание записей.

К информации о прошедших конференциях и к их записям предоставляют доступ модули раздела «Офис»: «Статистика АТС» и «Мои звонки».

Прослушивание записи конференции разрешено управляющему и всем участникам конференции, если иное не было выставлено в свойствах конференции управляющим или создателем в его отсутствие в момент активности конференции. Доступны 3 режима доступа к записи: только управляющий, все участники, указанные пользователи. Запись также доступна всем пользователям, контролирующим тех, кому разрешен доступ.


Серверное приложение (служба)


Серверное приложение (служба)

Сервер существует в двух разновидностях: как приложение и как служба.

Они работают идентично и полноценно с разницей в общении с приложением.

Служба сервера Oktell, как и другие службы операционной системы, имеет возможность регистрировать свои ошибки в системных журналах событий. При обнаружении ошибок, а также исключительных ситуаций, таких как сбой питания или непредвиденные аппаратные проблемы, служба автоматически перезапускается и ведет себя как предписывают ей многочисленные системные настройки, установленных администратором сервера. Служба не имеет оконного интерфейса. Все события, происходящие в логике, отражаются в собственных лог-журналах сервера Oktell.

Оконное приложение, регистрирующее сервер имеет преимущество в удобстве и быстроте запуска, а также в возможности просматривать сервисный лог-журнал в реальном времени в окне приложения.

Начальные настройки сервера определяются файлом конфигурации, где указаны пути к БД, к аппаратным драйверам и прочая сервисная и отладочная информация. После запуска сервера идет обращение в БД и загрузка установок администратора системы Oktell.

В каталоге сервера помимо сборок находятся:

· Каталог со сценариями (SCRIPTS);
· Файлы с необходимыми для автоматического озвучивания числительными (SCRIPTS\IVR\_StandardExpressions);
· Каталог со звуковыми файлами, используемыми при ожидании в различных очередях (SND);
· Часть драйверов и загрузчиков аппаратных ресурсов сервера (_Loaders);
· Каталог по умолчанию для файлов-записей разговоров (RecordedFiles);
· Каталог с лог-журналами различных модулей серверного приложения (Log).
· Приложение ServerCopier, которое совместно со служебными задачами может быть использовано для автоматического перезапуска сервера по расписанию.

При необходимости, вы можете переносить и копировать служебные файлы одной копии сервера в другую.

Все лог-журналы находятся в папке «LOG» в каталоге сервера. Сервер непрерывно пишет информацию в лог-журналы, разделенные по смысловым направлениям. Каждый день в соответствующем каталоге появляется новый файл с текущим журналом. Логи хранятся ровно неделю, после чего автоматически удаляются в связи с потерей актуальности и экономией дискового пространства (время хранения можно изменять в конфигурационных файлах). При полной трассировке объем лог журналов может доходить до 500 МБ в день. Отдельные сервисы можно отключать от трассировки выставлением соответствующих флагов в конфигурационном файле сервера в «0». Файловое представление лог журналов включает в себя:

· Лог исключительных ситуаций (Log\Exception);
· Лог сервисных операций АТС, менеджера задач, обработчика сценариев (Log\Service);
· Лог-трассировка встроенного контролера исполнения команд (Log\WatcherTrace);
· Лог исключений встроенного контролера исполнения команд (Log\Watcher);
· Лог прочих сообщений (Log\Common);
· Лог аппаратной части (Log\HW). Здесь находится древовидная файловая система аппаратных лог журналов Общий журнал, а также журнал каждого из аппаратных серверов, существующих в системе. Каждый сервер имеет общий журнал и отдельно журнал для каждого канала.

При необходимости решения проблем детально описывайте произошедшие обстоятельства, указывайте время и прикладывайте лог-журналы за интересующий день. Сборщик журналов находится в разделе «Общие настройки. Сборка лог-журналов».

Подробнее о некоторых аспектах функционирования сервера вы можете узнать в разделе «Принципы работы логики» или обратившись за справками к поставщику или разработчику. Также большой перечень вопросов вы можете закрыть, изучив логику работы сервера с точки зрения клиентского приложения, описанную в разделе «Клиентское приложение».


Дополнительно

В этом разделе:

— Принципы работы логики

— Возможные проблемы и способы их устранения

— Перечень файлов, необходимых для озвучивания числовых значений

— Структура пространственной БД

— Порты, используемые системой

— Параметры файлов конфигурации

— Форматы звуковых файлов

— Подключение внешних БД

— Обеспечение бесперебойности работы

— Резервное копирование баз данных

— Порядок обновления программы в ручном режиме

— История обновлений. Новые возможности


Принципы работы логики

 Содержание | Назад | Далее

В этом разделе:

— Менеджер очередей

— Сервис автодозвона

— Менеджер голосовых задач


Менеджер очередей

Все звонки на стандартные внутренние номера осуществляются с помощью единого механизма, называемого менеджером очередей Oktell. Подробнее о номерах в разделе «Администрирование. Внутренние номера».

Стандартные внутренние номера оперируют правилами. Правилом является список объектов дозвона (линий, пользователей, других внутренних номеров), снятие трубки на линии одного из которых будет считаться успешным дозвоном. В соответствии с правилом, каждый из объектов имеет время начала и продолжительность выдачи сигнала поступления звонка.

Обработчик очереди ждет осуществления одного из событий:

· один из объектов снял трубку;
· время очереди истекло (определяется настройками системы);
· после таймаута входящего вызова последнего из объектов очереди;

Если при звонке на номер все объекты номера заняты, он сразу задействует механизм очереди ожидания. В вызывающую линию будет воспроизведена мелодия ожидания. По мере освобождения объектов обработчик начинает их вызов. Коммутация произойдет, как только один из вызываемых объектов снимет трубку при вызове из обработчика очереди. При переключении с помощью компонентов сценариев IVR в обработчик могут быть переданы параметры работы, в частности, отказ от использования очереди ожидания.

Если при звонке на номер обработчик находит объекты, свободные для дозвона, он начинает отсчет времени, соответствующий распределению времен вызовов объектов в правилах стандартных внутренних номеров (раздел «Администрирование. Внутренние номера»). С течением времени постоянно осуществляется проверка на необходимость начать вызов какого-либо из объектов в соответствии с правилом, либо наоборот. В момент прекращения вызова обработчик в зависимости от настроек системы может перевести объект, не отреагировавший на поступивший звонок, в состояние «Отсутствует». Объекты, находящиеся в состояниях, отличных от «Готов», не вызываются в дальнейшем. В распоряжении обработчика 90 секунд на попытку дозвона без использования очереди. По истечении 90 секунды обработчик ведет себя в соответствии с настройкой «Повторить цикл обработки». Если флаг не стоит – выдает отбой в вызывающую линию. Если стоит – переводит звонящую линию в очередь ожидания занятых линий и воспроизводит мелодию ожидания.

Проверка очереди ожидания осуществляется вызываемыми объектами при переходе в состояние «Готов». Вызов объекта осуществляется в промежутке времени 60 секунд, по истечении которого он переводится в состояние «Отсутствует» в зависимости от настроек системы.

В вызывающую линию выдаются длинные гудки, если по ее запросу в реальном времени звонит хотя бы один телефонный аппарат и музыку очереди ожидания, если в реальном времени информация о звонке находится в очереди хотя бы одного объекта из правила набираемого номера

В остальных случаях в вызывающую линию передается сигнал отбоя.

Размещение звонка в очереди осуществляется на основании приоритета звонка, который задается в модуле общих настроек и может быть подвергнут корректировке в сценариях IVR. При выемке объекта из очередей вызываемым объектом выбирается объект с наибольшим приоритетом (наименьшим числом-индексом приоритета в установках). Среди первых размещенных в очередях звонков с одинаковым приоритетом выбирается тот, время ожидания которого максимально.

Система приоритетов может быть использована, например, для организации быстрого осуществления внутренних звонков в офисе при полностью загруженных входящими извне звонками пользователях, для выделения и сверхсрочной обработки вип-звонков, а также для организации сервисов многоуровневого меню IVR с вложенными ожиданиями, доведением информации и размещении в верхнем уровне списка.


Сервис автодозвона

Режим автодозвона включается автоматически при наборе номера из модуля «Телефон» в клиентском приложении. Также через модуль «Телефон» работает набор внутренних номеров из модуля «Офис. Персонал», внешних номеров из модуля «Офис. Клиенты», а также переключение на номера всех типов из диалоговых форм оператора.

При входе в сервис автодозвона производится попытка резервирования линии вызывающего оператора. В случае успеха резервирование остается до момента окончания работы сервиса. Если оператор свободен (также свободна его телефонная линия), сервис автодозвона задействуется в полном варианте. Если же у оператора снята трубка (и он не находится в коммутации или ожидании соединения), то сервис автодозвона осуществляет только одну попытку, после организации которой передавая право ожидания непосредственно в линию оператора.

Сервис организует работу очереди ожидания в случае звонка на внутренний номер и цикл попыток дозвона по внешним линиям, если звонок осуществляется на внешний номер (городской или мобильный). Звонки на внутренние номера действуют согласно настройкам очереди, а звонки на внешние номера действуют согласно настройкам автодозвона (модуль «Администрирование. Общие настройки»).

После получения ответа от абонента, до которого осуществляется дозвон, сервис воспроизводит в его линию мелодию ожидания соединения с оператором, одновременно начиная обратный вызов оператора.

В любой момент времени оператор может снять трубку и прервать сервис автодозвона, при этом текущая работа сервиса будет полностью переведена под ведение системной АТС Oktell. Таким образом, чтобы прекратить вызов с использованием автодозвона, достаточно снять трубку на телефонном аппарате и положить ее на место.


Менеджер голосовых задач

Общие принципы

Логика этого блока достаточно глубока и в большей части не связана с клиентскими интерфейсами. Некоторые основные и заметные пользователю (администратору) принципы:

· Пока пользователь назначен в задачу, он считается зарезервированным. Время резерва также включает в себя предвызывную и поствызывную обработку.

· При переключении звонка на другого оператора системы резервирование также переходит к нему. Переходит в этом случае и текущая форма сценария диалога.

· При переключении абонента на сценарий IVR резервирование с оператора снимается. Продолжать выполнение задачи начинает сервис IVR, который при необходимости может повторно переключить на того или иного оператора или пользователя, либо самостоятельно определить результат звонка. В нетривиальных входящих кампаниях довольно часто возможны случаи, когда после обработки в задаче фронт-офиса необходимо переключить звонок на другую задачу с другим набором ответственных операторов. Это становится возможным при переключении абонента на сценарий IVR с одновременным выходом из текущей задачи (необходима соответствующая настройка задачи на вкладке «Дополнительно» модуля «Call-центр. Голосовые задачи»).

· В исходящих задачах список абонентов и их номеров обновляется в соответствии с настройками синхронизации, а также каждый раз при завершении цикла прохода по списку, но не чаще чем раз в минуту.

· Обработка каждого звонка по задаче в сценариях всех типов может непосредственно использовать информацию из таблицы абонентов в строке, соответствующей абоненту, звонок которому находится в обработке.

· В качестве таблиц абонентов может быть использована любая таблица БД и даже запрос. Доступ к полям прикрепленной таблицы возможен, если таблица абонентов локальная, либо внешняя с явно указанной базовой таблицей БД. Однако отсутствие базовой таблицы не исключает возможность использования запроса для формирования списка абонентов для совершения исходящих звонков.

· При использовании больших таблиц абонентов, а также в случае работы большого количества задач со средними размерами таблиц, работу с ними во избежание переполнения памяти необходимо производить в режиме прямого доступа к БД. Переключение в этот режим не производится автоматически и является свойством задачи. В этом режиме в памяти сервера не создается кэш-образ таблицы, содержащий коды и номера телефонов, однако при значительной масштабности проекта существенно увеличивается плотность обращений к серверу баз данных. При использовании ограниченных версий MS SQL SERVER (MSDE и Personal edition) это может повлечь переполнение числа доступных пулов подключений и как следствие торможение работы всего комплекса в местах обращения к БД. В этом случае необходимо использовать разграничение доступа к БД; максимальное количество выделяемых подключений настраивается в модуле общих настроек в разделе «Управление сервером».

· Запрос в таблице абонентов может возвращать любые наборы данных, в которых есть идентификатор клиента и по крайней мере одно поле с телефонами. Телефоны могут быть как в разных полях, так и в одном поле через разделители (любые символы, кроме «*#123456789-()»). Телефоны могут содержаться даже в разных записях, имеющих один идентификатор. Поле идентификатора – целочисленное. При внесении через стоп-форму дополнительных номеров абонента, они заносятся через запятую в первое, обозначенное типом «Телефон», поле таблицы. Это возможно в случае, если соответствующее поле имеет достаточно большую емкость символов, а также если указана базовая таблица БД.

· После установки соединения с абонентом обратный дозвон до оператора будет производиться без учета правил переадресации.

· После дозвона до абонента и до поднятия трубки оператором абоненту воспроизводится мелодия ожидания соединения с оператором (общая, либо установленная задаче).

· Оператор, будучи зарезервированным на выполнение звонка по задаче, может снять трубку на телефоне и вместо привычного тона АТС услышит мелодию ожидания соединения с абонентом. При дозвоне до абонента в трубку телефона оператора воспроизводится щелчок и мгновенно следует коммутация. Такую же мелодию ожидания оператор слышит в трубке телефона в любой другой момент, находясь в зарезервированном задачей состоянии.

· При поступлении звонка по входящей задаче и отсутствии свободных операторов может быть задействована очередь ожидания. Первый снявший трубку оператор получит на обработку первый звонок из очереди. Очередь ожидания задачи задействуется только в случае, если разрешено ее использование соответствующей настройкой задачи (вкладка «Дополнительно») и свойством «Очередь» компонента «Вход в задачу» . Если одно из свойств отключено, будет осуществлен возврат в сценарий голосового меню. Вход в задачу осуществляется из сценария IVR и может получить отказ по нескольким веткам, соответствующим разным неподходящим состояниям задачи.

· Входящая задача может в своем распоряжении иметь таблицу абонентов. Это может быть использовано для маршрутизации, VIP-обслуживания, а также для создания анкетных таблиц в соответствии с задачами кампании.

· Время нахождения абонента в очереди может быть ограничено настройками задачи. В этом случае происходит возврат управления в обрабатывающий входящий звонок сценарий IVR по ветке «Время ожидания в очереди истекло».

· При постановке в очередь задачи учитывается текущий приоритет звонка, выставленный в сценарии.

· Использование очереди абонентов в задаче можно отключить. Это будет влиять как на входящие задачи, так и на исходящие задачи с прогрессивным и/или предиктивным набором.

· Личная очередь оператора анализируется не при опускании трубки, а после поствызывной обработки звонка по задаче.

· При отсутствии прикрепленного к задаче сценария диалога, а также в случае, если сценарий не был завершен, по завершении звонка появляется форма запроса успешности звонка (и необходимости перезвонить позднее с указанием времени). Если Вы используете собственные обработчики диалогов, и/или если Вам требуется особое ее поведение – пользуйтесь свойством «отображать стоп-карту» компонента «Стоп», а также служебными переменными сценария. Подробно в разделе «Сценарии диалога. Стоп-форма».

· В случае использования прогрессивного, предиктивного или их совмещенного наборов операторы резервируются в пул без привязки к конкретным абонентам. При уменьшении числа операторов мгновенной реакции не следует, однако эта информация используется при появлении возможности совершить очередной звонок. При выходе последнего оператора все звонки прекращаются, очередь абонентов обрывается, и соответствующая запись заносится в информацию о результате звонка.

· Обзвон с резервированием операторов наиболее лояльный к абонентам, но наименее продуктивный. Прогрессивный набор номеров менее лояльный, но существенно более эффективный, особенно при числе операторов > 2 и числе линий, существенно превышающем число операторов (эффективная зависимость нелинейна). На лояльность прогрессивного набора достаточно сильно влияют параметры задачи. Предиктивный дозвон лоялен только при малой дисперсии длительности разговора, а достаточно эффективен при качественной абонентской базе. Наиболее гибко работает совмещенный прогрессивно-предиктивный механизм на задаче из более двух операторов, однако найти точку оптимальности для параметров, зависящую от числа линий, операторов и качества абонентской базы достаточно трудно.

· Вся информация по звонкам, состояниям операторов и очередей моментально кладется в статистическую пространственную БД Oktell и становится доступна для построителей статистики.

· Состояние перерыва, выставляемое оператором внутри call-центра, позволяет ему вести личные разговоры. По завершении подобных разговоров статус перерыва не пропадает.

· Вход в режим «call-центр» мгновенно вводит оператора в перечень ресурсов и менеджер задач при дальнейшей обработке использует его наравне с другими ресурсами. Выход из режима «call-центр» прерывает текущий разговор оператора, завершает выполнение итерации задачи с занесением соответствующей информации в статистику.

Исходящее оповещение

Исходящее оповещение может производиться несколькими вариантами в соответствиями с настройками задачи. Одновременно менеджер задач производит работу со всеми активными задачами. Рекомендуется оптимально распределять ресурсы в случае, если необходимо производить работу одновременно нескольким задачам. В противном случае возможна ситуация, когда все ресурсы захватываются для работы одной задачей, а все остальные стоят без движения. Это становится возможным, если на задачи назначены одни и те же операторы и линии, а также при относительно большом списке абонентов в доминирующей задаче.

Для решения проблемы распределения общих ресурсов по разным задачам, одновременно производящим работу, пользуйтесь настройкой менеджера задач «Общие настройки. Менеджер задач. Приоритет исходящих задач».

У задач исходящего оповещения, обслуживаемых операторами, существует несколько принципиально отличающихся методик работы, настраиваемых при редактировании задач выбором типа. Каждый из типов задействует строго определенный пул дозвона с присущей ему спецификой.

Задачи с резервированием оператора и общим списком.

К таким задачам относятся задачи «с запросом подтверждения» и «с уведомлением». При благоприятных условиях активируется пул и у оператора появляется запрос подтверждения на дозвон. Существуют две разновидности задач с запросом: с простым запросом и с диалоговым сценарием запроса.

· В случае простого запроса у оператора после его резервирования в задачу появляется форма с информацией об абоненте (все поля из списка, отмеченные при настройке как информационные), и возможностью подтвердить согласие оператора на осуществление звонка, пропустить обработку (выставляется пауза для абонента и происходит переход к следующему) или отклонить абонента от дальнейшей обработки в задаче.

· В случае с диалоговым сценарием у оператора по созданному и назначенному супервизором сценарию производится обработка данных, отображение соответствующих форм, веб-узлов, запуск приложений и т.п., результатом которых является принятие решения о согласии в совершении звонка, пропуске или отклонении с переходом к следующему абоненту и новой итерации сценария. В сценарии доступны поля из прикрепленной таблицы абонентов по выбранному задачей абоненту, а также все другие возможности и функции сценариев диалога, описанные в разделе «Call-центр. Сценарии. Сценарии диалога». Для анализа менеджером задач анализируется соответствующая служебная переменная сценария диалога.

В случае отказа от звонка по той или иной причине производится завершение обработки текущего абонента, прерывается резервирование ресурсов и производится повторный анализ ситуации.

После подтверждения осуществления звонка у оператора поверх рабочего стола отображается информационное окно с информацией об абоненте из прикрепленной таблицы.

Задачи с резервированием без запроса не требуют подтверждения начала осуществления звонка оператором, что позволяет сэкономить некоторое время, которое уходит у оператора на предвызывную обработку.

Задачи с резервированием (в особенности с запросом подтверждения) имеют самую низкую производительность, поскольку под одного оператора звонок осуществляется только по одной линии, и в связи с жесткой зависимостью этапов резервирования, предвызывной обработки и дозвона время суммируется и пропорционально увеличивается.

ВНИМАНИЕ! В задачах с запросом подтверждения существуют два возможных варианта проведения резервирования линии: до запроса и после получения положительного ответа от оператора. Настройка существует глобально в системе в модуле общих настроек в разделе call-центра, а также дублируется в свойствах задачи для установления индивидуальных параметров.

В первом случае, если линии, назначенные в задачу доступны для входящих звонков, существует вероятность получения вызова по ней и вывода из резервирования, что может отразиться некорректно на совершении вызова после получения подтверждения.

Во втором случае при использовании линий задачи совместно с другими задачами или с АТС существует вероятность, что после получения подтверждения доступных линий обнаружено не будет и дозвон не начнется, а вместо него резервирование с оператора будет снято.

Необходимо аккуратно анализировать и применять это свойство.

Задачи с распределенным списком и ручным выбором абонентов.

Задачи с распределенным списком дают несколько дополнительных возможностей, однако существенно ограничивая динамику в работе задачи. Супервизор средствами комплекса при настройке задачи производит распределение абонентов из прикрепленной таблицы по операторам, назначенным в задачу. В дальнейшем каждый оператор производит работу только с ввереными ему абонентами.

Супервизор получает возможность контролировать ход выполнения задачи, а также производить управление, перебрасывая определенные группы абонентов от одного оператора к другому в модуле управления ресурсами.

Подобный тип организации работы дает возможность выстраивать многопроходные задачи, в которых более востребованные операторы подключаются только по мере получения определенных состояний, например при прорыве «барьера секретаря». А также в задачах со строгой отчетностью, где операторы получают в работу группу абонентов на долгое время и повторная обработка абонента другим оператором не допускается.

Оператор имеет возможность выбора абонента перед началом звонка (из своего списка абонентов). Ему доступна вся история звонков по задаче, состояния всех абонентов, а также возможность прослушивать записи разговоров по абонентам, с которыми разговор уже состоялся. Особенно актуальным это может оказаться при перемещении абонентов супервизором от одного оператора к другому для вхождения последнего в курс дела.

Окно запроса, появляющееся у оператора предоставляет информацию о последнем звонке, предлагая осуществить дозвон до следующего абонента или же на один из номеров предыдущего абонента.

При нажатии на кнопку «Список всех абонентов» у оператора отображается окно выбора абонентов, где предоставляется информация по состоянию всех незавершенных (по настройкам задачи) абонентам и их номерам. Текстовый фильтр позволяет найти интересующих абонентов по всем информационным полям. Оператору предоставляется возможность отобразить информационные поля, а также служебные поля состояний номеров. Двойным щелчком на плюсе в правой части таблицы открывается история состоявшихся звонков по абоненту с указанием служебных и пользовательских статусов.

Двойной щелчок на строке вне поля с плюсом выделяет выбранный номер для осуществления звонка по абоненту.

Задачи с распределенным пулом по производительности аналогичны задачам с запросом подтверждения на осуществление звонка и отличаются только временем предвызывной обработки. В задачах с распределенным пулом это время может быть увеличено в большую сторону из-за обращения оператора к таблице абонентов и к истории звонков.

При появлении в списке новых абонентов они остаются нераспределенными до момента перемещения их супервизором в модуле управления ресурсами одному или нескольким операторам.

ВНИМАНИЕ! Стоит помнить, что операция перераспределения при редактировании задачи производит разбиение без учета перемещений, осуществленных супервизором.

ВНИМАНИЕ! В задачах с запросом подтверждения существуют два возможных варианта проведения резервирования линии: до запроса и после получения положительного ответа от оператора. Настройка существует глобально в системе в модуле общих настроек в разделе call-центра, а также дублируется в свойствах задачи для установления индивидуальных параметров.

В первом случае, если линии, назначенные в задачу доступны для входящих звонков, существует вероятность получения вызова по ней и вывода из резервирования, что может отразиться некорректно на совершении вызова после получения подтверждения.

Во втором случае при использовании линий задачи совместно с другими задачами или с АТС существует вероятность, что после получения подтверждения доступных линий обнаружено не будет и дозвон не начнется, а вместо него резервирование с оператора будет снято.

Необходимо аккуратно анализировать и применять это свойство.

Задачи с прогрессивным набором.

При обнаружении свободного оператора, задача помещает его в очередь и осуществляет одновременно несколько звонков. Первый успешный вызов сразу коммутируется. Остальные звонки в зависимости от настроек задачи (лояльность, очередь прогрессивного набора) остаются в очереди для других операторов, или прекращаются. Априори достоверно, что прогрессивная схема менее лояльна к абонентам, чем схема с резервированием. Если в очереди ожидающих дозвона находятся несколько операторов, то первый успешный звонок выделяется для первого оператора в очереди. Очевидный факт, что абоненты при исходящем оповещение ждать ответа в основном не намерены. Сервер Oktell при использовании прогрессивной схемы пытается минимизировать время ожидания операторов, взяв в расчет именно этот принцип и практически не давая вырастать очереди абонентов.

Однако существуют настройки задач, при которых абоненты ждут операторов. Такие задачи редко представляют интерес. В этом случае очереди компенсируют друг друга, но лояльность к абонентам существенно снижается.

Прогрессивный дозвон имеет больший смысл, если число линий, выделенных для задачи больше числа операторов, единовременно обрабатывающих задачу. Разумно настроенная прогрессивная схема – крайне эффективный инструмент. В качестве примера можно привести следующий результат в самых крайних условиях: Оповещение одним оператором по двум линиям списка из 10 абонентов, где у каждого абонента от 1 до 5 телефонных номеров и ситуация усугубляется тем, что половина номеров в итоге не отвечает. Для оператора наличие «битых» номеров остается незаметным до самого конца, когда на обеих линиях остаются только абоненты, не имеющие ни одного нормального номера. При увеличении числа линий и числа операторов качество заметно повышается. Более эффективно и менее лояльно прогрессивный дозвон можно настраивать, если число операторов достаточно велико, а время обработки одного звонка достаточно мало.

В схемах, где число линий и операторов, назначенных в задачу, практически одинаково и значительно (20, 30, 40, 50, ...) прогрессивный дозвон экономит время поствызывной обработки и набора номера, производя работу в параллельном режиме, что в некоторых случаях приводит практически к тем же результатам что и в случае с числом линий, превышающим число операторов, а также имеет преимущество, делая невозможным рост очереди абонентов.

ВНИМАНИЕ! Прогрессивный набор при больших объемах таблиц абонентов и использовании большого числа линий и операторов производит серьезную нагрузку на БД. При организации длительных и массовых исходящих кампаний необходимо периодически производить обслуживание баз данных: чистку, переиндексацию, дефрагментацию, сжатие и т.д.

При высокой приоритетности непосредственно процесса исходящего оповещения по сравнению с получаемой многоуровневой статистикой рекомендуется настраивать процесс таким образом, чтобы необходимая статистика формировалась по мере выполнения задачи, а неактуальные данные (например старше 1 дня, 1 недели, 1 месяца в зависимости от конкретной ситуации) в нерабочее время удалялись или переносились из основной базы данных во вспомогательные.

ВНИМАНИЕ! Выбор сервера, обслуживающего БД MS SQL Server, необходимо производить в соответствии с предстоящими кампаниями. Большое значение имеет количество и скорость жестких дисков и объем оперативной памяти. Базу рекомендуется разделить по файловым группам, находящимся на разных жестких дисках для ускорения обработки информации.

ВНИМАНИЕ! При снижении скорости обработки информации в БД пул прогрессивного набора автоматически снижает производительность во избежание некорректных ситуаций, а также уведомляет администраторов и супервизоров задачи о необходимости принятия мер. По достижении порогового значения в скорости обработки пул производит автоматический перевод задачи в неактивное состояние.

Задачи с прогрессивным набором очень эффективное средство, дающее наибольшую производительность при рационально назначенных количественных и ресурсных свойствах. Занятость операторов в зависимости от длительности разговора, соотношения операторы / линии и качества телефонной базы может достигать 90% и более.

Задачи с предиктивным набором.

Такой способ организации задачи опирается на статистику по задаче. Применяя вероятностную модель к накопленной статистике менеджер задач может начать осуществлять дозвон еще до того, как оператор освободится, подгадывая момент получения успеха по звонку к моменту освобождения конкретного оператора. Можно повышать лояльность, сдвигая момент начала дозвона на заданное время относительно прогнозируемого. Каждый формируемый таким образом звонок рассчитывается для конкретного оператора. Однако, при включении предиктивного механизма используется общий механизм очередей. Таким образом, первый полученный звонок получит первый оператор из очереди, вне зависимости для кого он готовился. Предиктивная схема в общем случае менее эффективна и менее лояльна, чем прогрессивная. Но все же при достаточной статистической равномерности предиктивная схема может принести заметную выгоду.

ВНИМАНИЕ! При использовании в задаче большого числа операторов предиктивный набор теряет смысл и в чистом виде существенно уступает прогрессивному.

Возможно использование комбинированной прогрессивно-предиктивной схемы. В этом случае на работу настраивается пул прогрессивного набора, и включается механизм прогнозирования. В общем случае при неизвестном проценте «битых» номеров это наиболее продуктивная схема. При большом числе операторов неровности статистики, использованные в расчете неточного прогноза и понижающие теоретическую лояльность, сглаживаются.


Возможные проблемы и способы их устранения

Сервер не запускается, или запускается долго

· Убедитесь по горящей пиктограмме с зеленым треугольником в трее, что сервер БД Microsoft SQL Server запущен.
· Проверьте настройки в файле конфигурации серверного приложения: «*.exe.config». Имейте в виду, что сервер существует в двух вариантах, и соответственно, файлов конфигурации тоже два.
o Ссылка на базу данных указана верно.
o Логин к БД указан верно.
· Убедитесь в том, что логин указанный в файле конфигурации существует в сервере БД.
· Если сервер запускался до этого, оцените изменения, производимые в настройках системы до перезапуска – правильная ли информация находится в БД о рабочих местах, адресах и серверах.
· Убедитесь в наличии ключа защиты, горит ли на нем светодиод, обнаруживается ли он среди устройств системы. При невозможности корректно использовать USB-порт на сервере, существует возможность удаленного опроса ключа. За подробной информацией обращайтесь в службу технической поддержки.
· Выключите функции энергосбережения USB-концентратора.
· Убедитесь, что установлен Microsoft .NET Framework.
· Если используются многоканальные платы с внутренними линиями – убедитесь в подключении к ним блока питания.
· Убедитесь, что каталог DBAutoUpdate в корне серверного приложения, содержащий обновления для БД, пуст.
· Обратите внимание на лог-журнал исключительных ситуаций серверного приложения, находящихся в каталоге сервера по адресу «Log\Exception\exc_[дата].log». Возможно, в нем будут присутствовать строки, дающие возможность понять причину.
· Убедитесь в указании всех настроек и существовании всех путей для драйверов оборудования.
· Если возникает окно с ошибкой, возможно наличие некорректных значений в файле конфигурации или некорректный его формат.
· Обратитесь в системный лог-журнал операционной системы в поисках ошибок и особых ситуаций.
· Отправьте лог исключений поставщику для решения вашей проблемы с описанием того, что происходило с системой до и во время запуска. Если считаете необходимым, приложите скриншоты экранов.

Клиентское приложение не запускается (не появляется окно авторизации)

· «Программа уже запущена».
o Одновременно на компьютере невозможно запустить более 1 копии приложения в связи с монопольным доступом к драйверам системы.
o В случае использования в терминальном режиме убедитесь в наличии в файле конфигурации клиентского приложения строки «Terminal_Address» и уникальности значения ее ключа.
· Окно с ошибками.
o Убедитесь в наличии Microsoft .NET Framework.
o Убедитесь в наличии всех библиотек приложения.
o Убедитесь в наличии библиотек «DevExpress*.dll».
o Убедитесь в наличии сборок клиентского приложения в серверном каталоге и их корректности.
o При редактировании конфигурационного файла вручную используйте блокнот, иначе возможна потеря в текстовом формате символов, определяющих кодировку, и дальнейшая загрузка будет невозможна без восстановления файла конфигурации.
· Убедитесь, что права текущего пользователя ОС дают возможность работать с файлами и веткой «HKEY_CURRENT_USER» реестра.
· Убедитесь, что текущий пользователь ОС имеет право на полный доступ к папке с установленным клиентским приложением Oktell. Следуйте инструкциям в разделе «Установка клиентского приложения».
· Обратите внимание на лог-журнал исключительных ситуаций запускающего модуля, находящихся в каталоге клиентского приложения по адресу «Log\Starter\str_[дата].log». Возможно, в нем будут присутствовать строки, дающие возможность понять причину.
· Отправьте конфигурационный файл и лог-журналы клиентского приложения за текущий день поставщику для изучения, снабдив описанием (скриншоты, последовательность действий, а также действия, после которых произошло изменение поведения приложения).

Клиент не обнаруживает сервер при авторизации или существенная задержка в откликах

· Посмотрите, правильно ли указаны ссылки на сервер в файле конфигурации клиентского приложения.
· Проверьте сеть, и связь с сервером по адресу из файла конфигурации (командой «PING»).
· В случае установки на сервере более 1 сетевого адаптера, сделайте адаптер, слушающий сеть подключения клиентов первым (Сетевые подключения -> Меню «дополнительно» -> Дополнительные параметры). Если необходимо обеспечить доступ двум сетям, назначьте клиентским компьютерам, не обнаруживающим сервера, дополнительный шлюз с указанием адреса сервера (адрес сетевого интерфейса, обслуживающего сеть, к которой подключен конкретный клиент).
· В файле «<SystemRoot>\System32\Drivers\ETC\hosts» сервера укажите имена и адреса компьютеров сети (в серверный файл внесите информацию об операторском компьютере, а в файл на операторском компьютере внесите информацию о сервере);
· Проверьте подключение на порт 4050 сервера любым доступным способом (например клиент telnet).
· Обратите внимание на лог-журнал исключительных ситуаций клиентского приложения, находящихся в каталоге приложения по адресу «Log\Exception\exc_[дата].log». Возможно, в нем будут присутствовать строки, дающие возможность понять причину.
· Отправьте конфигурационный файл и лог-журналы клиентского приложения за текущий день поставщику для изучения, снабдив описанием (скриншоты, последовательность действий, а также действия, после которых произошло изменение поведения приложения).

После авторизации клиентское приложение не запускается

· Попробуйте зайти под системной записью администратора. Если безуспешно, значит ошибка в базе при установлении свойств в карте. Скорее всего адрес сервера состояний указан неверно. Поправьте ошибку самостоятельно или обратитесь за помощью в техподдержку.
· «Учетная запись системного администратора заблокирована». Сервер состояний запущен, функционирует, и в системе существует по крайней мере один пользователь с ролью администратора. Для решения вопросов зайдите под его учетной записью.
· Убедитесь что в настройках роли пользователя, под учетной записью которого осуществляется авторизация, стоит флаг «Расширенное рабочее место». Иначе система использует его компьютер только для управления аппаратными средствами (например, USB-телефоном).
· «Компьютер не значится в карте». Убедитесь, что компьютер, с которого осуществляется попытка подключения, указан в карте сети, имеет там правильный адрес и подключен к серверу LAN-связью; В карте офиса компьютер должен быть идентифицирован по одному из адресов, выводимых в данном окне непосредственно за текстом. Используйте команду PING в командной строке операционной системы для выявления возможности доступа к адресам.
· Убедитесь в наличии ключа защиты, горит ли на нем светодиод, обнаруживается ли он среди устройств системы.
· Если после авторизации клиентское приложение выдает «Сервер не доступен или находится в состоянии переинициализации», в конфигурационных файлах сервера найдите раздел «ContactServerName» и убедитесь, что в значении установлено «SP_STANDALONE_MODE».
· Обратите внимание на лог-журнал исключительных ситуаций клиентского приложения «Log\Exception\exc_[дата].log».
· Отправьте лог-журналы сервера и клиентского приложения за текущий день поставщику для изучения, снабдив описанием (скриншоты, последовательность действий, а также действия, после которых произошло изменение поведения приложения).

Телефон не издает звуков

· Если аналоговый телефон не издает звуков при поднятии трубки:
o Убедитесь в разделе «Администрирование»
▪ В карте сети телефонный аппарат не соединен логической связью с компьютером;
▪ Если аппарат соединен в карте логической связью с компьютером, убедитесь в модуле «Общие настройки» в разделе «Параметры АТС» в отсутствии флага «Блокировать аналоговую линию при неавторизованном пользователе»;
▪ Если флаг установлен, убедитесь, что на компьютере, управляющем аппаратом, запущено клиентское приложение и авторизован оператор;
o Проверьте подключение телефона к системе.
o Убедитесь в работоспособности телефонного аппарата.
o Попробуйте инициировать звонок на линию.
o Если после перезапуска сервера канал некоторое время работоспособен, проверьте соответствие числа каналов и ограничений в ключе защиты. В случае превышения ограничения система урезает часть каналов из таблиц размещения.
o При использовании плат серии «Ольха 9» убедитесь в работоспособности канала, загрузив тестовое приложение «МА9Т». Для плат серии «Ольха 14» приложение «МА14Т». Для плат «Synway» приложение «text.exe». Соответствующие программы можно среди драйверов к устройству, а также в каталоге дополнительных приложений на диске с дистрибутивом.
o Если после установки комплекса линия всегда находилась в подобном состоянии, убедитесь в наличии канала на плате, проверьте контакты мезонинов.
o Выясните, как обстоит дело с другими линиями аналогичного типа. В конфигурационном файле сервера убедитесь в наличии строк, определяющих запуск серверов оборудования («XX» - порядковый номер сервера):

Сервер плат «Ольха 9»:

<add key="START_SERVER_XX" value="Alder9 Server;oktell.HALAlder9Srv.dll;Alder9;_Loaders\" />

Сервер плат «Ольха 14»:

<add key="START_SERVER_XX" value="Alder14 Server;oktell.HALAlder9Srv.dll;Alder14;_Loaders\" />

Сервер плат «Synway»:

<add key="START_SERVER_XX" value="Synway Server;oktell.HALSynwaySrv.dll;ShCti;" />

Сервер SIP:

<add key="START_SERVER_XX" value="SIP Server;oktell.HALSipSrv.dll;SIP" />

o Определите момент, после которого выявилась проблема. Например, были внесены изменения в карту или назначены права, несколько раз выполнялась аппаратная команда и пр.
o Отправьте лог-журнал сервера за текущий день в техническую поддержку для решения проблемы с подробным описанием и указанием времени наблюдения.

· Если USB-телефон (гарнитура) не издает звуков при поднятии трубки:
o Проверьте любой доступный аналоговый телефон на наличие гудка. Если гудка нет, обратитесь к пункту «Если аналоговый телефон не издает звуков при поднятии трубки».
o Выставьте телефон временно как «звуковое устройство по умолчанию» и попытайтесь проиграть какой-нибудь звуковой файл.
o Убедитесь в параметрах громкости телефона как звукового устройства, что громкость на максимуме и звук не выключен.
o Подсоедините вместо этого телефонного аппарата любой другой аналогичный и попробуйте заново.
o Оцените другие рабочие места операторов на подобную проблему.
o Если после перезапуска сервера канал некоторое время работоспособен, проверьте соответствие числа каналов и ограничений в ключе защиты. В случае превышения ограничения система урезает часть каналов из таблиц размещения.
o Изучите настройки брандмауэров.
o Уточните, появилось ли при запуске системы уведомление о регистрации линии.
o Попробуйте нажать кнопку «#» на телефонном аппарате, вызвав тем самым смену сигналов вызова.
o Убедитесь в том, что устройство стоит корректно (USB Audio Device), и драйверы обнаружены и установлены.
o В настройках свойств USB-концентраторов отключите флаг использования режима энергосбережения.
o Проверьте все контакты оборудования, а также проводку на наличии зажимов, перекусов и пр.
o Проверьте настройки адреса и портов для подключения VoIP телефонов. В конфигурационном файле клиентского приложения и настройках соответствующего сервера в модуле «Настройки оборудования».
o Если сервер обслуживает 2 или более сетевых интерфейса, где в каждой из сетей находятся клиентские компьютеры, управляющие VoIP-гарнитурами или телефонами, необходимо настроить для каждого из интерфейсов загрузку своего VoIP-сервера для обеспечения взаимодействия клиентских устройств из разных сетей. Для этого в конфигурационном файле сервера должны быть строчки, содержащие адреса сервера в различных сетях:

<add key="START_SERVER_02" value="Buildin VOIP Server;;Voip;192.168.0.1:5003" />

<add key="START_SERVER_03" value="Buildin VOIP Server;;Voip;10.2.0.1:5003" />

o Если на клиентском компьютере установлено несколько сетевых устройств, то в конфигурационном файле клиента необходимо явно указать по какому из интерфейсов осуществлять посылку и прием пакетов от сервера:

<add key="NETCLIENT_LOCAL_ADDRESS" value="10.2.0.25" />

o Если во время работы отклики от устройства пропадают, оно перестает реагировать на команды сервера – проверьте локальную сеть на прохождение UDP пакетов по установленному порту сигнальной связи. Для анализа с двух сторон (на сервере и на клиенте) установите следящую за трафиком программу, настроенную на конкретный порт и пакеты UDP. В качестве подобной программы может быть использован Ethereal. Дистрибутив можно скачать бесплатно с web-сайта www.ehtereal.com, также он находится в разделе дополнительных программ на диске с дистрибутивом.
o Проверьте сеть на наличие вирусов, сетевых червей и прочих вредоносных программ, увеличивающих трафик, нагрузку на систему, а также изменяющих данные в передаваемых через сеть пакетах.
o Выключите функции энергосбережения сетевого адаптера.
o Если база данных была перенесена на сервер с другого компьютера, пересохраните карту офиса.
o Компьютер находился в спящем или ждущем режиме, вследствие чего сервер разъединил канал связи по таймауту. Перезапустите клиентское приложение.
o Отправьте лог-журналы за текущий день с сервера в техническую поддержку для решения вашей проблемы с подробным описанием и указанием времени наблюдения.

Телефон ведет себя некорректно

· Проверьте другие телефонные аппараты на наличие подобной проблемы.
· Для аналогового телефона
o Убедитесь в отсутствии видимых повреждений в проводке.
o Подсоедините другой (заведомо рабочий) телефонный аппарат на место неисправного.
o Отправьте лог-журналы за текущий день с сервера поставщику для решения вашей проблемы с подробным описанием и указанием времени наблюдения.
· Для USB-телефона
o Убедитесь в отсутствии ошибок при установке устройства.
o В настройках свойств USB-концентраторов отключите флаг использования режима энергосбережения.
o Подсоедините вместо этого телефонного аппарата любой другой аналогичный и попробуйте заново.
o Проверьте все контакты оборудования, а также проводку на наличии зажимов, перекусов и пр.
o Отправьте лог-журналы за текущий день с сервера поставщику для решения вашей проблемы с подробным описанием и указанием времени наблюдения.
· При наличии «обратного звука» (эха той же громкости, что и исходный звук) во время разговора через программный IP-шлюз, проверьте компьютер, использующий гарнитуру и встроенное звуковое устройство.
o Убедитесь, что звук динамиков не доступен микрофону напрямую (стандартное эхо).
o Проверьте звук, подключив к компьютеру любое внешнее звуковое устройство, USB-телефон или USB-гарнитуру.
o Включите проигрывание аудио (на внутренние динамики, наушники и пр.) и одновременно запишите в стандартной звукозаписи операционной системы голос. Если при воспроизведении записанного звука слышится проигрываемый звук – отключите функции микширования «на лету» в свойствах звукового устройства, переустановите драйвер или используйте другое звуковое устройство.
· При торможении звука, щелчках, пропусках
o При наблюдаемых эффектах на USB-телефоне в разговоре с аппаратным каналом платы CTI или наоборот
▪ На сервере производятся длительные и сложные запросы в БД. Вероятно идет построение статистических отчетов или журналов с одного из клиентских мест. Оцените в диспетчере задач загрузку процессора.
▪ На сервере производятся другие действия, существенно загружающие процессор и кэш.
▪ В сети присутствуют вирусы или другие вредоносные программы, блокирующие часть трафика.
▪ Чрезмерная загрузка сети не позволяет всем пакетам быть доставленными.
▪ Звуковое устройство имеет резко отличающуюся скорость воспроизведения/записи. Подключите другой телефон или попробуйте переключить вывод звука на стандартное аудиоустройство (гарнитуру).
o При наблюдаемых эффектах на коммутации двух аппаратных каналов плат CTI
▪ Платы не соединены шиной CTI.
▪ В модуле «Настройки аппаратуры» платы соответствующих каналов находятся в разных группах, что влечет принудительную VoIP-коммутацию. Одновременно большая загрузка процессора (см. предыдущий раздел).
▪ Производится звонок через стороннюю IP-телефонию, вследствие чего звук «портится». Попробуйте перезвонить или найти другой канал соединения с абонентом.
▪ Производится звонок на мобильный телефон, находящийся в зоне плохого приема сигнала.

Низкое качество звука, передающегося между устройствами

· Проверьте формат используемого кодека, возможно понижение качества обусловлено форматом сжатия.
· При низком качестве звука в VoIP канале (при использовании VoIP)
o Проверьте все форматы коммутаций (USB-вш, USB-вн.аналог, USB-USB, аналог-аналог), везде ли наблюдается проблема.
o Проверьте несколько разных каналов, клиентских компьютеров.
o Проверьте файл записи разговора, повторяется ли в нем проблема.
o Проверьте устройство, воспользуйтесь стандартной программой звукозаписи.
o Повторяется ли проблема при использовании другого режима взаимодействия с аудиоустройством (DirectX, WMM).
o При использовании цифровых внешних каналов (E1, SIP) проверьте качество звука при их аппаратной коммутации.
o При наблюдении треска/бульканья в динамике терминального устройства попробуйте увеличить размер JITTER-буфера и MM-буфера (в конфигурационном файле параметры JITTER_DEPTH и WAVE_COUNT соответственно).
o При низкой громкости увеличьте уровень записи микрофона устройства, задействуйте усиление воспроизведения на внешних каналах.
o При использовании ОС WINDOWS VISTA на комьютере пользователя и тресканьи звука в динамике увеличьте значение WAVE_COUNT в конфигурационном файле до 4.
o Оцените загрузку на сервере, хватает ли ресурсов процессора и сети на обслуживание всего потока звонков.
o Убедитесь в отсутствии влияния вирусов, антивирусов, файрволлов в задержке и фильтрации сетевого UDP трафика.
o При использовании удаленных VPN клиентов или клиентов из других сетей попробуйте организовать канал через сервер (параметр в конфигурационном файле OVER_SERVER).
o Включите полное логирование: при проблемах на стороне сервера в настройках аппаратуры включите все виды трассировок, при проблемах на стороне клиента в конфигурационном файле выставьте значение 15 параметра TRACE_HARDWARE. Произведите звонок и отправьте журналы в тех.поддержку.

· При низком качестве звука в аппаратных коммутациях (между каналами плат)
o При плохой слышимости (громкости) попробуйте настроить соответствующие значения в параметрах аппаратуры или вспомогательных программах. При отсутствии эффекта попробуйте добиться хорошей слышимости в тестовых программах.
o Убедитесь, что при коммутации не используется VoIP технология, платы-владельцы соединяемых каналов соединены шиной и находятся в одной группе в настройках аппаратуры.
o Проверьте терминальные устройства, соедините их через другие каналы или непосредственно.
o Проверьте внешнюю линию, соедините ее непосредственно с терминальным устройством.

Клиентское приложение работает нестандартно

· Если после запуска клиентского приложения вы видите в левом нижнем углу панели состояния текст «Информация недоступна». В этом случае по определенным причинам сервер не может создать канал обратной связи с компьютером-клиентом. Возможными причинами могут быть:
o Серверное и клиентское приложения разделены в сети прокси-сервером.
o Клиентское приложение запущено под пользователем операционной системы с ограниченными правами на доступ и использование ресурсов системы.
o Ошибки, занесенные в конфигурационные файлы. Несоответствие портов, нарушение свойств каналов и пр.
o Различие версий клиентского и серверного приложений.
· Если при управлении VoIP-устройством (USB-телефоном или гарнитурой) обнаруживается зацикливание процессов обнаружения и потери устройства, возможно это связано с большой загрузкой процессора. В качестве варианта можно использовать перенос управляющего модуля в общий процесс приложения (по умолчанию это отдельный процесс «PhoneHost»). Для этого в конфигурационном файле клиентского приложения необходимо поместить параметр (или изменить значение существующего):

<add key="SEPARATE_PROCESS" value="0" />

· Если после автоматического перезапуска клиентского приложения возникают проблемы, установите режим перезапуска с выгрузкой процесса (параметр в конфигурационном файле RestartApplicationWithProcess)
· Отправьте лог-журналы за текущий день с сервера и клиентского компьютера поставщику для решения вашей проблемы с подробным описанием и указанием времени наблюдения.

Сервер «тормозит»

· Включите лог-журнал служб АТС и проверьте его на зацикливание сценариев, убедитесь в корректности последнего форматированного сценария.
· Убедитесь, что параметры сервера соответствуют рекомендованным для использования совместно с VoIP-шлюзом.
· Убедитесь, что число VoIP-коммутаций соответствует норме и параметрам сервера; Возможно аппаратные каналы CTI также коммутируются через шлюз (если платы не объединены CT-bus и/или в настройках аппаратуры установлены разные индексы групп для плат).
· Попробуйте деактивировать все задачи, перезапустить сервер и оценить наличие проблемы.
· Убедитесь в отсутствии задач с большими списками, работающими через кэш в ОЗУ.
· Убедитесь в производительности БД, нагрузке на БД, жесткие диски.
· Попробуйте определить действие, повлекшее возникновение проблемы и отменить его.
· Отправьте лог-журналы за текущий день с сервера поставщику для решения вашей проблемы с подробным описанием и указанием времени наблюдения.

Невозможно осуществить исходящий городской звонок через «9»

· После набора «9» система не выдает сигнала
o Проверьте существование служебного номера «Выход в город».
o Убедитесь, что устройство функционирует нормально.
· После набора «9» система выдает сигнал «Занято»
o Для текущего пользователя не назначены права на исходящие звонки или не установлен порядок выделения внешних линий (модуль «Администрирование. Права»).
o Разрешенные для совершения звонка внешние линии выключены, запрещены для совершения исходящих или отмечены как подсоединенные к офисной АТС (модуль «Администрирование. Линии»).
o Убедитесь, что внешние линии свободны и доступны (модуль «Администрирование. Мониторинг. Линии»).
· После набора «9» и номера система не реагирует и звонка не происходит
o В модуле «Мониторинг линий» убедитесь что внешняя линия выделяется и в нее производится набор.
o В случае использования (выделения) цифровых внешних линий (Е1 или SIP) необходима команда посылки номера в линию. В мониторинге линий проверьте тип выделяемой линии. Убедитесь что в общих настройках заданы и включены режимы отправки номера в цифровую линию. Убедитесь, что значения корректны и используются.
o В свойствах выделяемой линии проверьте наличие префикса набора. Убедитесь в корректности значения.

Прочие возможные проблемы

· При работе с датами происходит некорректное преобразование из строкового типа. Это может случиться если в ОС или MS SQL Server установлены нестандартные способы представления формата Дата/время. В качестве одного из решений можно использовать ручную настройку формата дат в конфигурационном файле сервера. Необходимо найти там строки с масками преобразования даты в строку и изменить их надлежащим образом. Через конфигурационный файл можно задать 3 различных формата. Попытки их применения будут осуществляться в порядке следования.

<add key="Default_DateTime_Format1" value="dd.MM.yy HH:mm:ss" />

· Если при запуске сервера (при перезагрузке) возникает ошибка использования портов. Выгрузите приложение, подождите несколько секунд (20-30) для освобождения операционной системой портов и вновь запустите приложение. Также можно после выгрузки приложения на время отключить сеть или вынуть сетевой кабель.

Используйте базу знаний, находящуюся на сайте технической поддержки Oktell http://helpdesk.telsystems.ru, для решения возникающих вопросов.


Перечень файлов, необходимых для озвучивания числовых значений

Для озвучивания числовых значений и стандартных выражений в компоненте сценариев «Воспроизведение числа» используются наборы звуковых файлов из каталога «Scripts \ IVR \ _StandardExpressions», сгруппированные по голосам.

При формировании сценариев голосового меню необходимо озвучить стандартные файлы «Добрый день», «Для переключения нажмите...» и прочие. Для целостности голосового оформления сценариев рекомендуется озвучивать числительные тем же голосом. Записав необходимый для решаемой в сценарии задачи набор стандартных файлов, положите его в новую папку в приведенном выше каталоге. Этот набор станет доступным в сценарии при его открытии.

В стандартную поставку входят три голоса «Мария», «Артем» и «Егор». Наиболее полный набор голосов — Мария. Другими двумя голосами озвучены основные числительные в именительном падеже.

Также каталоги с голосами используются для озвучивания позиции и ожидаемого времени соединения в очереди ожидания (подробнее в разделе «Администрирование. Системные настройки. Очередь».

Ниже приведен полный список файлов, требуемый для полнофункциональной работы компонента. Все файлы должны быть с расширением «.wav», и озвучены текстом, аналогичным их названию. Каждое необходимое слово должно быть записано в двух вариантах: концовка речи (с понижением тона) и продолжение речи (с равным тоном). Названия этих файлов отличаются тем, что в конце имени файла с концовкой речи добавляется символ подчеркивания «_». При отсутствии такового, система подставляет вместо него стандартный файл без символа подчеркивания в конце. В случае отсутствия необходимого файла в момент воспроизведения, он пропускается, а воспроизведение остальных продолжается.

Один

Одна

Одно

Два

Две

Три

Четыре

Пять

Шесть

Семь

Восемь

Девять

Десять

Одиннадцать

Двенадцать

Тринадцать

Четырнадцать

Пятнадцать

Шестнадцать

Семнадцать

Восемнадцать

Девятнадцать

Двадцать

Тридцать

Сорок

Пятьдесят

Шестьдесят

Семьдесят

Восемьдесят

Девяносто

Сто

Двести

Триста

Четыреста

Пятьсот

Шестьсот

Семьсот

Восемьсот

Девятьсот

Целых

Десятая

Десятых

Сотая

Сотых

Тысячная

Тысячных

Десятитысячная

Десятитысячных

Рубль

Рубля

Рублей

Копейка

Копейки

Копеек

Доллар

Доллара

Долларов

Цент

Цента

Центов

Евро

Час

Часа

Часов

Минута

Минуты

Минут

Секунда

Секунды

Секунд

Года

Января

Февраля

Марта

Апреля

Мая

Июня

Июля

Августа

Сентября

Октября

Ноября

Декабря

Понедельник

Вторник

Среда

Четверг

Пятница

Суббота

Воскресенье

Тысяча

Тысяч

Тысячи

Миллион

Миллионов

Миллиона

Миллиард

Миллиардов

Миллиарда

Триллион

Триллионов

Триллиона

Квадриллион

Квадриллионов

Квадриллиона

Квинтиллион

Квинтиллионов

Квинтиллиона

Секстиллион

Секстиллионов

Секстиллиона

Септиллион

Септиллионов

Септиллиона

Октиллион

Октиллионов

Октиллиона

Нониллион

Нониллионов

Нониллиона

Дециллион

Дециллионов

Дециллиона

Первое

Второе

Третье

Четвертое

Пятое

Шестое

Седьмое

Восьмое

Девятое

Десятое

Одиннадцатое

Двенадцатое

Тринадцатое

Четырнадцатое

Пятнадцатое

Шестнадцатое

Семнадцатое

Восемнадцатое

Девятнадцатое

Двадцатое

Тридцатое

Двухтысячного

Девятисотого

Восьмисотого

Семисотого

Шестисотого

Пятисотого

Четырехсотого

Трехсотого

Двухсотого

Сотого

Девяностого

Восьмидесятого

Семидесятого

Шестидесятого

Пятидесятого

Сорокового

Тридцатого

Двадцатого

Девятнадцатого

Восемнадцатого

Семнадцатого

Шестнадцатого

Пятнадцатого

Четырнадцатого

Тринадцатого

Двенадцатого

Одиннадцатого

Десятого

Девятого

Восьмого

Седьмого

Шестого

Пятого

Четвертого

Третьего

Второго

Первого

Звездочка

Решетка

Минус

Ноль

Точка

Запятая

Тире

Слэш

Бэкслэш

А

Б

В

Г

Д

Е

Ё

Ж

З

И

Й

К

Л

М

Н

О

П

Р

С

Т

У

Ф

Х

Ц

Ч

Ш

Щ

Ъ

Ы

Ь

Э

Ю

Я

A

B

C

D

E

F

G

H

I

J

K

L

M

N

O

P

Q

R

S

T

U

V

W

X

Y

Z

ВНИМАНИЕ! В папке могут присутствовать и другие файлы, озвучивающие слова и фразы. При выборе типа проигрывания «Слова и фразы» осуществляется их последовательное воспроизведение. Разделение происходит любыми пустыми символами (табуляция, пробелы), а также символами ? и *, запрещенными в файловой системе. Расширение «.wav» автоматически подставляется в конец к каждому файлу.


Структура пространственной БД

Вся статистика работы в call-центре попадает в пространственную БД «oktell_cc_temp». Все отчеты, касающиеся работы Call-центра строятся на основе лежащей в ней информации. Подробнее об отчетах см. разделы «Call-center. Статистика» и «Call-center. Индикаторы».

Три пространственных таблицы:

A_Cube_CC_EffortConnections – информация о коммутациях в call-центре и попытках дозвона.

A_Cube_CC_OperatorStates – информация о состояниях операторов в call-центре.

A_Cube_CC_CallQueue – информация о состояниях и нагрузках очередей входящих задач.

А также таблицы с категориями:

A_Cube_CC_Cat_OperatorInfo – информация об операторах.

A_Cube_CC_Cat_OperatorStateTypes – информация об используемых состояниях операторов.

A_Cube_CC_Cat_Project – информация о проектах.

A_Cube_CC_Cat_Task – информация о задачах.

A_Cube_CC_Cat_TaskResultTypes – информация о результатах совершения звонков.

Для построения основных отчетов информация берется из пространственных таблиц, а при построении итоговой выборки по идентификаторам происходит пересечение с таблицами категорий для получения адекватных для восприятия показателей (названий, имен, описаний)

При построении выборок в связи с большими объемами данных, наполняющих пространственные таблицы, рекомендуется использовать временные таблицы, куда вставлять данные за интересующий период времени, взятые из основных таблиц. Основные используемые поля пространственных таблиц индексированы. Основной индекс по полю времени служит непосредственно этой цели.

Прочие касающиеся языка SQL темы находятся вне рамок руководства.

Ниже приводятся поля основных таблиц.

A_Cube_CC_EffortConnections

После каждого звонка или попытки звонка в задаче в эту таблицу автоматически заносится коммутационная информация со всей неслужебной информацией, которая может быть полезна при составлении отчетов.

[IdProject] [uniqueidentifier]

Id проекта совершенного звонка или попытки совершения звонка. Пересечение с таблицей A_Cube_CC_Cat_Project.

[IdTask] [uniqueidentifier]

Id задачи. Пересечение с таблицей A_Cube_CC_Cat_Task.

[IsOutput] [bit]

Флаг-признак исходящей задачи.

[IdEffort] [uniqueidentifier]

Id попытки звонка (менеджер задач устанавливает перед началом набора номера)

[IdOperator] [uniqueidentifier]

Id оператора, производившего обработку. IVR также считается оператором и имеет виртуальный код. Пересечение с таблицей A_Cube_CC_Cat_OperatorInfo.

Поле может быть не заполнено (is NULL), в случае, если попытка была прервана до установления соединения (например, занято).

[IdInList] [int]

Код абонента в списке, прикрепленном к задаче.

[AbonentNumber] [nvarchar] (20)

Номер абонента, по которому производился дозвон (исх. задача), или с которого производился звонок (вх. задача).

[CallResult] [int]

Результат звонка. Пересечение с таблицей A_Cube_CC_Cat_TaskResultTypes.

[CallResultInfo] [nvarchar] (100)

Описание результата (если было назначено).

[DateTimeStart] [datetime]

Дата и время начала звонка.

[DateStart] [datetime]

Дата начала звонка с нулевым временем.

[TimeStart] [datetime]

Время начала звонка с нулевой датой.

[DateTimeStop] [datetime]

Дата и время окончания звонка.

[IdConn] [uniqueidentifier]

Id коммутации. В контексте одного звонка при переключении оператором звонка на другого оператора или в IVR каждая коммутация имеет отдельную запись в таблице. Может быть не заполнено (is NULL).

[IdChain] [uniqueidentifier]

Id звонка (цепочки коммутаций). Одинаково для всех коммутаций, в контексте одного звонка. Может быть не заполнено (is NULL).

[IdAUser] [uniqueidentifier]

Id звонящего абонента. Может быть не заполнено (is NULL).

[IdBUser] [uniqueidentifier]

Id принимающего звонок абонента. Может быть не заполнено (is NULL).

[IdExtLine] [uniqueidentifier]

Id внешней линии, по которой происходит реализация звонка.

[LenTime] [float]

Длительность коммутации в секундах.

[LenQueue] [float]

Длительность ожидания в очереди абонентом перед коммутацией с первым оператором.

[IsBetweenOp] [bit]

Флаг коммутации, когда разговор происходит между двумя операторами, абонент находится во Flash-буфере. Может быть не заполнено (is NULL).

[OpponentInfo] [nvarchar] (100)

Информация об абоненте.

[IsHandled] [bit]

Флаг обработанного звонка. 0, когда коммутации не произошло.

[IsSuccess] [bit]

Флаг успешной обработки. Подробно см. раздел «Call-центр. Сценарии. Сценарии диалога. Стоп-форма».

[IsRecorded] [bit]

Флаг наличия файлов с записью разговора. Может быть не заполнено (is NULL).

[IdRecDir] [int]

Id каталога, в который происходит запись. Пересечение с таблицей основной БД A_Stat_RecordDirectories. Может быть не заполнено (is NULL).

[ALineNum] [nvarchar] (5)

Код линии, совершающей звонок.

[BLineNum] [nvarchar] (5)

Код линии, принимающей звонок.

[UserResult] [int]

Код пользовательского результата, который выставил оператор после разговора с абонентом.

Пересечение с таблицей из основной БД A_TaskManager_CubeUserResults. Подробно см. раздел «Call-центр. Сценарии. Сценарии диалога. Стоп-форма».

A_Cube_CC_OperatorStates

Каждую минуту сервер производит перерасчет состояний. В результате в таблице находится информация по каждому периоду пребывания оператора в одном из состояний:

· Предварительная обработка
· Ожидание ответа абонента
· Обратный вызов
· Разговор с абонентом
· Разговор между операторами
· Разговор по задаче
· Поствызывная обработка
· Прочие разговоры
· Перерыв
· Готов

Перечисленные состояния относятся только ко времени пребывания оператора в режиме Call-центр.

[Id] [int] | Целочисленный идентификатор для служебного пользования.
[IdTask] [uniqueidentifier] | Id задачи, в контексте которой оператор находился в данном состоянии. Пересечение с таблицей A_Cube_CC_Cat_Task. Может быть не заполнено (is NULL), если состояние не является участием в задаче.
[IsOutput] [bit] | Флаг-признак исходящей задачи. Может быть не заполнено (is NULL), если состояние не является участием в задаче.
[IdOperator] [uniqueidentifier] | Id оператора. Пересечение с таблицей A_Cube_CC_Cat_OperatorInfo.
[CallResult] [int] | Результат звонка, в ходе которого оператор находился в данном состоянии. Пересечение с таблицей A_Cube_CC_Cat_TaskResultTypes. Может быть не заполнено (is NULL), если состояние не является участием в задаче.
[State] [int] | Состояние оператора. Пересечение с таблицей A_Cube_CC_Cat_OperatorStateTypes.
[DateTimeStart] [datetime] | Дата и время начала пребывания в данном состоянии.
[DateStart] [datetime] | Дата начала пребывания в данном состоянии. Время нулевое.
[TimeStart] [datetime] | Время начала пребывания в данном состоянии Дата нулевая.
[DateTimeStop] [datetime] | Дата и время окончания пребывания в данном состоянии.
[LenTime] [float] | Длительность в секундах пребывания в данном состоянии.

A_Cube_CC_CallQueue

Во время поступления звонков во входящую задачу образуется очередь. Если очередь не пуста, в таблицу кладется информация о ее состоянии. Информация заносится каждый раз при смене одного из количественных параметров очереди.

[Id] [int] | Целочисленный идентификатор для служебного пользования.
[IdTask] [uniqueidentifier] | Id задачи, чья очередь содержится в записи.
[IdProject] [uniqueidentifier] | Id проекта задачи.
[DateTimeStart] [datetime] | Дата и время начала периода с неизменяемыми количественными значениями.
[DateStart] [datetime] | Дата начала периода, время нулевое.
[TimeStart] [datetime] | Время начала периода, дата нулевая.
[DateTimeStop] [datetime] | Дата и время окончания периода. У последней внесенной записи по задаче всегда пусто (is NULL).
[CountQueue] [int] | Количество абонентов, находящихся в очереди в текущем периоде
[CountOperator] [int] | Количество операторов, обслуживающих задачу, активных в текущем периоде.
[CountTalking] [int] | Количество ведущихся по задаче разговоров в текущем периоде. При ненулевой очереди отличается от общего числа активных операторов на число операторов, занятых в других задачах.
[elt1WaitStart] [datetime] | Дата и время начала ожидания первого абонента в очереди.
[elt1WaitSec] [int] | Время в секундах, прошедшее с начала ожидания первого абонента в очереди.

В таблицах категорий для пользования отведены два поля: [Id] и [Name]. В зависимости от типа данных [Id] принимает значения int или uniqueidentifier.


Порты, используемые системой

Системой Oktell при формировании сетевого трафика используется ряд зарезервированных портов. Для подключения клиентского приложения к серверу используется порт 4050. Для связи серверов используется порт 4051. Для связи логического сервера и сервера аппаратуры используется порт 4052. При использовании встроенного VoIP-сервера связь клиент-сервер на аппаратном уровне происходит с использованием портов 4003-4005. Диапазон портов для обмена голосовым трафиком между компьютерами: 4100-4199.

Информация о портах необходима при настройке брандмауэров, антивирусов, прокси-серверов и при использовании прочих внешних следящих программ.

Приведенные выше настройки для портов являются «используемыми по умолчанию», однако при различных конфликтах система позволяет задать порты в ручном режиме. Вся информация содержится в конфигурационных файлах приложений. На клиенте: oktell.ClientStarter.exe.config, на сервере два идентичных файла конфигурации оконного приложения и службы: oktell.ServerForm.exe.config и oktell.ServerService.exe.config.

ВНИМАНИЕ! При изменении портов не забывайте одновременно изменять настройки серверного и клиентского приложений. Используйте полнотекстовый поиск по файлу, чтобы удостовериться в полноценной замене.

ВНИМАНИЕ! При редактировании конфигурационного файла используйте блокнот, иначе возможна потеря в текстовом формате символов, определяющих кодировку, и дальнейшая загрузка будет невозможна без восстановления файла конфигурации.


Параметры файлов конфигурации

Ряд настроек комплекса хранится в файлах конфигурации соответствующих приложений. Файл конфигурации загружается однократно в момент запуска приложения, и хранящиеся в нем настройки не могут быть изменены в ходе работы. Любые изменения файлов конфигурации применяются только при следующем запуске соответствующего приложения.

Настройки файла конфигурации клиентского приложения влияют на работу только конкретного клиента.

Файлы конфигурации находятся в том же каталоге, в котором расположен запускаемый модуль.

Файл конфигурации клиентского приложения: oktell.ClientStarter.exe.config

Файл конфигурации серверной службы: oktell.ServerService.exe.config

Файл конфигурации серверного приложения: oktell.ServerForm.exe.config

Изменять файлы необходимо в редакторах, не изменяющих кодировку (рекомендуется стандартный редактор «Блокнот»). Такие редакторы как «Microsoft Word» и «Wordpad» сбивают кодировку, в следствие чего запуск приложения системы становится невозможным. При попытке запуска с некорректным конфигурационном файлом возникает системное окно с описанием ошибки.

Конфигурационные файлы содержат ряд служебных настроек, поэтому в целях сохранения целостности и работоспособности не рекомендуется изменять формат файла и параметры, у которых нет описания.

Формат представляет собой стандартный XML-документ со специфическими элементами. Допустимые настройки находятся в разделе между тегами <appSettings> и </appSettings>. Каждый конкретный параметр представляет собой строку

<add key="KEY_STRING" value="VALUE_STRING" />

где KEY_STRING - название параметра, VALUE_STRING - значение параметра. Комментарии располагаются между строками <!-- и -->.

Параметры файла конфигурации серверного приложения.

Language. Определяет языковую схему, используемую комплексом. В основном каталоге приложения находятся файлы Lang*.xml, представляющие собой наборы текстов для отображения в клиентских интерфейсах и БД. Для выбора того или иного языка необходимо в качестве значения данного параметра выставить соответствующее расширение имени файла (*). Например для использования файла LangRus.xml необходимо прописать значение «rus».

Язык по умолчанию – русский (применяется, если в конфигурационном файле не указан язык, или если не найден файл указанного языка).

Русский также является базовым языком. То есть если какого-либо кода не найдено в файле языка, то в альтернативу будет применен русский текст, заданный в коде программы. Язык также определяется в конфигурационном файле клиентского приложения, но после подключения к серверу клиентское приложение синхронизирует язык с установленным на сервере.

HALSeparate. Режим запуска модуля поддержки оборудования. 0 - в текущем процессе, 1 - в отдельном процессе. В случае, если оборудование в некоторых случаях вызывает критические ошибки, подгрузка модуля поддержки оборудования в отдельном процессе позволяет не терять основной работоспособности сервера. В моменты падения процесса основная служба перезапускает его, производит фоновую регистрацию и продолжает работу.

В момент перерегистрации все линии переходят в состояние «Отключена», пользователи переходят в состояние «Без телефона», все коммутации разрываются, логика резервирований очищается. Менеджер задач реагирует способом, аналогичным тому случаю, когда абоненты на внешних линиях положили трубки. Возможно файлы записей оборвавшихся разговоров будут иметь некорректный заголовок, что сделает невозможным их прослушивание стандартными средствами. Полностью процесс переинициализации занимает 5-10 секунд.

START_SERVER. Индексированные параметры, определяющие запускаемые серверы аппаратуры. Доступные серверы: Сервер CTI плат Ольха-9, Сервер CTI плат Ольха-14, сервер CTI плат Synway, сервер SIP, серверы VoIP телефонии. При установке системы параметры выставляются согласно выбранным в дистрибутиве значениям. Однако в сложных системах могут потребоваться модификации. Например, в случае если происходит замена типа платы на рабочей системе, использование нескольких разных типов плат, а также при запуске нескольких VoIP серверов, обслуживающих разные подсети. Загрузке подлежат серверы с индексами от 1 до 32 (в примере - часть строки XX).

Сервер плат «Ольха 9», «Ольха 14»:

<add key="START_SERVER_XX" value="Alder9 Server;oktell.HALAlder9Srv.dll;Alder9;_Loaders\" />

<add key="START_SERVER_XX" value="Alder14 Server;oktell.HALAlder9Srv.dll;Alder14;_Loaders\" />

Последний элемент строки после точки с запятой указывает путь к файлам-загрузчикам. По умолчанию это подкаталог серверной службы _Loaders.

Сервер плат «Synway»:

<add key="START_SERVER_XX" value="Synway Server;oktell.HALSynwaySrv.dll;ShCti;" />

Сервер SIP:

<add key="START_SERVER_XX" value="SIP Server;oktell.HALSipSrv.dll;SIP;sip:*:5060" />

Последний элемент строки после точки с запятой устанавливает детальные настройки сетевого интерфейса и порта, на которых запускаемый SIP-сервер будет активен. По умолчанию «sip:*:5060», то есть сервер слушает все интерфейсы на порте 5060. При необходимости установить какой-либо конкретный интерфейс необходимо вместо «*» указать его адрес.

Серверы VoIP:

<add key="START_SERVER_XX" value="Buildin VOIP Server;;Voip;localhost:4003" />

Последний элемент строки после точки с запятой указывает сетевой интерфейс и порт слушателя регистраций локальных устройств. При необходимости использования сервера для поддержки локальных устройств разных подсетей возможно запустить несколько VoIP-серверов - несколько однотипных строчек файла конфигурации с разными индексами и разными сетевыми интерфейсами.

Сервер виртуальных каналов

<add key="START_SERVER_XX" value="Virtual Server;oktell.HALVirtualSrv.dll;VS;12/10" />

Последний элемент строки указывает количество используемых каналов - внешних/внутренних.

MASTER_BOARD. При использовании плат семейства Ольха может потребоваться указание мастер-платы, от которой происходит синхронизация потока Е1. В этом случае параметр необходимо раскомментировать и указать номер мастер-платы, начиная с 0 в порядке их определения драйвером в системе. По умолчанию параметр закомментирован и используется значение по умолчанию 0.

USE_CT-BUS_BOARDx. При использовании плат семейства Ольха может потребоваться принудительное отключение CTBUS на одной или нескольких платах (например в случае, если шлейф шины охватывает менее установленного количества плат). Индексированный параметр, где вместо X ставится номер платы начиная с 0 в порядке определения системой, со значением 0 отключает использование CTBUS на плате. По умолчанию все платы используют шину CTBUS при ее наличии.

VOIP_PORT_START. Начальный порт для обмена голосовым трафиком через сервер VoIP телефонии.

VOIP_PORT_END. Конечный порт для обмена голосовым трафиком через сервер VoIP телефонии.

USE_AFFINITY_MASK. «1» - использовать разделение задач по процессорам. Половина процессоров для сервера логики, другая половина для сервера HAL. «0» - значение по умолчанию. В этом случае операционная система самостоятельно занимается распределением.

JITTER_DEPTH. Значение глубины джиттер-буфера на сервере. Минимальное значение - «4», по умолчанию - «4». При увеличении значения происходит рост задержки в голосовом обмене по направлению звука к серверу, эффективнее исключая влияние проблем сети.

TIMER_TYPE. Тип используемого таймера тактирования звуковых пакетов. На разных операционных системах и компьютерах различные варианты таймеров могут иметь достаточно сильную погрешность, влияющую на итоговое качество звука.

Возможные значения:

0 - Системный таймер по умолчанию. Дает более точное тактирование по сравнению с таймером на ожидании. Выдает точное тактирование в Windows Vista и некоторую погрешность в предыдущих версиях Windows. Система буферизации звука в этом случае сглаживает разброс, однако существуют компьютеры, где погрешность таймера постоянна. Это влечет пропуск пакетов и заметное ухудшение итогового качества звука. На таких компьютерах необходимо использовать другие типы таймеров. Рекомендуется мультимедийный.

1 - Системный таймер в собственном потоке приложения.

2 - Имплементация таймера в потоке с использованием функции WaitForSingleObject().

3 - Мультимедийный таймер. Дает наиболее точное тактирование, однако возможно не будет работать на серверах без звуковой подсистемы.

По умолчанию «0».

TIMER_HIGHRES. Тип используемого счетчика интервалов времени. «0» - миллисекундный системный счетчик GetTickCount, «1» - Query Performance Counter. По умолчанию «0».

ProcessPriority. Приоритет серверного процесса. По умолчанию «0» - Нормальный. «1» - выше среднего, «2» - высокий, «3» - реального времени.

DBServerName. Адрес сервера, на котором находится база данных MSSQL. По умолчанию «(local)».

DBName. Имя базы данных, к которой производится подключение. По умолчанию «oktell».

DBLogin. Имя пользователя, учетной записью которого пользуется система. По умолчанию «AutelService».

DBInstanceName. Имя экземпляра сервера MSSQL. По умолчанию «MSSQLSERVER». Для доступа к службе, обеспечивающей работу БД.

DBConnectionString. Строка подключения, задаваемая явно. Используется при настройке подключения к службам SQL с индивидуальными параметрами, при которых не подходят параметры по умолчанию. При отсуствии этого свойства, или пустом его значении, подставляется строка:

"server=(local);database=oktell;uid=AutelService;pwd=[pwd];pooling=false",

где значения параметров server, database и uid подставляются из вышеописанных свойств. При явном указании строки подключения пароль может быть указан явно, либо использована последовательность символов «[pwd]», указывающая системе на необходимость подстановки пароля для логина AutelService.

DBTransactionLogSize_1, DBTransactionLogSize_2. Размеры транзакционных лог-файлов баз данных - основной и пространственной. По умолчанию по 500 МБ.

RepUpdateDir. Каталог с обновлениями отчетов call-центра.

DBUpdateDir. Каталог с обновлениями для БД.

ContactServerName. Тип подключения к драйверу ключа по умолчанию. В случае невозможности осуществляется перебор всех возможных вариантов.

ShowServerLogAtStartUp. При использовании серверного приложения «1» включает трассировку служебного лог-журнала в окно приложения.

LicenseMode. Текущий режим лицензирования. По умолчанию «1» - использование файла сертификата.

Default_DateTime_Format. Индексированные параметры, определяющие нестандартныей варианты преобразования типа СТРОКА к типу ДАТАВРЕМЯ. Используются строки с индексами от 0 до 99, перебор в ходе работы осуществляется в порядке увеличения индексов.

SkipCloseMutexCommand. Режим автоматического закрытия сервера через мьютекс-команду необходим в целях исключения проблем с операциями обнаружения процессов. Встречаются системы, в которых отключены или недееспособны службы, необходимые для обнаружения внешнего процесса. В этом случае процесс копира не в состоянии при необходимости остановить серверный процесс перед обновлением и/или для перезапуска. «1» - пропускать команду закрытия, отданную через системные мьютексы процессом копира. «0» и другие значения - команда будет распознаваться и сервер будет реагировать на нее автоматическим закрытием.

Раздел LOG.

Хранит настройки лог-сервера комплекса. Среди неописываемых настроек - пути к папкам для сбора журналов.

LOG_storedays. Длительность хранения лог-журналов в днях. По умолчанию «7». По истечении указанного периода журналы удаляются системой. В некоторых случаях объем журналов может достигать нескольких гигабайтов за день.

LOG_root. Абсолютный или относительный путь к папке с лог-журналами. По умолчанию «Log», то есть относительный путь в каталоге серверной службы/приложения.

Раздел DEBUGGING.

Хранит настройки, согласно которым ведется заполнение служебного сервисного лог-журнала. По умолчанию все параметры выставлены в «1», что влечет полное логирование служб сервера. Полное или частичное отключение уменьшает размер журнала, однако не даст информации в случае возникновения сбоев и общением с технической поддержкой.

Раздел KEYREMOTE.

Хранит настройки для подключения к внешнему серверу, управляющему ключом защиты. Необходимо в редких случаях, если USB-порт на сервере не функционирует должным образом.

Параметры файла конфигурации клиентского приложения.

Language. Определяет языковую схему, используемую клиентским приложением до момента подключения к соответствующему серверу. После подключения производится принудительная синхронизация языковой схемы. Фактически это происходит в момент отображения окна авторизации. Подробнее в описании ключа в разделе серверного приложения.

NetConnectionName. Название подключения (сервера) для отображения в окне авторизации (при указании нескольких возможных подключений).

LogicServerAddress. Адрес для подключения к серверу логики.

LogicServerPort. Порт для подключения к серверу логики.

NETCLIENT_SERVER_ADDRESS. Адрес для подключения к серверу аппаратуры.

NETCLIENT_SERVER_PORT. Порт для подключения к серверу аппаратуры.

NETCLIENT_LOCAL_ADDRESS. Сетевой интерфейс, через который осуществляется подключение к серверу аппаратуры. Требуется указание, если клиентский компьютер находится в разных подсетях с более чем одним сетевым интерфейсом. По умолчанию параметр закомментирован.

NETCLIENT_LOCAL_PORT. Локальный порт для обмена сигнальным трафиком по UDP.

NETCLIENT_VOICE_PORT. Локальный порт для обмена голосовым трафиком по UDP.

ВНИМАНИЕ! Вышеперечисленные параметры определяют различные адреса и порты для организации сетевого канала подключения к серверу. Эти параметры могут присутствовать в конфигурационном файле несколько раз с добавлением к концу строки-ключа разных целочисленных индексов. Например NetConnectionName_1 и NetConnectionName_2. Индекс 0 не указывается, вместо него используется значение без индекса. В случае указания в конфигурационном файле нескольких подключений в окне авторизации будет отображен список их имен и доступен выбор одного из них. Это удобно использовать при работе с несколькими серверами с одних и тех же клиентских рабочих станций.

AutoUpdate. «1» - обновлять клиента автоматически. «0» - не обновлять автоматически при запуске, если обнаружено отличие версий. По умолчанию «1». Настоятельно не рекомендуется оставлять рабочую версию программы со значением «0» и использовать этот режим только для отладочных целей.

AutoUpdateGateway. «1» - обновлять шлюз автоматически. «0» - не трогать. По умолчанию «0». В список шлюзов требуется добавить адрес сервера, если подключение производится к серверу с несколькими сетевыми интерфейсами через интерфейс с индексом более 1.

TerminalAddress. Строка, определяющая уникальный адрес клиентского места. Приписывается ко всем адресам компьютера для определения клиентского места в карте офиса (например «FUTURAMA/terminal1»). Именно эту строку необходимо будет указать в карте офиса для идентификации. Решает проблему терминальных подключений, где все клиенты физически запускаются с одного компьютера. По умолчанию «».

TimeSynchronization. «1» - синхронизировать время с сервером при запуске, «0» - не синхронизировать. По умолчанию «1».

RestartApplicationWithProcess. «1» - любой перезапуск клиента производится с выгрузкой процесса. «0» - выгрузка процесса производится только для применения обновлений, другие перезапуски осуществляются внутри процесса. По умолчанию «0».

ProcessPriority. Приоритет процесса клиентского приложения и процесса обслуживания внешних звуковых устройств. «0» - нормальный, «1» - выше среднего, «2» - высокий, «3» - реального времени. По умолчанию «1».

HAL_skip_loading. «1» - пропускать загрузку модуля обслуживания устройств работы со звуком. «0» - нормальный режим.

Register_ocx. «1» - регистрировать библиотеки обслуживаемых устройств перед запуском, «0» - не регистрировать. По умолчанию «1».

TRACE_HARDWARE. Уровень трассировки аппаратного модуля. Битовая маска xxxx. C конца: 0 - TraceCall, 1-TraceEvents, 2-TraceVoice, 3-TraceNet. По умолчанию «1». Для полной трассировки значение «15».

SEPARATE_PROCESS. «1» - запускать отдельный процесс для работы с устройствами. «0» - работать с устройствами в собственном процессе. По умолчанию «1».

JITTER_DEPTH. Значение глубины джиттер-буфера на клиенте. Минимальное значение - «4», по умолчанию - «4». При увеличении значения происходит рост задержки в голосовом обмене по направлению звука в клиентское устройство, эффективнее исключая влияние проблем сети.

WAVE_COUNT. Значение глубины буфера обмена звука. Минимальное значение - «2», по умолчанию - «2». При увеличении значения происходит рост задержки в голосовом обмене по направлению звука в клиентское устройство, эффективнее исключая влияние проблем звукового устройства.

OVER_SERVER. «1» - обмен трафиком через сервер. «0» - обмен трафиком по возможности напрямую. По умолчанию «0».

WRITE_VOICE. Отладочный параметр для оценки звукового потока на входе в клиентский HAL из сети до воспроизведения непосредственно в устройстве. «1» - отладочная запись в файл включена, файл с именем, соответствующим текущему времени размещается в корне клиентского приложения . «0» - отладочная запись отключена. По умолчанию «0».

WAVEIN_AUTOCLOSE. «1» - закрывать устройство ввода звука после завершения коммутации. «0» - оставлять открытым. По умолчанию «0».

USE_DIRECTSOUND. Тип работы со звуком по умолчанию. Выбирается в клиентском интерфейсе. «1» - использовать для работы со звуком библиотеки DirectSound. «0» - обычный режим через системные функции Windows Multimedia (WMM). По умолчанию «0».

NETCLIENT_PAYLOAD. Кодек по умолчанию для обмена голосовым трафиком. Выбирается в клиентском интерфейсе. Здесь служит для задания начальной настройки. 0 - 711mulaw, 8 - 711alaw, 41 - gsm610. По умолчанию «8».

PHONEDEVICE_WAVEOUT. Устройство вывода звука (спикер) по умолчанию. Выбирается в клиентском интерфейсе. Здесь служит для задания начальной настройки.

PHONEDEVICE_WAVEIN. Устройство ввода звука (микрофон) по умолчанию. Выбирается в клиентском интерфейсе. Здесь служит для задания начальной настройки.

PHONEDEVICE. Имя устройства по умолчанию. Выбирается в клиентском интерфейсе. Здесь служит для задания начальной настройки.

SIGNAL_VOLUME. 0-100. Уровень громкости генерируемых в локальное устройство системных звуков и тонов. По умолчанию 50.

UseKeyHook. Параметр позволяет принудительно отключить режим перехвата действий клавиатуры для управления гарнитурой. Отключение может понадобиться при обнаружении проблем и конфликтов с операционной системой. «1» - режим перехвата активирован. «0» - режим перехвата деактивирован. По умолчанию «1».

WatcherResourceLogType. Формат логирования ресурсов. С помощью параметра можно настроить вывод в клиентский лог-журнал WATCHER информации по использованию процессом ресурсов системы. Объем используемой памяти, количество открытых дескрипторов, количество потоков, пользовательские системные ресурсы, ориентировочное среднее процессорное время по всему процессу и отдельно по всем его потокам. 0 - не логировать, 1 - информация о процессе каждую секунду, 2 - информация о процессе и активным потокам каждую секунду, 3 - информация о процессе и всем его потокам каждую секунду, 4 - информация о процессе каждую минуту. По умолчанию 4.

Memory_UseSameDialogForms. «1» - активирует режим использования одних и тех же окон в режиме операторских диалоговых форм без уничтожения и создания при каждом показе. Используется на компьютерах с минимальным объемом оперативной памяти во избежание скачкообразного роста используемой памяти. «0» - деактивирует режим. По умолчанию «0».

Debug_PingErrorRestart. «0» - отключает автоматическую перезагрузку клиентского приложения при отсутствии откликов сервера на команды Ping. Используется для отладочных режимов, в основном при отладке plugin-программ. «1» - обычный режим. По умолчанию «1».

PingTimeoutNotify. Устанавливает период в миллисекундах, при превышении которого в момент вызова метода Ping возникает уведомление о плохой связи с сервером.

ActivationServer. Ссылка на сайт активаций для режима автоматической активации тестовой версии. По умолчанию «http://activate.telsystems.ru».

Раздел LOG.

Хранит настройки лог-сервера комплекса. Среди неописываемых настроек - пути к папкам для сбора журналов.

LOG_storedays. Длительность хранения лог-журналов в днях. По умолчанию «7». По истечении указанного периода журналы удаляются системой. В некоторых случаях объем журналов может достигать нескольких гигабайтов за день.

LOG_root. Абсолютный или относительный путь к папке с лог-журналами. По умолчанию «Log», то есть относительный путь в каталоге клиентского приложения.


Форматы звуковых файлов

Система Oktell в соответствии с настройками осуществляет запись в форматах

· G.711 a-law (64 кБит/сек);
· G.711 mu-law (64 кБит/сек);
· MS GSM 6.10 (13 кБит/сек);

Выбор конкретного кодека осуществляется в клиентском интерфейсе в окне выбора устройств (для пользователей VoIP телефонии). Для CTI каналов в качестве кодека для записи установлен G.711 a-low как наиболее оптимальный. Конкретная коммутация происходит использованием одного из кодеков коммутируемых каналов с наименьшим трафиком. Подробнее в разделе «Телефон». Настраиваемый микшер производит сжатие записанных разговоров в MS GSM 6.10 для хранения. Подробнее в разделе «Упаковка записанных разговоров».

Воспроизведение может осуществляться в форматах

· G.711 a-law (64 кБит/сек);
· G.711 mu-law (64 кБит/сек);
· MS GSM 6.10 (13 кБит/сек);
· PCM 16bit 8000Hz Mono (128 кБит/сек);


Подключение внешних БД

Компонент «Запрос SQL» сценариев Oktell позволяет получить доступ к различным базам данных средствами ADO, OLE и ODBC.

Однако в некоторых случаях более широкого использования внешних БД существует процедура, упрощающая взаимодействие и настройку.

Для получения общего доступа к данным, хранящимся в СУБД, отличных от MS SQL Server, можно воспользоваться стандартной операцией подключения внешних (Linked) серверов к MS SQL Server.

Процесс линковки включает следующие этапы:

1. Регистрация прилинкованного сервера на MS SQL сервере, который обслуживает БД комплекса Oktell.

2. Написание необходимых запросов в формате TSQL.

Сервером MS SQL поддерживаются все распространенные форматы хранения данных. Ниже на примере базы MS ACCESS приводится процедура линковки внешнего сервера.

Подключение базы MS ACCESS

Регистрация в клиентском интерфейсе MS SQL Server.

1. В Enterprise Manager (далее EM) необходимо подключиться к SQL серверу, содержащему БД Oktell.

2. Открыть папку Security/Linked Servers.

3. С помощью контекстного меню папки зарегистрировать новый прилинкованный сервер.

4. В диалоговой форме на вкладке General необходимо указать

a. Название сервера.

b. Тип сервера. Для Access нужно выбрать провайдера - Microsoft Jet Ole DB Provider.

c. Источник данных: полный путь к файлу *.MDB базы данных Access.

Если сервер СУБД требует аутентификации, на вкладке Security следует назначить соответствующий вариант.

5. Если на шаге 4 все данные указаны верно, будет отображен список таблиц и представлений подключенной БД.

Зарегистрировать прилинкованный сервер можно также динамически с помощью системных хранимых процедур sp_addlinkedserver, sp_addlinkedsrvlogin:

EXEC sp_addlinkedserver 'AccessSample', 'Jet 4.0', 'Microsoft.Jet.OLEDB.4.0',

                  'C:\Data\db1.mdb', NULL, NULL

EXEC sp_addlinkedsrvlogin 'AccessSample', false, NULL, NULL

Получить данные с подключенной БД можно используя стандартный синтаксис TSQL. При указании таблиц необходимо использовать полный путь к ним (из четырех частей, разделенных точками) с указанием сервера, схемы и таблицы. Если схема пропущена, используется схема по умолчанию (для СУБД, работающих со схемами данных). Пример запроса:

Select * From [ACCESSSAMPLE]...[Table_Users]

Подключение файлов MS EXCEL

Регистрация прилинкованного сервера аналогична примеру с БД Access.

ВНИМАНИЕ! В графу Provider string необходимо занести значение «Excel 8.0»

При использовании динамического подключения через системные хранимые процедуры:

EXEC sp_addlinkedserver 'ExcelSource', 'Jet 4.0', 'Microsoft.Jet.OLEDB.4.0',

'c:\MyData\DistExcl.xls', NULL, 'Excel 8.0'

EXEC sp_addlinkedsrvlogin 'ExcelSource', 'false', NULL, NULL

Для получения данных из Excel необходимо, чтобы исходный XLS файл с данными содержал именованные диапазоны.

Пример запроса:

Select * From [Excel]...[Range]

Подключение базы данных ORACLE

Провайдер данных «Microsoft OLE DB Provider for Oracle» дает возможность выполнять запросы в базы данных Oracle.

1. Убедитесь, что версия клиентского программного обеспечения Oracle на сервере, обслуживающем SQL Server, не ниже требуемой провайдером. Microsoft OLE DB Provider for Oracle работает с версиями Oracle Client Software Support File версии 7.3.3.4.0 или позднее и SQL*Net версии 2.3.3.0.4.
2. Зарегистрируйте сетевой псевдоним (SQL*Net alias) на сервере, обслуживающем SQL Server, который ссылается на подключаемую базу данных Oracle. См. документацию к Oracle.
3. Выполните sp_addlinkedserver для регистрации линкованного сервера, указав MSDAORA в качестве провайдера и зарегистрированный на шаге 2 псевдоним в качестве источника данных. Приведенный пример использует алиас, определенный как OracleDB:

EXEC sp_addlinkedserver 'OrclDB', 'Oracle', 'MSDAORA', 'OracleDB'.

4. Используйте sp_addlinkedsrvlogin, чтобы провести маппинг (назначение) логинов SQL Server в логины Oracle. Приведенный ниже пример регистрирует логин SQL Server Joe к линкованному серверу, определенному на шаге 3, используя логин и пароль к Oracle (OrclUsr и OrclPwd):

EXEC sp_addlinkedsrvlogin 'OrclDB', false, NULL, NULL

Таблицы в линкованных базах Oracle должны указываться полным именем (из четырех частей, разделенных точками): [Имя сервера]..[Имя владельца].[Таблица]. Например:

Select * From OrclDB..MARY.SALES

Провайдеры данных OLE DB

SQLOLEDB Используется для подключения серверов SQL Server. В качестве источника указывается сетевое имя компьютера или [имя компьютера]\[имя экземпляра].
MSDAORA Используется для подключения серверов Oracle. В качестве источника указывается псевдоним (SQL*Net alias) подключаемой БД.
Microsoft.Jet.OLEDB.4.0 Используется для подключения любых продуктов Access/Jet. В качестве источника указывается полный путь к файлу базы данных. Также используется для подключения к файлам MS Excel. В этом случае в качестве источника данных указывается полный путь к файлу, а в качестве строки подключения – «Excel 8.0».
MSDASQL Используется для подключения любых продуктов через ODBC. Для идентификации сервера необходимо либо в качестве источника данных указать его DSN, либо сформировать строку подключения к источнику.

Существуют еще несколько провайдеров для узких задач и редко используемых баз данных.

За более подробной справкой обращайтесь к разделу помощи MS SQL Server или в службу технической поддержки.


Резервное копирование баз данных

 Содержание | Назад | Далее

Система Oktell работает с двумя базами данных: «oktell» и «oktell_cc_temp». Вопрос резервного копирования баз в случае необходимости полностью возлагается на администратора. Средства Microsoft SQL Server предоставляют широкие возможности по решению этого вопроса.


Порядок обновления программы в ручном режиме

Обновление проходит в несколько этапов. При необходимости обновления комплекса инструкция будет дополнительно предоставлена технической поддержкой. Ниже приведены общие этапы.

1. Производится остановка работающего сервера.

2. В некоторых случаях рекомендуется сохранить сборки работающего комплекса и произвести резервное копирование баз данных.

3. Распакованные файлы сборок клиентского и серверного приложения помещаются в соответствующие каталоги на сервере.

4. Производится корректировка конфигурационных файлов приложений. Основные моменты:
a. Имя (адрес) основной базы данных (сервер);
b. Порты, настроенные для VoIP-телефонии (сервер);
c. Аппаратные серверы, загружаемые системой (сервер);
d. Адрес для подключения к серверу логики (клиент);
e. Адрес и порт для подключения к шлюзу VoIP-телефонии (клиент).

5. Клиентские сборки по маске «oktell.Client*.dll» дополнительно помещаются в каталог серверного приложения.

6. Для последующего обновления всех клиентских рабочих мест сборки клиентского приложения дублируются в каталог серверного приложения «LiveUpdate».

7. Файлы обновления БД перед первым запуском находятся в каталоге сервера «DBAutoUpdate».

8. Запуск сервера.

9. Контроль корректности обновления БД (применение и удаление всех файлов в каталоге обновления «DBAutoUpdate»).

10. Контроль запуска всех аппаратных серверов, работоспособность аппаратной части телефонии.

11. Контрольный запуск клиентского приложения, его автоматическое обновление.


Content

Содержание

 Содержание


Системы автоматизации

телефонного обслуживания

(Сall-center)

Руководство пользователя

версия 2.5